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It’s in the Documentation

Business Objects documentation continues to deliver timely and indepth 
coverage of product information. Not just facts about product features, but a 
world of knowledge in the way of tips, samples, and troubleshooting 
instructions.

For your convenience, Business Objects documentation comes in a variety of 
formats including Windows online help, HTML, Acrobat PDF, paper, and 
multimedia. What’s more, you can gain quick access to it at any time directly 
from the product you are working with.

Documentation has been carefully designed to meet your needs for speed and 
ease of navigation. All the information you need is there just a few mouse clicks 
away.

The next sections highlight the key features of our documentation.

A Documentation Service on the Web
From the Help menu of all our products, you can check out More Tips and 
Samples, the Business Objects documentation service on the Internet. From here, 
you can discover the latest updates, tips, samples, and troubleshooting.

You can also get there by pointing your browser to the following URL:

http://www.businessobjects.com/services/infocenter

From the Tips and Tricks page, registered customer support contacts can explore 
the electronic version of the Business Objects documentation set. It offers 
extensive information on all Business Objects products, updates, 
troubleshooting, tips, and much more. 

In addition, registered DEVELOPER SUITE customers can download new 
documentation and code samples.

http://www.businessobjects.com/services/infocenter 


 It’s in the Documentation

 Error Message Guide vii

Multimedia
Business Objects multimedia comprises the BUSINESSOBJECTS Quick Tour, the 
INFOVIEW Quick Tour, and the BUSINESSMINER tutorial, all of which cover the 
essential features of these products.

The BusinessObjects Quick Tour
The BUSINESSOBJECTS Quick Tour is a multimedia presentation that takes you on 
a guided tour of the key features of BUSINESSOBJECTS. Its didactic approach makes 
it an ideal primer for first-time users of the product. 

You may wish to use it as an accompaniment to the guide Getting Started with 
BusinessObjects. 

An actual screen from the BusinessObjects Quick Tour
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The InfoView Quick Tour
The INFOVIEW Quick Tour is a multimedia presentation that highlights the key 
features of INFOVIEW. Intended primarily for new users, it offers an overview of 
all the features necessary for managing and distributing documents.

The INFOVIEW Quick Tour can be used as an accompaniment to the guide 
Getting Started with WebIntelligence.

An actual screen from the InfoView Quick Tour

The BusinessMiner Tutorial
This multimedia tutorial teaches novice users how to use the powerful desktop 
datamining software, BUSINESSMINER. Each lesson in this tutorial has a narrated, 
animated presentation which shows users how to answer a business question 
using BUSINESSMINER. Users can then try out the demonstrated tasks themselves 
by following the step-by-step exercises in the accompanying guide.
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Online Guides

User’s Guides
All user’s guides are available as Acrobat Portable Document Format (PDF) files. 
Designed for online reading, PDF files enable you to view, navigate through, or 
print any of their contents. The full list of Business Objects guides is provided in 
the Deployment Guide.

From a Business Objects product, you can open a guide from the commands of 
the Help menu.  

The Help menu of BusinessObjects provides commands for viewing documentation.

During installation, the BUSINESSOBJECTS installer program automatically copies 
these files to:

Business Objects\BusinessObjects 5.0\Online Guides\En

You can open a document from the Help menu provided that you have installed 
the Adobe Acrobat Reader, version 3.0 or higher on your machine. This Reader is 
available on the Business Objects CD-ROM. You can also download it for free 
from the Web site of Adobe Corporation.
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Online Help
For Business Objects Windows desktop products, online help is available in the 
form of .hlp and .cnt files that comply with the standards of Microsoft Windows 
online help.

From INFOVIEW, online help is available for both INFOVIEW and 
WEBINTELLIGENCE. 

What to Do for More Information
If you cannot find the information you are looking for, then we encourage you to 
let us know as soon as you can. We welcome any requests, tips, suggestions, or 
comments you may have regarding the contents of this or other Business Objects 
documentation. You can contact us by e-mail at:

documentation@businessobjects.com

To find out information about Business Objects products and services, visit our 
Web site at:

http://www.businessobjects.com

http://www.businessobjects.com
mailto:documentation@businessobjects.com 
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About this Guide

The Error Message Guide is an compilation of the error messages that can appear 
with ordinary use of Business Objects products.

The purpose of this online guide is to provide you with detailed troubleshooting 
information so that you can determine the reasons for an error and take the 
appropriate steps to resolve it.

The guide allows you to search for error messages by code. Each error message 
appears with its probable cause and the recommended course of action.

Audience
This guide is intended primarily for users of Business Objects products: 
supervisors, designers, power users, and basic users. It may also be used by 
database or network administrators.

How to Access this Guide
You can access this online guide from any of the Business Objects products by 
selecting the Error Messages Explained command from the Help menu. From 
INFOVIEW, click Error Messages in the navigation bar.

The PDF file is installed in the Online Guides\En folder of your Business Objects 
files.
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Locating an Error Message
In Acrobat Reader, you can locate an error message from the:

• List of Error Messages bookmark. 

Clicking the bookmark (in the left pane of the Reader) takes you to the list of 
all error messages. From this alphabetical list, you can click the error message 
to go to the section containing its explanation. 

• Find command on the Edit menu.

Enter all or part of the error message in the dialog box to search for it 
throughout the entire guide. 

The Error Message Guide in PDF format.

Click the
List of Error Messages
bookmark to view 
the error messages
by code 

Click an error message to go to its explanation
in the guide.

The Find command on
the Edit menu lets you search
for an error message.
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How Error Information is Presented in this Guide
Each message is given in bold with its full text followed by a code in parentheses, 
just as it appears in the product. The code conveys the category of the error. Here 
is an example of an error message:

You are not allowed to browse this query file (BQM0025). 

“You are not allowed to browse this query file” is the text of the error message 
and BQM0025 is the code which identifies it as a BUSINESSQUERY error.

For each error message, the guide describes the most likely cause and the 
recommended solution. Certain messages may have several possible causes or 
more than one solution. 

The messages are separated from each other by a divider.

How to Tell if an Error Message Comes from a Business Objects 
Product

You can identify an error message that originates from the use of a Business 
Objects product by its error code. This code is made up of a two or three character 
identifier followed by a number. An identifier can reveal either the nature of the 
error or the product from which the error message is issued.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 
Examples

The identifier “DSG” of the error code DSG0017 identifies an error message from 
DESIGNER.

The identifier “FOR” of the error code FOR0002 designates an error message 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 
relating to the manipulation of charts in BUSINESSOBJECTS.

The most common identifiers for error codes are listed in alphabetical order in the 
table appearing on the next page. Each identifier is shown with a brief 
description.
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The identifiers of error codes are listed below with their meanings.

ID   Meaning    ID Meaning

ADM SUPERVISOR (administration) FOR charts

ADT AUDITOR FRM framework

ADW SUPERVISOR (wizard errors) GUI graphical user interface

BCA BROADCAST AGENT 
(administration)

INS installation

BCAG BROADCAST AGENT (Scheduler) LOV list of values

BCB BROADCAST AGENT (Console) MCD OLAP

BOL bolightsvr OEX OLAP

BOMGR BOManager OLC, 
OLP

OLAP

BQ BUSINESSQUERY OMC OLAP

BQM BUSINESSQUERY QP SQL/query

CAT category QPF SQL

DA database RPT reports

DAC data access SBO connectivity

DBD OLAP UNM universe management

DMA data provider UNV universe

DMB creating variables USO password

DPP stored procedures/file errors USP BUSINESSOBJECTS (general)

DPQ connection USR security

DSG DESIGNER USU installation

DWZ BUSINESSOBJECTS

(New Report Wizard)
UX universe

DX document exchange VAR syntax error

ESB OLAP WI WEBINTELLIGENCE
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Conventions Used in this Guide
The conventions used in this guide are described in the table below.

Convention How Used

SMALL CAPITALS The names of all products such as BUSINESSOBJECTS, 
WEBINTELLIGENCE, SUPERVISOR, DESIGNER.

This font The names of BUSINESSOBJECTS classes, objects and 
conditions. 
For example, Customer, Sales, Revenue, Service, etc.

This font Code, SQL syntax, computer programs . 
For example:  @Select(Country\Country Id)
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Set-Up and Administration Error Messages

Set-up and administration error messages fall into the following categories:  

Range Category

ADM0003 - ADM0207 Administration errors

ADW0002 - ADW0025 Administration Wizard errors

INS0002 - INS0069 Installation errors
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The universe domain name is no longer valid. (ADM0003)

Cause Either the connection to the specified universe domain, or the universe domain 
itself is invalid.

Action Try the following:

1. Launch SUPERVISOR.

2. Select Tools > Repository.
The Repository Management dialog box is displayed.

3. Click the universe domain.

4. Click the Test button to check if the connection to the universe is valid.

5. Click the Integrity button to check if the universe domain itself is valid.

6. Do one of the following: 

Note: In a WEBINTELLIGENCE/BROADCAST AGENT environment, you should also 
check the connection on the server from which the connection is being made. Use 
SUPERVISOR on a Windows server, and another tool such as SQL*Plus on a UNIX 
server.

If Then...

the connection to the 
universe is invalid

Check the universe properties in Designer 
and then make sure that the connections to 
the repository and the Data Source Name 
are correctly set up (Tools > Connections > 
Edit).

the universe domain itself 
is invalid

Click the Scan button from the Repository 
Management dialog box. Then click Scan to 
display the Scan and Repair dialog box. 
From here, you can click Scan to report the 
errors, or you can click Repair to fix them.
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The document domain name is no longer valid. (ADM0004)

Cause Either the connection to the specified document domain, or the document 
domain itself is invalid.

Action Try the following:

1. Launch SUPERVISOR.

2. Select Tools > Repository.
The Repository Management dialog box is displayed.

3. Click the document domain.

4. Click the Test button to check if the connection to the document domain is 
valid.

5. Click the Integrity button to check if the document domain itself is valid.

To identify or repair errors, click Scan to display the Scan and Repair dialog box. 
From here, you can click Scan to report the errors, or you can click Repair to fix 
them.

Note: In a WEBINTELLIGENCE/BROADCAST AGENT environment, you should also 
check the connection on the server from which the connection is being made. Use 
SUPERVISOR on a Windows server, and another tool such as SQL*Plus on a UNIX 
server.

Cannot connect to the universe domain. (ADM0012)

Cause You cannot make a connection to the universe domain, either because there is no 
network connection, or the server on which the universe domain is located is 
down.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.
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Integrity problem. Please contact Business Objects Customer Support. (ADM0014)

Cause This message may be generated as a result of a Scan and Repair operation. The 
message means that one or more of the repository domains are corrupted. 

Action Contact Business Objects Customer Support.

Operation failed. (ADM0015)

Cause This error is displayed whenever you attempt to add new users to a damaged 
repository.

Action Run Scan and Repair in SUPERVISOR, as follows:

1.  In SUPERVISOR, go to Tools > Repository.
The Repository Management dialog box appears.

2.  Click the security domain.

3. Click the Scan button.
The Scan and Repair dialog box is displayed.

4.  Click Scan, and then click Repair.

Too many candidates (ADM0017)

Cause You tried to create or import a universe with too many loops, or a universe which 
endlessly loops between two or more tables.

Action The universe designer should run an Integrity Check on the universe to locate 
and fix the problem. The designer can then save and re-export the universe to the 
repository.
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Unsupported RDBMS (ADM0026)

Cause The installation of your ODBC databases is not correct, or the .sbo file has been 
changed or damaged. Each of the databases you are using has an associated .sbo 
file which is normally located in:

 Business Objects\Data Access 5.0 \database folder

The above error message is generated if you try to access your data warehouse 
via the repository after the associated database .sbo file has been moved, 
renamed, deleted, or damaged. This message can also occur if the .sbo is locked 
by another application or user.

Action Run Setup and re-install your ODBC connections (which you can find in the Data 
Access folder). This re-installs the Odbc.sbo file.

Example The name of the .sbo file for ODBC databases is Odbc.sbo.

Error encountered during processing. (ADM0032)

Cause This message may be generated when a Scan or Repair operation is performed. 
The message indicates that the structure or content of the repository is corrupted. 

Action Contact Business Objects Customer Support.

 Error updating repository. (ADM0034)

Cause This message may be generated when a Scan or Repair operation is performed. 
The message indicates that the structure or content of the repository is corrupted. 

Action Contact Business Objects Customer Support.
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You do not have access to this owner name. (ADM0037)

Cause The group to which you belong has not been granted access to the resource that 
you are trying to access.

Action The Supervisor or General Supervisor can modify your scope of management so 
that you can access this resource.

Unable to delete this Broadcast Agent. Ask the supervisor to scan and repair errors on your 
repository. (ADM0038)

Cause You tried to delete a BROADCAST AGENT server  for a particular group of users (via 
Group Properties), but SUPERVISOR is unable to delete the server due to missing 
links or inconsistencies in the repository.

Action To identify or repair the errors, click Scan to display the Scan and Repair dialog 
box. From here, you can click Scan to report the errors, or you can click Repair to 
fix them.

When you have done this, try deleting the BROADCAST AGENT server once more.

Password expiry information for user name is invalid. (ADM0051)

Cause In the User Definition dialog box, the Password Validity setting for the specified 
user is invalid. This message is generated when you run a Scan and Repair.

Action The supervisor should edit the user properties, and enter valid settings.
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The regular expression you gave for the list of characters allowed in the repository is invalid. 
(ADM0052)

Cause In SUPERVISOR, you entered a list of extra characters to be accepted as valid
(Tools > Options > Repository). However, one or more of the characters you 
entered are not supported by the RDBMS you are using.

Default valid characters are a-z (all lowercase letters), A-Z (all uppercase letters), 
0-9 (whole numbers from 0 to 9), dash (-), underscore (_), dollar ($) and space 
characters.

Action Edit the list of valid characters for the repository, using only characters that are 
supported by your RDBMS. The option is called Valid characters for repository 
(Tools > Options).

Parent class has changed. (ADM0069)

Cause One of the database objects you are trying to access belongs to a class whose name 
has been changed.

Action Ask the universe designer to fix the parent class definition, and to re-export the 
universe to the repository.

Parent class definition is incorrect. (ADM0070)

Cause One of the database objects you are trying to access belongs to a class which has 
an invalid name. Class names must be unique within a universe, and must not 
exceed 35 alphanumeric characters.

Action Ask the universe designer to fix the parent class definition, and to re-export the 
universe to the repository.
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 Input file error: no group defined on line [line number]. (ADM0071)

Cause You tried to import a list of users or groups from a text file. However, SUPERVISOR 
identified a user in the file who is not assigned to a group.

Action You have the following choices: 

You can correct any syntax errors in the import file with a text editor by scrolling 
to the specified line number, and adding the name of the group to the user 
information field. You can then try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Syntax You can use the following syntax to create new users from an import file:

NU, Group, UserName, UserPassword, Profile[GS,S,SD,D,U,V],
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N],
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Input file error: incorrect action on line [line number]. (ADM0072)

Cause You tried to import a list of users or groups from a text file. However, SUPERVISOR 
encountered an invalid command on the specified line.

Action You have the following choices: 

You can correct any invalid commands in the import file with a text editor by 
scrolling to the specified line number, and entering one of the recognized 
command below. Try importing the file once again.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.

Command Name Purpose

 NU New User

UU Update User

AG Add to Group

RG Remove from Group

DU Delete User

NG New Group

RR Rename Group

DG Delete Group

# Comment
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When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.
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Input file error: no user name defined on line [line number]. (ADM0073)

Cause You tried to import a list of users or groups from a text file. However, SUPERVISOR 
detected a missing user name on the specified line. 

Action You have the following choices: 

You can correct any syntax errors in the import file with a text editor by scrolling 
to the specified line number, and adding the user name. You can then try 
importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Syntax You can use the following syntax to create new users from an import file:

NU, Group, UserName, UserPassword, Profile[GS,S,SD,D,U,V],
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N],
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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User in group caused the following error: [error message]. (ADM0076)

Cause You tried to import a list of users or groups from a text file. However, SUPERVISOR 
detected a syntax error on the specified line. 

Action You have the following choices: 

Action You can correct any syntax errors in the import file with a text editor by scrolling 
to the specified line number, and entering the correct parameters. You can then 
try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Syntax You can use the following syntax to create new users from an import file:

NU, Group, UserName, UserPassword, Profile[GS,S,SD,D,U,V],
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N],
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

Example “Owen in group Development caused the following error: The password 
contains invalid characters. Valid characters are:  a-z A-Z 0-9 \- _ $ , and space 
(except at the beginning). (ADM0076).”

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration
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Cannot open the import file. (ADM0078)

Cause You tried to import a list of users into the repository, but the import file is 
damaged or corrupted.

Action Try opening the file in a text-editing application such as WordPad. If you cannot 
open the file, you need to create another one.

Cannot open the log file. (ADM0079)

Cause You tried to open an import log file, but the file is damaged or corrupted.

Action Try opening the file in a text-editing application such as WordPad. If you cannot 
open it, then delete it. The file is automatically generated whenever you import a 
list of users.
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User in group does not exist. (ADM0080)

Cause You tried to import a list of users or groups from a text file. However, the file 
contains an update command (UU) to rename a user who does not exist in a 
specified group. An update command is used to modify the properties of a user.

Action You have the following choices: 

You can correct any syntax errors in the import file with a text editor by scrolling 
to the specified line number, and entering the correct parameters. You can then 
try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Syntax You can use the following syntax to update users from an import file:

UU, Group, CurrentUserName, NewName, UserPassword, Profile[GS,S,SD,D,U,V], 
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N], 
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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The import file contains more than one update command for user in group. (ADM0081)

Cause You tried to import a list of users or groups from a text file. However, the file 
contains more than one update command for a particular user.  In such cases, 
SUPERVISOR takes the commands into account sequentially. 

Action More than one update command for a particular user may lead to undesired or 
conflicting modifications in the user’s properties. Open the import file to locate 
the commands and delete those that are unnecessary. 



v 5.1-2.7

 Error Message Guide 65

Line [line number]: cannot update user/group definition. (ADM0082)

Cause You tried to import a list of users or groups from a text file. However, the file 
contains invalid update information for a user or group.

Action You have the following choices: 

You can correct any errors in the import file with a text editor by scrolling to the 
specified line number, and entering the correct parameters. You can then try 
importing the file once again.When you import users and groups, SUPERVISOR 
generates an undo file. If you then import this file immediately after an import, 
you can reverse the effect of the operation. In other words, undo restores your 
configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration
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Syntax You can use the following syntax to update users from an import file:

UU, Group, CurrentUserName, NewName, UserPassword, Profile[GS,S,SD,D,U,V], 
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N], 
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.
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Cannot delete user in group because it does not exist. (ADM0083)

Cause You tried to import a list of users or groups from a text file. However, the file 
contains a command for deleting a user who does not exist in the specified group.

Action You have the following choices:  

You can correct the errors in the import file with a text editor by scrolling to the 
specified line number, and entering the correct parameters. You can then try 
importing the file once again. 

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Syntax Use the following syntax to delete a user from an import file:

RG, Group, ExistingUserName

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Cannot create user because the specified parent group does not exist. (ADM0084)

Cause You tried to import a list of users or groups from a text file. However, the file 
contains a command for creating a user who belongs to a group that does not 
exist.

Action You have the following choices:  

You can correct any syntax errors in the import file with a text editor by scrolling 
to the specified line number, and entering the correct parameters. You can then 
try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Syntax You can use the following syntax to create users from an import file:

NU, Group, UserName, UserPassword, Profile[GS,S,SD,D,U,V],
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N],
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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An error occurred during import. (ADM0085)

Cause SUPERVISOR was not able to import a list of users or groups because it could not 
open the import file.

Action The import file is probably either damaged or corrupted. Quit SUPERVISOR, and 
try opening the file in a standard text editor.
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Error during creation of password aging for user ID # [user ID number]. (ADM0087)

Cause You tried to import a list of users or groups from a text file. However, the file 
contains a command which sets password aging for a user. This command 
contains a syntax error. Password aging means that users are required to change 
their assigned passwords after a specified number of days.

Action You have the following choices:  

You can correct any syntax errors in the import file with a text editor by scrolling 
to the specified line number, and entering the correct parameters. You can then 
try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Syntax You can use the following syntax to create new users from an import file:

NU, Group, UserName, UserPassword, Profile[GS,S,SD,D,U,V],
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N],
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Error during update of password aging for user ID # [line number].  (ADM0088)

Cause You tried to import a list of users or groups from a text file. However, the file 
contains a command which sets password aging for a user. This command 
contains a syntax error. Password aging means that users are required to change 
their assigned passwords after a specified number of days.

Action You have the following choices:  

You can correct any syntax errors in the import file with a text editor by scrolling 
to the specified line number, and entering the correct parameters. You can then 
try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Syntax You can use the following syntax to create new users from an import file:

NU, Group, UserName, UserPassword, Profile[GS,S,SD,D,U,V],
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N],
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Subgroup in group already exists. The line will be processed as an update. (ADM0089)

Cause You tried to import a list of users or groups from a text file. However, the file 
contains a command to create an existing subgroup in a group. The command is 
thus processed as an update not a creation.

Action You have the following choices:  

You can correct any errors in the import file with a text editor by scrolling to the 
specified line number, and entering the correct parameters. You can then try 
importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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You are not authorized to create a group. Line [line number] will not be processed. 
(ADM0090)

Cause You tried to import a list of users or groups from a text file. This file includes a 
New Group (NG) command. However, another supervisor (or the General 
Supervisor) has not authorized you to create new groups.

Action You have the following choices:  

The General Supervisor can grant you the necessary security commands.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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You are not authorized to create a user with higher privileges than you. Line [line number] will 
not be processed. (ADM0091)

Cause You tried to import a list of users or groups from a text file. One user in the file 
has higher privileges than those in your own user properties. By “privileges” is 
meant the object security level assigned to a user. This level determines the 
objects a user can work with a universe.

Object security levels are from highest to lowest: Private, Confidential, Restricted, 
Controlled and Public. In an import file, these parameters are entered as: 

• PC (Private)

• CD (Confidential)

• R (Restricted)

• C1 (Controlled)

• PC (Public)

Action You have the following choices:  

Check to see that you have entered the parameter correctly in the import file. 
Otherwise, see the General Supervisor about how object security levels are 
assigned in your organization.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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You are not authorized to create a user. Line [line number] will not be processed. (ADM0092)

Cause You tried to import a list of users or groups from a text file. This file includes a 
New User (NU) command. However, another supervisor (or the General 
Supervisor) has not authorized you to create new users. 

Action You have the following choices:  

See the General Supervisor or the other supervisors at your site to find out about 
the reasons for the restriction.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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You are not authorized to delete a group. Line [line number] will not be processed. 
(ADM0093)

Cause You tried to import a list of users or groups from a text file. This file includes a 
Delete Group (DG) command. However, another supervisor (or the General 
Supervisor) has not authorized you to create new users. 

Action You have the following choices:  

See the General Supervisor or the other supervisors at your site to find out about 
the reasons for the restriction.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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You are not authorized to delete a user. Line [line number] will not be processed. (ADM0094)

Cause You tried to import a list of users or groups from a text file. This file includes a 
Delete User (DU) command. However, another supervisor (or the General 
Supervisor) has not authorized you to delete users. 

Action You have the following choices:  

See the General Supervisor or the other supervisors at your site to find out about 
the reasons for the restriction.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all 
remaining valid commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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You are not authorized to rename a user. Line [line number] will not be processed. 
(ADM0095)

Cause You tried to import a list of users or groups from a text file. This file includes an 
update command (UU) for renaming a user. However, another supervisor (or the 
General Supervisor) has not authorized you to rename users. 

Action You have the following choices:  

See the General Supervisor or the other supervisors at your site to find out about 
the reasons for the restriction.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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You are not authorized to rename a group. Line [line number] will not be processed. 
(ADM0096)

Cause You tried to import a list of users or groups from a text file. This file includes a 
Rename Group (RG) command. However, another supervisor (or the General 
Supervisor) has not authorized you to rename groups. 

Action You have the following choices:  

See the General Supervisor or the other supervisors at your site to find out about 
the reasons for the restriction.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration
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You are not authorized to disable a user. Line [line number] will not be processed. (ADM0097)

Cause You tried to import a list of users or groups from a text file. This file includes an 
update command (UU) for disabling a user’s login. However, another supervisor 
(or the General Supervisor) has not authorized you to disable user logins. 

Action You have the following choices:  

See the General Supervisor or the other supervisors at your site to find out about 
the reasons for the restriction.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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You are not authorized to change a user's properties. Line [line number] will not be 
processed. (ADM0098)

Cause You tried to import a list of users or groups from a text file. This file includes an 
update command (UU) for modifying one or more properties of a user. However, 
another supervisor (or the General Supervisor) has not authorized you to modify 
a user’s properties. 

Action You have the following choices:  

The syntax for the parameters comprising a user’s properties are given below.

UU, Group, CurrentUserName, NewName, UserPassword, Profile[GS,S,SD,D,U,V], 
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N], 
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

See the General Supervisor or the other supervisors to find out about the reasons 
for the restriction on modifying user properties.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Cannot create user as General Supervisor in a subgroup. (ADM0101)

Cause You tried to import a list of users or groups from a text file. This file includes an 
invalid new user command (NU) for creating a general supervisor within a 
group. You can create general supervisors only at the root level.

Action You have the following choices:  

Open the import file with a text editor and remove the group name from the user 
information field. Try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Error in creating a user/group definition. (ADM0102)

Cause You tried to import a list of users or groups from a text file but SUPERVISOR could 
not create a user or group. This problem is due to a syntax error in the import file.

Action You have the following choices:  

Syntax You can use the following syntax to create new users from an import file:

NU, Group, UserName, UserPassword, Profile[GS,S,SD,D,U,V],
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N],
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

Here is the syntax to create new groups from an import file:

NG, ParentGroup, GroupName

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Cannot create undo file. (ADM0103)

Cause 1 When importing a list of users or groups to the repository, SUPERVISOR normally 
creates an Undo file by default. In this case, however, it cannot create an Undo file 
because the BUSINESSOBJECTS folder is write-protected. 

Action Ask the system or network administrator to grant you full write access to the 
BUSINESSOBJECTS folder.

 Cause 2 When importing a list of users or groups to the repository, SUPERVISOR normally 
creates an Undo file by default. In this case, however, it cannot create an Undo file 
because the file would be too large for the disk.

Action Check the available disk space on the drive where BUSINESSOBJECTS is installed. 
You probably need to empty your Recycle Bin or delete some unnecessary files.
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Error in updating password aging for user ID. (ADM0104)

Cause You tried to import a list of users or groups from a text file but SUPERVISOR could 
not update the password aging for a user. Password aging means that users are 
required to change their assigned passwords after a specified number of days. 

Action You have the following choices:  

You can correct any errors in the import file with a text editor by scrolling to the 
specified line number, and entering the correct parameters. You can then try 
importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Syntax You can use the following syntax to update users from an import file:

UU, Group, CurrentUserName, NewName, UserPassword, Profile[GS,S,SD,D,U,V], 
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N], 
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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User has an unknown parent: [group name]. (ADM0105)

Cause You tried to import a list of users or groups from a text file. This file includes an 
invalid New User (NU) command for creating a user within an unknown group.

Action You have the following choices:  

Syntax You can use the following syntax to create new users from an import file:

NU, Group, UserName, UserPassword, Profile[GS,S,SD,D,U,V],
DisableLogin[Y,N], EnableOfflineLogin[Y,N], EnablePasswordModification[Y,N],
EnableRealTimeUserRightsUpdate[Y,N], EnableDeleteDocument[Y,N], 
ObjectSecurityLevel[PC,CD,R,Cl,PE], IdentificationStrategy[F,N], 
ChangePasswordAtFirstLogin[Y,N], PasswordValidityDays[N,1-365], 
PeriodicAction[Y,N]

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

For information on the commands and syntax you can use with an import file, 
refer to Chapter 8, “Importing and Exporting Users and Groups” in the 
Supervisor’s Guide.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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You are not authorized to remove a user. Line [line number] will not be processed. (ADM0113)

Cause You tried to import a list of users or groups from a text file. The file includes a 
Remove User from Group (RG) command. However, the General Supervisor or 
another supervisor has not authorized you to remove users from groups. 

Action You have the following choices:  

See the General Supervisor or the other supervisors at your site to find out about 
the reasons for the restriction.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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On line [line number], user name exceeds authorized length. (ADM0114)

Cause You tried to import a list of users or groups from a text file. The file includes a 
user definition with a user name made up of more than 32 characters.

Action You have the following choices:  

Open the import file with a text editor and enter a new user name with less than 
32 characters in the user information field. Try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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On line [line number], user’s password exceeds authorized length. The default password will 
be applied. (ADM0116)

Cause You tried to import a list of users or groups from a text file. The file includes a 
user definition with a password containing more than 32 characters. If you do not 
change the password, SUPERVISOR applies the default password which is the user 
name.

Action You have the following choices:  

Open the import file with a text editor and enter a password made up of less than 
32 characters in the user information field. If you simply remove the password 
from the file, then the user has no assigned password. Try importing the file once 
again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Example NU, Group1, Paul, P12345678901234567890123456789012345, U

In the New User command above, the user’s password exceeds the authorized 
length of 32 characters. If you do not change it, the password will be the same as 
the user name (Paul).

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Incorrect type on line [line number]. Default type (user) will be set. (ADM0117)

Cause You tried to import a list of users or groups from a text file. The file includes a 
missing or incorrect profile on the specified line of the import file.

Action You have the following choices:  

Open the import file with a text editor and enter a correct user profile:

• GS (General Supervisor)

• S (Supervisor)

• SD (Supervisor-Designer)

• D (Designer)

• U (User)

• V (Versatile)

If you do not specify a profile for a user in the import file, SUPERVISOR 
automatically applies the user profile. Try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Incorrect value for Object Security Level on line [line number]. Default value (public) will be 
set. (ADM0118)

Cause You tried to import a list of users or groups from a text file. The file includes a 
missing or incorrect security level on the specified line of the import file.

Action You have the following choices:  

Open the import file with a text editor and enter a correct security level:

• PE (Private)

• CL (Confidential)

• R (Restricted)

• CD (Controlled)

• PC (Public)

If you do not specify an object security level for a user in the import file, 
SUPERVISOR automatically applies the public object security level. Try importing 
the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Incorrect value for Identification Strategy on line [line number]. Default value (full) will be set. 
(ADM0119)

Cause You tried to import a list of users or groups from a text file. The file includes a  
missing or incorrect identification strategy on the specified line of the import file. 
Identification strategy refers to the password checking system associated with 
the user.

Action You have the following choices:  

Open the import file with a text editor and enter either F (Full) or N (Never). These 
parameters cause the BUSINESSOBJECTS repository either to always (F) or never 
(N) check the new user’s password at login. Try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all 
remaining valid commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Incorrect value for Change Password At First Login on line [line number]. Default value (full) 
will be set. (ADM0120)

Cause You tried to import a list of users or groups from a text file. The file includes a  
missing or incorrect Change Password At First Login parameter on the specified 
line of the import file.

Action You have the following choices:  

Open the import file with a text editor and enter a correct parameter: Y (Yes) or N 
(No). Try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Incorrect value for Enable Delete Document on line [line number]. Default value (yes) will be 
set. (ADM0127)

Cause You tried to import a list of users or groups from a text file. The file includes a  
missing or incorrect Enable Delete Document parameter on the specified line of 
the import file.

Action You have the following choices:  

Open the import file with a text editor and enter a correct parameter: Y (Yes) or N 
(No). Try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all 
remaining valid commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Error on line [line number]: Cannot remove a group as a user. This line will be processed as a 
Delete Group action. (ADM0130)

Cause You tried to import a list of users or groups from a text file. The file includes a  
Remove Group command which is invalid. You can delete but not remove a 
group. 

The syntax for deleting a group is as follows:

Syntax DG, GroupName

Action You have the following choices:  

Open the import file with a text editor and enter the correct command and syntax:

DG, GroupName

Then try importing the file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue deletes the group; it also processes all remaining commands 
but stops if it detects another syntax error. All valid 
commands have an effect on the configuration.
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Error on line [line number]: Cannot remove user from group because the user does not exist. 
(ADM0131)

Cause You tried to import a list of users or groups from a text file. The file includes a  
Remove Group command which is invalid because it specifies a user who does 
not exist or whose name is misspelled.

Action You have the following choices:  

Open the import file with a text editor and enter the user name. Try importing the 
file once again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

Example RG, Marketing, Paul, ,u 

The command above is an instruction to remove the user Paul from the 
Marketing group. However, there is no such user in the Marketing group.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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 Error on line [line number]: An error occurred during deletion of user in the group. (ADM0132)

Cause You tried to import a list of users or groups.  SUPERVISOR encountered a command 
to delete a user (DU), but the user information is corrupted, and cannot be deleted 
from the repository. 

Action You have the following choices:  

You should perform a Scan and Repair on the repository to fix the corrupted data, 
and then import the file again.

When you import users and groups, SUPERVISOR generates an undo file. If you 
then import this file immediately after an import, you can reverse the effect of the 
operation. In other words, undo restores your configuration to its original state.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Cannot read file. Please check the installation. (ADM0133)

Cause This error pertains to the rules file. The srrules.srr rules file determines and 
controls how SUPERVISOR performs a Scan and Repair operation. It is, in fact, the 
Scan and Repair script. This script file is installed in the BusinessObjects 5.0 
folder, and is provided in unencrypted format. System or network administrators 
can, at their own risk, modify the contents of this file.

If you receive the above error message, the srrules.srr file may have been:

• moved

• deleted

• renamed

• modified

• corrupted

Example

Action You need to replace the srrules file with a clean copy of the file, either from 
another BUSINESSOBJECTS installation, or with one provided by Business Objects 
Customer Support. 
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Incorrect rules file. Please check the installation. (ADM0134)

Cause The srrules.srr rules file determines and controls how SUPERVISOR performs a 
Scan and Repair operation. It is, in fact, the Scan and Repair script. This script file 
is installed in the BusinessObjects 5.0 folder, and is provided in unencrypted 
format. System or network administrators can, at their own risk, modify the 
contents of this file.

If you receive the above error message, the srrules.srr file has been modified.

Action You need to replace the srrules file with a clean copy of the file, either from 
another BUSINESSOBJECTS installation, or with one provided by Business Objects 
Customer Support. 

Cannot write to file. Check that it is not already in use by another application. (ADM0155)

Cause You tried to export a list of users/groups to a file which already exists in the file 
system, but the selected file is read-only, or is currently being used by another 
user or application.

Action If the file is read-only, then choose another filename, or ask the Windows NT 
administrator to provide you with access to the file. If the file is being used by 
another user or application, wait until the file is released, and then try again.

The default name is used as the password. Its length must be greater than the minimum 
password length that has been specified.  (ADM0157)

Cause Because you entered no password, the Default Name is used as the password. 
However, the Default Name contains invalid characters.

Action The characters that can be used are limited to the letters of the Latin alphabet, the 
numbers, $ and space (except at the beginning).

When creating users or groups in SUPERVISOR, you can define your own 
authorized characters. 
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The default user name contains invalid characters. Valid characters are  (ADM0158)

Cause The Default Name contains invalid characters.

Action The characters that can be used are limited to the letters of the Latin alphabet, the 
numbers, $ and space (except at the beginning).

When creating users or groups in SUPERVISOR, you can define your own 
authorized characters. 

The default group name contains invalid characters. Valid characters are (ADM0159)

Cause Because you entered no password, the Default Name is used as the password. 
However, the Default Name contains invalid characters.

Action The characters that can be used are limited to the letters of the Latin alphabet, the 
numbers, $ and space (except at the beginning).

When creating users or groups in SUPERVISOR, you can define your own 
authorized characters. 

Error while loading data for table. (ADM0161)

Cause This message may be one of the messages generated when you perform a Scan 
and Repair operation. SUPERVISOR cannot update data in the specified table due 
to a corrupted repository.

Action Contact Business Objects Customer Support.
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Error during update. (ADM0169)

Cause SUPERVISOR encountered errors while attempting to update the repository from 
an earlier version. This may be because the existing repository already contained 
errors, or because you are trying to update from a version of BUSINESSOBJECTS 
which pre-dates version 4.x.

Action You can update your repository only from BUSINESSOBJECTS 4.x. You cannot 
update directly to BUSINESSOBJECTS 5.0 from an earlier version (such as 3.x). If you 
want to update from version 3.x, you must first perform an intermediate update 
to version 4.x, and then update to 5.0.

In all cases, you are advised to run a Scan and Repair before updating your 
repository, and make sure the repository is stable, compact, and error-free. 

Line [line number]: You are not allowed to update your own settings. (ADM0170)

Cause 1 You tried to import a list of users/groups that were previously exported, or that 
already exist in your repository.

 Cause 2 While importing a list of users, SUPERVISOR encountered a command to update 
your own user profile on the specified line of the import file.

Action You have the following choices  

The General Supervisor  can grant you the necessary security commands.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuratin.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration
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Line [line number]: Password must contain more than [???] characters. The command will not 
be processed. (ADM0171)

Cause While importing a list of users, SUPERVISOR encountered a password that 
contained less than the minimum number of characters on the specified line of the 
import file. This minimum figure is specified by the General Supervisor. 

Action You have the following choices  

Line [line number]: encrypted password error. (ADM0172)

Cause You tried to import a user who was previously exported, and who now has a 
corrupted or incorrect encrypted password.

Action Include the No_Encrypted_Password command in the import file, and try 
importing it again. You may also need to remove the encrypted password from 
the specified line number, since it may contain illegal characters that would 
generate another error.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration.
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Line [line number]: Internal error while deleting user in group. (ADM0173)

Cause You attempted to import a list of users or groups. The file contains a command 
for deleting a user. However, SUPERVISOR cannot delete the user because the 
configuration of this user has become corrupted. 

Action You have the following choices:  

If you continue, you should later run a Scan and Repair to try to fix this problem.

If you click then Supervisor

Skip All ignores all syntax errors in the text file but processes all valid 
commands.

Abort ends the import operation with no effect on the configuration.

Continue processes all remaining commands but stops if it detects 
another syntax error. All valid commands have an effect on 
the configuration
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 The srrules.srr file containing the Scan and Repair script is different from the one shipped with 
BusinessObjects. Scan and Repair will not proceed. Please retrieve a correct srrules.srr file. 
(ADM0176)

Cause The srrules.srr rules file determines and controls how SUPERVISOR performs a 
Scan and Repair operation. It is, in fact, the Scan and Repair script. This script file 
is installed in the BusinessObjects 5.0 folder, and is provided in unencrypted 
format. System or network administrators can, at their own risk, modify the 
contents of this file.

If you receive the above error message, you tried to run a Scan or Repair after the 
srrules.srr file has been:

• moved

• deleted

• renamed

• modified

• corrupted

Action You need to replace the srrules file with a clean copy of the file, either from 
another BUSINESSOBJECTS installation, or with one provided by Business Objects 
Customer Support. 
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Checksum validation failed. (ADM0177)

Cause The srrules.srr rules file determines and controls how SUPERVISOR performs a 
Scan and Repair operation. It is, in fact, the Scan and Repair script. This script file 
is installed in the BusinessObjects 5.0 folder, and is provided in unencrypted 
format. System or network administrators can, at their own risk, modify the 
contents of this file.

If you receive the above error message, you tried to run a Scan or Repair. 
However, the srrules.srr file containing the Scan and Repair script is different 
from the one shipped with BUSINESSOBJECTS, and  Scan and Repair does not 
proceed. The srrules.srr file may have been:

• moved

• deleted

• renamed

• modified

• corrupted

Action You need to replace the srrules file with a clean copy of the file, either from 
another BUSINESSOBJECTS installation, or with one provided by Business Objects 
Customer Support. 

Error in dialog initialization. Contact Business Objects Customer Support. (ADM0178)

Cause This message may be one of messages generated when you perform a Scan and 
Repair operation. However, Scan and Repair cannot fix the problem due to a 
corrupted repository.

Action Contact Business Objects Customer Support.
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Error during update of the security command. Contact Business Objects Customer Support. 
(ADM0179)

Cause This message may be one of the messages generated when you perform a Scan 
and Repair operation. However, Scan and Repair cannot fix the problem due to a 
corrupted repository.

Action Contact Business Objects Customer Support.

Error during insertion of the security command. Contact Business Objects Customer Support. 
(ADM0180)

Cause This message may be one of the messages generated when you perform a Scan 
and Repair operation. However, Scan and Repair cannot fix the problem due to a 
corrupted repository.

Action Contact Business Objects Customer Support.

Error during deletion of the security command. Contact Business Objects Customer Support. 
(ADM0181)

Cause This message may be one of the messages generated when you perform a Scan 
and Repair operation. However, Scan and Repair cannot fix the problem due to a 
corrupted repository.

Action Contact Business Objects Customer Support.
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You cannot delete a built-in predefined setting. (ADM0182)

Cause This message is displayed if you try to delete one of the built-in predefined 
settings in SUPERVISOR. 

Action The built-in predefined settings cannot be deleted. You can delete only the 
predefined settings that you created yourself.

Example

The name of the predefined setting already exists. Please choose another. (ADM0183)

Cause You tried to create a new predefined setting in SUPERVISOR, but the name you 
entered is the same as an existing predefined setting. 

Action Enter a unique name for your new predefined setting.
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Error while retrieving [???] command rights. Contact Business Objects Customer Support. 
(ADM0184)

Cause This message may be one of the messages generated when you perform a Scan 
and Repair operation. However, Scan and Repair cannot fix the problem due to a 
corrupted repository.

Action Contact Business Objects Customer Support.

Unknown (ADM0194)

Cause This message may be one of the messages generated when you perform a Scan 
and Repair operation. However, Scan and Repair cannot fix the problems due to 
a corrupted repository.

Action Contact Business Objects Customer Support.

The current user cannot be found. Please contact your supervisor. (ADM0195)

Cause While you were logged into a BUSINESSOBJECTS session, your user ID was deleted 
from the repository by the supervisor.

Action The supervisor must first re-create your user ID before you can continue working 
with BUSINESSOBJECTS.
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The default connection cannot be found. Please check the connection value. (ADM0198)

Cause 1 The connection to the specified universe domain may be invalid.

Action Do the following:

1. Launch SUPERVISOR.

2. Select Tools > Repository.
The Repository Management dialog box is displayed.

3. Click the universe domain.

4. Click Test to to check if the connection to the universe domain is valid.

5. Check the universe properties.

6. Make sure that your connections to the repository and Data Source Name are 
correctly set up (Tools > Connections > Edit).

 Cause 2 You cannot make a connection to the universe domain, either because there is no 
network connection, or the server on which the universe domain is located is 
down.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should use database middleware (such as 
Net8 for Oracle) to check if there is any response from the repository database.

The specified PDF file cannot be found. (ADM0199)

Cause You tried view one of the online guides from the Help menu, but the associated 
PDF file has been moved, deleted, or renamed.

Action You need to copy the file back to its correct location: 

Business Objects\Online Guides\En

You can do this by copying the missing file from another BUSINESSOBJECTS 
installation, or by running the BUSINESSOBJECTS Setup program, and re-installing 
the necessary documentation components.
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Cannot start agent UX. Contact Business Objects Customer Support. (ADM0200)

Cause A required .dll file has been deleted or damaged.

Action First, run Setup to re-install SUPERVISOR, and then try to start SUPERVISOR. If the 
error persists, you may also have to re-install DESIGNER.

Error during copy. Contact Business Objects Customer Support. (ADM0201)

Cause This error message may occur when you import data to the repository. It 
indicates that one or more tables of the repository are corrupted.

Action Contact Business Objects Customer Support.

Cannot load driver's DLL. Make sure it is installed in the same folder as Supervisor.exe. 
(ADM0202)

Cause In SUPERVISOR, the General Supervisor has enabled Windows NT Authentication 
(Tools > Option > Security Policy), but BUSINESSOBJECTS cannot find the 
KNTUI50.DLL file that it needs to enable this feature.

Action The authentication driver is based on the BUSINESSOBJECTS Plug and Play security 
driver mechanism, so all you have to do to activate it is:

1. Delete or move KGLUI50.DLL from the BusinessObjects 5.0 folder.

2. Copy KNTUI50.DLL to KGLUI50.DLL.
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Cannot install driver. Contact Business Objects Customer Support. (ADM0203)

Cause In SUPERVISOR, the General Supervisor has enabled Windows NT Authentication 
(Tools > Options > Security Policy), but BUSINESSOBJECTS cannot install the 
KNTUI50.DLL file that it needs to enable this feature. The KNTUI50.DLL file may 
be damaged.

Action Copy a backed-up version of the the KNTUI50.DLL file to the BusinessObjects 5.0 
folder.

The domain you specified cannot be reached. To add a domain, you must have network 
access to it. (ADM0204)

Cause In SUPERVISOR, you tried to add a domain to be accepted by the Windows NT 
Authentication driver. You did this in the Options dialog, as follows:

 Tools > Options > Security Policy > Enable WinNT Authentication > New

However, the Domain you specified cannot be accessed.

Action You must have network access to the domain. Check that you have entered the 
domain description accurately, and that your network is working correctly. 

Example
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You must select the 'Start/End Date', 'Start/End Time' or 'How' parameter for this timestamp. 
(ADM0205)

Cause While editing a timestamp for a user/group, you disabled all of the timestamp 
checkboxes (Start/End Date - Start/End Time - How).

Action Check one or more of the Start/End Date - Start/End Time - How checkboxes. At 
least one of these checkboxes must be enabled.

The end time must be later than the start time. (ADM0206)

Cause While defining a Timestamp to determine when a group can log into an assigned 
BUSINESSOBJECTS application (User/Group Properties in SUPERVISOR), you 
entered an end date/time that preceded the start date/time.

Action Edit the end date—it must be later than the start date.

Setup failed! (ADW0002)

Cause 1 BUSINESSOBJECTS must create a temporary folder during installation.  This folder 
is deleted when the installation is finished. However, the disk is full.

Action Empty your Recycle Bin. If necessary, delete any redundant or unwanted files, 
and empty the Recycle Bin again.

 Cause 2 You have read-only privileges to the root C:\ drive.  

Action The system or network administrator can grant you Change or Full Control 
privileges on the C:\ root drive.
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There is no valid connection! (ADW0003)

Cause 1 While running the SUPERVISOR Administration Setup Wizard, you selected an 
invalid network layer.

Action Select a network layer which is available on your system. For testing purposes, 
you can always select the ODBC drivers.

 Cause 2 While running the SUPERVISOR Administration Setup Wizard, you selected a 
valid network layer, but did not specify a database engine or data source.

Action Once you have selected a valid network layer, you must click the Setup button 
and select the database engine you are using, as well as the name of the data 
source.

Cannot find key file. (ADW0005)

Cause You do not have read access to the LocData folder, which contains the key file.

Action The Windows NT administrator can grant you read access to this folder. This is 
done as follows:

1. Click the Sharing properties of the folder.

2. Select the Security tab.

3. Click the Permissions button.

4. Double-click on Everyone.

5. Check Read (R).
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Cannot create key file. (ADW0006)

Cause Safe Recovery failed to create the key file at the end of the wizard. This is because 
you do not have write privileges on the folder in which the file is located.

Action The Windows NT administrator can grant you write access to this folder. This is 
done as follows:

1. Click the Sharing properties of the folder.

2. Select the Security tab.

3. Click the Permissions button.

4. Double-click on Everyone.

5. Check Write (W).

Cannot create [name].KEY file. (ADW0007)

Cause Safe Recovery failed to create the key file at the end of the wizard. This is because 
you do not have write privilege on the folder in which the file is located.

Action The Windows NT administrator can grant you write access to this folder. This is 
done as follows:

1. Click the Sharing properties of the folder.

2. Select the Security tab.

3. Click the Permissions button.

4. Double-click on Everyone.

5. Check Write (W).
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Cannot create the General Supervisor. (ADW0008)

Cause There was a problem during the creation of the repository. The repository was 
only partly installed, and no General Supervisor was created.

Action Delete all the files that were already installed, and then run the Installation 
Wizard once more. When the repository has been installed, and the General 
Supervisor has been successfully created, run an integrity check
(Tools > Repository > Integrity) to verify that there are no further problems.

The company name contains invalid characters or is empty. (ADW0009)

Cause While running the Administration Setup Wizard, you used one or more invalid 
characters when entering the name of your company, or you left the field empty.

Action Enter or re-enter a Company Name, using only valid characters. Valid characters 
include: a-z  A-Z  0-9  \- _ $ , and Space (except at the beginning)

Note: When creating users or groups in SUPERVISOR, you can define your own 
authorized characters.
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No security domain exists for this connection. (ADW0010)

You ran a Safe Recovery and received this error.

Cause 1 The database connection does not point to the correct repository. Instead, it 
points to a repository which does not contain a security domain.

Action In Supervisor, check that the database connection points to the correct repository 
(Tools > Connections > Edit).

 Cause 2 The connection points to the correct security domain but some tables are missing 
in the database account.

Action Make sure the database account contains all the security domain tables necessary. 
For BUSINESSOBJECTS version 5.0 there should be 25 tables.

 Cause 3 The connection points to the correct security domain in the database account. 
However, even if the account has select privileges it is not the owner of the tables.

Action Specify the connection by indicating the owner of the account. The reason for this 
is that the SQL generated during a Safe Recovery executes a Select statement such 
as:

“Select M_ACTOR_N_ID from OBJ_M_ACTOR where 1=0” and another account 
name is not included (“...from owner.OBJ_M_ACTOR”).

Make sure that all the tables of the security domain are in the same account. They 
may not be in the same account if the repository was updated from version 4 and 
the update SQL file was customized.

You can also try the following:

• Run a trace using the BOLOGAPP.exe utility to find out exactly where the 
problem is.

• If you have two versions of BUSINESSOBJECTS, run a Safe Recovery in both 
versions specifying the same connection. You can then compare the results.
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Cannot create universe domain. (ADW0011)

Cause You tried to create a universe domain, but the system on which you want the 
domain to reside cannot be reached. Either the node is not running, or the 
network connection is down.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.

Cannot find RSS file. (ADW0012)

Cause A .rss file is associated with each of the databases that you are using. These files 
are located in the associated database folders, which can be found in the:

Business Objects\Data Access 5.0 folder.

You may receive the above error message if BUSINESSOBJECTS tries to access one 
of these databases after the associated .rss file has been deleted or corrupted.

Action You need to replace the deleted or corrupted .rss file with a clean copy of the file, 
either from another BUSINESSOBJECTS installation, or with one provided by 
Business Objects Customer Support. 

Cannot find Repository section in RSS file. (ADW0013)

Cause A .rss file is associated with each of the databases that you are using. These files 
are located in the associated database folders, which can be found in the
Business Objects\Data Access 5.0 folder.

You receive the above error message if BUSINESSOBJECTS tries to access the 
Repository section in one of these database .rss files after this section of the file 
has been corrupted.

Action You need to replace the corrupted .rss file with a clean copy of the file, either from 
another BUSINESSOBJECTS installation, or with one provided by Business Objects 
Customer Support. 
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Cannot find Create section in RSS file. (ADW0014)

Cause An .rss file is associated with each of the databases that you are using. These files 
are located in the associated database folders, which can be found in the 
Business Objects\Data Access 5.0 folder.

You may receive the above error message if BUSINESSOBJECTS tries to access the 
Create section in one of these database .rss files after this section of the file has 
been corrupted.

Action You need to replace the corrupted .rss file with a clean copy of the file, either from 
another BUSINESSOBJECTS installation, or with one provided by Business Objects 
Customer Support. 

Cannot find Table section in RSS file. (ADW0015)

Cause An .rss file is associated with each of the databases that you are using. These files 
are located in the associated database folders, which can be found in the 
Business Objects\Data Access 5.0 folder.

You may receive the above error message if BUSINESSOBJECTS tries to access the 
Table section in one of these database .rss files after this section of the file has been 
corrupted.

Action You need to replace the corrupted .rss file with a clean copy of the file, either from 
another BUSINESSOBJECTS installation, or with one provided by Business Objects 
Customer Support. 
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Cannot find Index section in RSS file. (ADW0016)

Cause A .rss file is associated with each of the databases that you are using. These files 
are located in the associated database folders, which can be found in the 
Business Objects\Data Access 5.0 folder.

You may receive the above error message if BUSINESSOBJECTS tries to access the 
Index section in one of these database .rss files after this section of the file has 
been corrupted.

Action You need to replace the corrupted .rss file with a clean copy of the file, either from 
another BUSINESSOBJECTS installation, or with one provided by Business Objects 
Customer Support. 

Cannot find Insert section in RSS file. (ADW0017)

Cause A .rss file is associated with each of the databases that you are using. These files 
are located in the associated database folders, which can be found in the 
Business Objects\Data Access 5.0 folder.

You may receive the above error message if BUSINESSOBJECTS tries to access the 
Insert section in one of these database .rss files after this section of the file has 
been corrupted.

Action You need to replace the corrupted .rss file with a clean copy of the file, either from 
another BUSINESSOBJECTS installation, or with one provided by Business Objects 
Customer Support. 

You must update the repository before creating a new domain. (ADW0018)

Cause You updated to BUSINESSOBJECTS 5.0 and attempted to create a new repository 
domain. However, you have not yet updated the repository.

Action Run SUPERVISOR, and run the Upgrade Wizard to update the repository to 
BUSINESSOBJECTS version 5.0.
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Cannot create document domain. (ADW0019)

Cause 1 The disk is full.

Action Empty your Recycle Bin. If necessary, delete any redundant or unwanted files, 
and empty the Recycle Bin again.

 Cause 2 You have read-only privileges to the root C:\ drive.  

Action The system or network administrator can grant you Change or Full Control 
privileges on the C:\ root drive.

 Cause 3 You are trying to create the document domain on another machine (cluster node), 
but either the machine is down, or the connection is not working correctly.

Action Run the ServConf utility to see if the machine is responding.

“Ping” the machine to see if the network connection is valid.
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Cannot create security domain. (ADW0020)

This problem occurs when the initial repository is being created.  It does not 
complete the installation of the security domain.  In most cases the problem 
occurs on the OBJ_M_MAGIC_ID table. 

Cause 1 The problem lies somewhere in your configuration.

Action Try the following to diagnose the problem:

•  Make sure you are using a supported platform to install the repository.

• Make sure that you are using database middleware compatible with the 
current version of BUSINESSOBJECTS.

•  Make sure there is enough space to create the repository tables.

•  If possible, try to create the tables on another database of the same type, and 
then export the tables if setup completes successfully.

•  Try running a Custom Install in SUPERVISOR.

 Cause 2 The external SQL file cannot be accessed or found during the installation of the 
product.

Action You need to manually amend the related *.sbo file.

Example Let’s say you are attempting to create a repository on IBM DB2/390 version 5 but 
received the above error message. Here are the steps you need to carry out to 
remedy the problem:

1. Open the db2.sbo file using a text editor such as Notepad.
This file is located in BusinessObjects 5.0\Data Access 5.0\Db2

2. In the sections [DEFAULT] and [DB2 Connect  for DB2/390 v5] add the 
following parameter: 
SQL DDL File=db2
This causes BUSINESSOBJECTS to point to the current SQL file thus enabling you 
to create a repository.

Note: This solution applies only to the creation of a new 5.0 repository. If does not 
have an effect on an update of the repository from version 4.x to 5.0
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Cannot find the external script. (ADW0021)

Cause You are trying to use an external SQL script in order to create a customized 
repository. However, BUSINESSOBJECTS does not have the correct pathname to the 
script.

Action Check the pathname to the script file, and correct it.

Cannot access network layer. (ADW0025)

Cause The error occurs when you try to launch a Business Objects product and connect 
to the repository, while the middleware that allows all clients to access the 
database is not properly installed. 

Action Check your middleware installation:

• When you install BUSINESSOBJECTS, make sure that the 
BUSINESSOBJECTS-RDBMS access is checked.

• At the end of the set-up, check the middleware.

• Check in the AUTOEXEC.BAT file that the database environment path is 
correct. It should be something like [Local drive]\Orawin\bin.
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An error occurred during the installation. Installation aborted. (INS0002)

Cause This error may be generated while the BUSINESSOBJECTS Installer is running. The 
problem may be due to:

• Insufficient disk space to continue the installation.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to install BUSINESSOBJECTS.

• .dll file conflicts: You may already have one or more .dll files installed which 
conflict with the .dlls that the Installer is trying to copy to your system.

• Locked files: One or more of the files or resources that the Installer needs to 
complete the installation may already be in use, or may be locked by another 
user or application. 

Action Try the following:

• Quit the installation, and free up some disk space. Empty your Recycle Bin 
and delete any unnecessary files, then try running the Installation Wizard 
again. 

• The Windows NT administrator can grant you full access to the folders on the 
system where you are trying to install BUSINESSOBJECTS.

• Whenever a .dll file conflict occurs, you can choose to skip the error message 
and continue with the installation. It may be that the .dlls that are installed 
with BUSINESSOBJECTS are more recent than the .dlls already installed, or they 
may be older. In either case, you should bear in mind that although you can 
complete the installation and run BUSINESSOBJECTS, you may later have 
problems running specific applications. If this is the case, you may need to run 
the Installer again, and re-install the .dll files provided with BUSINESSOBJECTS.

• To ensure that all files or resources that the Installer needs to complete the 
installation are available, quit all other applications before running the 
Installer. 
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An error occurred during the deinstallation. Deinstallation aborted. (INS0003)

Cause 1 You ran Setup and tried to uninstall one or more BUSINESSOBJECTS programs, but 
Setup could no longer find these files on the system.

Action To remove all BUSINESSOBJECTS programs from your system, start Add/Remove 
Programs in the Control Panel, select BusinessObjects 5.0, and click Add/
Remove.

If this does not remove all program elements, or you want to delete only specific 
BUSINESSOBJECTS programs, then use Windows Explorer to delete the files 
manually.

 Cause 2 You tried to uninstall, one or more BUSINESSOBJECTS programs on another 
machine on the network, but a network problem occurred during the operation.

Action Use the ServConf utility to check the programs.

Out of disk space (INS0004)

Cause While trying to install BUSINESSOBJECTS, the Installation Wizard detected that you 
do not have sufficient disk space.

Action Quit the installation, and free up some disk space. Empty your Recycle Bin and 
delete any unnecessary files, then try running the Installation Wizard again. 
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Cannot create the folder. (INS0006)

Cause 1 While installing BUSINESSOBJECTS, the installation was interrupted with this 
message because the disk is full.

Action Empty your Recycle Bin. If necessary, delete any redundant or unwanted files, 
and empty the Recycle Bin again.

 Cause 2 The installation of BUSINESSOBJECTS was interrupted with this message because 
you have read-only privileges to the root C:\ drive.  

Action The system or network administrator can grant you Change or Full Control 
privileges on the C:\ root drive.

 Cause 3 The installation of BUSINESSOBJECTS was interrupted with this message because 
you are trying to create the folder on another machine (cluster node), but either 
the machine is down, or the connection is not working correctly.

Action Run the ServConf utility to see if the machine is responding. Try “pinging” the 
machine.

Cannot delete the folder. (INS0007)

Cause 1 While uninstalling BUSINESSOBJECTS, the operation was interrupted with this 
message because you have read-only privileges to the root C:\ drive.  

Action The system or network administrator can grant you Change or Full Control 
privileges on the C:\ root drive.

 Cause 2 While uninstalling BUSINESSOBJECTS, the operation was interrupted with this 
message because you are trying to delete a folder on another machine (cluster 
node), but either the machine is down, or the connection is not working correctly.

Action Run ServConf utility to see if the machine is responding. Try “pinging” the 
machine to see if the network connection is valid.
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The folder does not exist. (INS0008)

Cause This error may be generated while the BUSINESSOBJECTS Installer is running. The 
problem may be due to:

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to install BUSINESSOBJECTS.

• Locked files: One or more of the files or resources that the Installer needs to 
complete the installation may already be in use, or may be locked by another 
user or application. 

Action Try the following:

• Ask the Windows NT administrator to grant you full access to the folders on 
the system where you are trying to install BUSINESSOBJECTS.

• To ensure that all files or resources that the Installer needs to complete the 
installation are available, quit all other applications before running the 
Installer. 

A file with this name already exists in this folder. (INS0009)

Cause This error may be generated while the BUSINESSOBJECTS Installer is running. The 
problem may be due to .dll file conflicts: You may already have one or more .dll 
files installed which conflict with the .dlls that the Installer is trying to copy to 
your system.

Action Whenever a .dll file conflict occurs, you can choose to skip the error message and 
continue with the installation. It may be that the .dlls that are installed with 
BUSINESSOBJECTS are more recent than the .dlls already installed, or they may be 
older. In either case, you should bear in mind that although you can complete the 
installation and run BUSINESSOBJECTS, you may later have problems running 
specific applications. If this is the case, you need to run the Installer again, and re-
install the .dll files provided with BUSINESSOBJECTS.



v 5.1-2.7

 Error Message Guide 127

An error occurred during the installation of the file. (INS0018)

Cause This error may be generated while the BUSINESSOBJECTS Installer is running. The 
problem may be due to:

• Insufficient disk space to continue the installation.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to install BUSINESSOBJECTS.

• Locked files: One or more of the files or resources that the Installer needs to 
complete the installation may already be in use, or may be locked by another 
user or application. 

Action Try the following:

• Quit the installation, and free up some disk space. Empty your Recycle Bin 
and delete any unnecessary files, then try running the Installation Wizard 
again. 

• Ask the Windows NT administrator to grant you full access to the folders on 
the system where you are trying to install BUSINESSOBJECTS.

• To ensure that all files or resources that the Installer needs to complete the 
installation are available, quit all other applications before running the 
Installer. 
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Error Number [line number]. (INS0019)

Cause This error may occur when the BUSINESSOBJECTS Installer tries to copy files to 
disk. It can be due to a variety of problems such as insufficient memory, limited 
access rights to the disk, or insufficient disk space.

Action Try the following:

• Quit the installation, and free up some disk space. Empty your Recycle Bin 
and delete any unnecessary files, then try running the Installation Wizard 
again.

• Ask the Windows NT administrator to grant you full access to the folders on 
the system where you are trying to install BUSINESSOBJECTS.

• To ensure that all files or resources that the Installer needs to complete the 
installation are available, quit all other applications before running the 
Installer.

• Close all other applications that may be running on your system, and then 
restart the installation. If the problem persists, you may have to increase the 
amount of RAM you have installed in your system.

The file is write-protected. (INS0020)

Cause This error may be generated while the BUSINESSOBJECTS Installer is running. The 
problem may be due to Windows NT access rights: The Windows NT 
administrator may not have granted you the necessary read/write authorization 
in the folder where you are trying to install BUSINESSOBJECTS.

Action The Windows NT administrator can grant you full access to the folders on the 
system where you are trying to install BUSINESSOBJECTS.



v 5.1-2.7

 Error Message Guide 129

A more recent version of the file already exists. (INS0021)

Cause This error may occur while the BUSINESSOBJECTS Installer is running. You may 
already have one or more .dll files installed which conflict with the .dlls that the 
Installer is trying to copy to your system.

Action Whenever a .dll file conflict occurs, you can choose to skip the error message and 
continue with the installation. It may be that the .dlls that are installed with 
BUSINESSOBJECTS are more recent than the .dlls already installed, or they may be 
older. In either case, you should bear in mind that although you can complete the 
installation and run BUSINESSOBJECTS, you may later have problems running 
specific applications. If this is the case, you need to run the Installer again, and re-
install the .dll files provided with BUSINESSOBJECTS.

File languages are different. (INS0022)

Cause This error may occur while the BUSINESSOBJECTS Installer is running. The problem 
may be due to .dll file conflicts. You may already have one or more language-
specific .dll files installed which conflict with the .dlls that the Installer is trying 
to copy to your system.

Action Whenever a .dll file conflict occurs, you can choose to skip the error message and 
continue with the installation. However, you should bear in mind that although 
you can complete the installation and run BUSINESSOBJECTS, you may later have 
problems running specific applications. If this is the case, you need to run the 
Installer again, and overwrite the .dll files which are causing the problem with 
the .dlls provided with BUSINESSOBJECTS.
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File CodePages are different. (INS0023)

Cause This error may occur while the BUSINESSOBJECTS Installer is running. The problem 
may be due to .dll file conflicts. You may already have one or more language-
specific .dll files installed which conflict with the .dlls that the Installer is trying 
to copy to your system.

Action Whenever a .dll file conflict occurs, you can choose to skip the error message and 
continue with the installation. However, you should bear in mind that although 
you can complete the installation and run BUSINESSOBJECTS, you may later have 
problems running specific applications. If this is the case, you need to run the 
Installer again, and overwrite the .dll files which are causing the problem with 
the .dlls provided with BUSINESSOBJECTS.

Out of disk space (INS0024)

Cause You ran out of disk space while trying to install BUSINESSOBJECTS.

Action Empty your Recycle Bin. If necessary, delete any redundant or unwanted files, 
and empty the Recycle Bin again.

Access violation (INS0025)

Cause This message may be displayed when you try to log into BUSINESSOBJECTS.

Action Rename the .lsi file to see if the error changes to “cannot locate local access 
security file."  If so, the .lsi file has been corrupted, and should be replaced with a 
fresh copy.  Then try to log in again. 
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Sharing violation (INS0026)

Cause 1 This error may be generated while the BUSINESSOBJECTS Installer is running. The 
problem may be due to Windows NT access rights: The Windows NT 
administrator may not have granted you the necessary read/write authorization 
in the folder where you are trying to install BUSINESSOBJECTS.

Action The Windows NT administrator can grant you full access to the folders on the 
system where you are trying to install BUSINESSOBJECTS.

 Cause 2 This error may be generated while the BUSINESSOBJECTS Installer is running. The 
problem may be due to locked files: One or more of the files or resources that the 
Installer needs to complete the installation may already be in use, or may be 
locked by another user or application. 

Action To ensure that all files or resources that the Installer needs to complete the 
installation are available, quit all other applications before running the Installer. 
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Not enough memory (INS0027)

Cause Windows NT does not have sufficient memory to continue the installation.

Action Delete any files that have already been installed, close all other applications that 
may be running on your system, and then restart the installation. If the problem 
persists, you may have to increase the amount of RAM installed on your system.

Cannot create temporary file. (INS0028)

Cause 1 The disk is full.

Action Empty your Recycle Bin. If necessary, delete any redundant or unwanted files, 
and empty the Recycle Bin again.

 Cause 2 You have read-only privileges to the root C:\ drive.  BUSINESSOBJECTS must create 
a temporary folder during installation.  This folder is deleted when the 
installation is finished.

Action The system or network administrator can grant you Change or Full Control 
privileges on the C:\ root drive.
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Cannot delete the old file. (INS0029)

Cause This error may occur while the BUSINESSOBJECTS Installer is running. The problem 
may be due to:

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to install BUSINESSOBJECTS.

• Locked files: One or more of the files or resources that the Installer needs to 
complete the installation may already be in use, or may be locked by another 
user or application. 

Action Try the following:

• Ask the Windows NT administrator to grant you full access to the folders on 
the system where you are trying to install BUSINESSOBJECTS.

• To ensure that all files or resources that the Installer needs to complete the 
installation are available, quit all other applications before running the 
Installer. 

Cannot read the target file. (INS0032)

Cause This error may be generated while the BUSINESSOBJECTS Installer is running. The 
problem may be due to:

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to install BUSINESSOBJECTS.

• Locked files: One or more of the files or resources that the Installer needs to 
complete the installation may already be in use, or may be locked by another 
user or application. 

Action Try the following:

• Ask the Windows NT administrator to grant you full access to the folders on 
the system where you are trying to install BUSINESSOBJECTS.

• To ensure that all files or resources that the Installer needs to complete the 
installation are available, quit all other applications before running the 
Installer. 
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An error occurred when the file was read. Invalid Product Description File Format (Error #[line 
number] line [line number]). (INS0033)

Cause This error may occur while you are trying to update your BUSINESSOBJECTS 
installation. If you are using a master installation (from disk) rather than an 
installation directly from the CD, the installation script may be corrupted.

Action Ignore the error, and try to continue the installation. If this is not possible, restart 
the installation. If the problem persists, you first need to uninstall 
BUSINESSOBJECTS, and then re-install directly from the BUSINESSOBJECTS CD.

An error occurred when the file was read. Invalid Product Description File Format
(Error #[line number]). (INS0034)

Cause This error may occur while you are trying to update your BUSINESSOBJECTS 
installation. If you are using a master installation (from disk) rather than an 
installation directly from the CD, the installation script may be corrupted.

Action Ignore the error, and try to continue the installation. If this is not possible, restart 
the installation. If the problem persists, you first need to uninstall 
BUSINESSOBJECTS, and then re-install directly from the BUSINESSOBJECTS CD.



v 5.1-2.7

 Error Message Guide 135

The Installer file is not compatible with the current version of BusinessObjects Setup. (INS0035)

Cause This error may be generated while the BUSINESSOBJECTS Installer is running. The 
problem may be due to .dll file conflicts: You may already have one or more .dll 
files installed which conflict with the .dlls that the Installer is trying to copy to 
your system.

Action Whenever a .dll file conflict occurs, you can choose to skip the error message and 
continue with the installation. It may be that the .dlls that are installed with 
BUSINESSOBJECTS are more recent than the .dlls already installed, or they may be 
older. In either case, you should bear in mind that although you can complete the 
installation and run BUSINESSOBJECTS, you may later have problems running 
specific applications. If this is the case, you need to run the Installer again, and re-
install the .dll files provided with BUSINESSOBJECTS.

An error occurred when the application was running. (INS0036)

Cause Following installation, you chose to view the Readme file, but the installation 
program could not find your Web browser program to view the file.

Action Make sure that your Web browser is correctly set up on your system.
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BusinessObjects Setup cannot modify your Windows configuration. You need to have the 
administrator rights before installing BusinessObjects. (INS0039)

Cause This message may be generated when you try to install BUSINESSOBJECTS or 
WEBINTELLIGENCE. 

Action To install BUSINESSOBJECTS or WEBINTELLIGENCE, you must be either a local 
administrator or a Domain administrator. This is because BUSINESSOBJECTS needs 
to be able to write to the system folder and registry.

Also, you must have the following Windows NT privileges:

• Act as part of the operating system

• Back up files and folders

• Log on as a service

• Restore files and folders

To do this:

1. Click your Start button, point to Programs, and then click User Manager for 
Domains.

2. Click Policies on the title bar menu, and select User Rights.

3. Select the option for Advanced User Rights at the bottom left corner.
From the drop-down list box, verify that the following rights have been 
granted to the administrator account you log in as. If you did not hit the Add 
button, then select the Show All Users. Browse for your administrator account 
you logged in with to the NT machine.
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The file cannot be found. (INS0040)

Cause After installation, you tried to run Setup again in order to install additional 
components. However, the Setup.inb file has been moved, deleted, or corrupted. 
This file is normally installed in the folder:

BusinessObjects 5.0\Setup 5.0 

Action Run the installation again from your original BUSINESSOBJECTS CD.

The file has a bad format. (INS0041)

Cause This error may occur while you are trying to update your BUSINESSOBJECTS 
installation. In order to do this successfully, BUSINESSOBJECTS needs to be able to 
locate and verify the license key which was installed with the previous version of 
the product. The license key is normally located in the folder:

BusinessObjects 5.0\Setup 5.0

In this case, the file has been corrupted.

Action You must either replace the license key file with a backup copy (or a copy from 
another system installed with the same license), or contact Business Objects 
Customer Support to supply you with a new key file. If neither of these options 
is available, you first need to uninstall BUSINESSOBJECTS, and then re-install 
directly from the BUSINESSOBJECTS CD.
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The file cannot be read. (INS0042)

Cause This error may occur while you are trying to update your BUSINESSOBJECTS 
installation. In order to do this successfully, BUSINESSOBJECTS needs to be able to 
locate and verify the license key which was installed with the previous version of 
the product. The license key is normally located in the folder:

BusinessObjects 5.0\Setup 5.0

In this case, you are either not authorized to read the file, or the file has been 
corrupted.

Action Check first with the Windows NT administrator to make sure you have read-
access to the necessary folders. If the problem persists, the file has probably been 
corrupted. You must then either replace the license key file with a back-up copy 
(or copy from another system installed with the same license), or contact Business 
Objects Customer Support to supply you with a new key file. 

If neither of these options is available, you first need to uninstall BUSINESSOBJECTS 
and then re-install directly from the BUSINESSOBJECTS CD.

You must specify a package name after the option. (INS0043)

Cause This error may be returned if you attempt to run an installation from the 
command line, but do not specify a package name.

Action Check the syntax of your command line parameters, and make sure you are using 
only valid command line options.

You must specify a licence key after the option. (INS0044)

Cause This error may be returned if you attempt to run an installation from the 
command line, but do not specify a license key.

Action Check the syntax of your command line parameters, and make sure you are using 
only valid command line options.
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You must specify a folder path after the option. (INS0045)

Cause This error may be returned if you attempt to run an installation from the 
command line, but do not specify a folder path.

Action Check the syntax of your command line parameters, and make sure you are using 
only valid command line options.

Invalid parameter (INS0046)

Cause This is a generic error which may be returned if you attempt to run an installation 
from the command line, but use illegal command options or incorrect syntax.

Action Check the syntax of your command line parameters, and make sure you are using 
only valid command line options.

BusinessObjects Setup cannot find any product description (.inb) file. Setup aborted. 
(INS0047)

Cause After installation, you tried to run Setup again in order to install additional 
components. However, the Setup.inb file has been moved, deleted, or corrupted. 
This file is normally installed in the folder:

BusinessObjects 5.0\Setup 5.0 

Action Run the installation again from your original BUSINESSOBJECTS 5.0 CD.
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There is nothing to install. Setup aborted. (INS0048)

Cause The serial number/product key you typed in on installation was not the correct 
one for the Business Objects product that you are trying to install.

Action If you cannot install the product, try the following:

• Verify the key is correct with your Business Objects sales representative.

• Make sure you have already installed the correct middleware and 
BUSINESSOBJECTS, and that they are functioning properly.

• If you still cannot install, manually create the folder, and try again.

Setup has found a shared installation of BusinessObjects in the folder. You can update this 
installation by running only the Setup of this folder. (INS0049)

Cause You are trying to update your BUSINESSOBJECTS installation from CD. However, 
your current version of BUSINESSOBJECTS was installed from a master installation 
in a shared folder.

Action You must first update the master installation in the shared folder, and then 
update local installations from this shared folder.
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Cannot create an OLE2 Compound file due to error [line number]. Setup aborted. (INS0053)

Cause By default, Windows uses two variables for temporary folders: TMP and TEMP. 
A problem occurs when:

• these variables point to folders that no longer exist

• these variables are not correctly defined. Sometimes the path may be correct, 
but there exists an extra space in between the TMP or TEMP and the equals 
sign (=). This causes the system to call the variable by a different name.

Action You need to check and/or modify the folders to which these variables point. 

For a Windows NT 4.0 machine:

1. Go to Settings on the Start bar.

2. Select Control Panel.

3. Double-click on System.

4. Select the Environment Tab.
The paths of the variables are found in the User variables window.

5. Modify these paths if necessary to ensure that they both point to the same 
existing folder. 
Be careful not to put any spaces between the drive name and the equals sign.

Your product license key is not valid. (INS0054)

Cause While installing BUSINESSOBJECTS, you entered an incorrect product license key.

Action Check that you have the right product license key, and that you have entered it 
correctly.
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Your Data Access license key is not valid. (INS0055)

Cause While installing BUSINESSOBJECTS, you entered an incorrect data access license 
key. This is the key that gives you access to your RDBMS.

Action Check that you have the right data access license key, and that you have entered 
it correctly.

Your license key has expired. (INS0056)

Cause The license key that you entered while installing BUSINESSOBJECTS has expired.

Action Contact Business Objects Customer Support and request a new license key. 

There is no available product with this license key. (INS0057)

Cause While installing BUSINESSOBJECTS, you entered a correct license key, but the 
product you are trying to install is not available for this key.

Action Check with the system or network administrator (or with Business Objects 
Customer Support) for guidelines on the products that you are authorized to 
install.
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You must enter a user name. (INS0058)

Cause While installing the BOManager parameters, you did not enter an account 
identity for the BOManager Automation Server. This is required for security 
reasons.

Action Enter your domain name and user name, followed by your password. You must 
have a local administrator’s account on the NT server on which you are running 
the installation.

After the installation, you can use the servconf.exe tool located in:

Business Objects\Server\BusinessObjects Manager 5.0 to view or modify these 
parameters.
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Setup has not detected support for some of the installed middleware. (INS0059)

Cause After installing BUSINESSOBJECTS, you clicked the Check MiddleWare... button to 
determine which of the installed middleware is supported on your system.

Action You can click the listbox to check for other middleware support (such as Open 
Client or IBM DB2). If you wish, you can save this information as a text file by 
clicking Save as... and entering a filename. Otherwise, click OK to finish the 
installation.

Example
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An error occured when the file was saved. The middleware checkup result was not saved. 
(INS0061)

Cause 1 After installing BUSINESSOBJECTS, you clicked the Check MiddleWare button to 
determine which of the installed middleware is supported on your system, and 
then tried to save the results as a text file. However, the disk is full.

Action Empty your Recycle Bin. If necessary, delete any redundant or unwanted files, 
and empty the Recycle Bin again.

 Cause 2 After installing BUSINESSOBJECTS, you clicked the Check MiddleWare... button to 
determine which of the installed middleware is supported on your system, and 
then tried to save the results as a text file. However, you have read-only 
privileges on the root C:\ drive.  

Action The network or system administrator can grant you Change or Full Control 
privileges on the C:\ root drive.

The path for the folder is invalid. (INS0063)

Cause You double-clicked a BUSINESSOBJECTS icon, and received this error message  
indicating that the path is invalid. This is because your system does not have 
access to the associated network drive.

Action Your access rights on the server have been changed. Also, BUSINESSOBJECTS may 
be installed to a mapped drive instead of using the UNC name.

The system or network administrator can grant you Change or Full Control 
privileges on the C:\ root drive.  

Reinstall BUSINESSOBJECTS without using a mapped drive, and using the UNC 
name from the Run command on the taskbar Start button.
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There is no BusinessObjects Master installation in this folder. (INS0064)

Cause You are trying to update one or more BUSINESSOBJECTS installations over the 
network from a master installation, but the Installer cannot find or access the 
system where the master is installed.

Action When you run the Setup Wizard to update your installation, check that the 
pathname to the original master installation is still correct. By default, the 
Installer searches for the update files in the folder from which it was originally 
installed. If this folder has been renamed or moved, then you need to manually 
locate the master installation folder.

There is no BusinessObjects Setup file (.inb) in this folder. (INS0065)

Cause You are trying to update one or more BUSINESSOBJECTS installations over the 
network from a master installation; however, the Setup.inb file has been moved, 
deleted, renamed, or corrupted. This file is normally installed in the folder:

BusinessObjects 5.0\Setup 5.0

Action If this file has been renamed or moved, then you need to manually locate the file. 
If you cannot find it, or if it has been corrupted, you need to run the installation 
again from your original BUSINESSOBJECTS CD.

This licence key does not activate [name]. (INS0066)

Cause You are trying to update one or more BUSINESSOBJECTS installations over the 
network from a master installation; however, the license key file has been moved, 
deleted, renamed, or corrupted.

Action If this file has been renamed or moved, then you need to manually locate the file. 
If you cannot find it or if it has been corrupted, you need to replace it with a back-
up copy of the file, or run the installation again from your original 
BUSINESSOBJECTS CD.
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Cannot initialize BusinessObjects configuration. (INS0067)

Cause You are trying to install or update a BUSINESSOBJECTS installation, but you are not 
authorized to enter or change information in the Windows Registry.

Action The Windows NT administrator can grant you write-access to the Registry. Note 
that for WEBINTELLIGENCE, you must be an administrator in order to access and 
write to the Registry.

Note: Incorrect Registry editing can cause unpredictable results. Please ensure 
that you know how to restore it if a problem occurs by understanding the restore 
concepts in the Registry online help.

Cannot get system configuration. (INS0069)

Cause You are trying to install BUSINESSOBJECTS using an operating system that is not 
supported.

Action Check that you are installing BUSINESSOBJECTS on one of the supported operating 
systems and releases. You can install BUSINESSOBJECTS under:

• Windows 98

• Windows NT version 4 with Service Pack 3

• Windows 2000



 Set-Up and Administration Error Messages

148 Error Message Guide



 Error Message Guide 149

  Chapter 2 Security Error Messages
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

In this chapter 

 ❑ Security Error Messages 150



 Security Error Messages

150 Error Message Guide

Security Error Messages

Security error messages range from USR001 to USR0063. 

You are not authorized to use Supervisor. (USR0001)

Cause You tried to launch SUPERVISOR, but you do not have the necessary authorization 
(i.e., you do not have a supervisor user profile).

Action A supervisor can change your user profile to supervisor (or supervisor-designer).

New password required. (USR0002)

Cause You tried to log into BUSINESSOBJECTS, but your password has expired.

Action A supervisor can do the following:

1. Right-click your user name and select Properties.

2. Go to the Definition tab.

3. Under Security, either uncheck Password Validity, or check Password 
Validity and set the number of days for which you require your password to 
be valid.
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Your login is not valid. (USR0003)

Cause 1 While trying to log into BUSINESSOBJECTS, you entered an incorrect user name or 
password three times in succession.

Action A supervisor can do the following:

1. Right-click your user name and select Properties.

2. Go to the Definition tab.

3. Under Properties, uncheck the Disable Login checkbox.

Cause 2 You are using the NT authentication driver to log into BUSINESSOBJECTS, but 
cannot make a connection.

Action When you log into Windows NT, your login details are not case-sensitive. If you 
mix uppercase and lowercase characters in the user name, it is always interpreted 
exactly as defined by the Domain Administrator. However, BUSINESSOBJECTS 
user names must be identical to their NT login names.

To check the case of the NT user name, use the SET command (in a DOS 
command prompt).You can then rename the user to match the name in 
SUPERVISOR.

Example If the BUSINESSOBJECTS user is User1, and the NT name has been defined as 
USER1, the user will not be able to log in. You need to rename the user to USER1 
in SUPERVISOR.
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Cause 3 You may also receive this error message when starting BROADCAST AGENT either 
manually, or as a service. The Server Name is affected by the 3-Strikes function, 
which can disable login after three incorrect passwords have been entered.

Action A supervisor can do the following:

1. Launch SUPERVISOR and locate the group hosting the BROADCAST AGENT 
server.

2. Right-click the group and select Properties.

3. Go to the Broadcast Agent tab.

4. Under Properties, uncheck the Disable Login checkbox.

Your login ID is not valid.  (USR0004)

Cause You misspelled your login name while trying to log into WEBINTELLIGENCE. This 
message is not displayed, but is entered into a log by the BologApp.exe tool.

Action Try to log in again, using the correct login name.

Your password is not valid. (USR0005)

Cause This message is displayed during a Change Password operation if the new 
password is not new or contains invalid characters.

Action Try changing your password again, using a password that is different from the 
old one, and make sure you do not use any unauthorized characters.

Note: The supervisor can add more characters to the list of characters accepted by 
the repository as valid.  These characters can be specified in the Repository tab of 
the Options dialog box.
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You are not authorized to use Designer. (USR0006)

Cause You tried to start DESIGNER, but do not have the necessary authorization 
(i.e., you do not have a designer user profile).

Action A supervisor can change your user profile to designer (or supervisor-designer).

You are not authorized to use BusinesObjects. (USR0007)

Cause You tried to start BUSINESSOBJECTS but do not have the necessary authorization.

Action A supervisor can grant you access to BUSINESSOBJECTS.
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Cannot access local security file. (USR0008)

Cause 1 You tried to launch a BUSINESSOBJECTS program but it could not access the 
security file. The security file stores information used by the product to manage 
repository and database connections. This file is stored in either the LocData 
folder for local installations, or in the ShData folder for shared installations over 
the network. In both cases, the file is identical except for the extension: .lsi (local) 
or .ssi (shared).

You must have read and write access to the lsi/ssi file, since data is written to it 
every time you log in.  By default, the name and path of the file are as follows:

N:\Program Files\Business Objects\BusinessObjects 5.0\ShData\Objects.ssi

C:\Program Files\Business Objects\BusinessObjects 5.0\LocData\Objects.lsi

Action Check the following:

• That the security file is present. 

• If this file is available in the correct folder, then it may be corrupted. 
BUSINESSOBJECTS automatically installs a backup file (.bak). You can use this 
file to replace a corrupted security file. It is located in the same folder as the 
original file.

• You have write access to the lsi/ssi folder or file.

 Cause 2 The server which hosts the repository is down or the network connection is not 
working.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.
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Cannot write to local security file. (USR0009)

Cause This error message may be displayed when you try to install BUSINESSOBJECTS.

The security file stores information used by the product to manage repository 
and database connections. This file is stored in either the LocData folder for local 
installations, or in the ShData folder for shared installations over the network. 

You must have read and write access to the lsi/ssi file, since data is written to it 
every time you log in. In this case, you may not have enough disk space to install 
BUSINESSOBJECTS, or the Windows NT administrator may not have granted you 
write access to the system. By default, the name and path of the file are as follows:

N:\Program Files\Business Objects\BusinessObjects 5.0\ShData\Objects.ssi

C:\Program Files\Business Objects\BusinessObjects 5.0\LocData\Objects.lsi

Action Abort the installation, and check that you have write-access to the system. If there 
is not much free disk space, free up some space on the system by deleting 
unnecessary files and emptying the Recycle Bin.

Cannot update local security file. (USR0010)

The security file stores information used by the product to manage repository 
and database connections. This file is stored in either the LocData folder for local 
installations, or in the ShData folder for shared installations over the network. 

Cause 1 This error message may be displayed when you try to install BUSINESSOBJECTS. 
You may not have enough disk space to install BUSINESSOBJECTS, or the Windows 
NT administrator may not have granted you write access to the system.

Action Abort the installation, and check that you have write-access to the system. If there 
is not much free disk space, try to free up some space on the system by deleting 
unnecessary files and emptying the Recycle Bin.

 Cause 2 If you are working in a shared installation of BUSINESSOBJECTS, you may receive 
this error if two or more users are trying to access the security file at the same time 
(typically when users are trying to log in at the beginning of the day).

Action Quit BUSINESSOBJECTS, and try logging in again later.
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Cannot read timestamp in local security file. (USR0011)

Cause The BUSINESSOBJECTS program cannot read the timestamp in the security file. The 
security file stores information used by the product to manage repository and 
database connections. This file is stored in either the LocData folder for local 
installations, or in the ShData folder for shared installations over the network. In 
both cases, the file is identical except for the extension: .lsi (local) or .ssi (shared).

You must have read and write access to the lsi/ssi file, since data is written to it 
every time you log in. By default, the name and path of the file are as follows:

N:\Program Files\Business Objects\BusinessObjects 5.0\ShData\Objects.ssi

C:\Program Files\Business Objects\BusinessObjects 5.0\LocData\Objects.lsi

You usually receive this error if you do not have write access to the folder or file, 
or if the security file is damaged.

Action Delete the security file and restart your BUSINESSOBJECTS application. A blank 
login box appears (without any previously defined names). However, you can 
still enter your previous login name and password. The security file is then 
automatically regenerated during login.
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Cannot access the repository. (USR0013)

Cause The BUSINESSOBJECTS database password has changed. You therefore cannot 
connect to the repository with the current key file. The key file contains the 
address of the security domain generated by SUPERVISOR.

Action The following procedure should be performed by a General Supervisor:

1. Set up the BUSINESSOBJECTS Database ID with a password that does not expire.

2. Perform a Safe Recovery, entering the database name, user ID and password.

3. Log into SUPERVISOR as a General Supervisor. 

4. Select Tools > Repository and click the Document Domain.

5. Click the Test button. 
This checks whether the connection to the document domain is still valid. 

It is likely that the ID and password used for the document and universe domains 
is the same as that used for the creation of the key file. 

Therefore, both the universe and document domain connections need to be 
modified to reflect any changes in the user ID and password, as these connections 
are stored in the repository and not the key file.
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Cannot retrieve time reference for the security domain. (USR0014)

Cause This message may be displayed immediately after you perform a Safe Recovery, 
and then try to log into any BUSINESSOBJECTS application. The problem is caused 
because the connection defined in the Safe Recovery process is functional but no 
longer points to the repository.

This error may also be generated if the key file in the LocData folder is incorrect. 
The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the BusinessObjects 5.0\LocData folder for 
local installations or in the BusinessObjects 5.0\ShData folder for shared 
installations.

Action Perform the Safe Recovery again, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
username: GENERAL
password: SUPERVISOR. 

3.  Click Next
This starts the Setup Wizard.  

4. Select Safe Recovery. 

5. Check that the appropriate account information (usually user name, 
password, database alias, and server name) actually points to the database 
which contains the repository. 

6. Insert this information in the appropriate boxes.  

7. Test the connection to make sure the server is responding, and click OK.  

8. Select the appropriate location for the key file to be stored or distributed.
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Cannot retrieve the universe’s list. (USR0015)

Cause You cannot retrieve the list of universes from the repository. This may be because 
the server which hosts the repository is down or the network connection is not 
working.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.

Cannot retrieve the universe constraints list. (USR0016)

Cause This error may occur when you try to export a universe or send a document to a 
user in a multiple repository environment. The error usually occurs if you 
terminate a task sent to BROADCAST AGENT (for example, by rebooting your 
system), or when a task is abnormally terminated by the BROADCAST AGENT.

Action In general, when there are problems with the repository, a supervisor is advised 
to run a  Scan and Repair (Tools > Repository); this feature allows the following 
operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot retrieve the timestamp list. (USR0017)

Cause 1 You cannot retrieve the list of timestamps from the repository. This may be 
because the server which hosts the repository is down or the network connection 
is not working.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.

 Cause 2 The repository may be damaged.

Action In general, when there are problems with the repository, a supervisor is advised 
to run a  Scan and Repair (Tools > Repository); this feature allows the following 
operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot retrieve the user rights list. (USR0018)

Cause 1 You cannot retrieve the list of user rights from the repository. This may be 
because the server which hosts the repository is down or the network connection 
is not working.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.

 Cause 2 A section of the repository may be damaged.

Action In general, when there are problems with the repository, a supervisor is advised 
to run a  Scan and Repair (Tools > Repository); this feature allows the following 
operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot retrieve the stored procedures list. (USR0019)

Cause 1 You cannot retrieve the list of stored procedures from the repository. This may be 
because the server which hosts the repository is down or the network connection 
is not working.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.

 Cause 2 A section of the repository may be damaged.

Action In general, when there are problems with the repository, a supervisor is advised 
to run a  Scan and Repair (Tools > Repository); this feature allows the following 
operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain



v 5.1-2.7

 Error Message Guide 163

Cannot retrieve the document/template list. (USR0020)

Cause 1 You cannot retrieve the list of documents/templates from the repository. This 
may be because the server which hosts the repository is down or the network 
connection is not working.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.

 Cause 2 A section of the repository may be damaged.

Action In general, when there are problems with the repository, a supervisor is advised 
to run a  Scan and Repair (Tools > Repository); this feature allows the following 
operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

You are not authorized to use Broadcast Agent. (USR0023)

Cause You tried to start BROADCAST AGENT, but you do not have the necessary 
authorization.

Action A supervisor can enable BROADCAST AGENT for your group in SUPERVISOR by 
clicking the group symbol in the Configuration tab, and from the Broadcast 
Agent tab, entering the necessary server information.
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You are not authorized to use BusinessQuery. (USR0024)

Cause You tried to start BUSINESSQUERY but do not have the necessary authorization.

Action A supervisor can enable BUSINESSQUERY for your group as follows:

1. Click the Configuration tab in SUPERVISOR.

2. Click the group.

3. Right-click the BUSINESSQUERY symbol.

4. Select Resource > Disable/Enable Configuration.

You are not authorized to use WebIntelligence. (USR0026)

Cause You tried to start WEBINTELLIGENCE but do not have the necessary authorization.

Action A supervisor can enable WEBINTELLIGENCE for your group as follows:

1. Click the Configuration tab in SUPERVISOR.

2. Click the group.

3. Right-click the BUSINESSQUERY symbol.

4. Select Resource > Disable/Enable Configuration.

You are not authorized to work in offline mode with the current BusinessObjects. (USR0027)

Cause When logging in, you checked the Use in Offline Mode checkbox, but the  
supervisor has not authorized you to work in offline mode.

Action A supervisor can enable offline login mode for your user ID from the Definition 
tab in your User Properties. 
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No security file (*.LSI or *.SSI) was found. You need one to work offline. (USR0029)

Cause You checked the Use in Offline Mode checkbox when you tried to log in, but you 
do not have a local installation of BUSINESSOBJECTS on your machine. You thus do 
not have a local security file.

The security file stores information used by the product to manage repository 
and database connections. This file is stored in either the LocData folder for local 
installations, or in the ShData folder for shared installations over the network. In 
both cases, the file is identical except for the extension .lsi (local) or .ssi (shared).

Action You can either install BUSINESSOBJECTS locally on your machine, or ask the 
supervisor to supply you with a security file that you can copy to either the 
LocData folder (for a local installation) or the ShData folder (for a shared 
installation).
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Invalid .key file. The .key file is not the one used to create the .lsi file. (USR0030)

Cause The error message refers to two files: the key file and the security file.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the BusinessObjects 5.0\LocData folder for 
local installations or in the BusinessObjects 5.0\ShData folder for shared 
installations.

The .lsi file is the local security file, which stores information used by the product 
to manage repository and database connections; it is stored in the LocData folder. 
(For shared installations, it is stored in the ShData folder as an .ssi file.)

You receive the above error message if you are using the wrong key file;  that is, 
the key file may have been renamed or deleted but you still have a corresponding 
.lsi or .ssi file.

Action Do the following:

• Rename or delete the .lsi or .ssi file.

• Ask the General Supervisor to run a Safe Recovery and create a new .key file. 
When you log in again using the new file, BUSINESSOBJECTS automatically 
generates a new .lsi or .ssi file.

Example You are working with BUSINESSOBJECTS 5.0 but are still using BOMain.key file 
(the default name of the key file) from version 4.0.
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Your repository needs to be updated to support BusinessObjects 5.0 products. Please 
contact your BusinessObjects supervisor. Click OK to quit. (USR0031)

Cause You have installed BUSINESSOBJECTS 5.0 over a previous version of 
BUSINESSOBJECTS, but were not prompted to update the repository. 

You must have a user profile of General Supervisor in order to update the 
repository.

Action A General Supervisor can launch SUPERVISOR and run the Upgrade Wizard to 
update the repository to BUSINESSOBJECTS version 5.0.
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You must enter the correct login to deploy BusinessObjects. (USR0032)

Cause You tried to start one of the BUSINESSOBJECTS programs, but BUSINESSOBJECTS 
cannot find the key file.

The security file stores information used by the product to manage repository 
and database connections. This file is stored in either the LocData folder for local 
installations, or in the ShData folder for shared installations over the network.

In both cases, the file is identical except for the extension .lsi (local) or .ssi 
(shared). If you are unsure of the file type, you can click Setup.exe (in the Setup 
5.0 folder) to find out. Click the Modify button to view the Settings box which 
indicates whether the key file is local or shared.

In this situation, the key file has been moved, renamed, deleted, or damaged.

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
username: GENERAL
password: SUPERVISOR. 

3.  Click Next
This starts the Setup Wizard.  

4. Select Safe Recovery, and enter the database name, user ID, and password.

Or a system or network administrator can reinstall BUSINESSOBJECTS. 
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The login you used is reserved. Choose another one. (USR0033)

Cause You may receive this error if you try to log into SUPERVISOR with the reserved 
username|password GENERAL|SUPERVISOR in order to create a new repository 
or perform a Safe Recovery. 

Action To clear this error, remove or rename the key file. The key file contains the 
address of the security domain generated by SUPERVISOR. It is generally stored in 
the BusinessObjects 5.0\LocData folder for local installations or 
the BusinessObjects 5.0\ShData folder for shared installations.

If you are unsure of the file type, you can click Setup.exe (in the Setup 5.0 folder) 
to find out. Click the Modify button to view the Settings box which indicates 
whether the key file is local or shared.

You cannot start this application in this mode. (USR0034)

Cause You tried to launch a BUSINESSOBJECTS program from VBA, possibly in Blind 
mode, but this type of operation is not allowed.

Action You must start BUSINESSOBJECTS programs in the standard way, using the Start 
menu or your desktop shortcut.
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You cannot start BusinessObjects Broadcast Agent without a repository. (USR0035)

Cause 1 You tried to start one BROADCAST AGENT, but BUSINESSOBJECTS cannot find the 
repository. Perhaps the server hosting the repository database is down.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.

 Cause 2 The key file has been moved, renamed, deleted, or damaged.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the BusinessObjects 5.0\LocData folder for 
local installations or the BusinessObjects 5.0\ShData folder for shared 
installations.

If you are unsure of the file type, you can click Setup.exe (in the Setup 5.0 folder 
of the BROADCAST AGENT machine) to find out. Click the Modify button to view 
the Settings box which indicates whether the key file is local or shared.

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
username: GENERAL
password: SUPERVISOR

3.  Click Next
This starts the Setup Wizard.  

4. Select Safe Recovery, and enter the database name, user ID, and password.

Or a system or network administrator can reinstall BUSINESSOBJECTS. 
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Cannot access the Library folder. (USR0036)

Cause BUSINESSOBJECTS cannot access the UserLibs, a folder which contains user DLL 
files. This is because you are not authorized to access this folder, or because the 
folder has been deleted, moved, renamed, or damaged.

Action Check that the UserLibs folder exists inside the BUSINESSOBJECTS 5.0 folder, and 
that you have full authorization to access it. If the folder has been damaged in 
some way, replace it with a backup copy, or have the system or network 
administrator reinstall BUSINESSOBJECTS. 

Cannot access the BOMain.key file. (USR0037)

Cause You cannot gain access to the repository because the current key file has been 
moved, deleted, renamed, or damaged.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the BusinessObjects 5.0\LocData folder for 
local installations or the BusinessObjects 5.0\ShData folder for shared 
installations.

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
username: GENERAL
password: SUPERVISOR

3.  Click Next
This starts the Setup Wizard.  

4. Select Safe Recovery, and enter the database name, user ID, and password.



 Security Error Messages

172 Error Message Guide

Cannot open the BOMain.key file. (USR0038)

Cause You cannot gain access to the repository because the current key file has been 
moved, deleted, renamed, or damaged.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the BusinessObjects 5.0\LocData folder for 
local installations or the BusinessObjects 5.0\ShData folder for shared 
installations.

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
username: GENERAL
password: SUPERVISOR

3.  Click Next
This starts the Setup Wizard.  

4. Select Safe Recovery, and enter the database name, user ID, and password.
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Cannot write in the BOMain.key file. (USR0039)

Cause You cannot gain access to the repository because the current key file has been 
moved, deleted, renamed, or damaged.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the BusinessObjects 5.0\LocData folder for 
local installations or  the BusinessObjects 5.0\ShData folder for shared 
installations.

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
username: GENERAL
password: SUPERVISOR

3.  Click Next
This starts the Setup Wizard.  

4. Select Safe Recovery, and enter the database name, user ID, and password.
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Invalid BOMain.key file. (USR0040)

Cause You cannot gain access to the repository because the current key file has been 
moved, deleted, renamed, or damaged.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the BusinessObjects 5.0\LocData folder for 
local installations or  the BusinessObjects 5.0\ShData folder for shared 
installations.

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
username: GENERAL
password: SUPERVISOR

3.  Click Next
This starts the Setup Wizard.  

4. Select Safe Recovery, and enter the database name, user ID, and password.

 Cannot find current repository. (USR0041)

Cause This message is displayed whenever there is a problem connecting to the 
repository. This can be due to network problems or because the machine which 
hosts the repository database is down. This message may also be generated as a 
result of actions which initiate connections to the repository (to send or retrieve 
documents, send to BROADCAST AGENT, etc).

Action Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR. (Tools > Connections > Edit).

Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.
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Cannot access external SQL files. (USR0042)

Cause 1 This error occurs when you try to launch BUSINESSOBJECTS and connect to the 
repository, while the BUSINESSOBJECTS layer that allows all clients to access the 
database is not properly installed. 

Action Check your middleware installation:

• When you install BUSINESSOBJECTS, make sure that the RDBMS BO access is 
checked.

• At the end of the Setup, check the middleware.

• Check in the AUTOEXEC.BAT file that the database environment path is 
correct. It should be something like [Local drive]\Orawin\bin.

 Cause 2 This error can occur on shared installations. 

Action A system or network administrator can resolve the problem by reinstalling the 
client software. Or a General Supervisor can perform a Safe Recovery in order to 
generate a new security file andkey file.

The person reinstalling the software can also check for corrupt folders or faulty 
ODBC/database configurations. 
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Cannot communicate with SQLBO. (USR0043)

Cause Each of the databases you are using has an associated .dll file which is normally 
located in the Business Objects\Data Access 5.0 folder. Each of these files has an 
Sq prefix as follows:

• Sqboci50.dll for Oracle databases

• Sqodbc50.dll for ODBC databases

The above error message is generated if you try to access your data warehouse 
via the repository after the associated database .dll file has been moved, renamed, 
deleted, or damaged. This message can also occur if the .dll is locked by another 
application or user.

Action Replace the .dll file with a backup copy if you have one, or from another 
BUSINESSOBJECTS installation. If these are not available, the Data Access module 
must be reinstalled.

Cannot obtain connection. (USR0044)

Cause An .rss file is created for each of the databases you are using. This file contains the 
necessary connection information, and is stored in the database folder:

Business Objects\Data Access 5.0\database name

This error is generated if BUSINESSOBJECTS cannot find the .rss file under the 
database folder, and therefore cannot establish a connection to the database.

Action Copy a backup of the .rss file to the database folder. If you do not have a backup, 
the connection must be created once again by the supervisor.
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Cannot reach repository database. (USR0045)

Cause 1 This error occurs when you launch BUSINESSOBJECTS and try to connect to the 
repository. BUSINESSOBJECTS cannot resolve the connection string. For most 
databases this generally means that the database "alias" (it could be an ODBC 
DSN, a server name, etc) is not correctly defined or is not found.

Action A database administrator should check your database configuration. 

Example For Oracle databases, BUSINESSOBJECTS uses an Oracle file to connect to the data-
base: the tnsnames.ora file. The problem may then be:

• This file on the client system may not contain the TNS name that the designer 
defined in the BUSINESSOBJECTS connection (server name) or in the key file.

• The tnsnames.ora file is either not up-to-date or does not exist on the client 
(stored in C:\Oracle folder\Network\Admin). A supervisor, designer, or 
database administrator can check whether this file corresponds to the latest 
version of the Oracle database.

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
username: GENERAL
password: SUPERVISOR

3.  Click Next
This starts the Setup Wizard.  

4. Select Safe Recovery, and enter the database name, user ID, and password.
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Cause 2 The database access package is not installed.

Action Try the following:

1. Run Setup.

2. Locate the data access driver  in the Data Access 5.0\database folder. 

3. Click on the checkbox and install this driver.

Example The database access package for Oracle is Net8. It is located in the folder Data Ac-
cess 5.0\Oracle.

Cannot access network layer. (USR0046)

Cause Each of the databases you are using has an associated .sbo file which is normally 
located in the Business Objects\Data Access 5.0 \database folder:

• Oracle.sbo for Oracle databases

• Odbc.sbo for ODBC databases

The above error message is generated if you try to access your data warehouse 
via the repository after the associated database .sbo file has been moved, 
renamed, deleted, or damaged. This message can also occur if the .sbo is locked 
by another application or user.

Action Replace the .sbo file with a backup copy if you have one, or from another 
BUSINESSOBJECTS installation. If these are not available, your Data Access module 
must be reinstalled. 
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Cannot access external SQL folder. (USR0047)

Cause 1 This error occurs when you try to launch BUSINESSOBJECTS and connect to the 
repository, while the BUSINESSOBJECTS layer that allows all clients to access the 
database is not properly installed. 

Action Check your middleware installation:

• When you install BUSINESSOBJECTS, make sure that the RDBMS BO access is 
checked.

• At the end of the Setup, check the middleware.

• Check in the AUTOEXEC.BAT file that the database environment path is 
correct. It should be something like: [Local drive]\Orawin\bin.

 Cause 2 This error can occur on shared installations.

Action  In these situations, a system or network administrator can resolve the problem 
by reinstalling the client software. Or a General Supervisor can perform a Safe 
Recovery in order to generate new security file and key file.

The person reinstalling the software should also check for corrupt folders or 
faulty ODBC /database configurations. 
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Internal problem (USR0049)

Cause 1 If you do not have the .rss file in the database folder, you may get this error when 
running BUSINESSOBJECTS.

An .rss file is created for each of the databases you are using. This file contains the 
necessary connection information, and is stored in the database folder:

Business Objects\Data Access 5.0\database name

Action Copy the appropriate .rss file and save it in the database folder.

 Cause 2 When you use BUSINESSOBJECTS in Enterprise mode, you may receive this error 
after entering a user name and password.  This indicates that the database .rss file 
in the Business Objects\database folder has been corrupted or does not exist.  If 
you are a Windows NT user, this could also mean that you are not authorized to 
read the file.

Action A system or network administrator can restore the file from a back-up, copy one 
from another working installation of BUSINESSOBJECTS, or reinstall 
BUSINESSOBJECTS on this machine.

If you are an NT user, see the Windows NT administrator for more information 
on your access rights.

 Cause 3 This error may also occur when a user tries to log into BUSINESSOBJECTS. The user 
name may not be defined anywhere in SUPERVISOR.  However, when trying to 
re-create the same user, you may see the message "A user/group with that name 
already exists. Please choose another name."

Action A database administrator can delete the user from the OBJ_M_ACTOR table in 
the repository.  A supervisor can then re-create the user again in SUPERVISOR.
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 Cause 4 You receive the above error message if you are using the wrong key file;  that is, 
the key file may have been renamed or deleted but you still have a corresponding 
.lsi or .ssi file.

Action Do the following:

• Rename or delete the .lsi or .ssi file.

• Ask the General Supervisor to run a Safe Recovery and create a new .key file. 
When you log in again using the new file, BUSINESSOBJECTS automatically 
generates a new .lsi or .ssi file.
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You have damaged the BusinessObjects login security. (USR0050)

Cause You cannot log into BUSINESSOBJECTS because your local security file (.lsi) has 
been damaged or deleted. 

The security file stores information used by the product to manage repository 
and database connections. This file is stored in  the LocData folder for local 
installations, or the ShData folder for shared installations over the network.

This problem may occur when a user logs in, becomes impatient with lack of 
response to the login, and reboots the system. This immediately corrupts the 
security file.

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
username: GENERAL
password: SUPERVISOR

3.  Click Next
This starts the Setup Wizard.  

4. Select Safe Recovery, and enter the database name, user ID, and password.
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We cannot store security information for your session. (USR0051)

Cause You tried to update some of the security settings in SUPERVISOR, but you cannot 
store these changes because the local security file (.lsi) is already in use by another 
application.

The security file stores information used by the product to manage repository 
and database connections. This file is stored in either the LocData folder for local 
installations, or the ShData folder for shared installations over the network.

Action Wait a few moments, and then try again. You may also want to stop any other 
processes that are running on your system.

The local security file is locked by another application. (USR0052)

Cause You tried to update some of the security settings in SUPERVISOR, but you cannot 
store these changes because the local security file (.lsi) is locked by another 
application. You may not even be able to log into SUPERVISOR.

The security file stores information used by the product to manage repository 
and database connections. This file is stored in either the LocData folder for local 
installations, or the ShData folder for shared installations over the network.

Action Stop any other processes that are running on your system, and quit all 
unnecessary applications.
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Cannot load authentification driver. (USR0053)

Cause In SUPERVISOR, you have enabled Windows NT Authentication
(Tools > Options > Security Policy) but BUSINESSOBJECTS cannot find the 
KNTUI50.DLL file that it needs to enable this feature.

Action The authentication driver is based on the BUSINESSOBJECTS Plug & Play security 
driver mechanism, so all you have to do to activate it is:

1. Delete or move KGLUI50.DLL from the BusinessObjects folder.

2. Copy KNTUI50.DLL to KGLUI50.DLL.

Cannot find authentification driver entry-point function. (USR0054)

Cause In SUPERVISOR, you have enabled Windows NT Authentication
(Tools > Options > Security Policy). However, the KNTUI50.DLL file that is 
needed to enable this feature is not the correct file, or has been changed or 
damaged.

Action Try the following:

1. Delete the KNTUI50.DLL file from the BusinessObjects 5.0 folder.

2. Copy a backup of the KNTUI50.DLL file to the BusinessObjects 5.0 folder (if 
you have one), or copy it from another BUSINESSOBJECTS installation. If these 
are not available, BUSINESSOBJECTS must be reinstalled.
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Cannot find authentification driver exit-point function. (USR0055)

Cause In SUPERVISOR, you have enabled Windows NT Authentication 
(Tools > Options > Security Policy). However, the KNTUI50.DLL file that is 
needed to enable this feature is not the correct file, or has been changed or 
damaged.

Action Try the following:

1. Delete the KNTUI50.DLL file from the BusinessObjects 5.0 folder.

2. Copy a backup of the KNTUI50.DLL file to the BusinessObjects 5.0 folder (if 
you have one), or copy it from another BUSINESSOBJECTS installation. If these 
are not available, BUSINESSOBJECTS must be reinstalled. 

Server error (USR0057)

Cause You may get this error message when you try to access the WEBINTELLIGENCE 
home page. An invalid path is defined in your Web server or you have installed 
a product which uses the same CORBA technology, such as NET DYNAMIC. 

Action Try the following:

1. Check the default home page in your Web server.

2. Check if you have other products which use the CORBA technology installed 
on the same system.

3. Change the path and uninstall the other products which are using CORBA.
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(Invalid key file) (USR0058)

Cause You tried to log into BUSINESSOBJECTS, but the key file could not be opened. It may 
have been corrupted. 

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the BusinessObjects 5.0\LocData folder for 
local installations or the BusinessObjects 5.0\ShData folder for shared 
installations.

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
Username: GENERAL 
Password: SUPERVISOR.

3. Click Next.
This starts the Setup Wizard.

4. Select Safe Recovery, and enter the database name, user ID, and password. 
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This password is not correct. You are allowed only n more login attempt(s). (USR0059)

Cause This message is displayed when you try to launch SUPERVISOR using an incorrect 
password. 

Action Enter the correct password. As indicated in the error message, you are allowed a  
maximum of three attempts to enter the correct password. If you fail to do so, you 
must ask the General Supervisor to give you another password.

If you are the General Supervisor, and are locked out because of entering three 
incorrect passwords, you should have already created a second General 
Supervisor to cover such an emergency. If you have not created a second General 
Supervisor, you will have to restore your repository from a backup copy. If you 
have no backup copy, contact Business Objects Customer Support.

Note: The user name and password are case-sensitive and must be entered 
exactly as they were when the user was created. In addition, characters created 
with the CAPS LOCK key may be treated differently from those created with the 
SHIFT key even if they appear identical on the screen.
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Error during opening of the lsi file. (USR0060)

Cause You tried to log into BUSINESSOBJECTS, but the security file (.lsi) could not be 
opened. It may have been corrupted.

The security file stores information used by the product to manage repository 
and database connections. This file is stored in either the LocData folder for local 
installations, or in the ShData folder for shared installations over the network. In 
both cases, the file is identical except for the extension: .lsi (local) or .ssi (shared).

You must have read and write access to the lsi/ssi file, since data is written to it 
every time you log in.  By default, the name and path of the file are as follows:

N:\Program Files\Business Objects\BusinessObjects 5.0\ShData\Objects.ssi

C:\Program Files\Business Objects\BusinessObjects 5.0\LocData\Objects.lsi

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
Username: GENERAL 
Password: SUPERVISOR.

3. Click Next.
This starts the Setup Wizard.

4. Select Safe Recovery, and enter the database name, user ID, and password. 
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The key file name given in the command line does not exist in the data folder. (USR0061)

Cause You tried to log into BUSINESSOBJECTS, but the key file cannot be found. It may 
have been deleted, renamed, moved, or corrupted. 

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the BusinessObjects 5.0\LocData folder for 
local installations or the BusinessObjects 5.0\ShData folder for shared 
installations.

Action A General Supervisor can perform a Safe Recovery, as follows:

1. Rename or delete the key file.

2. Log into SUPERVISOR with the reserved ID:
Username: GENERAL 
Password: SUPERVISOR.

3. Click Next.
This starts the Setup Wizard.

4. Select Safe Recovery, and enter the database name, user ID, and password. 

You cannot log in because your NT Primary Domain is not trusted by the repository. (USR0062)

Cause You are trying to log into BUSINESSOBJECTS using Windows NT Authentication. 
However, you cannot do so because the NT Domain to which you belong is not 
included in the list of authorized domains specified by the supervisor.

Action A supervisor can add your domain to the list of “trusted” domains.
(In SUPERVISOR, Tools > Options > Security Policy > Enable WinNT 
Authentication > New)
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Your supervisor has prohibited use of the NT authentication driver. (USR0063)

Cause You are trying to log into BUSINESSOBJECTS using Windows NT Authentication. 
However, you cannot do so because the  supervisor has disabled this feature.

Action A supervisor can enable Windows NT Authentication.

(In SUPERVISOR,  Tools > Options > Security Policy > Enable WinNT 
Authentication)

This application is incompatible with the repository because the repository is from a more 
recent release. Please contact your Business Objects supervisor. (USR0064)

Cause You have tried to log into the repository from a Business Objects product from a 
previous release that is incompatible with the current repository. 

Action To log into the current repository, install the current version of the Business 
Objects product you wish to use.
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Universe Error Messages

Universe error messages fall into the following categories:  

Problem during fetching. (DA0002)

Cause 1 You cannot retrieve a universe from the repository. This may be because the 
server which hosts the repository is down or the network connection is not 
working.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.

Cause 2 The repository security domain may be damaged.

Action In general, when there are problems with the repository, a supervisor is advised 
to run a Scan and Repair (Tools > Repository); this feature allows the following 
operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

Range Category

DA0002 - DA0013 Database errors

DSG001 - DSG0086 DESIGNER errors

UNV0001 - UNV0049 Universe errors

UNM0001 - UNM0016 Universe management errors
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Error during SQL execution. (DA0003)

Cause BUSINESSOBJECTS has encountered an exceptional error while attempting to access 
your corporate database.

Action Contact Business Objects Customer Support.

A connection required to refresh this document is unavailable. (DA0004)

Cause 1 BUSINESSQUERY cannot refresh a query because the universe has been moved to a 
different repository or domain, without a change in name. BUSINESSQUERY can no 
longer find this universe or the associated connection.

Action As changing source is not possible with BUSINESSQUERY, you must do the 
following:

1. Open the .bqy file.

2. Edit the query, and press Run (don't just refresh the data provider).

3. Save the query as a .bqy file using the same name as before. 
The BUSINESSQUERY query then points to the correct universe and connection.

Cause 2 You may be attempting to refresh a document based on an outdated or invalid 
universe in the repository.

Action The designer of the universe should export a new version of the universe to the 
repository. Try refreshing the document once again.
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Connection or SQL sentence error. (DA0005)

Cause 1 You may get a connection or SQL sentence error after changing the date format 
in the sbo file.

Example The following example is for a customer using Oracle and BUSINESSOBJECTS 
version 4.1.2.

You change the input date format from yy to yyyy in the .sbo file (both 
InputDateFormat and InitDateFormat). Then you create the following SQL 
condition:

date object = 10/28/1998  (type in a constant)

Once you run the query, you will see the SQL syntax error.

Cause 2 This is a Windows NT registry problem. 

Action The solution is to change the registry settings as follow:

1. Enter regedit from the command line or Run menu.
The Registry Editor appears.

2. Locate  HKEY_LOCAL_MACHINE > SOFTWARE > Oracle.

3. From the Edit menu, select Add Value.

4. Type NLS_DATE_FORMAT in the Value Name box.

5. Select Data Type = REG_SZ, and click OK.
The registry prompts you for a string value.

6. Type in the date format you want, and click OK.
For example, DD-MON-YYYY.

7. Exit the registry.

Caution: Incorrect Registry editing can cause unpredictable results. Please ensure 
that you know how to restore it if a problem occurs by understanding the restore 
concepts in the Registry online help.
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Cause 3 Your ODBC drivers have been moved, deleted, renamed, or damaged.

Action Try the following to resolve the error:

1. Install the Microsoft ODBC driver again.

2. If this does not work, re-install Microsoft Access 97.

Cannot find the universe or you do not have any rights to this universe. (DA0008)

Cause Each time you refresh your document, you get this error message and 
BUSINESSOBJECTS does not retrieve any data.

Action Try the following:

• Contact the BUSINESSOBJECTS supervisor to inquire about obtaining rights to 
the universe.

• Make sure that you are connected to the repository. Use the Login As 
command on the Tools menu to log in again, this time in online mode.

• Select Tools > Options and click the File Locations tab. Check the path for the 
document.

If you are working offline, you need to retrieve the universe from the repository. 
Your query requires the universe in order to refresh the document, and is unable 
to do so in offline mode.

BLOB column cannot fetch more than one row. (DA0009)

Cause Your corporate database does not support the retrieval of Binary Large Objects 
(BLOBs) which extend beyond a single row.

Action Contact Business Objects Customer Support.
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Some of the objects from the universe are missing or ambiguous. You cannot run the query 
on this universe. (DA0010)

Cause This message is displayed whenever you try to run a query on a universe which 
has missing objects.

Action Delete the objects from the report that seem to be missing. You can check which 
objects they are in the Details tab of the error message. Then change the objects in 
the query from Data > View Data.
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Cannot find the universe. (DA0011)

You may get this message when refreshing a report or trying to edit data. This 
means that the report cannot find the universe in the file system or in the 
repository if you are working in enterprise mode.

Cause 1 The name or location of the universe has been changed.

Action If the name or the location of the universe has been changed, you can do the 
following in BUSINESSOBJECTS:

1. Select Data > View Data > Definition tab.

2. Click the button with the three periods (...) to the right of the universe name  
(in the General group box).

3. Select the universe from the Change Universe dialog box, and click OK.

Cause 2  The universe has not yet been exported to the repository

Action Ask the designer to export the universe to the repository. You can also copy the 
universe locally to your file system if its connection is local.

Cause 3 The universe file (.unv) no longer exists. It has been deleted from the subfolder of 
the Universe folder.

Action Import the universe from the repository or copy it from the file system if its 
connection is local.
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Cause 4 The report is based on a universe assigned to one repository but you wish to 
access it from a second repository.

Action If the universe has not been associated with the second repository, a designer can 
do the following:

1. Open the local copy of the universe in DESIGNER.
The universe is located in the Universe\Universe folder.

2. Select File > Parameters and create a shared connection.

3. Assign the shared connection to the local universe.

4. Select File > Save As and click the option Save for All Users.

5. Open the report in BUSINESSOBJECTS.

6. Select Data > View Data > universe > [...].

7. Assign the report to the local universe. 
It is the one without a specified domain (displayed with a dot to the right).

8. Refresh the report.

9. Select File > Save As and click the option Save for All Users.

10. Log out of BUSINESSOBJECTS.

11. Log back into BUSINESSOBJECTS with a user from the second repository.

12. Select Data > View Data > universe > [...].

13. Assign the report to the universe in a universe domain of the second 
repository.
The report should now refresh correctly against the universe in the second 
repository.

Cause 5 The universe has been disabled in SUPERVISOR.

Action A supervisor can enable the universe.
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Cause 6 There is a problem with the identifiers between the document and the universe. 
BUSINESSOBJECTS 5.0 uses different universe ID numbers from those in previous 
versions. Sometimes these ID numbers are not correctly generated in each 
document. 

When occurs, it is necessary to correct the ID number in each universe manually.

Action First, a designer needs to correct the universe ID in DESIGNER version 4.x as 
follows:

1. In DESIGNER  4.X, open the universe.

2. Select File > Parameters.

3. Change the universe name in the Definition tab.

4. Save File > Save As and enter a different file name.
For example,  if the universe is named universe1.unv, save it as universe2.unv.

5. Select File > Export to export the renamed universe to a version 4. repository.

At this point, the designer should re-assign the universe to the document.

1. In BUSINESSOBJECTS version 4.x, open the document that produced the error.

2. Select Data > View Data, and click the Definitions tab.

3. Click the button to the right of the universe name [...] to change the data 
provider of the document to the renamed universe.
Based on the previous example, change the data provider from universe1.unv 
to universe2.unv.

4. Refresh the document.

5. Save the document.
This action regenerates the document’s universe ID.

6. Open the document in BUSINESSOBJECTS version 5.0.
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Cannot find the universe that uses the connection. (DA0012)

Each time you refresh your document, you get this error message and 
BUSINESSOBJECTS does not retrieve any data.

Cause 1 You are not connected to the repository.

Action Use the Login As command on the Tools menu to log in again, this time in online 
mode.

Cause 2 You are working offline but require the universe in order to refresh the 
document. You cannot do this in offline mode.

Action You need to obtain a local copy of the universe from the repository if you wish to 
continue working offline. 
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Cause 3 The report is based on a universe assigned to one repository but you wish to 
access it from a second repository.

Action Do the following:

1. Open the local copy of the universe in DESIGNER.
The universe is located in the Universe\Universe folder.

2. Select File > Parameters and create a shared connection.

3. Assign the shared connection to the local universe.

4. Select File > Save As and check the option Save for All Users.

5. Open the report in BUSINESSOBJECTS.

6. Select Data > View Data > universe > [...].

7. Assign the report to the local universe. 
It is the one without a specified domain (displayed with a dot to the right).

8. Refresh the report.

9. Select File > Save As and check the option Save for All Users.

10. Log out of BUSINESSOBJECTS.

11. Log back into BUSINESSOBJECTS with a user from the second repository.

12. Select Data > View Data > universe > [...].

13. Assign the report to the universe to a universe domain in the second 
repository.
The report should now refresh correctly against the universe in the second 
repository.

You interrupted a query. Response from the server: (DA0013)

Cause This message is displayed if you run a query on a universe, and then interrupt the 
operation while the query is still running.

Action Whenever a query is interrupted in this way, BUSINESSOBJECTS displays a 
response from the database server. It is displayed after the above error message, 
and varies according to the database you are using.
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The outer joins around the operator are inconsistent. (DSG0001)

Cause 1 Various errors can occur because of outer join structures that the database cannot 
handle.

Action Define your outer joins as you would like them to work using the description  
below the Detect button in the Edit Join dialog box. Then systematically reverse 
the outer joins by checking the other Outer join checkbox.

A good workaround with SQL Server 6.5 is to use the ANSI type outer join 
generation, which works well.

Cause 2 A table in a join operation has an outer join to more than one other table. A table 
can have an outer join to only one other table. 

Action Specify only one outer join to this table, then retry the operation. 

Cause 3 Once you have modified a universe structure, there may still be objects 
referencing tables that have been deleted. Running a query against such a 
universe may result in this error message.

Action Delete these outdated objects from the universe and re-create them with 
references to the new tables.

Unknown cardinality (DSG0002)

Cause This error may occur whenever you run an Integrity Check on a universe 
structure from DESIGNER or SUPERVISOR.

Action Check that the database on which the universe was built actually has data in it; 
otherwise, the Check Cardinalities feature always returns a one-to-one 
relationship thus causing Integrity Check to return a cardinality error message.

If you are sure that the cardinalities are correct, then you can ignore this error 
message.  BUSINESSOBJECTS is only warning you of possible errors in the universe 
structure.
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Unknown cardinality! (DSG0003)

Cause This error may occur whenever you run an Integrity Check on a universe 
structure from DESIGNER or SUPERVISOR.

Action Check that the database on which the universe was built actually has data in it; 
otherwise, the Check Cardinalities feature always returns a one-to-one 
relationship thus causing Check Integrity to return a cardinality error message.

If you are sure that the cardinalities are correct, then you can ignore this error 
message.  BUSINESSOBJECTS is only warning you of possible errors in the universe 
structure.

The specified file cannot be found. (DSG0005)

Cause You tried to view one of the online User’s Guides from the Help menu, but the 
associated PDF file has been moved, deleted, or renamed.

Action You need to copy the file back to its correct location: 

Business Objects\Online Guides\En

You can do this by copying the missing file from another BUSINESSOBJECTS 
installation, or by running the BUSINESSOBJECTS Setup program, and re-installing 
the necessary documentation components.

Cannot export a read-only universe. (DSG0017)

Cause You have read-only privileges on the folder in which universes are stored. 
However, you need to save a universe to disk before DESIGNER can export it.

Action A network or system administrator can grant you Change or Full Control 
privileges on the folder in which universes are stored.
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Table name exceeds 110 characters. (DSG0040)

Cause You tried to rename a table, using more than 110 characters in the table name.

Action Click OK to dismiss the error message, and enter a shorter name for the table.

The specified default universe folder does not exist. (DSG0041)

Cause You tried to specify a folder which does not exist.

Action Click the Browse button, and then use the browser to indicate the right path to 
the universe folder.

The universe is corrupted and cannot be opened. (DSG0046)

Cause The universe you are trying to access is damaged.

Action Delete your local version of the universe, import the universe from the 
repository, and then open it.

The connection to the network is not present. (DSG0048)

Cause You cannot retrieve a universe from the repository. This may be because the  
network connection is not working.

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.
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Duplicated items were found. Universes cannot be linked. (DSG0049)

Cause When trying to link two universes, DESIGNER found identical items in each 
universe.

Action Start DESIGNER, open both universes, then locate and delete any duplicated items.

A universe cannot be linked to itself. (DSG0051)

Cause You tried to link a universe to itself. You can link a universe only to another 
distinct universe.

Action In DESIGNER, do this:

1. Select Edit > Links.
The Universe Parameters dialog box appears.

2. Click the Add Link button.
The Universe to Link dialog box appears.

3. Use the Up One Level button to point to another universe.

Universe not found. (DSG0052)

Cause You are trying to access a linked universe (a universe which has been derived 
from another “master” universe). However, the master (or parent) universe on 
which this universe is based cannot be found. Because the derived universe 
requires specific components that are available only in the master universe, the 
derived universe cannot be opened. 

Action The master universe may have been renamed, moved, or deleted. To fix the 
problem, you need to export another copy of the master universe to the 
repository.
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Cannot load universe. (DSG0053)

Cause You are trying to open a linked universe (a universe which has been derived from 
another “master” universe). However, the master (or parent) universe on which 
this universe is based cannot be loaded. Because the derived universe requires 
specific components that are available only in the master universe, the derived 
universe cannot be opened. 

Action One or more of the components of the master universe may be corrupted. To fix 
the problem, you need to export a working version of the master universe to the 
repository.

Memory error (DSG0054)

Cause You are trying to open a linked universe (a universe which has been derived from 
another “master” universe). However, the master (or parent) universe on which 
this universe is based cannot be loaded because Windows NT does not have 
sufficient memory.

Action Close all applications that may be running, and restart your system. If the 
problem persists, you may have to increase the amount of RAM installed on your 
system.

Items already used. (DSG0055)

Cause In DESIGNER, you tried to delete a link between two components, but you cannot 
do so because one or the other of the linked components is currently being used.

Action Check that you really want to remove this link. If so, you must wait until the 
linked components are no longer being used.
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This universe to be linked belongs to another repository. The link cannot be done. (DSG0086)

Cause You tried to link universes that have different connections. However, you can 
link only universes that share the same connection. You cannot link universes 
that point to different types of databases.

Action Try the following in DESIGNER:

• Run a query in each of the universes, and then link the two queries in a 
document.

• Create “attached tables” in the first database that connect to the second 
database. This way you can create one universe for both sets of data. The 
connection to the first database is the only connection that is used since it 
provides the connection to the second database itself. In DESIGNER, you would 
only have one connection. 

Universe memory error (UNV0001)

Cause You are trying to access a universe. However, the universe cannot be loaded 
because Windows NT does not have sufficient memory.

Action Close all applications that may be running, and restart your system. If the 
problem persists, you may have to increase the amount of RAM installed on your 
system.

Internal universe error (UNV0002)

Cause A required .dll resource file has been moved, deleted, renamed, or corrupted.

Action You may have to re-install DESIGNER. Contact Business Objects Customer 
Support for more information.
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Cannot load universe. (UNV0003)

Cause While running DESIGNER, you tried to open a universe. However, specific 
components in the universe cannot be loaded.  

Action One or more components of the universe are corrupted. Try to obtain another 
working copy of the universe if one is available. Then export this universe to the 
repository and try re-importing it.

Cannot load universe parameters. (UNV0004)

Cause While running DESIGNER, you tried to open a universe. However, specific 
parameters in the universe cannot be loaded.  

Action One or more parameters in the universe are corrupted. Try to obtain another 
working copy of the universe if one is available. Then export this universe to the 
repository and try re-importing it. 

Cannot load universe tables. (UNV0005)

Cause While running DESIGNER, you tried to open a universe. However, specific tables 
in the universe cannot be loaded.

Action One or more the tables in the universe are corrupted. Try to obtain another 
working copy of the universe if one is available. Then export this universe to the 
repository and try re-importing it. 



v 5.1-2.7

 Error Message Guide 209

Cannot load universe contexts. (UNV0006)

Cause While running DESIGNER, you tried to open a universe. However, specific 
contexts in the universe cannot be loaded.

Action One or more contexts in the universe are corrupted. Try to obtain another 
working copy of the universe if one is available. Then export this universe to the 
repository and try re-importing it.

Cannot load the modification list of the universe. (UNV0007)

Cause While running DESIGNER, you tried to open a universe. However, specific 
components in the universe cannot be loaded.  

Action One or more of the components in the Audit table (UNV_Audit) in the universe 
domain are corrupted. Try to obtain another working copy of the universe if one 
is available. Then export this universe to the repository and try re-importing it.
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Cannot load universe joins. (UNV0008)

Cause While running DESIGNER, you tried to open a universe. However, specific joins in 
the universe cannot be loaded.  

Action One or more joins in the universe are corrupted. Try to obtain another working 
copy of the universe if one is available. Then export this universe to the repository 
and try re-importing it.

Cannot load universe objects. (UNV0009)

Cause While running DESIGNER, you tried to open a universe. However, specific objects 
in the universe cannot be loaded.  

Action One or more objects in the universe are corrupted. Try to obtain another working 
copy of the universe if one is available. Then export this universe to the repository 
and try re-importing it.

Cannot load universe hierarchies. (UNV0010)

Cause While running DESIGNER, you tried to open a universe. However, specific 
hierarchies in the universe cannot be loaded.  

Action One or more hierarchies in the universe are corrupted. Try to obtain another 
working copy of the universe if one is available. Then export this universe to the 
repository and try re-importing it.
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Cannot load linked universes. (UNV0011)

Cause You are trying to open a linked universe (a universe which has been derived from 
another “master” universe). However, the master (or parent) universe on which 
this universe is based cannot be loaded. Because the derived universe requires 
specific components that are available only in the master universe, the derived 
universe cannot be opened.

Action One or more of the components of the master universe may be corrupted, or the 
master universe may have been renamed, moved, or deleted. To fix the problem, 
you need to export a working version of the master universe to the repository.

Cannot load SQLBO. (UNV0015)

Cause This error is generated when BUSINESSOBJECTS cannot find the sqlbo.dll file. This 
file is needed to ensure proper connectivity with the database middleware. The 
sqlbo.dll is grouped together with a series of other dll files in the cnxsrv50.dll.

This file is located in the \Business Objects\Business Objects 5.0 folder.

Action The cnxsrv50.dll file may have been deleted, renamed, moved, or damaged. If 
you have a backup copy of this file, you should copy it to your \Business Objects 
5.0 folder. If you do not have another copy of the file, you should contact Business 
Objects Customer Support, or re-install BUSINESSOBJECTS.
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The server is not responding. (UNV0017)

Cause This message may occur when you try to access the database (to “ping” a 
connection, refresh the structure of the universe, or refresh a document).

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.

The server is not responding. (UNV0018)

Cause This message may occur when you try to access the database (to “ping” a 
connection, refresh the structure of the universe, or refresh a document).

Action Verify the network connection by “pinging” the server. If the network is running 
properly, the database administrator should then use database middleware (such 
as Net8 for Oracle) to check if there is any response from the repository database.
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Unknown error during fetch. (UNV0020)

Cause 1 This means that the formulas or variables you are trying to fetch were deleted 
and/or the information was purged from the report. 

Action In BUSINESSOBJECTS, select Data > Variables. In the Variables dialog box, check 
whether the formulas or variables still exist and have assigned values.

Cause 2 You attempted to insert a table into your universe and received the above 
message. 

The Microsoft ODBC BUSINESSOBJECTS drivers are not installed. Only the Generic 
ODBC drivers are installed. In the connection of your universe, MS SQL Server is 
specified as the database engine.

Action Do the following:

1. Install the Microsoft ODBC BUSINESSOBJECTS drivers.

2. Edit the connection by specifying Generic ODBC data source as the database 
engine.
Be aware that Generic ODBC has limited functionality. It is designed only to 
provide support of very basic database commands. It is recommended to use 
a native driver whenever available.
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Unknown error during query execution. (UNV0021)

Cause 1 The query has generated a database error. This error was not generated by 
BUSINESSOBJECTS. Specific database errors are not displayed in BUSINESSOBJECTS.

Action You should activate a trace to locate the source of the error. To do this, you can 
use either the trace utility delivered by your database supplier (e.g. for Oracle, 
this is SQL+), or you can use BUSINESSTRACKER, the utility supplied with 
BUSINESSOBJECTS.

Whichever tool you use, you first need to quit BUSINESSOBJECTS, start the trace, 
and then restart BUSINESSOBJECTS. A trace is then generated, which records all 
SQL transactions that pass between the front-end client and the repository, as 
well as between the repository and the corporate database. 

You can scroll the trace information on-screen, or save it to a file. You can also 
send it to Business Objects Customer Support for analysis.

The BUSINESSTRACKER utility is installed by default in the following folder:  

C:\Program Files\Business Objects\Business Objects 5.0

It is an executable file called Bologapp.exe

In the trace file, you need to look for any error or negative values. You can 
conduct a search by using the Edit > Find command and typing words such as: 
error, 0, -1 and so on.

Cause 2 You attempted to insert a table into your universe and received the above 
message. 

The Microsoft ODBC BUSINESSOBJECTS drivers are not installed. Only the Generic 
ODBC drivers are installed. In the connection of your universe, MS SQL Server is 
specified as the database engine.

Action Do the following:

1. Install the Microsoft ODBC BUSINESSOBJECTS drivers.

2. Edit the connection by specifying Generic ODBC data source as the database 
engine.
Be aware that Generic ODBC has limited functionality. It is designed only to 
provide support of very basic database commands. It is recommended to use 
a native driver whenever available.
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Unknown RDBMS error. (UNV0022)

Cause The query has generated a database error. This error was not generated by 
BUSINESSOBJECTS. Specific database errors are not displayed in BUSINESSOBJECTS.

Action You should activate a trace to locate the source of the error. To do this, you can 
either use the trace utility delivered by your database supplier (e.g. for Oracle, 
this is SQL+), or you can use BUSINESSTRACKER, the utility supplied with 
BUSINESSOBJECTS.

Whichever tool you use, you first need to quit BUSINESSOBJECTS, start the trace, 
and then restart BUSINESSOBJECTS. A trace is then generated, which records all 
SQL transactions that pass between the front-end client and the repository, and 
between the repository and the corporate database.

You can scroll this trace information on-screen or save it to a file. You can also 
send it to Business Objects Customer Support for analysis.

The BUSINESSTRACKER utility is installed by default in the following folder:  

C:\Program Files\Business Objects\Business Objects 5.0\

It is an executable file called Bologapp.exe

In the trace file, you need to look for any error or negative value. You can conduct 
a search by selecting Edit > Find and typing words such as: error, -0, -1 and so on.
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Invalid definition (UNV0023)

Cause 1 You may get this error message when you run an Integrity Check on a universe 
in DESIGNER. This may be due to the following:

• Tables have been removed from the universe and these tables are being 
referenced in the object definitions.

• Joins have been deleted in an incorrect fashion, such as deleting tables around 
the joins.  The location of the joins can be found when you do a print preview.

Action Try the following:

1. Remove all the references from the object definitions and refresh the structure 
of the universe if you have added or deleted tables.

2. Refresh the structure of the universe. Export and import the universe if you 
find some join definitions are missing.

Cause 2 Alternatively, this message may be displayed in the SQL Editor when you 
attempt to create or edit an SQL statement, and then click Parse to test the syntax.

Action Check the syntax of the SQL statement or function. From the SQL Editor, you can 
view the correct syntax of any function by clicking it. The syntax appears in the 
Description box.
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An aggregate function is present in the WHERE clause. (UNV0024)

Cause In DESIGNER, you started the SQL Editor and attempted to enter an aggregate-
aware function in a WHERE clause. This is not allowed.

Action Remove the aggregate-aware function from the WHERE clause.

Several calls to @Aggregate_Aware function. (UNV0025)

Cause In DESIGNER, you started the SQL Editor and attempted to enter more than one 
aggregate-aware function in a single statement. This is not allowed.

Action Remove all but one of the aggregate-aware functions.

Nested @Aggregate_Aware functions. (UNV0026)

Cause In DESIGNER, you started the SQL Editor and attempted to nest an aggregate-
aware function within another aggregate-aware function. This is not allowed.

Action Remove the nested aggregate-aware function.

Cross references (UNV0027)

Cause You are working with a linked universe (a universe which has been derived from 
another “master” universe). However, the derived universe contains cross-
references to the master universe, and the master universe cannot be opened.

Action The master universe may have been renamed, moved, or deleted. To fix the 
problem, you need to export a working version of the master universe to the 
repository.
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Table does not exist. (UNV0029)

Cause The table or view entered does not exist, a synonym that is not allowed here was 
used, or a view was referenced where a table is required. Existing user tables and 
views can be listed by querying the data dictionary. 

Certain privileges may be required to access the table. If an application returned 
this message, the table that the application tried to access does not exist in the 
database, or the application does not have access to it.

Action Check each of the following:

• The spelling of the table or view name. 

• That a view is not specified where a table is required. 

• That an existing table or view name exists. 

• Contact the database administrator if the table needs to be created or if user or 
application privileges are required to access the table. 

Also try the following:

1. Note the tables that are referred to in the SQL used by BUSINESSOBJECTS.

2. In DESIGNER, bring up the Table Browser by selecting the Insert > Table 
command and check whether the same tables are visible.

If you are attempting to access a table or view in another schema, make certain 
the correct schema is referenced and that access to the object is granted. 
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This object does not exist. (UNV0039)

Cause After a universe was exported to another domain with a new connection, the 
structure could not be found.

DESIGNER is not able to find which owner and qualifier names it should be using 
to access the tables in the structure.

Action You must specify the owner (i.e. user name) and qualifier (i.e. database name) for 
all tables. If you do not remember them, edit the table browser, insert one of the 
tables you are using, and make a note of its owner and qualifier names.

Select all tables, right-click them, select Rename Table, and specify their owner 
and qualifier. Apply the change and export the universe. You should now be able 
to refresh the structure. 

If you still cannot do this, then delete the corresponding local .unv file and 
re-import it: this updates the .unv file's structure. Since the owner and qualifier 
are now specified in the structure, DESIGNER is able to find them any time you 
open the universe.

An alternative solution is the use of synonyms. Depending on the characteristics 
of your RDBMS, aa database administrator can implement synonyms to help 
circumvent table owner issues.

Example This problem may happen when you have defined a universe with a test 
connection: after you changed the connection to the production one, the above 
error message displays whenever you attempt to open the universe. Using the 
Refresh Structure command just gives the same result.
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Strategy connection not found. (UNV0049)

Cause This message may be displayed when an external object strategy is used to access 
the repository.

Action The connection referenced in the [CONNECTION] section of the .PRM file must 
be defined as a personal connection. If it is defined as a secured connection then 
it is not going to work. This is because this connection will let you access every 
metadata structure, and might not be available for all other users.

Note: External strategy files are declared in the .PRM files located in the various 
RDBMS subfolders of the Data Access 5.0 folder.

May be inconsistent. (UNM0001)

Cause The universe may contain:

• Invalid syntax in the SQL definition of an object, condition, or join

• Loops

• Isolated tables

• Missing or incorrect cardinalities.

Action Run an Integrity Check on the universe. This checks whether the structure of your 
universe matches the requirements of the database.
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Bad number format (UNM0002)

Cause There is a syntax error in the SQL formula you entered. The number format  is 
incorrect.

Action Re-enter the number, and resubmit the formula.

Missing quote ""..."" (UNM0003)

Cause There is a syntax error in the SQL formula you entered. The formula lacks a single 
quotation mark.

Action Enter the missing single quote, and resubmit the formula.

Missing double quote ""..."" (UNM0004)

Cause There is a syntax error in the SQL formula you entered. The formula lacks a 
double quotation mark.

Action Enter the missing double quote, and resubmit the formula.

Missing closing bracket {...} (UNM0005)

Cause There is a syntax error in the SQL formula you entered. The formula lacks a 
closing bracket.

Action Enter the missing closing bracket, and resubmit the formula.
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Missing opening parenthesis after function name (UNM0006)

Cause There is a syntax error in the SQL formula you entered. The formula lacks an 
opening parenthesis.

Action Enter the missing opening parenthesis, and resubmit the formula.

Missing closing parenthesis (UNM0007)

Cause There is a syntax error in the SQL formula you entered. The formula lacks a 
closing parenthesis.

Action Enter the missing closing parenthesis, and resubmit the formula.

Missing parameters (UNM0008)

Cause There is a syntax error in the SQL formula you entered. The formula lacks one or 
more parameters.

Action Enter the missing parameters, and resubmit the formula.

Wrong number of parameters (UNM0009)

Cause There is a syntax error in the SQL formula you entered. The formula may either 
lack one or more parameters or have too many parameters.

Action Enter the correct number of parameters, and resubmit the formula.
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Bad character (UNM0010)

Cause There is a syntax error in the SQL formula you entered. You included an 
unauthorized character in one of the field statements.

Action Check and correct the syntax. Then resubmit the formula.

Bad indent (UNM0011)

Cause There is a syntax error in the SQL formula you entered. You included an illegal 
indent in one of the field statements.

Action Check and correct the syntax. Then resubmit the formula.

Incompatible operand (UNM0012)

Cause There is a syntax error in the SQL formula you entered. You included an operand 
that is not compatible with the current SQL function.

Action Check and correct the SQL. Then resubmit the formula.

Looping in variable definition (UNM0013)

Cause There is a syntax error in the SQL formula you entered. You included a loop 
which cannot be resolved.

Action Check and correct the syntax. Then resubmit the formula.
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Returns type incompatible with the user object type. (UNM0014)

Cause There is a syntax error in the SQL formula you entered. There are inconsistencies 
in the User Object Definition.

Action Check and correct the syntax. Then resubmit the formula.

Syntax error (UNM0015)

Cause This error message appears when special characters are used in object names, 
including:
[ ] = & @ × $ % , ; ! ß £ ~ § µ + ' ( ) { } -

Action Do not use special characters in object names.

Cannot create two user objects with the same name. (UNM0016)

Cause You tried to create a user object with a name that is already assigned to another 
user object.

Action Choose a unique name for the user object. Then resubmit the formula. 
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Document and Universe Exchange Error Messages

Document and universe exchange error messages fall into three categories:  

The category name contains invalid characters. Valid characters are: (CAT0001)

Cause You tried to name a new category, using unauthorized characters.

Action Re-enter the category name, using only valid characters. Valid characters include: 
a-z  A-Z  0-9  \- _ $ , and Space (except at the beginning).

Tip: A General Supervisor can define authorized characters for the repository by 
using the optionValid characters for repository (Tools > Options).

Range Category

CAT0001 Category errors

DX0001 - DX0047 Document Exchange errors

UX0001 - UX0071 Universe Exchange errors
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Cannot generate temporary file. (DX0001)

Cause You tried to send a document to the repository. However, BUSINESSOBJECTS 
always temporarily saves files locally to disk before sending them to the 
repository. These temporary files are stored in the folder:

Business Objects\BusinessObjects 5.0\UserDocs

Either you do not have write-access to the disk, or the disk is full.

Action Empty your Recycle Bin. If necessary, delete any redundant or unwanted files, 
and empty the Recycle Bin again. If you have read-only privileges on the 
root C:\ drive,  the system or network administrator can grant you full access 
privileges on the C:\ root drive.

The file will not be secured on your workstation. (DX0002)

Cause You tried to publish a document to corporate documents before saving it. In 
order to secure the local version of this document, you must first save it. 
Otherwise, any security restrictions placed on the document in the repository 
would not apply to the document on the file system until it is overwritten by the 
version in the repository.

Action Save the local version of this document before publishing it.
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RSS file not accessible. (DX0003)

Cause This error can occur when security domain tables are shifted to a different 
database. As a result, the Connection parameters of the universe are no longer 
valid

Action A designer can restore the connection as follows: 

1. Create a new connection (Tools > Connections) for the universe.

2. Assign the connection to the universe (File > Parameters).

3. Save the universe.

4.  Re-export the universe to the repository (File > Export).

Wrong SQL used. (DX0004)

Cause BUSINESSOBJECTS has encountered an exceptional error while attempting to access 
your corporate database. 

Action Contact Business Objects Customer Support.
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Error during import. (DX0005)

Cause An error occurred while you were retrieving a document from the repository. 
The import was aborted for one of the following reasons:

• There was a network error.

• The server which hosts the document domain has failed.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

Error during import. (DX0007)

Cause An error occurred while you were retrieving a document from the repository. 
The import was aborted for one of the following reasons:

• There was a network error.

• The server which hosts the document domain has failed.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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Cannot obtain unique ID on security domain for export. (DX0008)

Cause You tried to export a universe or send a document to a user, but the Magic_ID 
assigned to the universe or document in the repository has been corrupted.

The error usually occurs when the user terminates a task submitted to 
BROADCAST AGENT abnormally by rebooting his or her PC. The same also 
happens when the task is abnormally terminated by BROADCAST AGENT. There 
may be other reasons, but these two are most frequent.

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

This should correct the anomaly in the Magic_Id, so that from then onwards you 
do not get this error. 
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Unknown error during import of document.  Import canceled. Document cannot be imported. 
(DX0009)

Cause Documents are successfully exported to the repository and users can retrieve 
them, but as soon as you want to open these files, you see the above error 
message. This error occurs when the client computer does not have the same 
character settings as the database to read the information. In addition to the 
middleware settings, these character settings must be set in an environment 
variable.

Action Modify the client computer to use the same character settings as the database.

On the client computer, set the variable DB2CODEPAGE with the same setting 
that exists in your database (ask the database administrator for the variable and 
its setting). The most common value is 850, but may vary when you have specific 
languages.

Make sure you change these settings on the client side, not the server. Where you 
add DB2CODEPAGE to your environment variables depends on your operating 
system:

• For Windows 2000: You can find the environment variables in My Computer 
> Properties > Advanced > Environment Variables.

• For Windows NT (3.51 and 4.0): You can find the environment variables in My 
Computer > Properties > Environment tab.

Then re-export the document to the repository and import the document. 
Information can then be read in the same way it was exported. 
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Unable to close document.  Import canceled. Document cannot be imported. (DX0010)

Cause This message may be generated after you have opened a universe with an 
associated List of Values (LOV). An LOV is a file which contains the data values 
associated with an object.

Although the LOV file is still open, you have lost your connection to the 
document domain.

Action If the document domain is hosted on a different server, try “pinging” the server 
on which it resides to make sure it is responding. If the network is running 
properly, the database administrator then use database middleware (such as 
Net8 for Oracle) to check if there is any response from the repository database.

If the document domain has been damaged, a supervisor can run a Scan and 
Repair  (Tools > Repository); this feature allows the following operations on the 
security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Unable to create file associated with document.  Import canceled. Document cannot be 
imported. (DX0011)

Cause You tried to import a document from the repository, but you cannot write the file 
locally to disk. This may be due to:

• Windows NT access rights: the Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to import the file.

• Insufficient disk space to import the file.

Action Try the following:

• Ask the Windows NT administrator to grant you full access to the folders on 
the system where you are trying to import the file.

• Quit the application, free up some disk space, delete any unnecessary files and 
empty your Recycle Bin. Then try to import the file again.

• Change the default location in which you import the documents.

Unable to delete previous file. Import canceled. Document cannot be imported. (DX0012)

Cause This message may be generated when you try to re-import a document from the 
repository. Because a previous version of the document already exists on your 
system, you must delete the previous version before importing the new version. 
In this case, however, the previous version of the document cannot be deleted. 
This may be because:

• you do not have write-access to the file or folder.

• the file is currently open and being used by another application.

Action Try the following:

• Shut down any other applications that are running, and try re-importing the 
document again. 

• Ask the Windows NT administrator to grant you full access privileges to the 
file and/or folder.
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Unable to write to document. Import canceled. Document cannot be imported. (DX0014)

Cause This message may be displayed when you try to import reports after migrating 
from one database to another or running a Safe Recovery to create a new key file. 

Action When you re-create the key file, only the connection to the security domain is 
rebuilt. The connections to the univere and document domains remain the same. 
You must therefore do one of the following:

• Edit the connections so that they point to the new database.

• Change your aliases to point to the new database.

• Create a new document and universe domain, and import the information 
into them. Once this is done, check that the new domains work correctly, then 
delete the old domains.
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Unable to get data from document .  Import canceled. Document cannot be imported. 
(DX0015)

Cause This message may be displayed when you attempt to import a document from 
the repository. The problem may be because:

• There is no valid connection to the document domain.

• There is a problem exchanging information with the document domain of the 
repository. This can be due to corrupted tables in the repository database.

• The document is damaged.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to import the document.

• Locked file: The document may already be open or in use by another user or 
application.

Action First try the following:

1. Check if other users can access the document. 
If they cannot, ask the owner of the document to resend it to the repository.

2. Ask the Windows NT administrator to grant you full access to the folders on 
the system where you are trying to import the document.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain. 

2. Click the Test button. 

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to create the repository.
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Import failed. (DX0016)

Cause This message may appear when you attempt to import a document from the 
repository. The problem may be because:

• There is no valid connection to the document domain.

• There is a problem exchanging information with the document domain of the 
repository. This can be due to corrupted tables in the repository database.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to import the document.

• Locked file: The document may already be open or in use by another user or 
application. 

Action First try the following:

• Check if other users can access the document.

• Ask the Windows NT administrator to grant you full access to the folders on 
the system where you are trying to import the document.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain. 

2. Click the Test button. 

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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The file cannot be deleted. (DX0017)

Cause This message may be displayed when you attempt to delete or import a 
document from the repository.

Action The document file (.rep) is probably open. Close the document file and repeat the 
procedure.

The file name is not compliant with the platform you are working on. Change the name. 
(DX0018)

Cause You tried to retrieve a document from the repository, but the file name is not 
compatible with the platform you are using.

Action Change the name of the document so that it is compliant with your platform and 
then re-export it. Then try retrieving the document once again.
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The file is read-only. You cannot send it to repository. (DX0019)

Cause 1 You tried to send a read-only document to the repository. However, 
BUSINESSOBJECTS always saves files locally to disk before sending them to the 
repository.

Action Change the document properties by right-clicking the file, selecting Properties, 
and disabling Read Only. 

Cause 2 You do not have write access to the folder containing the document.

Action The Windows NT Administrator can grant you write access to the folder as 
follows:

1. Click the Sharing properties of the folder.

2. Select the Security tab.

3. Click the Permissions button.

4. Double-click on Everyone.

5. Check Write (W).



v 5.1-2.7

 Error Message Guide 239

No document domain available. (DX0020)

Cause This message may be displayed when you attempt to publish a document. The 
problem may be because:

• There is no valid connection to the document domain.

• There is a problem exchanging information with the repository because there 
is no document domain, or there are corrupted tables in the repository 
database.

• You attempted to send a document to the repository, but the server on which 
the repository is installed is not responding.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain. 

2. Click the Test button. 

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Could not open: document (DX0021)

Cause You could not open the specified document either because the document has 
been deleted, renamed, or damaged, or you cannot access the document domain.

Action Try the following:

• Check if other users can access the document. If they cannot, ask the owner of 
the document to resend it to the repository.

• If you suspect the file is currently being accessed by another user, wait a while, 
and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

You requested to export the secured file. This action on the file is forbidden to you. The export 
was canceled for the document. (DX0022)

Cause This message may be displayed when you attempt to send a document to the 
repository.

Action If no restrictions are placed on your profile by the supervisor, check the c:\temp 
folder:

1. Delete the unused documents in the c:\temp folder (if possible, empty the 
content in the temp folder).

2. Reboot the machine. 

3. Resend the document to the repository.
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The properties are not up-to-date with the last time the document was exported! (DX0023)

Cause Although documents are stored in the document domain, their properties are 
stored in the security domain. When you import or export documents, both the 
document and the document properties must be transferred. If the document and 
security domains are located on separate servers, the time required to transfer the 
document and the properties may differ. This may result in a de-synchronization 
during the transfer, which can generate the above error message.

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

Then try to re-export the document once more.

Unknown error during export of document. Export stopped. Document not exported. (DX0024)

Cause 1 The table space in the repository is full. There is not enough room to store your 
document. 

Action Ask the database administrator to increase this table space.

Cause 2 The system hosting the repository has run out of free disk space. 

Action The network or system administrator needs to free up some disk space on this 
system.
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Database error during export of document. Export stopped. Document not exported. 
(DX0025)

Cause 1 The repository is full. There is not enough room to store your document. 

Action Ask the database administrator to increase this table space.

Cause 2 The system hosting the repository has run out of free disk space. 

Action The sytem or network administrator needs to free up disk space on this system.

Cause 3 The table size for obj_x_documents is too small.

Action Ask the database administrator to increase the table size for obj_x_documents.

Break during export of document: Export has stopped. Document is not exported. (DX0026)

Cause During the export of a document to the repository, the process was interrupted 
due to a network failure, or a problem on the repository server. 

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

Try exporting the document once again.

Cannot open file associated with document. Document not exported. (DX0027)

Cause You tried to export a document to the repository, but the file cannot be opened. 
The file may be damaged.

Action Try exporting other files. If this does not work, see the supervisor for more 
information on the repository you are using.
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Cannot begin transaction and export document. Problem with the repository. Document not 
exported. (DX0028)

Cause You could not export a document because of errors in the repository.

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

Try exporting the document once again.
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Cannot begin transaction and export document. Problem with the Broadcast Agent. 
Document not exported. (DX0029)

Cause 1 The BROADCAST AGENT machine is out of disk space or memory.

Action You can:

• Reboot the BROADCAST AGENT machine.

• Reduce the number of concurrent tasks in the BROADCAST AGENT Console on 
the server machine, to prevent this error from recurring.

• Run ScanDisk, empty the Recycle Bin and purge the Temp folder on the server 
machine.

• Install more BROADCAST AGENT machines to ensure failover and load-
balancing.

Note: For more information on BROADCAST AGENT, refer to the Broadcast Agent 
Administrator’s Guide.

Cause 2 BROADCAST AGENT is not working, either when you launch it, or while it is 
processing tasks. This could be due to installation or configuration problems, the 
configuration of the server machine itself, or the result of an unrecognized error 
code that has been sent by an incompatible version of BOManager.

Action Relaunch BROADCAST AGENT. If you receive the same error message, see your 
system administrator.
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Cannot delete previous document. Document not exported. (DX0030)

Cause This message may be generated when you try to re-export a document to the 
repository. Because a previous version of the document already exists in the 
repository, you must first delete the previous version of the document before 
exporting the new version. In this case, however, you cannot delete the previous 
version of the document because the repository cannot be accessed.

Action Try the following:

• If you suspect that the document domain is currently locked by another user, 
run the scheduled task once more. If this problem occurs frequently, check if 
your repository database supports row-level locking. If so, you may need to 
manually activate this feature.

• Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator 
should then use database middleware (such as Net8 for Oracle) to check if 
there is any response from the repository database.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository and click the document domain.

2. Click the Test button.
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Cannot obtain information on previous document. Document not exported. (DX0031)

Cause This message may be generated when you try to re-export a document to the 
repository. Because a previous version of the document already exists in the 
repository, you must first delete the previous version of the document before 
exporting the new version.

In this case, however, the previous version of the document cannot be found. This 
may be because the previous version of the document has been moved, renamed, 
or deleted by the supervisor, because the document domain tables have been 
corrupted, or because the document type is not supported by BUSINESSOBJECTS.

Action Check that the previous version of the file is still available in the document 
domain.

A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot terminate transaction and export document. Problem with dx repository. Document 
not exported. (DX0032)

Cause You started to export a document to the document domain of the repository, but 
you cannot successfully complete the operation because a problem has occurred 
on the document domain. This may be because:

• You have lost your connection to the document domain.

• The document domain is locked by another user, or the tables have become 
corrupted.

• The machine on which the document domain resides has run out of free disk 
space.

Action Try the following:

• Check that there is sufficient disk space on the server hosting the document 
domain.

• If you suspect the file is currently being accessed by another user, wait a while, 
and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Text button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot terminate transaction and export document. Problem with master repository. 
Document not exported. (DX0033)

Cause You started to export a document to the document domain of the repository, but 
you cannot successfully complete the operation because a problem has occurred 
on the security domain. This may be because:

• You have lost your connection to the security domain.

• The security domain is locked by another user, or the tables have become 
corrupted.

Action A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Text button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Export failed. (DX0034)

Cause This message may be displayed when you attempt to export a document to the 
repository. The problem may be because:

• There is no valid connection to the document domain.

• There is a problem exchanging information with the document domain of the 
repository. This can be due to corrupted tables in the repository database.

• Locked file: The document may already be open or in use by another user or 
application. 

Action If you suspect the file is currently being accessed by another user, wait a while, 
and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Text button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Unable to connect to repository. (DX0035)

Cause The BUSINESSOBJECTS database password has changed. You cannot log into the 
repository with the current key file.

Action A General Supervisor can do the following:

1. Set up the BUSINESSOBJECTS database ID with a password that does not expire.

2. Log into SUPERVISOR as a General Supervisor.

3. Perform a Safe Recovery, entering the database name, user ID, and password.

4. Select Tools > Repository, and click the document domain.

5.  Click the Test button. 
This checks whether this connection to the document domain is still valid. 

It is likely that the user ID and password used for the document and universe 
domains are the same as that used for the creation of the security domain. 

Both the connections of the universe and document domain therefore need to be 
modified to reflect any changes in the user ID and password, as these connections 
are stored in the repository and not the key file. A General Supervisor can do this 
using Tools > Connections.
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Cannot load the dll. Check the Microsoft Exchange installation. (DX0037)

Cause A required .dll file has been deleted or damaged.

Action Check your Microsoft Exchange installation. If the error persists, you may have 
to re-install Microsoft Exchange.

Cannot open file associated with document. (DX0040)

Cause You are trying to send a document by mail, but the file that you are trying to send 
cannot be opened. This may be because:

• The file has been corrupted.

• The file may be located on a machine that is down or has lost its connection to 
the network.

• If the file is located on a shared disk, it may already be in use by another 
application or user.

Action Check that the file you want to send is accessible, and check that you can open it 
yourself before trying to send it.

Cannot send the message. (DX0041)

Cause You are trying to send a document by mail (MAPI), but BUSINESSOBJECTS cannot 
launch your mailing application.

Action Your mailing application cannot be started, probably due to a missing .dll file or 
an incomplete configuration. Try re-installing the application.
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Unable to update connection information locally. (DX0042)

Cause The repository connection information is no longer correct.

Action The General Supervisor must regenerate the key file in order to change the 
parameters of the connection to your repository. The steps are as follows:

1. Rename the key file to disactivate it.
The key file is located either in the LocData folder (for local installations) or 
the ShData folder (for shared installations).

2. Launch SUPERVISOR as General Supervisor

3. Run a Safe Recovery.

4. In the Advanced tab, check the Disconnect after each transaction parameter.

5. Quit SUPERVISOR.

6. Test the connection.
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No properties are available for this document! (DX0043)

Cause Although documents are stored in the document domain, their properties are 
stored in the security domain. When you import or export documents, both the 
document and the document properties must be transferred. This message may 
be generated in the following circumstances:

• If the document and security domains are located on separate servers, the time 
required to transfer the document and the properties may differ. This may 
result in a de-synchronization during the transfer.

• The repository tables which are used to store document properties may be 
damaged or corrupted.

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

Try exporting the document once again.
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Unable to get the document's properties! (DX0044)

Cause Although documents are stored in the document domain, their properties are 
stored in the security domain. When you import or export documents, both the 
document and the document properties must be transferred. This message may 
be generated when the connection to the machine hosting the security domain is 
no longer working, or the machine itself is down.

Action If the security domain is hosted on a different server, try “pinging” the server to 
make sure it is responding. If the network is running properly, the database 
administrator should then use database middleware (such as Net8 for Oracle) to 
check if there is any response from the repository database.

Database error: (DX0045)

Cause This error may be generated when you try to import, export, or refresh a 
document. The problem is not with BUSINESSOBJECTS, but with your data 
warehouse.

Action Note down the error information which is returned with this message, and check 
it against your database vendor’s troubleshooting documentation.
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The document domain is not responding! (DX0046)

Cause 1 You are trying to send a document to, or retrieve a document from the repository, 
but there is no response from the document domain.

Action The server hosting the document domain may be unavailable. Check if this is the 
case using the Servconf utility. Servconf.exe is a utility automatically installed 
with the Enterprise Server Products option in:
Business Objects\Server\BusinessObjects Manager 5.0

This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runs BusObj.exe processes (under the 
control of the BOManagers).

Defining the appropriate settings is essential to ensure the correct behavior and 
performance of your BOManager system, especially regarding the number of 
BusObj.exe processes that can be launched simultaneously. These values control 
how Windows NT allocates system memory to your server systems.

At any given time, several BusObj.exe processes can be running simultaneously 
from one or more BOManagers. If for any reason there is insufficient system 
memory available for a given BOManager, then processes may fail in various and 
unpredictable ways.

Cause 2 The repository may contain errors, or may be damaged. 

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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You need a more recent version of BusinessObjects to import this document. (DX0047)

Cause You are using a version of BUSINESSOBJECTS which is older than 5.0. You therefore 
cannot import documents created with version 5.0.

Action To use 5.0 documents, you must upgrade your BUSINESSOBJECTS installation to 
version 5.0.

Example The diagram below illustrates the interaction of 4.1 and 5.0 documents with  
BUSINESSOBJECTS repositories. 

      Upgraded
Business Objects
   5.0 Repository

5.0 Client 4.x Client

4.1

Business Objects
  4.1 Repository

4.1

4.1

5.0 Client

5.0

5.0
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The universe was exported but may contain errors. Please refer to the designer of this 
universe. (UX0001)

Cause You successfully exported a universe, but BUSINESSOBJECTS detected 
inconsistencies in the structure or content of the universe.

Action Run an Integrity Check on the universe to fix the problem, and then to export it 
again.

You are not authorized to use this universe. (UX0003)

Cause Your access rights to the document or universe domain cannot be verified. This 
can occur when:

• You have copied a file through the file system, but it has not been associated 
with the document or universe domain in SUPERVISOR.

• You (or the supervisor) exported a document to the repository and then 
deleted it.

When you export a document, your access rights to the document are exported 
with the document ID. When this document is deleted, you no longer have access 
to it. This is a measure to protect the integrity of the document domain.

Action If you cannot access the document or universe directly from SUPERVISOR, or you 
are not connected to the repository, you can:

1. Open the document or universe with the profile of another user who has 
access to it or with the profile of the General Supervisor.

2. Save the document or universe (File > Save As), but select the option
Save for All Users in the lower right-hand corner of the dialog box.

3. Re-send the document or universe to the user.

Ask the General Supervisor to re-export the document and re-assign it to you or 
your group.
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No universe domain is available. Contact your supervisor for help. (UX0010)

Cause You cannot export documents or universes to the repository because it lacks the 
necessary rows representing connections in the OBJ_M_RESLINK table.

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

Try exporting a universe again. If the problem persists, contact Business Objects 
Customer Support.

The universe does not exist in this universe domain. (UX0011)

Cause You are trying to import a derived universe, which means that it is linked to 
another universe.

Linked universes are universes that share common components such as 
parameters, classes, objects, or joins. Among linked universes, one universe is 
said to be the kernel universe while the others are the derived universes. 

In this case, the kernel universe was removed from the universe domain but not 
the security domain.

Action Check for the location of the kernel universe, and re-export it to the universe 
domain. For more information on linked universes, refer to Chapter 10, “Working 
with Linked Universes,” in the Designer’s Guide.
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The file name[name]does not exist in your local folder. (UX0012)

Cause You are trying to re-import a derived universe from the repository. A previous 
version of the universe already exists on your system, but a previous version of 
the master universe cannot be found. This may be because the master universe 
has been deleted from your system.

Action Delete the previous version of the universe from your system, and re-import the 
universe. 

Could not retrieve columns of universe tables. The associated universe connection is not 
valid. (UX0013)

Cause 1 You are trying to import a universe, but DESIGNER cannot retrieve the necessary 
columns because the connection is no longer valid.

Action The server is not responding. Check your connection and modify it if necessary, 
then refresh the structure of your universe.

Cause 2 You are trying to import a universe, but since you started your current DESIGNER 
session, the supervisor has deleted this universe.

Action Before you can import this universe, the universe designer must export it to the 
repository once again.
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The connection associated with the universe has not been defined. You must create a 
secured connection. (UX0014)

Cause You are trying to access data in the repository, but the link between the universe 
domain and the security domain has been corrupted. You no longer have secure 
access to the universe domain.

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

The connection associated with the universe has not been defined. You must create a 
connection. (UX0015)

Cause You are trying to access data in the repository, but the link between the universe 
domain and the security domain has been corrupted. You no longer have secure 
access to the universe domain.

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Could not update the connection locally. (UX0016)

Cause You are trying to update your connection to the repository, but there are network 
problems or the machine which hosts the repository database is down. This 
message may also be generated in the course of an operation which initiates 
connections to the repository (to send or retrieve documents, send to BROADCAST 
AGENT, etc).

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

A supervisor can test that the connections to the repository and the Data Source 
Name are correctly set up in SUPERVISOR (Tools > Connections > Edit).

Cannot open the universe. (UX0023)

Cause 1 You are trying to import a universe, but the universe is damaged.

Action Delete your local version of the universe, import the universe from the repository 
again, and then try opening it.

Cause 2 One of more of the components of the universe may be corrupted.

Action To fix the problem, the designer of the universe needs to export a working version 
of the universe to the repository.
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 Cannot load the repository. (UX0028)

Cause You are trying to access data in the repository, but BUSINESSOBJECTS cannot load 
the file kgtrep50.dll. There is a problem with the connection to the security 
domain.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

A supervisor can test that the connections to the repository and the Data Source 
Name are correctly set up on SUPERVISOR (Tools > Connections > Edit)..

Cannot release the current repository. (UX0029)

Cause DESIGNER is unable to free up some of the resources which it initialized in order 
to set up a connection to the repository.

Action Try launching DESIGNER once again.

The universe file name does not exist. (UX0032)

Cause You are trying to import a universe, but the universe file has been renamed, 
moved or deleted from the universes folder which is located in:
Business Objects\BusinessObjects 5.0 \Universes

Action Check that the universe file is physically available and fully accessible in the 
Universes folder. If you cannot find the universe, check with the other designers 
at your site to determine its possible location.
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The universe domain does not exist. (UX0033)

Cause You are trying to import a universe, but the universe domain has been deleted by 
the supervisor.

Action Check with the supervisor for information about the repository. The universe 
domain may have to be re-created.

The universe ID does not exist in the repository. (UX0034)

Cause You are trying to import a derived universe, which means that it is linked to 
another universe.

Linked universes are universes that share common components such as 
parameters, classes, objects, or joins. Among linked universes, one universe is 
said to be the kernel universe while the others are the derived universes. 

In this case, the kernel universe was removed from the repository.

Action Check for the location of the kernel universe, and re-export it to the repository. 
For more information on linked universes, refer to Chapter 10, “Working with 
Linked Universes,” in the Designer’s Guide.

The universe name does not exist. (UX0036)

Cause You are trying to import a universe, but this universe has been renamed, moved 
or deleted by the supervisor or by another authorized designer.

Action Check with the supervisor, and any other authorized designers. The universe 
may have to be re-exported to the repository.
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The repository is not responding! (UX0037)

Cause This message is displayed when there is a problem connecting to the repository. 
This can be due to network problems or because the machine which hosts the 
repository database is down. This message may also be generated in the course 
of an operation which initiates connections to the repository (to send or retrieve 
documents, send to BROADCAST AGENT, etc.).

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

A supervisor can test that the connections to the repository and the Data Source 
Name are correctly set up in SUPERVISOR (Tools > Connections > Edit).
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The universe domain is not responding! (UX0038)

Cause 1 The server hosting the repository universe domain is down or the network 
connection is not working.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

Cause 2 This message is displayed when there is a problem exchanging information with 
the universe domain of the repository. This can be due to corrupted tables in the 
repository database.

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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The context name does not exist! (UX0039)

Cause While running DESIGNER, you tried to import or export a universe. However, one 
or more contexts in the universe cannot be accessed.  

Action To fix the problem:

1. Open the source version of the universe.

2. Select Tools > Detect Contexts to list the candidate contexts of the universe. 

3. Run an Integrity Check on the universe.

4.  Export a working version to the repository.

The document domain does not exist on the same data account. You cannot export your 
lists of values. (UX0040)

Cause Although your document domain and universe domain are defined in the same 
data account, there is a problem with the List of Values (LOV) table.

An LOV is a file which contains the data values associated with an object.

LOVs are stored in the document domain as a table called OBJ_X_DOCUMENTS. 
However, in order for a document export to succeed, this same table must also 
exist in the univere domain. This is not the case in your data account.

Action You can create the LOV table manually, or (if you are a supervisor) use the wizard 
available in SUPERVISOR to create it in the same database as the universe domain.

Example You have a development, testing and production repository as well as 
development, testing and production domains. You have created a universe with 
a few objects having files that are LOVs.  All of the objects refresh before use and 
export with the universe.  The LOVs display with no problem in DESIGNER, but 
the above error message is displayed when you try to export the universe.
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The document domain account is different. You cannot import your lists of values. (UX0041)

Cause From DESIGNER, you may see the message when importing a universe. From 
BUSINESSOBJECTS, you may see it when importing a universe (through Tools > 
Universes) or when trying to view Lists of Values (LOVs)  (through Tools > 
Universes > Lists of Values).

The message appears when the LOV which is supposed to be with the universe 
in the repository cannot be found. 

Action To avoid this error message, export only one LOV of the universe (i.e. refresh the 
LOV before the export to create the .lov file). The universe's ID is then present in 
the document domain (with the LOV), and the domain is recognized as the right 
one. 

Of course, you must export all other LOVs assigned to objects with the option 
checked Export with universe if you want them to be imported with the universe.

Cannot export the lists of values. (UX0042)

Cause Due to limitations on the data types of some databases, there is no support for the 
document domain (or document exchange), BROADCAST AGENT, or the import or 
export of document (.rep) files. Therefore, it is not possible to export universes 
with Lists of Values (LOVs) to the repository, as LOVs are stored in the document 
domain of the repository.

Action Use an alternative for the distribution of LOV files (such as e-mail or floppy disk), 
and copy the LOV files associated with a universe to the following folder:

BusinessObjects 5.0\UserDocs\Universe_Domain_name\Universe_name

Alternatively, a supervisor can create specific universe and document domains 
on another database (Oracle, SQL Server, MS Access, etc.) while keeping your 
security domain on the same database.
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Cannot update the lists of values in the universe domain. (UX0043)

Cause A List of Values (LOV) is a file which contains the data values associated with an 
object. It is stored as a table in the document domain. This message is generated 
when you try to re-export a universe with an associated LOV (you have checked 
the Export with universe checkbox in DESIGNER), but your universe and document 
domains exist in different data accounts. 

Action To export an LOV with a universe, both the universe and document domains 
must exist in the same data account. You must therefore create a document 
domain in the same data account as your universe domain.

Cannot import the lists of values. (UX0044)

Cause A List of Values (LOV) is a file which contains the data values associated with an 
object, and is stored in the document domain. This message is generated when 
you try to import a universe with an associated LOV, but the universe and 
document domains exist in different data accounts. 

Action To import an LOV with a universe, both the universe and document domains 
must exist in the same data account. A supervisor must therefore create a 
document domain in the same data account as your universe domain.

Incremental export operations are not available. Do you want to export the whole universe? 
(UX0045)

Cause You have made extensive modifications to your universe, and are trying to export 
them to the repository. However, not all of these modifications have been saved 
or exported correctly.

Action Click Yes to perform a normal full export of the universe to the repository.
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Cannot lock the universe. (UX0046)

Cause Normally, you can lock a universe in DESIGNER from the Import/Export dialog 
box. This ensures that only one designer can update or modify the universe at any 
given time. In this case, however, the universe cannot be locked. This may be 
because:

• The universe is already locked by another designer.

• The universe domain cannot be accessed.

Action Try the following:

• Find out which other designers have access to the universe, and request that 
they unlock the universe.

• If the universe domain is hosted on a different server, try “pinging” the server 
to make sure it is responding. If the network is running properly, the database 
administrator should then use database middleware (such as Net8 for Oracle) 
to check if there is any response from the repository database.

Cannot save the universe. (UX0047)

Cause You need to save a universe to disk before DESIGNER can export it. However, you 
have read-only privileges to the disk where you are trying to save the universe, 
or the disk is full.  

Action Try any of the following:

• Empty your Recycle Bin. If necessary, delete any redundant or unwanted files, 
and empty the Recycle Bin again.

• If you have read-only privileges on the disk,  the Windows NT administrator 
can grant you full access privileges.

• Save your universe to another folder or computer in which you have write 
privileges. In DESIGNER, select File > Save As and indicate another location for 
saving your universe.
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Cannot delete previous universe. (UX0048)

Cause This message may be generated when you try to re-export a universe to the 
repository, or re-import a universe from the repository. In both cases, because a 
previous version of the universe already exists, you must first delete the previous 
version before exporting/importing the new version. This message is generated 
if the previous version of the universe cannot be accessed:

•  in the repository (during an export).

•  on your system (during an import).

Action For an export, try the following:

• If you suspect that the universe domain is currently locked by another user, 
try exporting again. If this problem occurs frequently, check if your repository 
database supports row-level locking. If so, the database administrator may 
need to manually activate this feature.

• Check if the machine hosting the universe domain is responding by “pinging” 
the server. If the network is running properly, the database administrator 
should then use database middleware (such as Net8) to check if there is any 
response from the repository database.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Text button.

For an import, check to see whether you have read-only privileges on your disk. 
If so, ask the Windows NT administrator to grant you full access privileges.
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[character] is replaced by [character]. (UX0049)

Cause You have imported a universe, but the universe contained invalid characters in 
the class, context, or object definitions. By default, BUSINESSOBJECTS automatically 
replaced these invalid characters with blank characters.

Action You can continue to work normally. However, you should remember that the 
universe you have imported is no longer identical to the universe in the 
repository.

Cannot create destination folder or universe file. (UX0050)

Cause You are trying to import a universe from the repository. However, you do not 
have write-access to your local disk, or the disk is full.

Action Empty your Recycle Bin. If necessary, delete any redundant or unwanted files, 
and empty the Recycle Bin again. If you have read-only privileges on the root C:\ 
drive,  the Windows NT administrator can grant you full access privileges on the 
C:\ root drive.

Database error: (UX0051)

Cause This error may be generated when trying to import or export a universe. The 
problem is not with BUSINESSOBJECTS, but with your data warehouse.

Action Note down the error information which is returned with this message, and check 
it against your database vendor’s troubleshooting documentation.



 Document and Universe Exchange Error Messages

272 Error Message Guide

Unable to create the list of values file. (UX0052)

Cause 1 A list of values (LOV) is a file which contains the data values associated with an 
object, and is stored in the document domain. This message is generated when 
you try to export a universe with an associated LOV (you have selected the Export 
with universe checkbox), but your universe and document domains exist in 
different data accounts.

Action To export an LOV with a universe, both the universe and document domains 
must exist in the same data account. You must therefore create a document 
domain in the same data account as your universe domain.

Cause 2 BUSINESSOBJECTS cannot create the LOV in the document domain. This may be 
because the document domain is located on a server machine which is down or 
has lost its connection to the network. Alternatively, the document domain tables 
may be corrupted, or there may be insufficient disk space.

Action Check that there is sufficient disk space on the machine on which the document 
domain resides. Delete any unnecessary files and empty the Recycle Bin.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot open the list of values file. (UX0053)

Cause A List of Values (LOV) is a file which contains the data values associated with an 
object, and is stored in the document domain. This message may be generated 
when you try to open a universe with an associated LOV. The document domain 
tables may be corrupted. 

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot close the list of values file. (UX0054)

Cause A List of Values (LOV) is a file which contains the data values associated with an 
object, and is stored in the document domain. This message may be generated 
after you have opened a universe with an associated LOV. Although the LOV file 
is still open, you have lost your connection to the document domain.

Action If the document domain is hosted on a different server, try “pinging” the server 
to make sure it is responding. If the network is running properly, the database 
administrator should then use database middleware (such as Net8 for Oracle) to 
check if there is any response from the repository database.

If the document domain has been damaged, a supervisor can run a  Scan and 
Repair (Tools > Repository); this feature allows the following operations on the 
security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Unable to delete the previous lists of values file. (UX0055)

Cause A List of Values (LOV) is a file which contains the data values associated with an 
object, and is stored in the document domain. This message may be generated 
when you try to re-export a universe to the repository. Because a previous version 
of the universe already exists in the repository, you must first delete the previous 
version of the LOV file before exporting the new version. In this case, however, 
you cannot delete the previous version of the LOV file because the document 
domain cannot be accessed.

Action Try the following:

• If you suspect that the document domain is currently locked by another user, 
run the scheduled task once more. If this problem occurs frequently, check if 
your repository database supports row-level locking. If so, you may need to 
manually activate this feature.

• Check if the machine which hosts the document domain is responding by 
“pinging” the server. If the network is running properly, the database 
administrator should then use database middleware (such as Net8 for Oracle) 
to check if there is any response from the repository database.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.
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Unable to write to the list of values file. (UX0057)

Cause A List of Values (LOV) is a file which contains the data values associated with an 
object, and is stored in the document domain. This message may be generated 
when you try to export a universe to the repository. In this case, you cannot write 
to the LOV file. This may be because you do not have the necessary authorization,  
the document domain tables are full, or the system which hosts the document 
domain has run out of free disk space. 

Action Try the following:

• You may have read-only privileges on the disk which hosts the document 
domain. Ask the Windows NT administrator to grant you full access 
privileges.

• Ask the database administrator to increase the space of the document domain 
table.

• Free up some disk space on the document domain machine: Delete any 
unnecessary files and empty the Recycle Bin. Then try to export the universe 
again.
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Unable to get data from the lists of values file. (UX0058)

Cause A List of Values (LOV) is a file which contains the data values associated with an 
object, and is stored in the document domain. This message may be generated 
when you try to open a universe with an associated LOV. The document domain 
tables may be corrupted. 

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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RSS file not accessible. (UX0059)

Cause One .rss file is created for each of the databases you are using. This file contains 
the necessary connection information, and is stored in the database folder: 

BusinessObjects 5.0\Data Access 5.0\database_name. 

This error is generated if BUSINESSOBJECTS cannot find the .rss file under the 
database folder, and therefore cannot establish a connection to the database.

Action Copy a backup of the .rss file to the database folder. If you do not have a backup, 
a supervisor must create the connection once more in SUPERVISOR. 

 Incorrect SQL used. (UX0060)

Cause 1 A List of Values (LOV) is a file which contains the data values associated with an 
object, and is stored in the document domain. This message may be generated 
when you try to access a universe with an associated LOV using freehand SQL 
statements that you enter in the SQL Editor.  The SQL you used may not be 
compatible with your corporate database.

Action Check which versions of SQL are supported by your corporate database.

Cause 2 BUSINESSOBJECTS has encountered an exceptional error while attempting to access 
your corporate database.

Action Contact Business Objects Customer Support.
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Not enough memory. (UX0061)

Cause Windows NT does not have sufficient memory to run the various server systems 
which have been configured.

Action Run the Servconf.exe utility to modify your memory settings. Servconf.exe is a 
utility automatically installed with the Enterprise Server Products option in:
Business Objects\Server\BusinessObjects Manager 5.0

This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runs BusObj.exe processes (under the 
control of the BOManagers).

Defining the appropriate settings is essential to ensure the correct behavior and 
performance of your BOManager system, especially regarding the number of 
BusObj.exe processes that can be launched simultaneously. These values control 
how Windows NT allocates system memory to your server systems.

At any given time, several BusObj.exe processes can be running simultaneously 
from one or more BOManagers. If for any reason there is insufficient system 
memory available for a given BOManager, then processes may fail in various and 
unpredictable ways. 
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Cannot begin transaction and export universe. Problem with the security domain. (UX0062)

Cause You are trying to export a universe to the repository, but the security domain is 
either inaccessible or has been damaged.

Action If the security domain is hosted on a different server, try “pinging” the server to 
make sure it is responding. If the network is running properly, the database 
administrator should then use database middleware (such as Net8 for Oracle) to 
check if there is any response from the repository database.

A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.



v 5.1-2.7

 Error Message Guide 281

Cannot begin transaction and export universe. Problem with the document domain. 
(UX0063)

Cause You are trying to export a universe to the repository, but the document domain 
is either inaccessible or has been damaged.

Action If the document domain is hosted on a different server, try “pinging” the server 
to make sure it is responding. If the network is running properly, the database 
administrator should use database middleware (such as Net8 for Oracle) to check 
if there is a response from the repository database.

A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot obtain information on previous [name]. (UX0064)

Cause This message may be generated when you try to re-export a universe to the 
repository. Because a previous version of the universe already exists in the 
repository, a previous version of the List of Values (LOV) should also be available 
in the document domain. An LOV is a file which contains the data values 
associated with an object.

In this case, however, the previous version of the LOV cannot be found in the 
document domain. This may be because the LOV file has been moved, renamed, 
or deleted by the supervisor.

Action Check that the previous version of the file is still available in the document 
domain.

A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervsor may have to re-create the 
repository.
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Cannot delete previous [name]. (UX0065)

Cause This message may be generated when you try to re-export a universe to the 
repository. Because a previous version of the universe already exists in the 
repository, a previous version of the List of Values (LOV) should also be available 
in the document domain. An LOV is a file which contains the data values 
associated with an object.

This file must be deleted before the new LOV can be exported. In this case, 
however, the previous version of the LOV cannot be deleted from the document 
domain. This may be because you do not have write-access to the document 
domain disk.

Action You may have read-only privileges on the disk which hosts the document 
domain. Ask the Windows NT administrator to grant you full access privileges.
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Cannot terminate transaction and export universe. Problem with the document domain. 
(UX0066)

Cause You started to export a universe to the repository, but cannot complete the 
operation because the document domain is either no longer accessible or has been 
damaged.

Action If the document domain is hosted on a different server, try “pinging” the server 
to make sure it is responding. If the network is running properly, the database 
administrator should then use database middleware (such as Net8 for Oracle) to 
check if there is any response from the repository database.

A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot terminate transaction and export universe. Problem with the security domain. 
(UX0067)

Cause You started to export a universe to the repository, but cannot complete the 
operation because the security domain is either no longer accessible or has been 
damaged.

Action If the security domain is hosted on a different server, try “pinging” the server to 
make sure it is responding. If the network is running properly, the database 
administrator should then use database middleware (such as Net8) to check if 
there is any response from the repository database.

A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

Database error during export of the list of values file. (UX0068)

Cause This message may be generated after a BusObj.exe task has finished processing 
(i.e., accessing the repository to send a document, perform an update, etc). The 
problem is due to the way in which your repository database has been set up to 
handle user access.

Action Check with the database administrator to make sure the database is neither full 
nor corrupted.
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Export of the lists of values interrupted. (UX0069)

Cause A List of Values (LOV) is a file which contains the data values associated with an 
object, and is stored as a table in the document domain. This message is generated 
when you lose your connection to the document domain while you are trying to 
export a universe.

Action Verify if the repository is responding by “pinging” the server. If the network is 
running properly, the database administrator should then use database 
middleware (such as Net8 for Oracle) to check if there is any response from the 
repository document domain.

Universe already exists in the domain. Do you want to overwrite it? (UX0071)

Cause The universe that you are trying to export has the same name as another universe 
that has already been exported to the universe domain.

Action If you are updating an existing universe, then you can overwrite the universe that 
is already in the universe domain. If you are exporting a new universe, then 
rename the universe using a unique name, and try exporting it again. 
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Connectivity Error Messages

Connectivity error messages fall into the following categories:  

The server is not responding! (SBO0001)

Cause 1 The middleware is not configured correctly.

Cause 2 The BUSINESSOBJECTS connection parameters are invalid.

Cause 3 The database server is down.

Action Click the Details button in the Test Connection dialog box. Make a note of the 
database or middleware error message, and contact your database administrator.

Connection name already exists. (SBO0003)

Cause You tried to create a connection with the name of an existing connection.

Action Enter a different name for the connection in the Name box, check the other 
parameters, and click OK.

Range Category

SBO0001 - SBO00016 Connectivity error messages

DAC0001 - DAC0005 Data access error messages
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The Name field is empty. (SBO0005)

Cause You have not entered a name for the connection you are trying to create.

Action Enter a name for your connection in the Name box, check the other parameters, 
and click OK.

Cannot load the connection driver: (SBO0008)

Cause 1 The database middleware is not installed on your PC.

Action Install the middleware.

Cause 2 The database middleware is not installed correctly on your PC.

Action Reinstall the middleware.

Cause 3 The connection driver is not installed correctly on your PC.

Action Reinstall the connection driver as follows:

1. Click the Start button, point to Programs, point to the BusinessObjects 5.0 
folder, and then click Setup.
The BUSINESSOBJECTS installer program is displayed.

2. Click the Begin button to get to the screen called Choose the Products and 
Modules.

3. In the left pane, scroll until you can view Data Access.
The right pane shows all the products and modules already installed on your 
machine.

4. Click Data Access to view the connection drivers you can install.

5. Click the connection driver, then click the Install button.
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Cannot access the connection driver: (SBO0009)

Background This error occurs when you try to launch a BUSINESSOBJECTS application once you 
have created the repository.

Cause The connection driver is not installed correctly on your PC.

Action Reinstall the connection driver as follows:

1. Click the Start button, point to Programs, point to the BusinessObjects 5.0  
folder, and then click Setup.
The BUSINESSOBJECTS installer program is displayed.

2. Click the Begin button to get to the screen called Choose the Products and 
Modules.

3. In the left pane, scroll until you can view Data Access.
The right pane shows all the products and modules already installed on your 
machine.

4. Click Data Access to view the connection drivers you can install.

5. Click the connection driver, then click the Install button.
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Cannot load the .prm file. (SBO0010)

Cause BUSINESSOBJECTS cannot find the driveren.prm file. A driveren.prm file contains all 
the parameters necessary for creating and managing BUSINESSOBJECTS universes 
as well as generating queries.

You usually have one driveren.prm file for each RDBMS you are working with at 
the following location:

C:\Program Files\Business Objects\Data Access 5.0\RDBMS\

Action Reinstall the connection driver as follows:

1. Click the Start button, point to Programs, point to the BusinessObjects 5.0 
folder, and then click Setup.
The BUSINESSOBJECTS installer program is displayed.

2. Click the Begin button to get to the screen called Choose the Products and 
Modules.

3. In the left pane, scroll until you can view Data Access.
The right pane shows all the products and modules already installed on your 
machine.

4. Click Data Access to view the connection drivers you can install.

5. Click the connection driver, then click the Install button.
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Cannot load the .rss file. (SBO0011)

Cause BUSINESSOBJECTS cannot find the driver.rss file. This frequently occurs when you 
use a different RDBMS for your repository and your universe and have not 
installed all the necessary connection drivers. You need to install (reinstall) the 
missing connection driver.

The driver.rss file is used to create the BUSINESSOBJECTS repository. You usually 
have one driver.rss file for each RDBMS you are working with at the following 
location:

C:\Program Files\Business Objects\Data Access 5.0\RDBMS\

Action Reinstall the connection driver as follows:

1. Click the Start button, point to Programs, point to the BusinessObjects 5.0 
folder, and then click Setup.
The BUSINESSOBJECTS installer program is displayed.

2. Click the Begin button to get to the screen called Choose the Products and 
Modules.

3. In the left pane, scroll until you can view Data Access.
The right pane shows all the products and modules already installed on your 
machine.

4. Click Data Access to view the connection drivers you can install.

5. Click the connection driver, then click the Install button.
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Cannot find the connection driver key in the Windows registry. (SBO0012)

Background This error message appears only in BUSINESSTRACKER.

Cause BUSINESSOBJECTS cannot find in the Windows Registry the key in which the 
BUSINESSOBJECTS driver was installed. This may happen if the driver is not 
installed on your PC or if it was not installed correctly.

Action Install the connection driver as follows:

1. Click the Start button, point to Programs, point to the BusinessObjects 5.0 
folder, and then click Setup.
The BUSINESSOBJECTS installer program is displayed.

2. Click the Begin button to get to the screen called Choose the Products and 
Modules.

3. In the left pane, scroll until you can view Data Access.
The right pane shows all the products and modules already installed on your 
machine.

4. Click Data Access to view the connection drivers you can install.

5. Click the connection driver, then click the Install button.
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Cannot find the SQL syntax list in the .sbo file: (SBO0014)

Background This error message appears only in BUSINESSTRACKER.

Cause BUSINESSOBJECTS cannot access the SQL Syntax list from the driver.sbo file. The 
driver.sbo file contains all the default connection parameters. It is located at:

C:\Program Files\Business Objects\Data Access 5.0\RDBMS\

Action Reinstall the connection driver as follows:

1. Click the Start button, point to Programs, point to the BusinessObjects 5.0 
folder, and then click Setup.
The BUSINESSOBJECTS installer program is displayed.

2. Click the Begin button to get to the screen called Choose the Products and 
Modules.

3. In the left pane, scroll until you can view Data Access.
The right pane shows all the products and modules already installed on your 
machine.

4. Click Data Access to view the connection drivers you can install.

5. Click the connection driver, then click the Install button.
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Cannot access the .sbo file: (SBO0015)

Background This error message relates to the driver.sbo file.

Cause 1 BUSINESSOBJECTS cannot access the SQL Syntax list from the driver.sbo file. The 
driver.sbo file contains all the default connection parameters. It is located at:

C:\Program Files\Business Objects\Data Access 5.0\RDBMS\

Cause 2 BUSINESSOBJECTS cannot open the driver.sbo file.

Cause 3 BUSINESSOBJECTS cannot find the driver.sbo file.

Action Reinstall the connection driver as follows:

1. Click the Start button, point to Programs, point to the BusinessObjects 5.0 
folder, and then click Setup.
The BUSINESSOBJECTS installer program is displayed.

2. Click the Begin button to get to the screen called Choose the Products and 
Modules.

3. In the left pane, scroll until you can view Data Access.
The right pane shows all the products and modules already installed on your 
machine.

4. Click Data Access to view the connection drivers you can install.

5. Click the connection driver, then click the Install button.
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The connection did not succeed. (SBO0016)

Cause 1 You did not enter the correct password.

Action Reenter the password in the Login tab.

Cause 2 The database server is down.

Action Ask the database administrator to restart the server.

Unable to create the [name] connection. (DAC0001)

Cause The connection driver or one of its components is no longer present on your PC.

Action Reinstall the connection driver as follows:

1. Click the Start button, point to Programs, point to the BusinessObjects 5.0 
folder, and then click Setup.
The BUSINESSOBJECTS installer program is displayed.

2. Click the Begin button to get to the screen called Choose the Products and 
Modules.

3. In the left pane, scroll until you can view Data Access.
The right pane shows all the products and modules already installed on your 
machine.

4. Click Data Access to view the connection drivers you can install.

5. Click the connection driver, then click the Install button.
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Unable to edit the connection: network layer is not available.  (DAC0002)

Cause The connection driver or one of its components is no longer present on your PC.

Action Reinstall the connection driver as follows:

1. Click the Start button, point to Programs, point to the BusinessObjects 5.0 
folder, and then click Setup.
The BUSINESSOBJECTS installer program is displayed.

2. Click the Begin button to get to the screen called Choose the Products and 
Modules.

3. In the left pane, scroll until you can view Data Access.
The right pane shows all the products and modules already installed on your 
machine.

4. Click Data Access to view the connection drivers you can install.

5. Click the connection driver, then click the Install button.

Unable to test the connection: network layer is not available. (DAC0003)

Cause The connection driver or one of its components is no longer present on your PC.

Action Reinstall the connection driver as follows:

1. Click the Start button, point to Programs, point to the BusinessObjects 5.0 
folder, and then click Setup.
The BUSINESSOBJECTS installer program is displayed.

2. Click the Begin button to get to the screen called Choose the Products and 
Modules.

3. In the left pane, scroll until you can view Data Access.
The right pane shows all the products and modules already installed on your 
machine.

4. Click Data Access to view the connection drivers you can install.

5. Click the connection driver, then click the Install button.
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Unable to modify secured connections in offline mode. (DAC0004)

Cause You cannot modify secured connections if you are in offline mode. Offline mode 
basically means working with universes stored locally on your PC.

Action From DESIGNER or from BUSINESSOBJECTS, select Login As on the Tools menu. 
Then in the User Identification dialog box, uncheck the Use in Offline Mode option.

Unable to retrieve secured connections. (DAC0005)

Cause Cannot access the repository.

Action Launch SUPERVISOR. From the User Identification dialog box, click the Admin 
button. From the Administration Setup wizard, run a Safe Recovery to restore the 
repository. 
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BusinessObjects General Error Messages

BUSINESSOBJECTS general error messages include the following ranges and 
categories:  

 The password confirmation does not match. (USO001)

Cause You have tried to change your password using the Change Password command 
and the password you typed in the Confirm Password box is not the same as the 
password you typed in the New Password box. This could simply be due to a 
typing error, for example.

Action Type the password again in the New Password box and then type exactly the 
same password in the Confirm Password box.

You are not allowed to drill in a block that displays multiple queries on same universe or 
multiple data sources. (USP0001)

Cause You cannot analyze a table, crosstab or chart in drill mode if it contains data from 
different types of data providers or if it contains data from different queries on 
the same universe. 

Action If you want to set up a report for analyzing in drill mode, make sure the block you 
want to drill on contains data from the same data provider. If you want to check 
which data provider the data belongs to, open the Data Manager. To do this, from 
the Data menu, select View Data. 

Example You have a table that displays data from a query on a BUSINESSOBJECTS universe 
and data from a personal spreadsheet and want to analyze the data in this table 
in drill mode.

Range Category

USO001 Password

USP0001 - USP0005 General
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You cannot save this document as a .bqy file. The document must contain only one data 
provider, which must be a query on a universe. (USP0003)

Cause You can save a BUSINESSOBJECTS document as a BUSINESSQUERY file only if it 
contains data from a query on a BUSINESSOBJECTS universe. BUSINESSQUERY is not 
designed to manipulate data from other sources.

Action If you want to save data in a document in a BUSINESSQUERY file, make sure the 
document contains only one universe data provider. To check this, from the Data 
menu, select View Data to open the Data Manager.

Example You have a BUSINESSOBJECTS document that contains data from a query on a 
BUSINESSOBJECTS universe and data from a personal data file. You want to save 
this file as a BUSINESSQUERY file.

This icon indicates that the 
data provider is a query 
on a BusinessObjects 
universe.

There is only one data 
provider in this document.

List of the data returned by 
this data provider.
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Cannot connect to the Business Objects web site. (USP0004)

Cause Some commands on the menus of Business Objects products open pages on the 
company’s web site. If you do not have Internet access or do not have an Internet 
browser installed on your computer, this message is displayed if you select one 
of these commands.

Action If you want to use commands that open pages on the Business Objects web site, 
you need to install and correctly configure an Internet browser and make sure 
you have access to the Internet from your computer.

Example The command More Tips and Samples in the BUSINESSOBJECTS Help menu takes 
you directly to the Tips and Tricks page on the Business Objects web site. 

You cannot use this version of BusinessQuery files with BusinessObjects 5.0. (USP0005)

Cause You can open BUSINESSQUERY 4.1 files in BUSINESSOBJECTS 5.0 only if you choose 
BOMain.key from the Security Domain list when you log into BUSINESSOBJECTS. 
This is because BUSINESSOBJECTS 5.0 was designed to support multiple security 
domains but BUSINESSQUERY 4.1 currently does not. 

Action Try logging into BUSINESSOBJECTS again. After entering your name and password 
in the User Identification box, choose BOMain.key from the Security Domain list.

Example You tried to open a BUSINESSQUERY 4.1 file in BUSINESSOBJECTS 5.0.
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You are not authorized to access this query file because its security domain is not the one 
you are working with. (USP0006)

Cause A BUSINESSQUERY or WEBINTELLIGENCE document can only be opened in 
BUSINESSOBJECTS if the name of the key file is BOMain.key.

Action Change the name of your key file to BOMain.key. The key file is stored by default 
at:

Business Objects\BusinessObjects 5.0\LocData

Example A user creates a WEBINTELLIGENCE document and sends it to the repository. If the 
name of the key file on the WEBINTELLIGENCE server is TEST.key and the user’s 
local .key is called TEST.key, the user must change name of the local key file to 
BOMain.key for the WEBINTELLIGENCE document to open in BUSINESSOBJECTS.

Cannot download online guide from server (USP0007)

Cause The online guide you tried to download is not available. This is because your 
administrator chose not to install this guide when installing your
Business Objects products.

Action Ask your administrator to install the online guides on the server.
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BusinessObjects Reporting and Analysis Error 
Messages

BUSINESSOBJECTS reporting and analysis error messages include the following 
ranges and categories:  

Unable to turn to chart. (RPT0001)

Cause You tried to turn a table which contains only dimension/detail variables or only 
measure variables into a chart using either the chart toolbar or the Turn to Chart 
command. To display data in a chart you need at least one measure variable and 
one dimension or detail variable.

Action If you want to display your data in a chart, make sure you have at least one 
measure variable and one dimension or detail variable in the table before turning 
it to a chart.

Range Category

RPT0001 - RPT0039 Building reports

DWZ0002 - DWZ0011 New Report Wizard

DMB0003 - DMB0008 Creating variables

FOR0001 - FOR0003 Charts
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Failed to create object. Make sure the application is entered in the system registry. (RPT0004)

Cause You tried to insert an object into a BUSINESSOBJECTS report using the 
Insert > Object command. The Insert > Object command allows you to insert an 
OLE object in a report. An OLE object is created from a registered application. 

This error can occur if the object type you chose to insert is either not associated 
with an application or is associated with an application that is no longer installed 
on your computer.

Action Make sure the application associated with the object type is correctly installed on 
your computer and that it has not been deleted or renamed. 

Example You tried to insert a Microsoft Word document in your report but Microsoft 
Word is not installed on your computer. BUSINESSOBJECTS cannot find the 
application and displays this error message.
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 Cannot find default.ret file. Application default settings will be used. (RPT0005)

The styles settings used to create a Standard report are contained in the 
default.ret file. You can customize and save these styles settings using the 
Standard Report Styles dialog box. If BUSINESSOBJECTS cannot find this file with 
your custom settings, it re-creates it using the application default settings.

Cause 1 You have moved the default.ret file from the BUSINESSOBJECTS Template folder.

Action Close the Standard Report Styles dialog box without making any changes and 
then make sure the default.ret file is in the BUSINESSOBJECTS Template folder.

Cause 2 You have changed the location of your BUSINESSOBJECTS Template folder. 

Action Update the Templates folder path to point to the folder where the default.ret file 
is saved. To do this:

1. Select Tools > Options.

2. Click the File Locations tab.

3. Change the User Templates path.

Cause 3 You have inadvertently deleted the default.ret file.

Action If you are using a customized default.ret file used throughout the company, make 
a copy of the file from another user.
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Cannot use default.ret file. Any changes you make to standard style settings will not be 
saved. (RPT0006)

You tried to open the Standard Report Styles dialog box to edit styles and this 
message is displayed.

Cause 1 You have moved the default.ret file from the BUSINESSOBJECTS Template folder.

Action Make sure the default.ret file is in the BUSINESSOBJECTS Template folder.

Cause 2 You have changed the location of your BUSINESSOBJECTS Template folder. 

Action Update the Templates folder path to point to the folder where the default.ret file 
is saved. To do this:

1. Select Tools > Options.

2. Click the File Locations tab.

3. Change the User Templates path.

Cause 3 You have inadvertently deleted the default.ret file.

Action If you are using a customized default.ret file used throughout the company, make 
a copy of the file from another user.

Cause 4 The default.ret file has been set as a read-only file which means that any changes 
you make in the Standard Report Styles dialog box are not be saved.

Action Check with your BUSINESSOBJECTS supervisor that you have the right to change 
the standard report styles settings.
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Cannot use default.ret file. Any changes you have made will not be saved. (RPT0007)

Cause The default.ret file has been set as a read-only file which means that any changes 
you make in the Standard Report Styles editor are not saved.

Action Check with your BUSINESSOBJECTS supervisor that you have the right to change 
the standard report styles settings.

Remove variance. (RPT0009)

Cause You cannot group values of a dimension variable in a table or crosstab if the table 
or crosstab contains a variance calculation on the dimension variable you are 
trying to group.

Action First remove the columns or rows containing the variance calculation before 
trying to group values. Then you can reinsert the variance calculation on the 
grouped values.

Example You have a table displaying sales revenue per quarter and you have inserted a 
variance calculation to show the difference in revenue between Q1 and Q2. You 
now try to group the quarters into two semesters, H1 and H2, and you get this 
error message. 

The variable must have a name. (RPT0020)

Cause When you create a new variable in the BUSINESSOBJECTS Variable Editor or by 
turning an existing formula into a variable, you have to give the variable a name. 
A variable without a name is treated as a formula by BUSINESSOBJECTS.

Action Click the Definition tab of the Variable Editor and type a name for the variable in 
the Name box.
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Min Greater Than Max (RPT0025)

Cause Occurs when you are setting up a BUSINESSOBJECTS alerter. When defining the 
alerter conditions on the Conditions tab of the Edit Alerter dialog box, you used 
two operators, the less than (<) operator and the greater than (>) operator. The 
value you set to use with the less than (<) operator is smaller than the value you 
set to be use with the greater than (>) operator as shown in the example below:

This does not work because BUSINESSOBJECTS cannot find a value that is at the 
same time less than 15 and greater then 25.

Action Edit the Alerter conditions to ensure that the value you enter to be used with the 
greater than (>) operator is in fact greater than the value you set to be used with 
the less than (<) operator.
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Incompatible Operators (RPT0026)

Cause Occurs when you are setting up a BUSINESSOBJECTS alerter and you have defined 
two operators which are not compatible. In the example below, Value 1 is set to 
be equal to (=) 25 and Value 2 to be less than (<) 15. Obviously,  BUSINESSOBJECTS 
cannot find values which are at the same time equal to 25 and less than 15 so it  
displays an error message! 

Action If you are setting more than one value in the Conditions tab, make sure that the 
operators you are using are compatible with the values you have set.
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Incorrect number of parameters. You must have two values. (RPT0027)

Cause Occurs when you are setting up a BUSINESSOBJECTS alerter and you have chosen 
the Between operator and entered only one value in the Value box. When you use 
the Between operator, you must enter two values and separate them with a semi 
colon (;).

Action Make sure that you have entered two values in the Value box of the Conditions 
tab and separated the two values by a semi colon (;) as shown below. If you are 
choosing values from the List of Values list, select the first value, hold down the 
Ctrl key and select the second value, and then click OK. The semi colon separator 
is added automatically in this case.
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Incorrect number of parameters. You must have at least 1 value. (RPT0028)

Cause Occurs when you are setting up a BUSINESSOBJECTS alerter and you have chosen 
the InList operator and not entered at least one value in the Value box.

Action Enter at least one value in the Value box of the Conditions tab. 

Missing conditions (RPT0029)

Cause Occurs when you are setting up a BUSINESSOBJECTS alerter and you have not set 
any conditions on the Conditions tab and then clicked OK to create the alerter.

Action BUSINESSOBJECTS cannot create an alerter if you have not set any conditions on the 
Conditions tab. Go back to the Conditions tab and set the required conditions.

Empty interval (RPT0030)

Cause Occurs when you are setting up a BUSINESSOBJECTS alerter. On the Conditions tab 
you have set two different operators and have set the same value for each of the 
operators.

Action Make sure that you have set a different value for each of the chosen operators.
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Cannot find default: default settings of the application will be used. (RPT0033)

The styles settings used to create a Standard report are contained in the 
default.ret file. You can customize and save these style settings using the 
Standard Report Styles editor. If BUSINESSOBJECTS cannot find this file with your 
custom settings, it re-creates it using the application default settings.

You have created a new Standard report and this message is displayed after the 
query has been run and just before the new report is displayed.

Cause 1 You have moved the default.ret file from the BUSINESSOBJECTS Template folder.

Action Make sure your customized default.ret file is in the BUSINESSOBJECTS Template 
folder.

Cause 2 You have changed the location of your BUSINESSOBJECTS Template folder. 

Action Update the Templates folder path to point to the folder where the default.ret file 
is saved. To do this:

1. Select Tools > Options.

2. Click the File Locations tab.

3. Change the User Templates path.

Cause 3 You have inadvertently deleted the default.ret file.

Action If you are using a customized default.ret file used throughout the company, make 
a copy of the file from another user.



 BusinessObjects Reporting and Analysis Error Messages

316 Error Message Guide

You cannot insert a ranking. There is no measure for this dimension. (RPT0034)

Cause If there is no measure variable in your report that is compatible with the 
dimension variable you have selected, you will not be able to insert a ranking.

Action Include a measure variable which is compatible with the dimension variable you 
want to rank in your report either by editing the data provider or creating a local 
variable.

Example When you insert a ranking on data, you rank a dimension variable, for example 
month, according to a measure variable, for example, sales revenue, to display 
the top three sales revenue making months.

It is impossible to insert a BusinessObjects document object into a BusinessObjects 
document. (RPT0035)

Cause This message occurs if you try to insert a BUSINESSOBJECTS document as an OLE 
object into a report using the Insert > Object command.

Action You cannot insert a BUSINESSOBJECTS document as an OLE object in a 
BUSINESSOBJECTS report.

The maximum axis value must be greater than the minimum axis value. (RPT0037)

Cause In the Scale tab of the Format Axis Label dialog box, you have set the Maximum 
value on the scale to a value which is smaller than the value you have set in the 
Minimum value box.

Action Enter a value in the Maximum box that is greater than the value in the Minimum 
box.
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The maximum and minimum axis values must be greater than zero on a logarithmic scale. 
(RPT0038)

Cause In the Scale tab of the Format Axis Label dialog box, you have set the scale on a 
chart to display a Logarithmic scale and set the Minimum or Maximum value on 
this scale to a value which is zero or less than zero.

Action Enter a value greater than zero in the Minimum or Maximum value box.

The unit value must be greater than zero. (RPT0039)

Cause In the Scale tab of the Format Axis Label dialog box, you have set the Major Unit 
to a value which is zero or less than zero.

Action Enter a value greater than zero in the Major Unit box.

No stored procedure (DWZ0002)

Cause Occurs when you are creating a new report in the New Report Wizard and have 
chosen to use a Stored Procedure to obtain the data and BUSINESSOBJECTS cannot 
find the selected stored procedure.

Action Check that the stored procedure exists and that it has not been renamed, moved 
or deleted.
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No universe (DWZ0003)

Cause 1 You have no universes in your Universes folder.

Action Check that the universes you use are in the Universes folder in the 
BUSINESSOBJECTS folder.

Example You are creating a new report in the New Report Wizard and have chosen to 
build your query on a universe but there are no universes listed in the Available 
Universes list.

Cause 2 The location of the Universes folder has been changed. 

Action Update the Universes folder path to point to the folder where the universes you 
are allowed to use are stored. To do this:

1. Select Tools > Options.

2.  Click the File Locations tab on the Options dialog box.

3. Update the universe path.
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No template (DWZ0004)

You are creating a new report in the New Report Wizard and want to use a 
template but none are listed in the Available Templates list.

Cause 1 You have no templates in your BUSINESSOBJECTS Template folder.

Action Check that the templates you use are in the Template folder in the 
BUSINESSOBJECTS folder.

Cause 2 The location of the Template folder has been changed. 

Action Update the Template folder path to point to the folder where the templates you 
use are stored. To do this:

1. Select Tools > Options. 

2. Click the File Locations tab on the Options dialog box.

3. Update the Template path.

You must place at least one variable in each folder. (DWZ0005)

Cause This message occurs when you use the Insert Crosstab wizard and do not place 
one variable in each of the three folders on the Pivot Data for the Crosstab screen. 
To display data in a crosstab, you typically place dimension type variables in the 
Row and Column folders, and measure type variables in the Body folder.

Action Place one variable in each of the three folders on the Pivot Data for the Crosstab 
screen. If you have only two variables, you will not be able to create a crosstab.
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To create the chart you need at least one measure and one dimension or detail. (DWZ0008)

Cause This message occurs when you use the Insert Chart wizard and do not choose one 
measure type variable and one dimension or detail type variable from the Select 
the Variables list. You need at least one measure and one dimension or detail 
variable to display data in a chart.

Action Choose at least one measure type variable and one dimension or detail type 
variable from the Select the Variables list.

You must select at least one variable. (DWZ0009)

Cause This message occurs when you use the Insert Table wizard and did not select the 
variables you want to display in your table in the Select the Variables list.

Action Choose at least one variable from the Select the Variables list.



v 5.1-2.7

 Error Message Guide 321

Internal Error. Please check your Data Provider installation. (DWZ0010)

Cause Occurs when you are creating a new report in the New Report Wizard and 
BUSINESSOBJECTS has encountered a problem with the chosen data provider.

Action Make sure that all the components for the data provider you are using have been 
correctly installed.

If you are trying to connect to an OLAP server, you must have all the necessary 
middleware software installed on the client machine.

Example Here are some of the things to check on a client machine in order to access an 
Oracle Express server:

• Check for the transport option ncacn_ip_tcp while installing SNAPI version 
6.2. The NCACN_IP_TCP protocol uses a Microsoft RPC transport. You can 
use it to connect to a Windows NT server.

• Check that BUSINESSOBJECTS is linked to the RSNAPI dll named 
XWSNLR32.DLL (You can find it in all SNAPI versions: 6, 6.01, 6.1, 6.2) .
XWSNLR32.DLL dynamically loads the dll named XSSNR32.DLL, which 
itself loads the other dlls it needs dynamically.

• Check that the SNAPI files are located in your path or system environment 
variables:
XWSNLR32.DLL
XWSNR32.DLL

Preview not available. This template contains only styles. (DWZ0011)

Cause A template can contain styles and structure. The template structure consists of the 
blocks that contain the data. You cannot use a template that contains only styles 
to create a new report because there is no structure to contain the data.

Action Create your report first (either create a standard report or use a template that 
contains structure) and then apply the template which contains only styles to the 
report. To do this, select Format > Report and then Apply Template.
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Incorrect data type (DMB0003)

Cause Occurs when you are writing a formula in the Formula Editor, the Formula Bar, 
or directly in a cell and have included in your formula data types that cannot be 
used together or have used the wrong data type in a BUSINESSOBJECTS function. 
The two examples below show two situations in which this error could occur.

Example 1 You are writing a formula to combine text and a date in a cell using the & or the 
+ operator or using the Concatenation() function: 
="Invoice date "&<Date>

This formula returns an error because you cannot combine a character string and 
a date. You can combine only character strings using the & and + operators or the 
Concatenation() function.

Action Use the BUSINESSOBJECTS online help in the Formula Editor to check the syntax in 
the  function or statement in your formula. Be sure  to use the required data types.

If you want to combine text with dates or numbers, you must first convert the 
date or number into a character string. You can do this using the FormatDate() 
and FormatNumber() functions. The formula:
="Invoice date: "&FormatDate(<Date>, "dd/mm/yyyy")

will give you the following result: Invoice date: 15/08/1999

The syntax and 
required data types for 
the selected function 
are shown here. Click here to check the

syntax for the function or
statement you are using.
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Example 2 You are writing a formula using an If Then Else statement:
If (<Number of Guests>>500) Then "Well done" Else "0"

This formula returns an error because you have used a number in one part of the 
statement and a character string in another part. You cannot mix output types 
using If Then Else syntax because BUSINESSOBJECTS does not know whether to 
return a number (0) or a character string (“Well done”).

Action You can fix the problem in the formula above by using the same data type in both 
parts of the statement as shown in the two examples below:

If (<Number of Guests>>500) Then "Well done" Else "To be improved"

If (<Number of Guests>>500) Then 1 Else 0
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Too many parameters (DMB0005)

Cause Occurs when you are writing a formula in the Formula Editor, the Formula Bar, 
or directly in a cell and you have included too many parameters in a 
BUSINESSOBJECTS function you are using in the formula.

Action Use the BUSINESSOBJECTS online help to check that the syntax you are using for 
the function in your formula is correct. The syntax and required variable types for 
BUSINESSOBJECTS functions are shown in the Formula Editor when you select the 
function in the Functions list as shown below: 

Example You try to use the Abs() function with two parameters as shown below:
=Abs(2,-3)

Since you can use only one parameter with this function you get an error 
message.

The syntax and
required variables
are shown here.

Click here to get more
information on the selected
function.



v 5.1-2.7

 Error Message Guide 325

Not enough parameters (DMB0006)

Cause Occurs when you are writing a formula in the Formula Editor, the Formula Bar, 
or directly in a cell and you do not have the correct number of parameters in a 
BUSINESSOBJECTS function you are using in the formula. 

Action Use the BUSINESSOBJECTS online help to check that the syntax you are using for 
the function in your formula is correct. The syntax and required variable types for 
BUSINESSOBJECTS functions are shown in the Formula Editor when you select the 
function in the Functions list.

Example You tried to use the Abs() function without entering a parameter as shown below:
=Abs()

Since this function requires one parameter, you get an error message.

Syntax error (DMB0007)

Cause Occurs when you are writing a formula and have made a mistake in the syntax.

Action When BUSINESSOBJECTS displays this error message, click OK to close the error 
message box. BUSINESSOBJECTS highlights the part of the formula where there is a 
syntax problem. Use the BUSINESSOBJECTS online help to check that the syntax 
you are using for functions and operators in your formula is correct.



 BusinessObjects Reporting and Analysis Error Messages

326 Error Message Guide

Variables are not compatible. (DMB0008)

Cause Occurs if your formula contains dimension variables which are incompatible. 
This error can also occur if you try to create a table or other type of block using 
incompatible variables; however, BUSINESSOBJECTS usually does not allow you to 
create a block using incompatible variables.

Two dimension variables can be incompatible if they belong to different data 
providers or, in a universe, if they belong to different contexts. The universe 
designer creates contexts when a universe maps to a database containing two or 
more paths between tables. Queries containing incompatible objects generate 
multiple SELECT statements and retrieve multiple microcubes.

Action Make sure that the variables you are using in your formula are compatible. 
Compatibility rules determine which dimension variables can be combined in the 
same block or formula. To see if you have variables that are not compatible with 
a selected dimension variable:

1. Open the Report Manager, and click the Data tab.

2. In the list of variables, select the dimension variable.
Any dimension variables that are not compatible with the selected variable 
are dimmed and italicized. 
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Example The following formula contains two variables which cannot be used together 
because they do not belong to the same microcube even though the data comes 
from the same universe. When BUSINESSOBJECTS ran the query on the universe, it 
created two microcubes because <Reservation Year> and <Year> do not belong 
to the same context. For BUSINESSOBJECTS, there is no relationship between the 
two variables so it cannot create a formula using them.

= If <Reservation Year>="FY97" And <Year>="FY94" Then 0
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The chart cannot be displayed. You must place at least one measure on the Y-axis. 
(FOR0001)

Cause On the Pivot tab of the Format Chart dialog box, you have re-organized the 
variables on the chart axes and not placed at least one measure variable in the 
Y-axis folder. You need to have at least one measure variable to display data on 
a chart.

Action Add a measure variable to the Y-axis folder.

The chart cannot be displayed. You must place at least one variable on the X-axis. 
(FOR0002)

Cause On the Pivot tab of the Format Chart dialog box, you have re-organized the 
variables on the chart axes and not placed at least one dimension or detail 
variable in the X-axis folder. You need to have at least one dimension or detail 
variable to display data on a chart.

Action Add a dimension variable to the X-axis folder.

The chart cannot be displayed. You can place only measures on the Y-axis. (FOR0003)

Cause On the Pivot tab of the Format Chart dialog box, you have re-organized the 
variables on the chart axes and placed a measure variable in the X-axis folder. 
Measure variables can be displayed only on the Y-axis.

Action Move the measure variable from the X-axis folder to the Y-axis folder. 
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Data Access Error Messages

Data access error messages include the following ranges and categories:  

The server is not responding. (DWZ0001)

Cause This error message appears in DESIGNER when you run a process that requires the 
database server and the database server does not respond. There are three 
possible causes:

• The middleware is not configured correctly.

• The BUSINESSOBJECTS connection parameters are invalid.

• The database server is down.

Action Click the Details button in the Test Connection dialog box. Make a note of the 
database or middleware error and contact the database administrator.

Range Category

DWZ0001 server

DPP0001 file error

DPQ0001 - DPQ0006 connection

QPF0001 SQL

QP0001 - QP0027 SQL/query

DPS0001 - DPS0002 stored procedures

DMA0002 - DMA0008 data provider
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Cannot open file. (DPP0001)

Cause This error message appears after the failure to open any of the following files that 
you are using as a personal data file:

• dBase

• Excel

• text

The file is unavailable because it was possibly deleted, renamed, moved, or 
damaged. It is also possible that you are not authorized to use the file; for 
example, the file is in a folder with restricted access.

Action You need to check the status of the file.

You are not authorized to use this stored procedure. (DPP0002)

Cause You tried to open a document that was created using a stored procedure, after the 
stored procedure was deleted.

Action Contact your database administrator.

Connection is not defined. (DPQ0001)

Cause This error message appears when you try to run a query you have created in the 
Free-Hand SQL Editor. There is no connection defined between BUSINESSOBJECTS 
and the database you want to access with your query. It is therefore impossible 
to access data for your report.

Action You need to create a database connection from the Free-Hand SQL Editor or the 
database administrator needs to define a new connection to the database with 
DESIGNER or SUPERVISOR. 

You can create a new connection in the Add a connection dialog box, which you 
display by clicking the Create a new connection button in the Free-Hand SQL 
Editor. For further information, refer to the BusinessObjects User’s Guide.
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The server is not responding! (DPQ0003)

Cause This error message appears when you refresh a document in BUSINESSOBJECTS. 
There are three possible causes:

• The middleware is not configured correctly.

• The BUSINESSOBJECTS connection parameters are invalid.

• The database server is down.

Action Click the Details button in the Task Connection dialog box. Make a note of the 
database or middleware error and contact the database administrator.

Connection problem (DPQ0005)

Cause This error appears when you attempt to run a query that you have created in the 
Free-Hand SQL Editor. A connection is a set of parameters that provides access 
to a database. This message appears when the connection has not been correctly 
defined.

Action If you have defined the connection to the database from the Free-Hand SQL 
Editor, you need to edit it. To edit the connection, select the connection in the 
Connection list in the Free-Hand SQL Editor, and click the Edit connection button.

If you are using a connection that you did not define in the Free-Hand SQL 
Editor, the database administrator needs to edit the connection in DESIGNER or 
SUPERVISOR. 
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Does not exist. (DPQ0006)

Cause This error occurs when you try to run a SQL script that you have created in the 
Free-hand SQL Editor. The SQL data provider cannot find information about the 
connection to a database that it is supposed to use and displays this error 
message.

Action You need to look at the database connection to be used by the SQL script to make 
sure that it exists and that it is still valid.

If the database connection does not exist, you can define it in the Free-Hand SQL 
Editor.

If the database connection exists, is one that you defined in the Free-Hand SQL 
Editor, and needs to be modified, then you can edit it by selecting the connection 
from the Connection list in the Free-Hand SQL Editor and clicking the Edit 
Connection button.

If the database connection exists and you did not define it, then the database 
administrator needs to edit it in DESIGNER or SUPERVISOR.

The only authorized SQL command is ““Select”” (QPF0001)

Cause This error occurs when the SQL has been modified (most likely, manually) and 
the Select command was replaced. The SQL Select command is required for 
report generation. 

Action You need to add the Select command to the SQL and regenerate it. You can 
perform these operations in the Query Panel or in the Free-Hand SQL Editor. 
BUSINESSOBJECTS does not accept a comment as the first SQL command.
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Error during SQL generation. (QP0001)

Cause This error occurs during the execution of a query. The two possible causes are an 
error in the SQL or a problem in the connection between BUSINESSOBJECTS and the 
database. 

Action You should verify the SQL. If the SQL appears to be correct, test the connection.

Internal memory error during SQL generation. (QP0002)

Cause This error occurs when there is no longer enough memory to generate the SQL.

Action You should close other applications and then rerun the query. 

Memory error during SQL generation. (QP0003)

Cause This error occurs when there is no longer enough memory to generate the SQL.

Action You should close other applications and then rerun the query.



v 5.1-2.7

 Error Message Guide 335

Incompatible combination of objects. (QP0004)

Cause This error is caused by any of the following problems in the definition of the 
universe:

• There are incompatible objects in the universe and the universe designer did 
not set the option that allows multiple SQL statements for each context.

• There are no contexts in the universe and the query has created a loop.

• The query objects exclude all possible SQL choices for an aggregate aware 
function.

• The universe contains an object which references more than one table on 
separate contexts.

Action The universe designer needs to make appropriate modifications to the universe 
with DESIGNER.

Outer joins are incoherent. (QP0005)

Cause This error is caused by a universe definition problem. There is a bad combination 
of outer joins among tables in the database.

Action The universe designer needs to make appropriate modifications to the universe 
with DESIGNER.

Cartesian product not allowed. (QP0006)

Cause A Cartesian product is the result of a query in which two or more tables are not 
linked by a join. If executed, the report shows results for each possible 
combination of each table row. The BUSINESSOBJECTS universe designer specified 
that Cartesian products would not be allowed when this universe was created. 

Action The universe designer needs to make appropriate modifications to the universe 
with DESIGNER. The designer can allow Cartesian products or create the 
necessary links among tables in the database.
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The query does not reference a table. (QP0007)

Cause This error is caused by a universe definition problem. There is an object in the 
universe that cannot be used all alone. In addition, no SQL statement recognizes 
this object.

Action The universe designer needs to make appropriate modifications to the universe 
with DESIGNER. For further information, refer to the Designer’s Guide.

There is a reference to a table that has been deleted. (QP0008)

Cause This error occurs when you regenerate a SQL statement after having refreshed a 
database and the universe has been modified. The SQL statement cannot execute 
because it references a table that no longer exists in the universe.

Action The universe designer needs to modify the universe with DESIGNER so that all its 
objects are linked to tables in the universe. 

One of the objects in the query is not valid. (QP0009)

Cause This error occurs when one of the objects in a query no longer exists in the 
universe.

Action The universe designer can return the object to the universe with DESIGNER or you 
can remove the object from your query.
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One of the properties in the query is not valid. (QP0010)

Cause This error message appears when you run a query that includes predefined 
condition objects from the Query Panel. One of the condition objects in the query 
no longer exists in the universe. The query cannot execute and the error message 
appears.

Action See  the universe designer about the universe and the condition object. Using 
DESIGNER, the universe designer can define objects that act as predefined 
conditions on a class. Either the universe designer needs to define the condition 
object or you need to create the query without the condition. For further 
information about defining condition objects refer to the Designer’s Guide.

The .PRM file cannot be found. (QP0011)

Cause BUSINESSOBJECTS cannot find a .prm file. A .prm file contains all the parameters 
necessary for creating and managing BUSINESSOBJECTS universes as well as 
generating queries. This error indicates that BUSINESSOBJECTS has been 
incorrectly installed.

Action Re-install BUSINESSOBJECTS. Refer to the Installation Guide for further information.

The complex condition has created a Cartesian product. (QP0013)

Cause This error occurs when you insert a calculation as part of a complex condition. 
The calculation is using objects that reference unlinked tables. A Cartesian 
product is the result of a query in which two or more tables are not linked by a 
join. If executed, the report shows results for each possible combination of each 
table row.

Action The universe designer can use DESIGNER to link the tables referenced by the 
objects in your calculation. Or you can remove the condition from the query.
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Loop in complex condition. (QP0014)

Cause This error occurs when you insert a calculation as part of a complex condition. 
The calculation uses objects whose tables form a loop.

Action The universe designer needs to use DESIGNER to link the tables referenced by the 
objects in your query so that they do not form a loop. Or you can remove the 
condition from the query.

This query is too complex. One of the subqueries contains incompatible objects. (QP0015)

Cause This error occurs when you have a complex query containing multiple 
subqueries and the objects in one subquery are incompatible with the objects in 
another subquery. 

Action You need to examine the subqueries of the complex query to assure that all 
objects in all subqueries are compatible.

For further information about complex queries, refer to BusinessObjects User 
Guide.

The server is not responding. (QP0016)

Cause This error message appears when you run a query from the Query Panel and no 
data is being returned from the server. There are three possible causes:

• The middleware is not configured correctly.

• The BUSINESSOBJECTS connection parameters are invalid.

• The database server is down.

Action Click the Details button in the Task Connection dialog box. Make a note of the 
database or middleware error and contact the database administrator.
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Columns of the SELECT clause are different from the result objects. (QP0017)

Cause This error typically occurs after you modify the SQL by hand in the Free-Hand 
SQL Editor. There are either too many or not enough fields in the Select clause in 
comparison with the number of objects in the Query Panel.

Action You need to edit the SQL so that there are the same number of fields in the Select 
clause as there are objects in the Query Panel.
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Syntax error in variable. (QP0018)

Cause This error occurs when one of the objects in the query contains an @Prompt or an 
@Variable that is incorrectly defined in the universe.

Action The universe designer needs to redefine the @Prompt or @Variable in the 
universe with DESIGNER.

Syntax of @Prompt

The syntax of the function is as follows:

@Prompt(‘message’,[‘type’],[lov],[MONO|MULTI],[FREE|CONSTRAIN])

where

• message is the text of a message within single quotes. 

• type is one of the following: ‘A’ for alphanumeric, ‘N’ for number, or ‘D’ for 
date.

• lov can be either:

a list of values enclosed in brackets (each value must be within single quotes 
and separated by commas); or
the name of a class and object separated by a backslash and within single 
quotes.

• MONO means that the prompt accepts only one value. 
MULTI means that the prompt can accept several values.

• FREE refers to free input as opposed to CONSTRAIN, which means that the 
end user must choose a value suggested by the prompt.

Note: The last four arguments are optional. However, if you omit an argument, 
you must still enter the commas as separators.
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Syntax of @Variable

The syntax of the function is as follows:

@Variable(‘myname’)

where myname can be one of the following:

• The text of an interactive object previously created with the @Prompt function; 
i.e. the first argument entered in the @Prompt function.

• A BUSINESSOBJECTS system variable such as BOUSER or BOPASS. These 
variables represent respectively the user name and password forming the user 
identification. System variables also exist for the connection to the RDBMS. 

For more information on the correct syntax for defining @Prompt or @Variable, 
refer to the Designer’s Guide.
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You are not authorized to use the object. (QP0019)

Cause This error occurs when one user tries to open a document created by another user 
and that document contains an object for which the user does not have access 
rights. 

Action The BUSINESSOBJECTS supervisor can give the user access rights to the object.

Aggregate aware resolution failed. (QP0020)

Cause This error occurs during SQL generation because a measure object that was 
defined using the @Aggregate_Aware function was incorrectly defined. It is 
necessary to define these measure objects to set up aggregate awareness. 
Aggregate awareness enhances the performance of SQL transactions. Because of 
the incorrect definition, the SQL cannot be generated.

Action The universe designer needs to examine the measure objects defined with the 
@Aggregate_Aware function to make certain that their syntax is correct. 

Syntax of @Aggregate_Aware

The syntax of the @Aggregate_Aware function is as follows:

@Aggregate_Aware (sum(agg_table_1, ... sum(agg_table_n))

where agg_table_1 is the table with the highest level of aggregation, and 
agg_table_n the table with the lowest level. You must enter the names of all 
aggregate tables as arguments. Also, be aware of the order in which you place the 
names of tables; the precedence is from left to right.

The designer should also make certain that there is a list of incompatible objects 
and/or incompatible predefined conditions for each aggregate table in the 
universe.

For further information on aggregate awareness and the @Aggregate_Aware 
function, refer to the Designer’s Guide.
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Ambiguous condition on a measure. Remove it or cancel your scope of analysis. (QP0021)

Cause When you choose a deeper scope of analysis, you add objects from lower levels 
in the hierarchy to the query. SQL uses the Group By order to generate a 
synchronized subquery. The operators Equal to, Except, Greater than, Less than, 
Greater than or equal to, and Less than or equal to can generate a synchronized 
subquery. The operators Between, Matches pattern, and In list cannot generate a 
synchronized subquery. The SQL cannot be generated. 

Action You can modify the query or you can remove the scope of analysis.

You cannot create a new tab before including at least one result object in this tab. (QP0022)

Cause This error message appears if you try to create a second query that you want to 
combine with a first query and you have removed all the result objects from the 
first query.

Action You need to place at least one result object in the first query tab.

You cannot combine subqueries. (QP0023)

Cause This error message appears if you try to combine a subquery of one query with a 
second query. This is not allowed.
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You cannot delete this query. You must delete the condition first. (QP0025)

Cause This message appears if you try to delete a query that has an attached subquery 
without first deleting the attached subquery.

Action In order to delete the query, you must first delete the subquery.

Some obsolete objects have been removed from the query. (QP0027)

Cause This error occurs during SQL generation because your query contains objects that 
the universe designer has removed from the query.

Action You need to reconstruct the query without the deleted objects.

This stored procedure has been removed. (DPS0001)

Cause A stored procedure is a type of BUSINESSOBJECTS data provider. A stored 
procedure is an SQL script that is stored on the RDBMS. The supervisor defines 
a connection to the database containing the stored procedure and then assigns it 
to the user. In this case, you are trying to use a stored procedure that has been 
deleted. BUSINESSOBJECTS cannot generate the report.

Action Either the supervisor needs to redefine the connection to the database containing 
the stored procedure and assign it to you or you need to use another data 
provider.
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You are not allowed to use this stored procedure (DPS0002)

Cause This error message appears when you attempt to use a stored procedure as a data 
provider and the supervisor has not given you permission to use it.

Action Contact the supervisor for permission to use the stored procedure.

Bad hierarchy name (DMA0002)

Cause This message appears when you try to name a hierarchy with the same name as 
an existing hierarchy.

Action Use a unique name for the new hierarchy.
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Export failed! (DMA0005)

Cause 1 This error message appears as the result of a failure after you have selected one 
of the following file export options:

• Export to local file format -- In the case of an attempted export to a dBase or 
Excel file, there has been a general export failure that was possibly caused by 
unavailable target files, a Microsoft DAO internal error (such as an absent 
ISAM driver), or not enough disk space.

In the case of an attempted export to a text file, there has been a general export 
failure that was possibly caused by unavailable target files or not enough free 
disk space.

• Copy to DDE -- In the case of an attempted export to DDE (the Windows 
Clipboard), there has been a general export failure that was most likely caused 
by insufficient memory.

• Export to RDBMS -- In the case of an attempted export through a 
BUSINESSOBJECTS connection, there has been a general export failure possibly 
caused by an improper middleware configuration or connection, the database 
server being down, or the user not being authorized to modify an existing 
table in the database indicated by the connection. In the case of Export to 
RDBMS, this error message follows a message generated from the 
middleware that contains more specific information. 

Action You need to check the option you selected for export and then take the 
appropriate following steps:

If you checked, Then

Export to local file format make certain that the target files are available 
and that there is enough free disk space. If both 
of these conditions are met, look for Microsoft 
DAO internal errors such as no ISAM driver.

Copy to DDE make certain there is enough free memory.

Export to RDBMS the preceding (middleware) error message 
should give you more specific information. 
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Cause 2 In BUSINESSOBJECTS, you attempted to export data to Microsoft Excel. However, 
the data contains objects with names made up of special characters that have 
specific meanings in Microsoft Excel. 

Action When exporting the data do this:

1. Instead of  clicking the option Export to Local File Format, click Copy to DDE:

This allows you to copy the data to the Microsoft Windows clipboard.

2. Launch Excel and paste (special) the data in the cells you wish.
The object names are displayed correctly.

An alternate solution is to use BUSINESSQUERY if it is available at your site. It also 
accepts BUSINESSOBJECTS data which it displays correctly.
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Editing this data provider requires an additional BusinessObjects component which has not 
been installed on your computer. Please contact your system administrator (DMA0006).

Cause This error message appears when you attempt to edit a data provider for a 
BUSINESSOBJECTS report and that data provider requires a component that has not 
been installed on your computer. 

Action You should contact the system administrator to help you identify the missing 
component and to install it.

Example You want to edit a data provider that uses an OLAP server and you do not have 
the specific OLAP Access Pack installed on your computer.

The following data providers have not been successfully refreshed: [list] (DMA0007)

Cause This message appears in the following situations:
Essbase OLAP Access Pack: If you use an table alias name that contains a 
parenthesis.
All other Business Objects products: You begin to refresh a document that 
prompts you to select values. The Enter or Select Values dialog box appears. 
Rather than select values, you select Cancel in the Enter or Select Values dialog 
box and stop the data provider from being refreshed.

Action Essbase OLAP Access Pack: A table alias name should not contain parenthesis.  
Contact your system administrator.
All other Business Objects products: This is not an error. It is a message to tell you 
that the report cannot display new data because you stopped the data provider 
from being refreshed.
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A variable prevented the data provider from being refreshed. (DMA0008)

Cause This message appears in the following situation. You begin to refresh a 
document, but one of the variables contained in the data provider (@Variable, 
@Prompt, @Script) cannot be resolved. This prevents the data provider from 
being refreshed.

Action You or the universe designer should examine and, if necessary, modify the 
variables in the query. You can do this in the Free-Hand SQL Editor or the 
universe designer can do it in DESIGNER. For further information about the correct 
syntax for variables, refer to the Designer’s Guide.
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OLAP Error Messages

The following ranges of codes identify OLAP error messages:

• OLP001 - OLP0050

• OLC0001 - OLC0055

• DBD003 - DBD0015

• ESB0002 - ESB0015

• OEX0004 - OEX0034

• OMC0002 - OMC0003

• MCD0001 - MCD0003 

Warning: See details for further information. (OLP0001)

Cause The length of a warning message is too large for a Warning dialog box. This 
warning message appears to prompt you to click Details to see another warning 
message.

Action Click Details and act on the information in the second warning message.

The server is not responding! (OLP0003)

Cause This message appears after you click Continue in the OLAP Panel Grid to 
generate your BUSINESSOBJECTS report. BUSINESSOBJECTS cannot generate the 
report because of a server problem.

Action Contact your database administrator or system administrator. 

Example The server is down or there is no open connection between the client and the 
server. 
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General error (OLP0005)

Cause This is an initial error message that prompts you to click Details to see another 
error message. It might mean that the connection to the OLAP server is not 
properly configured on your client PC.

Action Click Details and look for an explanation of the second error message in this 
guide.

Example You are trying to create a report based on an SAP BW server. When you enter the 
server information and click Next, you obtain the above error message.

Check that your client machine is correctly configured to connect to an SAP BW 
server. The steps to do so are as follows:

1. Install DCOM and Microsoft Data Access Components (MDAC).

2. Check that you have the following dlls in the same library: 
mdrmsap.dll
mdxpars.dll
mdrmdlg.dll 

3. Make sure the file librfc32.dll is in the system folder (System32 for Windows 
NT).

4. Register the following dlls: mdrmsap and ScErrLkp.
• You can do this by selecting Start > Run > REGSVR32 (location folder)

 \mdrmsap.dll and REGSVR32 (location folder)\ScErrLkp.dll.
• You can also launch the REGSVR32.exe application, and then drag and 

drop the two files.
• You should receive a message confirming the successful registration of the 

dlls.

5. Modify the saprfc.ini file to connect to the server.
For example:
DEST=ServerName
TYPE=A
ASHOST=/H/IP Address
SYSNR=43
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6. For Windows 98, add the saprfc.ini variable to the path in the autoexec.bat file.
set RFC_INI=folder\saprfc.ini
Note: There are no spaces after the equal sign (=).
For Windows NT, add the following in the System Properties Panel:
Environment System Variable=RFC_INI 
Value=folder\saprfc.ini

Note: The above steps are the prerequisite configuration for BUSINESSOBJECTS to 
connect to a SAP BW server.

Memory error (OLP0006)

Cause Insufficient memory. This is typically a problem of a lack of space in memory 
rather than the temporary non-release of memory space that can occur in multi-
thread processes.

Action You should review the Installation Guide to make certain that you have sufficient 
memory for BUSINESSOBJECTS. You can also close other applications to free up 
memory.

You are not authorized to edit this data provider. (OLP0007)

Cause The database administrator has not given you write access to the data provider. 

Action Ask the database administrator to give you write access to the data provider.
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Unable to establish server connection. (OLP0010)

Cause A bad parameter in the wizard screen for connecting to an OLAP server.

Example Different servers can require you to enter different parameters to establish a 
connection. If a screen asks for your password, you may have typed it incorrectly. 
You may have chosen an incorrect configuration.

Action Retype your password and make sure that all the configurations on the list are 
valid.

Unable to disconnect from server. (OLP0011)

Cause A problem with the server.

Action Contact the system administrator.

Too many columns (OLP0012)

Cause For Essbase and DB2, the Grid can have a maximum of 255 columns. If an action 
such as adding a column or drilling down would create more than 255 columns, 
the error message appears.

Action You can reduce the number of columns in the Grid by taking a dimension from 
the across edge and using it as a filter.
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 Cannot add dimension to across edge (OLP0013)

Cause This message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. Typically, adding the 
dimension to the across edge was one of the things you did before refreshing the 
report. There is very likely a problem with this dimension.

Action The database administrator should examine the dimension you tried to add to the 
across edge to make sure it is correctly defined on the server.

Cannot add dimension to down edge. (OLP0014)

Cause This message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. Typically, adding the 
dimension to the Down Edge was one of the things you did before refreshing the 
report. There is very likely a problem with this dimension.

Action The database administrator should examine the dimension you tried to add to the 
across edge to make sure it is correctly defined on the server.
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Cannot add measure. (OLP0015)

Cause This message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. There is either a 
problem with the measure itself or adding the measure to the grid creates too 
many columns in the Grid.

Action Note the OLAP server to which BUSINESSOBJECTS is connected. 

• If you are connected to an Essbase or DB2 server, look at the number of 
columns in the across edge. If the number is close to 255, you should reduce 
the number of columns.

• Examine the measure definition.

Example It is also possible to add a measure to the across edge that creates more than 255 
columns. Essbase and DB2 cannot support more than 255 columns. 

A measure could have been incorrectly defined.

Cannot add filter. (OLP0016)

Cause This message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. Typically, adding the 
filter was one of the things you did before refreshing the report. It is very likely 
that you have chosen a value that cannot be used as a filter.

Action You or the database administrator should look at the definition of the value you 
are using as a filter. 
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Cannot remove dimension from across edge. (OLP0017)

Cause This message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. Typically, removing a 
dimension from the across edge was one of the things you did before refreshing 
the report. It is likely that removing a particular dimension from the across edge 
caused a problem with the query generation, particularly when you attempt to 
remove the only dimension from an edge.

Action You should look at the Grid to see if the remaining dimensions, measures, and 
filters form a query. If there is no dimension on the across edge, you should add 
one.

Cannot remove dimension from down edge. (OLP0018)

Cause This message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. Typically, removing a 
dimension from the down edge was one of the things you did before refreshing 
the report. It is likely that removing a particular dimension from the down edge 
caused a problem with the query generation, particularly when you attempt to 
remove the only dimension from an edge.

Action You should look at the Grid to see if the remaining dimensions, measures, and 
filters form a query. If there is no dimension on the down edge, you should add 
one.
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Cannot remove measure. (OLP0019)

Cause This message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. Typically, removing a 
measure from the Grid was one of the things you did before refreshing the report. 
It is likely that removing a measure from the Grid caused a problem with the 
query generation, particularly when you attempt to remove the only measure.

Action You should look at the Grid to see if the remaining dimensions, measures, and 
filters form a complete query. If there are no measures in the Grid, you should 
add one.

Cannot remove filter. (OLP0020)

Cause This message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. Typically, removing a 
filter from the Filters box was one of the things you did before refreshing the 
report. It is likely that removing a filter from the Filters box caused a problem 
with the query generation.

Action You should look at the Grid to see if the dimensions, measures, and filters form a 
query. Verify that there are dimensions on both edges and at least one measure 
somewhere in the Grid. Make sure that removing the filter does not create a 
report with more than 255 columns for Essbase and DB2 servers.
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Cannot swap axes. (OLP0021)

Cause This message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. Typically, swapping 
axes was one of the things you did before refreshing the report. It is possible that 
swapping axes caused a problem with the query generation. 

If you are connected to an Essbase or DB2 server, it is also possible that swapping 
axes created a report with more than 255 columns. Essbase and DB2 support no 
more than 255 columns.

Action If you are connected to an Essbase or DB2 server, you should look at the Grid to 
see if you are generating a report with more than 255 columns. Rearrange the 
dimensions and measures or create a filter so as to reduce the number of columns.

Cannot move dimension. (OLP0022)

Cause This message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. Typically, moving a 
dimension was one of the things you did before refreshing the report. It is 
possible that moving the dimension caused a problem with the query generation.

If you are connected to an Essbase or DB2 server, it is also possible that moving a 
dimension created a report with more than 255 columns. Essbase and DB2 
support no more than 255 columns.

Action Rearrange the dimensions and measures or create a filter so as to reduce the 
number of columns. 
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Internal error (OLP0023)

This error message appears when you have a corrupted document that the 
installed version of BUSINESSOBJECTS cannot read. There are three reasons why 
this might be happening:

Cause 1 There is a problem with the connection to the server.

Cause 2 There is a problem with the connection to the database.

Cause 3 You are trying to open a document created with BUSINESSOBJECTS 4.1.3 and an 
OLAP server using a later BUSINESSOBJECTS version. 

Action If you know that the document you are trying to open was created with 
BUSINESSOBJECTS 4.1.3, you should install CSP31. CSP31 is available from 
Business Objects Customer Support.

If you know that the document was not created with BUSINESSOBJECTS 4.1.3, you 
and the database administrator should look at the connections to the server and 
the database.
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Cannot drill down. (OLP0031)

Cause This error message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. It is likely that you 
drilled down on a dimension before refreshing the report. By drilling down, you 
could have encountered a problem with the definition of a dimension or its 
members. 

If you are connected to an Essbase or DB2 server, drilling down may create a 
report of more than 255 columns. Essbase and DB2 support no more than 255 
columns.

Action If you are connected to an Essbase or DB2 server, you should look at the Grid to 
see if you are generating a report with more than 255 columns. Essbase and DB2 
support no more than 255 columns. Rearrange the dimensions and measures or 
create a filter so as to reduce the number of columns.

If you are connected to another platform, look at the definition of the dimensions 
you were drilling to make sure they are valid.

Cannot drill up. (OLP0032)

Cause This error message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. It is likely that you 
drilled up on a dimension before refreshing the report. By drilling up, you could 
have encountered a problem with the definition of a dimension or its members. 

Action You should look at the definitions of dimensions you were drilling to make sure 
they are valid.
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A configuration problem in the network, server, or client occurred. The OLAP Panel cannot 
be displayed. (OLP0037)

Cause If you see this message the first time you try to launch BUSINESSOBJECTS after an 
installation, then the problem has been caused by a faulty installation. If you are 
not launching BUSINESSOBJECTS for the first time after an installation, then there 
is a configuration problem in the network, server or client. 

Action If this is the first time you launched BUSINESSOBJECTS after an installation, you 
should reinstall the product. If this is not the first time, the system administrator 
should check the network, server, and client.

Columns axis corrupted. (OLP0044)

Cause This error message appears when BUSINESSOBJECTS cannot read a document to 
refresh it and discovers a problem with the database objects in the across edge. 
Typically, this involves situations where database objects such as dimension 
members in the Cube Outline do not exist in the database. 

Action You or the database administrator should review the dimensions in the across 
edge to make sure that they are defined correctly and that there is an exact 
correspondence between the Cube Outline and the database.

Rows axis corrupted. (OLP0045)

Cause This error message appears when BUSINESSOBJECTS cannot read a document to 
refresh it and discovers a problem with the database objects in the down edge. 
Typically, this involves situations where database objects such as dimension 
members in the Cube Outline do not exist in the database. 

Action You or the database administrator should review the dimensions in the down 
edge to make sure that they are defined correctly and that there is an exact 
correspondence between the Cube Outline and the database.
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Cannot replace dimension in across edge. (OLP0047)

Cause This error message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. It is likely that you 
attempted to replace a dimension in the across edge before refreshing the report. 

There can be a problem with the definition of the dimension you want to use as a 
replacement.

If you are connected to an Essbase or DB2 server, the replacement dimension may 
create a report with more than 255 columns. Essbase and DB2 support no more 
than 255 columns.

Action If you are connected to an Essbase or DB2 server, and the Grid configuration 
would create a report with more than 255 columns, reconfigure the across edge 
using filters to reduce the number of columns.

If you are connected to another server, the database administrator should review 
the definition of the dimension you want to use as a replacement.

Cannot replace dimension in down edge. (OLP0048)

Cause This error message appears in a secondary dialog box after you click Details in a 
General Error dialog box. The General Error dialog box appears when there is a 
problem refreshing a BUSINESSOBJECTS generated report. It is likely that you 
attempted to replace a dimension in the down edge before refreshing the report. 

There can be a problem with the definition of the dimension you want to use as a 
replacement.

Action The database administrator should review the definition of the dimension you 
want to use as a replacement.
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The database outline is empty. (OLP0050)

Cause A corrupted database.

Action The database administrator needs to fix problems with the database.

Cannot create OLAP object. (OLC0001)

Cause This error occurs before generation of the MDX query. BUSINESSOBJECTS cannot 
create one of the OLAP objects necessary for the query. The most likely cause is 
not having the correct DLLs installed.

Action Make certain that you have installed the DLL versions on the BUSINESSOBJECTS 
CD-ROM.

Cannot connect to the OLAP server. (OLC0005)

Cause BUSINESSOBJECTS cannot connect to the OLAP server. The server may not be 
running or you may have entered an incorrect user name or password in a login 
box.

Action Re-enter your user name and password. If you have entered them correctly, 
verify that the server is running.
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Cannot execute query. Error code: (OLC0010)

Cause BUSINESSOBJECTS cannot execute the MDX query on the OLAP server. The MDX 
generated by the query in the OLAP Query Panel includes options that are not 
supported by the MS OLAP Services server you are connected to.

Action Simplify the filters in the query. If you are unable to pinpoint the option(s) 
unsupported by the server, contact Business Objects Customer Support, and send 
them a description of the OLAP Query Panel contents and the generated MDX 
code, in order to trace the code causing the error.

No column and no data to fetch. Error code: (OLC0015)

Cause BUSINESSOBJECTS has generated the MDX query and is fetching the data to create 
the report. During the fetch operation, it encounters a column with no values. The 
report that appears shows values only for the columns for which data can be 
fetched. Most frequently, this condition occurs when you have turned on missing 
data suppression and the query encounters empty values. 

Action In the OLAP Panel Options dialog box, clear the Suppress missing or erroneous data 
from the results of the query check box and  resubmit the query.

OLE DB not registered in registry. Error code: (OLC0020)

Cause This error occurs during the initialization of OLE DB. It is caused by incorrect 
installation of OLE DB.

Action Re-install MDAC 2.5, which is the middleware that contains OLE DB.
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An error occurred during the execution of the query: Error code (OLC0025)

Cause This message results from an MDX syntax error.

Action Contact Business Objects Customer Support, and send them a description of the 
OLAP Query Panel contents plus the generated MDX code, in order to trace the 
code causing the error.

 No information about the column: Error code (OLC0030)

Cause BUSINESSOBJECTS has generated the MDX query and is fetching the data to create 
the report. During the fetch operation, it encounters a column with no values. The 
report that appears shows values only for the columns for which data can be 
fetched. Most frequently, this condition occurs when you have turned on missing 
data suppression and the query encounters empty values.

Action In the OLAP Panel Options dialog box, clear the Suppress missing or erroneous data 
from the results of the query check box and  resubmit the query.

Cannot fetch a row: Error code (OLC0035)

Cause This error occurs during query execution. To build the report, the query fetches 
the data line by line. It cannot fetch a particular line and displays the error 
message. This error is frequently the result of a problem with the connection.

Action Make certain that the connection is working well and then resubmit the query.
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Cannot retrieve a result of the query: Error code (OLC0040)

Cause This error occurs during query execution. The query is unable to retrieve data 
that it needs to build the report.

Action You can modify and retry the query. If the message reappears, contact Business 
Objects Customer Support, and send them a description of the OLAP Query 
Panel contents plus the generated MDX code.

Cannot determine the type of sort for the dimension. (OLC0050)

Cause You have defined a custom sort for a dimension in the OLAP Query Panel. 
BUSINESSOBJECTS cannot determine the type of sort you want to run.

Action You should verify the custom sort. 

Cannot create a sort on the dimension from the definition in the OLAP Query Panel. 
(OLC0055)

Cause You have defined a custom sort for a dimension in the OLAP Query Panel.  
BUSINESSOBJECTS has been able to read the custom sort definition but cannot 
transform it into a BUSINESSOBJECTS custom sort.

Action Verify and modify the custom sort.

Cannot initialize OLAP DB2. (DBD0003)

Cause BUSINESSOBJECTS cannot connect to the DB2 server. The cause is usually an 
incorrect installation and a missing DLL.

Action Reinstall BUSINESSOBJECTS including the OLAP Access Pack. The installation 
message boxes note if there are missing DLLs.
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Dimension member not found. (DBD0004)

Cause This message appears when a prompt filter is part of the report. You select a 
dimension member at the prompt and BUSINESSOBJECTS cannot refresh the report 
because it cannot find the dimension member you selected. The most likely cause 
is that the definition of the dimension on the server does not include the 
dimension member.

Action The database administrator needs to review the database and make certain that 
there is exact correspondence between the database on the server and the Cube 
Outline. 

Child name of name not found. (DBD0005)

Cause This message appears when a prompt filter is part of the report. At the prompt, 
you select a dimension member that is the child of another dimension member, 
and BUSINESSOBJECTS cannot refresh the report because it cannot find the 
dimension member. The most likely cause is that the definition of the dimension 
on the server does not include the dimension member.

Action The database administrator needs to review the database and make certain that 
there is exact correspondence between the database on the server and the Cube 
Outline. 

An error occurred during the generation of the OLAP DB2 report script. (DBD0009)

Cause The Grid configuration cannot produce a script acceptable to the DB2 server 
calculation engine. This typically occurs when you have placed too many 
database objects along one edge.

Action Reconfigure the Grid to have more balance between the across and down edges.
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Bad value (DBD0010)

Cause You have entered an unacceptable value in one of the fields in the Data Retrieval 
box on the General tab of the OLAP Panel Options dialog box.

Action Look at the values and modify them as needed.

Non-existent alias table (DBD0011)

Cause You have selected an alias table that does not exist from the General tab of the 
OLAP Panel Options dialog box.

Action Select an existing alias table from the list in the OLAP Panel Options dialog box.

The fetching mode is incorrect. (DBD0015)

Cause You have selected a fetching mode that does not exist from the Filters box on the 
General tab of the OLAP Panel Options dialog box.

Action Select an existing fetching mode in the OLAP Panel Options dialog box.

No application! Contact your database administrator. (ESB0002)

Cause This error message displays after you enter your password and click Next in the 
New Report wizard. It is caused by the database not being installed on the server 
or you not having permission to access the database.

Action The database administrator needs to review the database installation and give 
you access rights.
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Cannot initialize Essbase. (ESB0003)

Cause BUSINESSOBJECTS cannot connect to the Essbase server. The cause is usually an 
incorrect installation and a missing DLL.

Action Reinstall BUSINESSOBJECTS including the OLAP Access Pack. The installation 
message boxes note if there are missing DLLs.

Dimension member not found. (ESB0004)

Cause This message appears when a prompt filter is part of the report. You select a 
dimension member at the prompt and BUSINESSOBJECTS cannot refresh the report 
because it cannot find the dimension member you selected at the prompt. The 
most likely cause is that the definition of the dimension on the server does not 
include the dimension member.

Action The database administrator needs to review the database and make certain that 
there is exact correspondence between the database on the server and the Cube 
Outline. 

Child name of name not found. (ESB0005)

Cause This message appears when a prompt filter is part of the report. At the prompt, 
you select a dimension member that is the child of another dimension member, 
and BUSINESSOBJECTS cannot refresh the report because it cannot find the 
dimension member. The most likely cause is that the definition of the dimension 
on the server does not include the dimension member

Action The database administrator needs to review the database and make certain that 
there is exact correspondence between the database on the server and the Cube 
Outline. 
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An error occurred during generation of the Essbase report script. (ESB0009)

Cause The Grid configuration cannot produce a script acceptable to the Essbase server 
calculation engine. This typically occurs when you have placed too many 
database objects along one edge.

Action Reconfigure the Grid to have more balance between the across and down edges.

Bad value (ESB0010)

Cause You have entered an unacceptable value in one of the fields in the Data Retrieval 
box on the General tab of the OLAP Panel Options dialog box.

Action Look at the values and modify them as needed.

Non-existent alias table (ESB0011)

Cause You have selected an alias table that does not exist from the General tab of the 
OLAP Panel Options dialog box.

Action Select an existing alias table from the list in the OLAP Panel Options dialog box.

The fetching mode is incorrect. (ESB0015)

Cause You have selected a fetching mode that does not exist from the Filters box on the 
General tab of the OLAP Panel Options dialog box.

Action Select an existing fetching mode in the OLAP Panel Options dialog box.
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Cannot initialize Express. (OEX0004)

Cause BUSINESSOBJECTS cannot connect to the Express server. The cause is usually an 
incorrect installation and a missing DLL.

Action Reinstall BUSINESSOBJECTS including the OLAP Access Pack. The installation 
message boxes note if there are missing DLLs.

The fetching mode is incorrect. (OEX0005)

Cause You have selected a fetching mode that does not exist from the Filters box on the 
General tab of the OLAP Panel Options dialog box.

Action Select an existing fetching mode in the OLAP Panel Options dialog box.

Bad value (OEX0008)

Cause You have entered an unacceptable value in one of the fields in the Data Retrieval 
box on the General tab of the OLAP Panel Options dialog box.

Action Look at the values and modify them as needed.

You cannot add the measure because at least one dimension is empty. (OEX0011)

Cause In Express, variable (measure) definitions include dimensions. You have a 
selected a measure that includes at least one empty dimension. A measure 
defined with an empty dimension is not acceptable to BUSINESSOBJECTS.

Action You can use a different measure or ask the database administrator to redefine the 
measure you used without including empty dimensions in the definition.
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Cannot attach database. Verify database name and password. (OEX0012)

Cause Either the database name or the password is incorrect. 

Action Verify the database name and retype your password.

Cannot connect to pcExpress. (OEX0013)

Cause There is an installation or connection problem on your local computer. 

Action Verify that both pcExpress and BUSINESSOBJECTS are correctly installed and 
configured.

Cannot connect to server. (OEX0014)

Cause There is an installation or connection problem between your local computer and 
the Express server.

Action Verify that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server.

Invalid function arguments (OEX0015)

Cause This is an Express SNAPI error message that appears after BUSINESSOBJECTS fails 
to connect to Express.

Action Verify that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server. For further assistance, refer to the Express 
documentation.
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Insufficient memory (OEX0016)

Cause This is an Express SNAPI error message that appears after BUSINESSOBJECTS fails 
to connect to Express. It indicates insufficient memory for Express.

Action Verify that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server. Refer to the Express documentation for 
further information.

General error (OEX0017)

Cause This is an Express SNAPI error that appears after BUSINESSOBJECTS fails to 
connect to Express.

Action Verify that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server. Refer to the Express documentation for 
further information.

Output buffer is too small. (OEX0018)

Cause This is an Express SNAPI error indicating that storage allocated is too small for a 
returned value.

Action Verify that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server. Refer to the Express documentation.
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No servers match specification. (OEX0019)

Cause This is an Express SNAPI error that appears after BUSINESSOBJECTS fails to 
connect to Express. Express cannot find the server you selected in the wizard.

Action Check the specification of the selected server. Verify that both Express and 
BUSINESSOBJECTS are correctly installed and configured locally and on the server. 
Refer to the Express documentation.

End of data or edge (OEX0020)

Cause This is an Express SNAPI error that appears after BUSINESSOBJECTS fails to 
connect to Express. 

Action Verify that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server. Refer to the Express documentation for 
further information.

Fatal error - session destroyed. (OEX0022)

Cause This is an Express SNAPI error message that indicates that a fatal error has 
destroyed the Express session. 

Action After verifying that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server, reconnect to the server. Refer to the Express 
documentation for further information.
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Cannot load service provider DLL. (OEX0023)

Cause This is an Express SNAPI error that appears after BUSINESSOBJECTS fails to 
connect to Express. Express could not load a service provider DLL.

Action Verify that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server. Refer to the Express documentation for 
further information.

API function not implemented. (OEX0024)

Cause This is an Express SNAPI error that appears after BUSINESSOBJECTS fails to 
connect to Express. Express called an API function that could not be 
implemented.

Action Verify that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server. Refer to the Express documentation for 
further information.

Data type mismatch (OEX0025)

Cause This is an Express SNAPI error that appears after BUSINESSOBJECTS fails to 
connect to Express.

Action Verify that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server. Refer to the Express documentation for 
further information.
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Cannot initialize new session. (OEX0026)

Cause This is an Express SNAPI error that appears after BUSINESSOBJECTS fails to 
connect to Express. The connection process failed because it could not initialize a 
new Express session.

Action Verify that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server. Refer to the Express documentation for 
further information.

Server is shutting down. (OEX0027)

Cause This is an Express SNAPI error that appears when BUSINESSOBJECTS loses its 
connection to Express. The server to which you have connected or are attempting 
to connect to is shutting down.

Action After verifying that both Express and BUSINESSOBJECTS are correctly installed and 
configured locally and on the server, reconnect to the server. Refer to the Express 
documentation for further information.

Local SNAPI is already executing. (OEX0028)

Cause This is an Express SNAPI error that appears after BUSINESSOBJECTS fails to 
connect to Express. The SNAPI connection could not be used for BUSINESSOBJECTS 
because it was already executing. 

Action Make sure that no other applications that are running concurrently are using the 
SNAPI connection. Then, reconnect to the server. Refer to the Express 
documentation for further information.



v 5.1-2.7

 Error Message Guide 379

Cannot fetch values from dimension. (OEX0029)

Cause There is a database error that is preventing BUSINESSOBJECTS from fetching values 
from a dimension in an Express database. 

Action Verify that the dimension is correctly defined. Refer to the Express 
documentation for further information.

Dimension is empty. (OEX0030)

Cause BUSINESSOBJECTS is trying to fetch values from a dimension for your query and 
the dimension has no values.

Action Verify that the dimension is correctly defined. Refer to the Express 
documentation for further information.

Error during execution phase. Check dimension values. (OEX0031)

Cause BUSINESSOBJECTS is trying to fetch a dimension value for your query and the 
dimension value is not there. 

Action Verify that the dimension is correctly defined. Refer to the Express 
documentation for further information.
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The number you have entered in the ““LimitNumberofDimensionValues”” field must be 
between value and value. (OEX0033)

Cause The ““LimitNumberof DimensionValues”” field allows you to limit the number 
of dimension values to retrieve when a dimension without hierarchies is inserted 
into the Grid. Express limits the number of dimension values retrieved to no 
more than 1,000. You set this number on the General tab of the OLAP Panel 
Options dialog box. This error message displays when you set an incorrect 
number.

Action Set an allowable number on the General tab of the OLAP Panel Options dialog 
box.

The hierarchy for the dimension does not exist. (OEX0034)

Cause You have selected a dimension hierarchy that does not exist. This can result from 
the hierarchy having been deleted from the database. 

Action You can either select another hierarchy or examine the database on the server to 
see if the hierarchy does exist, but is not visible to BUSINESSOBJECTS for other 
reasons. 

No application! Contact your database administrator. (OMC0002)

Cause This error message displays after you enter your password and click Next in the 
New Report wizard. It is caused by the database not being installed on the server 
or you not having permission to access the database.

Action The database administrator needs to review the database installation and give 
you access rights.
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Cannot initialize MetaCube. (OMC0003)

Cause The MetaCube server was not correctly installed.

Action The database administrator needs to reinstall the server.

An error occurred during the creation of OLE DB for OLAP objects. (1322224)

Cause This message appears when you try to refresh a document. Refreshing the 
document involves the creation of OLE DB for OLAP objects. The Microsoft 
OLAP Services server is unable to create the objects for any of the following 
reasons:

• Server is down.

• Communication error between BUSINESSOBJECTS and the server.

• Insufficient memory

Action You should first make sure that the server is running. If the server is running, the 
most likely cause is insufficient memory. You can reduce memory usage by 
reducing the size of the Grid. To reduce the size of the Grid, create filters. 

The folder cannot be deleted; it is not empty or it may contain filters, queries, or folders. 
(MCD0001)

Cause You cannot delete a folder containing filters, queries, or folders. When you create 
a folder, it appears in both the Filters list and the Saved Queries list. If you create 
a filter and save it in Folder n, the filter appears in the folder in the Filters list but 
not in the folder in the Saved Queries list. If you attempt to delete Folder n from 
either list, the error message appears. 

Action Cut and paste the filter or saved query to another folder in order to empty the 
folder you want to delete.
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The query cannot be loaded in the OLAP Panel. (MCD0002)

Cause You can create a query in MetaCube Explorer that contains a definition that is too 
complex for BUSINESSOBJECTS. When you try to edit this type of query in the 
OLAP Grid, this error message appears.

Action You can edit the query in MetaCube Explorer.

The multipass SNAPIN has not been activated. (MCD0003)

Cause The installation cannot find the MetaCube multipass snapin feature at the 
location specified.

Action Find the true location of the multipass snapin feature and rerun the installation.
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BusinessQuery Error Messages

The code range for BUSINESSQUERY is as follows:

• BQM001 - BQM0018

• BQ0001 - BQ0098

This is not BusinessQuery data. (BQM0001)

Cause This message appears if:

• You click a worksheet cell, which is either blank or contains data that you did 
not obtain using a BUSINESSQUERY query.

• You then select the Edit Query or the Refresh Query command on the 
BusinessQuery menu.

• The command that you selected then becomes unavailable.

Action To use the Edit Query or Refresh Query commands:

1. Open the workbook.

2. Click a cell containing BUSINESSQUERY data.

3. Select the command you want.
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You cannot insert a query in cells containing BusinessQuery data. (BQM0002)

Cause You have selected a cell containing BUSINESSQUERY data, then selected the Insert 
Query command. BUSINESSQUERY only allows you to insert queries in cells that 
do not contain BUSINESSQUERY data.

If you have removed the link between a query in the workbook and its query file, 
Excel lets you insert (or create) a query in a cell containing BUSINESSQUERY data. 

You remove the link between an inserted query and its query file by selecting the 
Remove button in the QueryDirector. BUSINESSQUERY then prompts you to 
remove the query and its query file, or leave the data as it is but break the link to 
the query file:

If you:

• Select the second option, as illustrated above

• Select a cell containing BUSINESSQUERY data

• Select the Insert Query command on the BusinessQuery menu

BUSINESSQUERY displays the following prompt:

In other words, you get the error message BQM0002 only if there is still a link 
between the query in the workbook and its corresponding query file.

Action Select a blank cell, then select the Insert Query command again.
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This is not a valid Excel range. (BQM0003)

Cause You are creating or editing a query, and have tried to apply a condition using the 
operand Type an Excel Range in the Query Panel.

This operand lets you create a condition based on the values in the range of cells 
that you refer to. You can use it, for example, to exclude a list of customers from 
the data that you want to retrieve from your corporate database.

To refer to a range of cells, you must use standard Excel range syntax, e.g., 
A1:H9

where A and H refer to columns, 1 and 9 to rows. The error appears when you 
use the wrong syntax.

Action In the Query Panel:

1. Click OK to dismiss the error message box.

2. In the Operands list, double-click Type an Excel Range.

3. In the condition itself, type the co-ordinates of the range that you want to refer 
to in your condition:
• Type the reference to the top left cell in the range, e.g., A1
• Type a colon (:)
• Type the reference to the bottom right cell in the range, e.g., H9.

4. Press Enter.
BUSINESSQUERY adds parentheses and single quotes around the range that you 
typed; these are required but you do not have to type them yourself.

5. Continue to build or edit the query, or click Run to retrieve the data.

Example In the condition, you have typed
A1/H9

that is, instead of separating the range values with a colon (:), you have used a 
slash (/).
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Partial result returned! (BQM0008)

Cause 1 You ran or refreshed a query, then canceled it before all the data was returned 
from the database. BUSINESSQUERY displayed the Interrupted Execution dialog 
box, in which you chose to keep the partial result by selecting Stop the execution 
and keep the partial result, as shown here:

By then displaying the message Partial result returned! (BQM0008), 
BUSINESSQUERY is simply informing you that the data in your worksheet is not 
complete.

Action To get the full set of data from the database, use the Refresh Query command on 
the BusinessQuery menu.
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Cause 2 The BUSINESSOBJECTS supervisor may have restricted the number of rows of data 
that you are allowed to retrieve from the database. Similarly, the universe may 
contain row limitations.

Action In both these cases, you, the BUSINESSQUERY end user, cannot retrieve the full set 
of data from your database. The only thing that you can do is to contact your 
supervisor or designer, and ask him or her to remove the row limitations either 
on your user profile, or on the universes that you use.

Example The universe designer set a limitation of 500 rows of data in the universe that you 
are using. The database that you are querying in BUSINESSQUERY contains more 
than 500 rows of data.

When you run or refresh queries on this universe, BUSINESSQUERY detects that 
there are more rows of data in the database than in the result returned. 
BUSINESSQUERY informs you of this fact by displaying the Partial Result Returned 
message.
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Renaming or deleting a query file affects all workbooks containing the associated query. 
(BQM0009)

Cause 1 You have used the Insert Query command on the BusinessQuery menu. In the 
Insert Query dialog box that appears, you have renamed a query.

The query names listed in the Insert Query dialog box are actually the names of 
query files. A query file corresponds to a query that you created, and has a .bqy 
file extension.

If you change the name of the query file, you also change the name of the query 
as is it inserted in a worksheet.

Cause 2 You have used the Insert Query command on the BusinessQuery menu. In the 
Insert Query dialog box that appears, you have deleted a query by right-clicking 
the query name, then selecting the Delete command on the pop-up menu that 
appears.

The query names listed in the Insert Query dialog box are actually the names of 
query files. A query file corresponds to a query that you created, and has a .bqy 
file extension.

If you delete the query file, the data returned by that query remains in your 
workbooks. However, you can no longer be able to edit or refresh the query 
because it no longer exists.

If you do try to refresh a workbook containing data from a query that you have 
deleted, BUSINESSQUERY displays the following error message: “Cannot access 
the requested file (BQ0079).”
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Action To avoid deleting the query, click Cancel in the error message dialog box:

If you click OK, you will not be able to retrieve the query file. The only 
workaround is as follows:

1. Re-create the same query, with the same name, in a blank worksheet.

2. Use the Refresh All Queries command on the BusinessQuery menu.
BUSINESSQUERY reactivates the link between the queries inserted in your 
workbook and the new query that you have built.

3. Open and refresh all workbooks containing the query that you initially 
deleted.

You cannot use this version of BusinessQuery files with BusinessQuery 5.0. (BQM0018)

Cause You tried to open a BUSINESSQUERY file created with a version of BUSINESSQUERY 
more recent than 5.0.

Action To open this file, you must install a version of BUSINESSQUERY released after 5.0.
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Failed to load BusinessQuery. Please run the Setup again. (BQ0001)

Cause This message most likely means that BUSINESSQUERY was not properly installed 
on your computer. Installation may have been interrupted, or some files may not 
have been correctly copied.

Action We advise you to use the BUSINESSOBJECTS Setup program to uninstall 
BUSINESSQUERY completely. Then, reinstall BUSINESSQUERY from scratch.

To run the Setup program:

1. On your Windows Start menu, point to Programs, BusinessObjects 5.0, Setup.

2. In the dialog box that appears, click Desktop Products, then click Begin.

3. In the Choose Products and Modules dialog box that appears, check 
BusinessQuery in the right pane, as shown here:
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4. Click Remove.
Setup removes BUSINESSQUERY and displays the following message:

5. Click Exit.

6. Re-install BUSINESSQUERY.
For information on installing all BUSINESSOBJECTS products, refer to the 
Installation Guide.
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This file cannot be replaced. (BQ0004)

Cause You tried to replace one query file with another but received this error message 
instead. The problem may be due to:

• Insufficient disk space to continue the operation.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to carry out the action.

Action Try the following:

• Quit Excel, and free up some disk space. Delete any unnecessary files, and 
empty your Recycle Bin. Then launch Excel, load BUSINESSQUERY and try the 
action once again.

• Ask the Windows NT Administrator to grant you full access to the folders on 
the system in which you are performing the action.

These files are the same. (BQ0005)

Cause You tried to insert a query by pointing to it with the Browse button. However,  
BUSINESSQUERY does not let you do this because the query is located in the default 
folder for queries. This is somewhat like trying to replace the file with itself. 

Tip: You can modify the default locations of BUSINESSQUERY files from the File 
Locations tab of the Options dialog box. 

Action This error is simple to resolve. First dismiss the error message box by clicking the 
OK button. Then from the Available Queries list of the Insert Query dialog box, 
locate the desired query, click it, and click OK. 

If the query you are looking for is not displayed in this list, try locating it once 
again with the Browse button.



 BusinessQuery Error Messages

394 Error Message Guide

This file cannot be copied. (BQ0006)

Cause You tried to copy a BUSINESSQUERY file but received this error message instead. 
The problem may be due to:

• Insufficient disk space to continue the operation.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to carry out the action.

Action Try the following:

• Quit Excel, and free up some disk space. Empty your Recycle Bin and delete 
any unnecessary files. Then launch Excel, load BUSINESSQUERY and try the 
action once again.

• Ask the Windows NT Administrator to grant you full access to the folders on 
the system in which you are performing the action.

This file cannot be created. (BQ0007)

Cause You tried to create a BUSINESSQUERY file but received this error message instead. 
The problem may be due to: 

• Insufficient disk space to continue the operation.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to carry out the action.

Action Try the following:

• Quit Excel, and free up some disk space. Empty your Recycle Bin and delete 
any unnecessary files. Then launch Excel, load BUSINESSQUERY and try the 
action once again.

• Ask the Windows NT Administrator to grant you full access to the folders on 
the system in which you are performing the action.



v 5.1-2.7

 Error Message Guide 395

The file cannot be moved. (BQ0008)

Cause You tried to move a BUSINESSQUERY file but received this error message instead. 
The problem may be due to:

• Insufficient disk space to continue the operation.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to carry out the action.

Action Try the following:

• Quit Excel, and free up some disk space. Empty your Recycle Bin and delete 
any unnecessary files. Then launch Excel, load BUSINESSQUERY and try the 
action once again.

• Ask the Windows NT Administrator to grant you full access to the folders on 
the system in which you are performing the action.

The file cannot be deleted. (BQ0009)

You tried to delete a file and BUSINESSQUERY displayed this error message. 

Cause 1 The system or network administrator may not have granted you the 
authorization to delete the file.

Action Ask the Windows NT Administrator to grant you full access to the folders on the 
system in which you are performing the action.

Cause 2 The file you are trying to delete may be in use by another user. 

Action One way you check whether this is the case is to try opening the same file via the 
Windows Explorer.
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This query file cannot be deleted. (BQ0010)

You tried to delete a file and BUSINESSQUERY displayed this error message. 

Cause 1 The system or network administrator may not have granted you the 
authorization to delete the file.

Action Ask the Windows NT Administrator to grant you full access to the folders on the 
system in which you are performing the action.

Cause 2 The file you are trying to delete may be in use by another user. 

Action One way you check whether this is the case is to try opening the same file via the 
Windows Explorer.

This query file cannot be renamed. (BQ0011)

Cause You tried to rename a query file but received this error message instead. The 
problem may be due to:

• Insufficient disk space to continue the operation.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to carry out the action.

Action Try the following:

• Quit Excel, and free up some disk space. Empty your Recycle Bin and delete 
any unnecessary files. Then launch Excel, load BUSINESSQUERY and try the 
action once again.

• Ask the Windows NT Administrator to grant you full access to the folders on 
the system in which you are performing the action.
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This query file cannot be duplicated. (BQ0012)

Cause You tried to duplicate a query file but received this error message instead. The 
problem may be due to:

• Insufficient disk space to continue the operation.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to carry out the action.

Action Try the following:

• Quit Excel, and free up some disk space. Empty your Recycle Bin and delete 
any unnecessary files. Then launch Excel, load BUSINESSQUERY and try the 
action once again.

• Ask the Windows NT administrator to grant you full access to the folders on 
the system in which you are performing the action.
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A query file with the name you specified already exists. Use a different name. (BQ0013)

Cause You have tried to rename a query with the name of another query. 

Action Choose a unique query name.

Example You have tried to rename “Query 1” as “Sales Info,” but your workbook already 
contains a query with that name.

The query contains objects that have been deleted from the universe. (BQ0016)

Cause The universe designer has removed objects from a universe which you 
previously used to build a query. When you refresh the query, this message 
indicates that some of the objects you included no longer exist. Thus, the query 
cannot retrieve data based on the deleted objects.

Action Ask your universe designer to edit the universe according to your needs, then run 
the query again.

If the designer re-creates the objects that were deleted, you get all your data the 
next time you refresh the query.

Example You built a query on the eFashion universe, and included the following objects:  
State, City, Sales Revenue, Week, Quantity Sold. You use this query to monitor 
weekly sales per state and city.

It’s Monday morning and as usual, you refresh the query to find out the latest 
sales information. However, since last week, your universe designer has changed 
the universe by deleting the Quantity Sold object. Thus, your worksheet no longer 
displays the number of items sold.
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Cannot process this sheet. (BQ0020)

Cause For unknown reasons BUSINESSQUERY could not process the queries contained in 
the worksheet of your Excel file. The Excel file may be damaged or corrupted.

Action Quit Excel, launch it once again and load BUSINESSQUERY. If the error persists, 
then the file is probably irretrievably damaged. Run a standard utility program 
such as ScanDisk which checks files, folders, and the disk surface for errors and 
then repairs them. If this does not work, then use a back-up of the file, if one is 
available.

BusinessQuery is not correctly initialized. (BQ0021)

An internal error has occurred in BUSINESSQUERY. This may be due to a number 
of reasons:

Cause 1 There is a problem with the installation or configuration of BUSINESSOBJECTS.

Action Quit Excel and launch it once again. Load BUSINESSQUERY. If the error persists, 
re-install BUSINESSQUERY and BUSINESSOBJECTS on your computer. For 
information on installing all BUSINESSOBJECTS products, refer to the Installation 
Guide

Cause 2 There is an error in the registry of your computer perhaps because you changed 
some of its settings. As a result, your computer may have become non functional.

Action In general, you should not edit your registry unless it is absolutely necessary. If 
there is an error, you can restore the registry to its state when you last successfully 
started your computer. For instructions on this topic, refer to the online help of 
the Registry Editor.

Cause 3 There is a memory problem with your computer.

Action Quit Excel, and free up some disk space. Empty your Recycle Bin and delete any 
unnecessary files. Then launch Excel, load BUSINESSQUERY and try the action once 
again.
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Not enough memory (BQ0023)

Cause Your computer does not have enough active memory to perform the task that you 
have requested.

Action Quit Excel, and free up some disk space. Empty your Recycle Bin and delete any 
unnecessary files. Then launch Excel, load BUSINESSQUERY and try the action once 
again.

An unexpected error has occurred. (BQ0024)

Cause This is an unspecified error, which has no identifiable cause.

Action We advise you to:

1. Save then close the workbook that you are working in.

2. Unload BUSINESSQUERY by using the Unload command on the BusinessQuery 
menu.

3. Quit Excel.

4. Launch Excel.

5. Load BUSINESSQUERY by using the Load command on the BusinessQuery 
menu.

6. Open the workbook, and continue to work with BUSINESSQUERY.

You are not granted to work with this universe. (BQ0027)

Cause The BUSINESSOBJECTS supervisor has not given you the right to use the universe. 
Supervisors can provide or deny access to universes on a per user basis.

Action Ask the supervisor to give you the right to work with this universe, then try 
again.
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The selected universe has an invalid ID. (BQ0032)

Cause You tried to create a new query based on a universe with an invalid ID. An ID is 
assigned to a universe by the repository when a designer exports it to the 
repository for the first time. For some reason, this ID has become invalid possibly 
because it is no longer current or as the result of successive import/export actions 
carried out by the designer.

Action Check the status of the universe with its designer. It may need to be exported to 
the repository.

Invalid file (BQ0034)

Cause You tried to perform an action on a BUSINESSQUERY file that is corrupted or 
damaged. You cannot work with this file.

Action Run a standard utility program such as ScanDisk which checks files, folders, and 
the disk surface for errors and then repairs them. If this does not work, then use 
a back-up of the file, if one is available.
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The Excel OLE Automation Server generated an unpredictable exception. (BQ0035)

Cause There is no specific cause for this error.

Action There is no miracle cure for this error. It simply indicates that Microsoft Excel has 
recognized that a process inside the application is not working correctly, and 
requires that you:

1. Quit then relaunch Excel. 

2. Continue working with BUSINESSQUERY in the normal way.

If you continue to receive this message, consider:

• Rebooting your computer.
• Checking that Excel is correctly installed
• Uninstalling and reinstalling Excel.

An error occurred while loading BusinessQuery. (BQ0038)

Cause 1 Your system path contains two instances of BQ, but only one is required.

Example Instead of

PATH=c:\winnt\system32;c:\BQ

your path is as follows:

PATH=c:\winnt\system32;c:\BQ;c:\BQ

Action Here’s what to do:

1. Quit Excel.

2. Use a DOS window to remove all repetitions of BQ from the path.

3. Restart your computer and launch Excel.

4. Select Load on the BusinessQuery menu.
If you still get the error message, refer to the following cause and action.
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Cause 2 At the beginning of a BUSINESSQUERY work session, you have tried to start 
BUSINESSQUERY by selecting the Load command on the BUSINESSQUERY menu. An 
unspecified error has prevented BUSINESSQUERY from loading correctly.

Action We suggest that you do the following:

1. Close and save all open workbooks.

2. Quit Excel.

3. Launch Excel.

4. Make sure that the BusinessQuery 5.0 add-in is visible and switched on in the 
Add-Ins dialog box (Add-Ins command > Tools menu).

5. If the add-in is listed, click Cancel and go to step 9. 
• If it is not, click Browse to locate the BUSINESSQUERY add-in. 
• By default, the file you need (bqapi.xll) is stored in the following folder:

Program Files\Business Objects\Business Objects 5.0

6. Click the file, then click OK.

7. Check the BusinessQuery 5.0 box in the list of add-ins, then click OK.

8. Click Load on the BusinessQuery menu.
If BUSINESSQUERY loads correctly, the User Identification dialog box appears, 
enabling you to enter your user name and password to start working with the 
application.
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An unexpected error occurred while BusinessQuery was unloading. (BQ0050)

Cause At the end of a BUSINESSQUERY work session, you have tried to unload the 
application by selecting the Unload command on the BUSINESSQUERY menu. An 
unspecified error has prevented BUSINESSQUERY from unloading correctly.

Action We suggest that you:

1. Close and save all open workbooks.
At this point, the BusinessQuery menu is grayed.

2. Quit Excel.

3. Launch Excel.
The BusinessQuery menu is now available.

4. Select the Unload command on the BusinessQuery menu.

Cannot send the documents. (BQ0073)

Cause Sending documents or queries requires a connection to the repository. Therefore, 
if the server hosting the repository is down, or the connection to this server is lost, 
you cannot send documents.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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Cannot retrieve documents. (BQ0074)

Cause Retrieving documents or queries requires a connection to the repository. 
Therefore, if the server hosting the repository is down, or the connection to this 
server is lost, you cannot retrieve documents.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

Cannot create the folder. (BQ0077)

Cause An action that you are trying to perform in BUSINESSQUERY requires that a folder 
be created on your file system. For security reasons, you cannot create folders on 
the file system, or at least this part of the file system.

Action The Windows NT administrator can grant you the right to create folders on the 
file system.

Example You create your first query on the Efashion universe. BUSINESSQUERY needs to 
create a folder in which to store the query file (.bqy file) corresponding to the 
query. By default, the folder is called Efashion and created in the UserBQY folder. 
The complete path to the folder is:

Program Files\Business Objects\BusinessObjects 5.0\UserBQY\Efashion

The Cannot create the folder message is returned because your Windows user 
profile does not give you the right to create folders on the file system, on which 
BUSINESSQUERY is installed.
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Cannot access the folder. (BQ0078)

Cause An action that you are trying to perform in BUSINESSQUERY requires access to a 
folder your file system.

BUSINESSQUERY actions that require access to a folder include:

• Creating, inserting, or refreshing queries

• Using the Pack/Unpack feature

• Checking query properties in the QueryDirector

Action There are many potential reasons why you cannot access folders on the file 
system:

• The folder may be on a network file system, and your connection is lost.

• The folder may be on a network file system, and you are working offline.

• The folder has been protected or removed by your system administrator.

The way you overcome the error depends on the reason why you cannot access 
the folder you need.

Example If you get this message when trying to insert a query in a workbook, it means that 
the folder that contains your query files is inaccessible. This probably means that 
the folder is on a remote server, not on your computer. Therefore, you should 
check:

• That your connection to the server is functioning correctly.

• That you still have the right to access the server.

• Whether you are working offline. If so, and you are working without a 
network connection, wait until your connection to the network is recovered, 
then try again.
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Cannot access the requested file. (BQ0079)

Cause You have tried to perform an action on a file that no longer exists, or which is 
stored in a location that you cannot access.

Action If the file you need exists but you cannot access it, either wait until you can access 
it, or make a connection to that location. For example, if you are working offline 
but the file you need is on a server, connect the server, then try again.

Refer to: 

• BQM0009 for information on restoring deleted query files

• BQ0078 for information on folder access problems

Example You have opened a workbook containing the query named eFashion. However, 
before opening the workbook, you deleted the query file, eFashion.bqy, from 
your computer. 

BUSINESSQUERY cannot refresh the query, because the query file which holds the 
definition of the query no longer exists.
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Cannot get information about this universe. (BQ0080)

Cause The universe has an unknown status in the repository. This means that there is a 
problem with the universe, but that BUSINESSQUERY cannot determine its exact 
cause.

Action You cannot fix this problem in BUSINESSQUERY. It is an issue for the universe 
designer or the supervisor, who must check that:

• The universe opens correctly in DESIGNER, and that its definition is correct.

• The universe has been correctly exported to the repository. If the universe is 
no longer in the repository, the supervisor or designer must re-export it.

In any case, we recommend that the universe designer open the universe in 
DESIGNER, check that it has not been changed or damaged in any way, then 
re-export it to the repository. For information on working with universes in 
DESIGNER, refer to the Designer’s Guide.
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File operation error. (BQ0084)

Cause A file required to perform an action in BUSINESSQUERY causes this error. This has 
been known to occur when users select the Pack/Unpack command on the 
BusinessQuery menu.

The following are known causes of this error:

• You do not have the right to use at least one of the files involved in the action 
that you are trying to perform. 

• At least one of the files has a read-only status.

• At least one of the files is corrupted.

Action Check all the files involved in the action that you are trying to perform.

Example You select Pack/Unpack on the BusinessQuery menu. This command places all 
the query files into one workbook, thereby making it easy for you to distribute 
them. This action requires that you have write access to the query files; these files 
cannot be corrupted.

Two of the query files of the queries in your workbook have been set to read-only. 
Therefore, BUSINESSQUERY cannot pack them into the workbook, and returns the 
File operation error message.
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Cannot refresh the data provider. (BQ0091)

Cause 1 BUSINESSQUERY cannot refresh your queries because the data provider on which 
they are based no longer exists, or has been removed. A data provider is the 
mechanism that brings data from its source to your report. In BUSINESSQUERY the 
data provider is a universe, which in turn is based on a database or personal data 
file.

Action Ask the universe designer for information on where the universe is located and 
on which repository it resides.

Cause 2 Refreshing a data provide requires a connection to the repository. Therefore, if 
the server hosting the repository is down, or the connection to this server is lost, 
you cannot refresh the data provider.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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An internal error has occurred. (BQ0095)

Cause An internal error occurred as a result of an installation or configuration problem 
with BUSINESSQUERY and/or BUSINESSOBJECTS. 

Action Quit Excel. Then launch the application once again, load BUSINESSQUERY and try 
the action one more time. If this error occurs frequently, re-install BUSINESSQUERY 
and/or BUSINESSOBJECTS on your computer. For information on installing all 
BUSINESSOBJECTS products, refer to the Installation Guide.

You are not authorized to execute this command. (BQ0096)

Cause The BUSINESSQUERY command that you have tried to use has been restricted by 
the BUSINESSOBJECTS supervisor. Supervisors can enable/disable commands on a 
per user basis.

Action The supervisor can enable you to use this command. Once this has been done, try 
again.
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Partial insertion. Returned rows exceed Excel boundaries. (BQ0097)

Cause 1 The query that you have just run or refreshed has returned more rows than your 
version of Excel allows in one worksheet. BUSINESSQUERY has inserted as many 
rows as Excel allows.

Action You can:

• Restrict the number of rows returned by your query, either by setting an 
upper limit (Options button, Query Panel), or by applying a query condition. 
Refer to the BusinessQuery for Excel User’s Guide for more information.

• Ask your supervisor to set a maximum number of rows in your user profile.

• Upgrade to a version of Excel that supports the number of rows that your 
queries return.

Example You are working with Excel 95, which allows 16,000 rows in a worksheet. Your 
query has returned 25,000 rows, so only the first 16,000 are inserted.

Cause 2 Your worksheet contains multiple queries inserted from top to bottom in the 
worksheet. When you update the workbook (i.e., refresh all the queries it 
contains), the data returned exceeds Excel’s row limit. 

Action Insert queries from left to right in the worksheet, as opposed to from top to 
bottom. If you do this, you may wish to set a different SmartSpace strategy in 
BUSINESSQUERY. SmartSpace controls how queries are inserted in the worksheet. 
it also determines how data is managed when changes occur; for example,  
shifting cells down when new rows of data are inserted.

For information on Smart Space strategy, refer to the BusinessQuery for Excel 
User’s Guide.
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 Partial insertion. Returned columns exceed Excel boundaries. (BQ0098)

Cause 1 The query that you have just run or refreshed has returned more than 256 
columns of data. Excel worksheets can contain up to but not more than 256 
columns of data.

BUSINESSQUERY has inserted the first 256 columns of data in the worksheet, but 
the remaining data is not displayed.

Action BUSINESSQUERY returns one column of data per result object in your query. 
Therefore, you must include no more than 256 result objects in a single query.

If you need data returned by more than 256 objects, you can create two or more 
queries, then insert these in the same worksheet.

Cause 2 This error may occur when you are working with many queries in the same 
worksheet. If the queries are inserted from left to right in the worksheet, the right-
most query may exceed Excel’s 256 column limit.

Action Insert queries from top to bottom in the worksheet, as opposed to from left to 
right. If you do this, you may wish to set a different SmartSpace strategy in 
BUSINESSQUERY. SmartSpace controls how queries are inserted in the worksheet. 
it also determines how data is managed when changes occur; for example,  
shifting cells down when new rows of data are inserted.

For information on Smart Space strategy, refer to the BusinessQuery for Excel 
User’s Guide.
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Broadcast Agent Error Messages

BROADCAST AGENT error messages fall into three main categories:  

Invalid file name specified for the -vars option. (BCA0001)

Cause Variables used by the scheduled task are stored in a file. However, this file cannot 
be found for any of the following reasons:

• The name given is incorrect.

• The file has become corrupted or deleted.

• The permissions on the file make it inaccessible to the BOManager user.

• The repository record containing the name of the file has become corrupt.

Action Check that the name given in the -vars option is the name of the correct file, and 
that the file exists.

If the error recurs, the supervisor or database administrator can run a disk 
checking utility (on UNIX systems, the fsck utility; or on Windows NT systems, 
the ScanDisk utility). The supervisor can also run a Scan and Repair operation to 
correct any corruption which may have occurred on the disk or in the repository.

Range Category

BCA0001 - BCA0138 BCA Administration errors

BCAG0020 - BCAG1380 BCA Scheduler errors

BCB0001 - BCB0026 BCA Console errors
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Cannot save the delay between each refresh! (BCA0003)

Cause The connection to the repository has failed. This may be because:

• The server has lost its connection to the repository due to network problems.

• The relevant records in the repository are currently locked by another user.

• The tables have become corrupted.

Action Try the following:

• If you suspect the record is currently begin accessed by another user, wait a 
few minutes, and then try again. 

• Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

A supervisor can test the connection to the document domain as follows:

• Select Tools > Repository, and click the document domain.

• Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot create macro in the document. (BCA0004)

Cause 1 BROADCAST AGENT is unable to insert the VBA custom macro into the document. 
This may be because the task is running on a UNIX-only cluster, which does not 
support VBA.

Action If the task has been sent to a UNIX-only BROADCAST AGENT, then re-send the task 
to a Windows-based BROADCAST AGENT.

Use the Business Objects Services Administrator to check that at least one 
Windows-based server node is up and running in the cluster.  Also make sure 
that the Enable Batch Processing option in the BOManager parameters on that 
node is set to On.

If the problem persists, try the following:

• If you suspect the file is currently being accessed by another user, wait awhile, 
and then try accessing it again.

• Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

Cause 2 The connection to the repository is down. This may be because:

• The server has lost its connection to the repository due to network problems.

• The relevant records in the repository are currently locked by another user.

• The tables have become corrupted.
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Action A supervisor can test the connection to the document domain as follows:

• Select Tools > Repository, and click the document domain.

• Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.

Cannot load the security domain. (BCA0009)

Cause Access to BROADCAST AGENT is controlled via the security domain. However, this  
access is denied because of one of the following:

• There is no repository.

• The repository has not been updated to version 5.0.

• The repository tables have been damaged.

Action The supervisor can run the Administration Setup wizard to install or update the 
repository. If this has already been done, then the supervisor must run a Scan and 
Repair to fix any errors.
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Cannot resubmit [name] to Broadcast Agent. Check if its status still corresponds to the one 
displayed! (BCA0012)

Cause BROADCAST AGENT cannot access the repository. This may be due to:

• network problems

• the machine hosting the repository is down

• the repository domains are locked by another user, or the tables have become 
corrupted.

Action Try the following:

• If you suspect the file is currently being accessed by another user, wait a while, 
and then try accessing it again.

• Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

A supervisor can test the connection to the document domain as follows:

• Select Tools > Repository, and click the document domain. 

• Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot load the Broadcast Agent DLL. (BCA0013)

Cause This error may occur when you launch the Console, and when BUSINESSOBJECTS 
cannot find the BROADCAST AGENT dll file. This file is normally located in the
Business Objects 5.0 folder and is called kagtbcli.dll.

Action The dll file may have been deleted, renamed, moved, or damaged. If you have a 
backup copy of this file, you should copy it to the Business Objects 5.0 folder. If 
you do not have another copy of the file, you need to re-install BROADCAST 
AGENT.

Cannot launch BusinessObjects. (BCA0014)

Cause To process a document, BROADCAST AGENT launches BUSINESSOBJECTS on the 
server, via the Run command:

"C:\Program Files\Business Objects\BusinessObjects 5.0\Busobj.exe"

In this case, BROADCAST AGENT is unable to process a document because it cannot 
launch BUSINESSOBJECTS.

Note: The equivalent message in version 4.1 is Cannot launch the User Module.

Action On the BROADCAST AGENT machine, you can:

• Check the Busobj.exe file for size, creation date, modification date. 

• Run BUSINESSOBJECTS manually.

• Run ScanDisk.

• Check that the machine is not out of memory. Quit some applications if 
necessary.

• Re-install BUSINESSOBJECTS if necessary.
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The list of users has not been updated on the security domain. (BCA0016)

Cause There may be a problem with the security domain.

Action Run the Console and check Task Properties. If all the settings are correct here, 
then the supervisor should run a Scan and Repair  to fix any security domain 
problems (Tools > Repository); this feature allows the following operations on 
the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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There is no Broadcast Agent administrator defined for the group(s) to which you belong. 
Contact your supervisor. (BCA0017)

Cause No BROADCAST AGENT has been enabled in SUPERVISOR for the group(s) to which 
the current user belongs.

Action Either:

Use SUPERVISOR to define a BROADCAST AGENT for the relevant group, and then 
resubmit the document.

Or

Log in as a user in a group for which a BROADCAST AGENT has been defined 
already, and resubmit the document.

Cannot send the document to Broadcast Agent. (BCA0018)

Cause There is a problem with the memory management routines on the Broadcast 
Agent server node, or there is a problem with the repository.

Action Shut down BROADCAST AGENT, and cold-boot the BROADCAST AGENT server 
machine. This resets the memory management system of the machine. Now try 
to resubmit the document.

If this does not work, the problem may be due to repository corruption. In this 
case, the supervisor should run a Scan and Repair (Tools > Repository); this 
feature allows the following operations on the security domain or a document 
domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot generate temporary file. (BCA0019)

Cause BUSINESSOBJECTS always saves files temporarily to a local disk before sending 
them to the repository. Either you do not have write-access to the disk, or the disk 
does not have enough free space to store the file.

Action On Windows systems, empty your Recycle Bin. If necessary, delete any 
redundant or unwanted files, and empty the Recycle Bin again. If you have read-
only privileges on the root C:\ drive, ask the Windows NT administrator to grant 
you full access privileges on the C:\ root drive.

On UNIX machines, run the df utility to check if you have available disk space. If 
you do not, then you should delete unnecessary files or move them to a different 
partition.

Document was not saved by BusinessObjects. (BCA0020)

Cause 1 The document has been sent to BROADCAST AGENT with a script which has a “1” 
in its name.

Action Remove the 1 from the script’s name.

Example The script is called script1.spt.

Cause 2 The supervisor has disabled the Save Document command. Indeed, if the user 
you send the document to has the Save command disabled, BUSINESSOBJECTS 
cannot save the document.

Action The supervisor should modify the user’s rights.

Cause 3 The UserDocs folder path contains more than 256 characters.

Action Change the path to either a mapped folder or a new location, so that it contains 
fewer than 256 characters.
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BusinessObjects failed! (BCA0021)

Cause BUSINESSOBJECTS was shut down while processing a document.

Note: The equivalent message in version 4.1 is The User module failed.

Action This error often originates from a custom macro attached to a BUSINESSOBJECTS 
document. Therefore, you can:

• Run and debug the macro interactively.

• Perform the actions that were set (refresh, print etc.) on the server machine 
where BROADCAST AGENT is running.

Cannot remove document from Broadcast Agent. Check if its status still corresponds to the 
one displayed! (BCA0022)

Cause You are trying to delete a task using the BROADCAST AGENT Console, but the task 
has a Running or Delayed Execution status.

Action You cannot delete a task that has a Running or Delayed execution status. To 
delete a task from the task queue. You must wait until the task has been 
processed, and then:

1. Click the name of the document in the Broadcast Agent Console.

2. Click the Delete button.

3. Confirm the operation by clicking OK.
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Cannot start refresh timer! (BCA0026)

Cause BROADCAST AGENT cannot connect to the document domain either due to 
network problems or because the machine which hosts the document domain is 
down. 

Action Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR. (Tools > Connections > Edit).

Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

Cannot stop refresh timer! (BCA0028)

Cause BROADCAST AGENT cannot connect to the document domain due either to 
network problems or because the machine which hosts the document domain is 
down. 

Action Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR (Tools > Connections > Edit).

Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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Cannot pause task. (BCA0030)

Cause BROADCAST AGENT cannot connect to the document domain either due to 
network problems or because the machine which hosts the document domain is 
down. 

Action Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR (Tools > Connections > Edit).

Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

Cannot resume task. (BCA0032)

Cause BROADCAST AGENT cannot connect to the document domain either due to 
network problems or because the machine which hosts the document domain is 
down. 

Action Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR (Tools > Connections > Edit).

Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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Cannot connect to the document domain! (BCA0033)

Cause BROADCAST AGENT cannot connect to the document domain either due to 
network problems or because the machine which hosts the document domain is 
down.

Action Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR (Tools > Connections > Edit).

Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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Cannot connect to the security domain! (BCA0034)

Cause 1 The supervisor sets time restrictions for the user who sent the document. The 
schedule the user set for the document is not allowed according to the time 
restriction. Thus, access to the repository’s security domain is denied.

Action Either re-send the document at a different time, or change the time restrictions for 
the user in SUPERVISOR.

Cause 2 Too many concurrent BROADCAST AGENT tasks are running at the same time, and 
all are trying to update the objects.lsi file at the same time. (This file is used in 
offline mode.)

Action Reduce the number of concurrent tasks in the BROADCAST AGENT  from the 
Business Objects Services Administrator. Locate the settings of the BROADCAST 
AGENT and modify the option called Nb max running jobs.

Cause 3 You have at least two concurrent BROADCAST AGENT tasks and you are running 
version 4.1.3. In this version, some concurrent BROADCAST AGENT tasks cannot 
access the security domain or the objects.lsi file.

Action Update to BUSINESSOBJECTS version 4.1.4 or higher.

Cause 4 You have a corrupt objects.lsi file.

Action Make a new copy of your objects.lsi file from the objects.bak file in the LocData 
or ShData folder.

You can also try setting the Error Recovery to (number of Concurrent tasks 
allowed) + 1 (Console > Options, Advanced tab).
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Cannot disconnect from the security domain! (BCA0035)

Cause This message may be generated after a BusObj.exe task has finished processing 
(i.e., accessing the repository to send a document, perform an update, etc). The 
problem is due to the way in which your repository database has been set up to 
handle user access.

Action Although you can continue to work normally, if this message appears repeatedly, 
you should contact the database administrator for advice.

Cannot find the security domain! (BCA0036)

Cause BROADCAST AGENT is trying to access the repository, but the link between the 
document domain and the security domain has been corrupted, and you no 
longer have secure access to the document domain.

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot find SQL external file!  (BCA0037)

Cause BROADCAST AGENT is trying to use an external SQL script in order to send files to 
the repository. However, BROADCAST AGENT does not have the correct pathname 
to the script.

Action Check the pathname to the script file, and correct it.

Cannot load sqlbo.dll! (BCA0038)

Cause This error is generated whenever BUSINESSOBJECTS cannot find the sqlbo.dll file. 
This file is needed to ensure proper connectivity with the database middleware. 
The sqlbo.dll is grouped together with a series of other dll files in the cnxsrv50.dll. 
This file is located in the Business Objects\Business Objects 5.0 folder.

Action The cnxsrv50.dll file may have been deleted, renamed, moved, or damaged. If 
you have a backup copy of this file, you should copy it to your Business Objects 
5.0 folder. If you do not have another copy of the file, you should contact Business 
Objects Customer Support, or possibly re-install BUSINESSOBJECTS.

Cannot obtain a connection! (BCA0039)

Cause BROADCAST AGENT cannot connect to the document domain due either to 
network problems or because the machine which hosts the document domain is 
down. 

Action Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR (Tools > Connections > Edit).

Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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Check the connection: cannot obtain cursor. (BCA0040)

Cause BROADCAST AGENT cannot connect to the document domain due either to 
network problems or because the machine which hosts the document domain is 
down. 

Action Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR (Tools > Connections > Edit).

Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

Check the connection: cannot obtain network layer. (BCA0041)

Cause BROADCAST AGENT cannot connect to the document domain either due to 
network problems or because the machine which hosts the document domain is 
down. 

Action Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR (Tools > Connections > Edit).

Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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Cannot refresh the data of the security domain! (BCA0042)

Cause The problem comes from the decimal separator in your database: a comma (,) is 
used instead of a period (.).

Action If you are using version 4.1.3, apply the CSP30; if you’re using version 4.1.4, apply 
the CSP53. This problem is fixed in version 4.1.5. 

Unable to launch the listener! (BCA0043)

Cause BROADCAST AGENT cannot start the Scheduler. This may be due to insufficient 
memory, network problems or because the machine which hosts the Scheduler is 
down. 

Action Try the following:

• Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR (Tools > Connections > Edit).

• Verify the network connection by “pinging” the server hosting the repository. 
If the network is running properly, the database administrator should then 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

• Memory “leakage” problems can occur if the machine has been running and 
processing jobs for an extended period of time. In this case, shut down 
BROADCAST AGENT, and cold-boot the BROADCAST AGENT machine (and the 
machine which runs the Scheduler, if this is different). This should re-establish 
the connection to the database, and is often all that is required.
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Cannot find task information. (BCA0045)

Cause The Scheduler’s task information is stored in the repository. This message is 
generated if the Scheduler cannot access this task information. This may be 
because:

• You have lost your connection to the document domain.

• The document domain is locked by another user, or the tables have become 
corrupted.

Action If you suspect the file is currently being accessed by another user, wait awhile, 
and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

• Select Tools > Repository, and click the document domain. 

• Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the folloing operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.

Cannot load resource file. Check the installation. (BCA0046)

Cause One of the resource files needed to start the BROADCAST AGENT application has 
been deleted, moved, renamed, or corrupted.

Action You need to run the Setup program, and re-install BROADCAST AGENT.
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There is no Broadcast Agent defined for the group(s) to which you belong. Contact your 
supervisor. (BCA0064)

Cause You tried to send a document to BROADCAST AGENT, but no BROADCAST AGENT 
has been defined for the group to which you belong.

Action A supervisor can grant your group access to BROADCAST AGENT.

Cannot find document on hard disk. (BCA0065)

Cause Scheduled tasks can include scripted operations such as opening files from 
specific locations on specific machines. This message is generated if a scheduled 
task cannot open a file. This may be because the file has been moved, renamed, 
or deleted from the specified location.

Action Check that the requested file is still available in the specified location.

Expiration date cannot be prior to the first occurrence date. (BCA0066)

Cause You are using the BROADCAST AGENT Console to schedule a task (from the 
Scheduling tab in Task Properties), but you have specified an expiration date that 
precedes the start date.

Action Change the start date to a date that precedes the expiration date.
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Name not available (BCA0067)

Cause BROADCAST AGENT is trying to run a scheduled task to update a channel, but the 
specified channel has been removed in SUPERVISOR.

Action A supervisor can do the following:

1. Launch SUPERVISOR.

2. Right-click one of the groups, and select the Properties.

3. In the dialog box, click the Broadcast Agent tab.

4. Click the Broadcast Agent radio button.

5. Click Manage Channels.

6. Click the Add button, and enter information about the channel that was 
deleted.

7. Click Close, and then OK to apply the changes.

Unknown document (BCA0068)

Cause The document type you are trying to access is not supported by this release of 
BUSINESSOBJECTS. You can access only WEBINTELLIGENCE or BUSINESSOBJECTS 
documents.

Action Ask the owner of the document to resend it to BROADCAST AGENT as a 
WEBINTELLIGENCE or BUSINESSOBJECTS document.
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Cannot open bochan.cdx without read access. (BCA0069)

Cause This message is generated when you try to open the default template for channel 
files without having the necessary read access to the channel definition file (CDF).

Action The Windows NT administrator can grant you full access to the folders on the 
system.

Cannot generate channel index file: BOChannelldx.htm. (BCA0070)

Cause This message is generated when you select Publish to Channel, and there is 
insufficient disk space on the BROADCAST AGENT machine to generate the index 
file, or you have no write access to the folders on the machine. 

Action Try the following:

• Free up some disk space, delete any unnecessary files and empty the Recycle 
Bin, then try again. 

• Ask the Windows NT administrator to grant you full access to the folders on 
the system.
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Channel error (BCA0071)

Cause The supervisor can set up channels for BROADCAST AGENT, so that users can 
automatically publish documents to them. However, to use these channels, 
BROADCAST AGENT needs to interact with the repository, which is created and 
maintained by the supervisor. 

This error message may be generated in the following circumstances:

• The machine which hosts the security domain may be down, or the network 
connection to this machine may no longer be working.

• The supervisor has renamed or deleted this channel.

• The section of the security domain used to store the channel information may 
be damaged.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

A supervisor can check to make sure the channel list still exists.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

The specified file cannot be found. (BCA0072)

Cause You are trying to access the online PDF documentation, but these files were either 
not installed, or were deleted after installation. These PDF files should be located 
in the Online Guides\En folder.

Action Run BUSINESSOBJECTS Setup (Start > Programs > BusinessObjects 5.0 > Setup) and 
install or re-install the documentation.
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Cannot create the list of users. (BCA0090)

Cause 1 BROADCAST AGENT cannot write to the security domain of the repository. This 
may be because the server that hosts the repository is down or the network 
connection is not working.

Action Ask your administrator to verify the network connection by “pinging” the server. 
If the network is running properly, the administrator should then use a utility 
such as SQL NET to check if there is any response from the repository database.

Cause 2 Some of the security domain tables may be full or damaged, notably:

• DS_Pending_Job table

• Obj_M_Timestamp table

• Obj_M_Genpar table (properties)

Action Ask the supervisor to run a Scan and Repair to perform one of the following 
operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compact the database

Cause 3 The Broadcast Agent user account does not have correct permissions to write to 
the database, or the database itself has reached a size limit or has filled its 
maximum disk capacity.

Action Check with your database administrator that the password has not been changed, 
and that it is still possible to write data to the DB tables.
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Cannot get the list of users from the security domain. (BCA0091)

Cause 1 BROADCAST AGENT cannot access the security domain of the repository. This may 
be because the server which hosts the repository is down or the network 
connection is not working.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

Cause 2 Some of the security domain tables may be full or damaged, notably:

• DS_Pending_Job table

• Obj_M_Timestamp table

• Obj_M_Genpar table (properties)

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot refresh the list of users from the security domain. (BCA0092)

Cause BROADCAST AGENT, like all BUSINESSOBJECTS products which interact with the 
repository, can sometimes cause errors which need to be fixed in routine 
repository maintenance.

In this case, it is likely that a document has been scheduled for distribution to a 
specific list of users. When the scheduled time arrives, BROADCAST AGENT tries 
first to update the list of users from the security domain of the repository before 
distributing the document. 

However, in the meantime one of the following may have occurred:

• The supervisor has renamed or deleted this list of users.

• The section of the security domain used to store the user lists may be 
damaged.

• The machine hosting the security domain may be down, or the network 
connection to this machine may no longer be working.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

A supervisor can check to make sure the user list still exists.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot set the job frequency properly. (BCA0097)

Cause You are trying to change the BROADCAST AGENT task information, but you can no 
longer access the repository. This may be because:

• You have lost your connection to the repository.

• The repository is locked by another user, or the tables have become corrupted.

Action If you suspect the repository is locked by another user, wait a while and then try 
accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot update the list of users. (BCA0098)

Cause The list of users is stored in the repository. This message is generated if the 
Scheduler cannot access this user list. This may be because:

• You have lost your connection to the repository domains.

• The repository domains are locked by another user, or the tables have become 
corrupted.

Action If you suspect the file is currently being accessed by another user, wait a while, 
and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot set the new starting date. (BCA0100)

Cause The Scheduler’s task information is stored in the repository. This message is 
generated if you try to set a new starting date for a task, and the Scheduler cannot 
access the task information. This may be because:

• You have lost your connection to the repository domains.

• The repository domains are currently being accessed by another user, and are 
temporarily locked. This is a standard and automatic database feature that 
ensures that only one user or process can update a given value at a given time.

• Some of the repository tables have become corrupted.

Action If you suspect the file is currently being accessed by another user or process, wait 
a while, and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot set the scheduling parameter. (BCA0101)

Cause The Scheduler’s task information is stored in the repository. This message is 
generated if you try to set scheduling parameters for a task, and the Scheduler 
cannot access the repository. This may be because:

• You have lost your connection to the repository domains.

• The repository domains are locked by another user, or the tables have become 
corrupted.

Action If you suspect the file is currently being accessed by another user, wait a while, 
and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot set the job priority. (BCA0102)

Cause The Scheduler’s task information is stored in the repository. This message is 
generated if you try to set priority parameters for a task, and the Scheduler cannot 
access the repository. This may be because:

• You have lost your connection to the repository domains.

• The repository domains are locked by another user, or the tables have become 
corrupted.

Action If you suspect the file is currently being accessed by another user, wait a while, 
and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot set the job title. (BCA0103)

Cause The Scheduler’s job information is stored in the repository. This message is 
generated if you try to set a job title, and the Scheduler cannot access the 
repository. This may be because:

• You have lost your connection to the repository domains.

• The repository domains are locked by another user, or the tables have become 
corrupted.

• The file is currently being accessed by another user.

Action If you suspect the file is currently being accessed by another user, wait a while, 
and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain
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Cannot reset the list of users. (BCA0104)

Cause The list of users is stored in the repository. This message is generated if you are 
trying to reset the list of users, and the Scheduler cannot access this user list. This 
may be because:

• You have lost your connection to the repository domains.

• The repository domains are locked by another user, or the tables have become 
corrupted.

Action If you suspect the file is currently being accessed by another user, wait a while, 
and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain



v 5.1-2.7

 Error Message Guide 449

Cannot get column names. (BCA0106)

Cause The Scheduler’s job information is stored in the repository. This message is 
generated if you try to retrieve scheduled job information, and the Scheduler 
cannot access the repository. This may be because:

• You have lost your connection to the repository domains.

• The repository domains are locked by another user, or the tables have become 
corrupted.

Action If you suspect the file is currently being accessed by another user, wait a while, 
and then try accessing it again.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain



 Broadcast Agent Error Messages

450 Error Message Guide

Cannot send the document to the users! (BCA0107)

Cause BROADCAST AGENT is trying to process your scheduled request to distribute a 
report to a list of users, but cannot do so because:

• There is no connection to the repository.

• The user list no longer exists.

• You are not authorized to perform this action.

Action Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

A supervisor can do the following:

• Check that the user group has not been deleted in SUPERVISOR.

• Check whether you are authorized to use BROADCAST AGENT.

A supervisor can also test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.
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Cannot obtain the list of users to whom you want to send the document! (BCA0108)

Cause The user requested that BROADCAST AGENT distribute the document to other 
users via the repository.

BROADCAST AGENT has successfully processed the document but cannot 
distribute it because the list of users cannot be retrieved from the security domain 
of the repository.

Action In SUPERVISOR:

1. Run a Scan and Repair on the security domain.

2. Check that each user from the distribution list still exists in the right groups.

3. If necessary, re-create the user list.

In BUSINESSOBJECTS:

1. Select the Console command on the Tools menu.

2. Click the task, then click Properties.

3. In the Properties dialog box, click the Distribution tab.

4. Click the To button, and check that all the users appear on the distribution list.

5. If necessary, delete the user list, and recreate it. 

6. If necessary, delete the task and send the document again.

In SUPERVISOR run a Scan and Repair on the security domain.

On the BROADCAST AGENT machine, check that the time zone, date and time are 
correct.

Example You send a document to BROADCAST AGENT and select John, Ken, Marcia and Eric 
as the users who are to receive the processed document.

Between the time you send the document and the time BROADCAST AGENT comes 
to process it, the supervisor has deleted Marcia and John from the repository. 
Thus, BROADCAST AGENT cannot retrieve the user list and the task fails.
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Your login has been disabled by your supervisor. (BCA0109)

Cause In order to use BROADCAST AGENT, the group to which you belong must have the 
necessary authorization. This is set up by the supervisor in the Broadcast Agent 
tab of your group properties. This message is generated if your login has been 
disabled by the supervisor.

Action Your login (currently disabled) must be enabled by the supervisor.



v 5.1-2.7

 Error Message Guide 453

RSS file not accessible. (BCA0110)

Cause One .rss file is created for each of the databases you are using. This file contains 
the necessary connection information, and is stored in the database folder:

Business Objects\Data Access 5.0\<database name>

This error is generated if BUSINESSOBJECTS cannot find the .rss file under the 
database folder, and therefore cannot establish a connection to the database.

Action Copy a backup of the .rss file to the database folder. If you do not have a backup, 
a supervisor must create the connection once more in SUPERVISOR.

Wrong SQL used. (BCA0111)

Cause BUSINESSOBJECTS has encountered an exceptional error while attempting to access 
your corporate database. 

Action Contact Business Objects Customer Support.

Error during import. (BCA0112)

Cause An error occurred while you were retrieving a document from the repository. 
The import was aborted because of one of the following:

• There was a network error.

• the server which hosts the document domain has failed.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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Not enough memory. (BCA0113)

Cause Windows NT does not have sufficient memory to run the various server systems 
which have been configured.

Action Run the Servconf.exe utility to modify your memory settings. Servconf.exe is a 
utility automatically installed with the Enterprise Server Products option in:

Business Objects\Server\BusinessObjects Manager 5.0

This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runs BusObj.exe processes (under the 
control of the BOManagers). 

Defining the appropriate settings is essential to ensure the correct behavior and 
performance of your BOManager system, especially regarding the number of 
BusObj.exe processes that can be launched simultaneously. These values control 
how Windows NT allocates system memory to your server systems.
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At any given time, several BusObj.exe processes can be running simultaneously 
from one or more BOManagers. If for any reason there is insufficient system 
memory available for a given BOManager, then processes may sometimes fail in 
various and unpredictable ways. 

Recommended settings

In the “System Heap Size” group:

• Either keep your system’s current value for the Interactive setting or reset this 
value to the Windows NT default of 3072.

• In the System Heap Size (Kb) group, set the Non-Interactive setting value to 
512 (try 1024 if you encounter problems thereafter).

In the Identify for BusObj.exe Automation Server group:

• Select the option This User.

• Type the name of a valid user account (using the “domain_name\user_name” 
format, without the quotes but with the backslash).

This account must be in the group ‘Administrators’ and have the special rights 
“Log on as a batch jo” and “Act as part of the operating system.”

For more detailed information on the settings of Servconf.exe, refer to Chapter 4, 
“Server Sizing, Capacity, and Optimization” in the Deployment Guide.



 Broadcast Agent Error Messages

456 Error Message Guide

Error during import. (BCA0114)

Cause An error occurred while you were retrieving a document from the repository. 
The import was aborted because of one of the following:

• There was a network error.

• The server which hosts the document domain has failed.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

Cannot obtain unique ID on security domain for export. (BCA0115)

Cause You tried to export a universe or send a document to a user, but the Magic_ID 
assigned to the universe or document in the repository has been corrupted.

Action The error usually occurs when the user terminates a task submitted to 
BROADCAST AGENT abnormally (by rebooting his computer, for example). The 
same also happens when the task is abnormally terminated by BROADCAST 
AGENT. There may be other reasons, but these two are most frequent.

A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

This should correct the anomaly in the Magic_ID. 
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Database error during export; export stopped. (BCA0117)

Cause This error may occur when you try to export a document to the repository. The 
repository tables may be full.

Action Check that there is sufficient disk space on the machine hosting the document 
domain.

Break during export; export stopped. (BCA0118)

Cause This error may occur when you try to export a document to the repository. The 
network connection to the repository may be lost, the repository server may have 
gone down, or the repository tables may be full.

Action Try the following:

• Verify the network connection by “pinging” the server hosting the repository. 
If the network is running properly, the database administrator should then 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

• Check that there is sufficient disk space on the machine hosting the document 
domain.
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 Cannot open file. (BCA0119)

Cause Whenever BROADCAST AGENT sends a scheduled document to the repository, it 
first saves the document locally to disk as a temporary file. This is done in order 
to compress the file before sending it to the repository, thereby speeding up the 
transfer process. Once the document has been sent to the repository, the 
temporary file is automatically deleted. 

In order to send the compressed file to the repository, BROADCAST AGENT first 
needs to be able to open the file. This message is generated when BROADCAST 
AGENT cannot open this temporary file. This may be because the file was not 
processed correctly.

Action You need to re-send the document to BROADCAST AGENT.



v 5.1-2.7

 Error Message Guide 459

Cannot begin transaction on the security domain. (BCA0120)

Cause The BROADCAST AGENT Scheduler cannot start a scheduled task because there is 
no longer a connection with the security domain. This may be because:

• You have lost your connection to the repository.

• The security domain is locked by another user, or the tables have become 
corrupted.

Action Try the following:

• If you suspect that the security domain is currently locked by another user, 
run the scheduled task once more. If this problem occurs frequently, check if 
your repository database supports row-level locking. If so, the database 
administrator may need to manually activate this feature.

• Verify the network connection by “pinging” the server hosting the repository. 
If the network is running properly, the database administrator should then 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

A supervisor can test the connection to the security domain as follows:

1. Select Tools > Repository, and click the security domain.

2. Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot begin transaction to start exporting documents on the document domain. 
(BCA0121)

Cause The BROADCAST AGENT Scheduler cannot start a scheduled task because there is 
no longer a connection with the document domain. This may be because:

• You have lost your connection to the repository.

• The document domain is locked by another user, or the tables have become 
corrupted.

Action Try the following:

• If you suspect that the document domain is currently locked by another user, 
run the scheduled task once more. If this problem occurs frequently, check if 
your repository database supports row-level locking. If so, the database 
administrator may need to manually activate this feature.

• Verify the network connection by “pinging” the server hosting the repository. 
If the network is running properly, the database administrator should then 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot delete previous document. (BCA0122)

Cause This message may be generated when BROADCAST AGENT tries to re-send or 
re-publish a scheduled document to the repository. Because a previous version of 
the document already exists in the repository, BROADCAST AGENT must first 
delete the previous version before sending the new version. In this case, however, 
the previous version of the document cannot be deleted because the repository 
cannot be accessed.

Action Try the following:

• If you suspect that the document domain is currently locked by another user, 
run the scheduled task once more. If this problem occurs frequently, check if 
your repository database supports row-level locking. If so,  the database 
administrator may need to manually activate this feature.

• Verify the network connection by “pinging” the server hosting the repository. 
If the network is running properly, the database administrator should then 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.
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Cannot obtain information on previous document. (BCA0123)

Cause This message may be generated when BROADCAST AGENT tries to re-send or 
re-publish a scheduled document to the repository. Because a previous version of 
the document already exists in the repository, BROADCAST AGENT must first 
delete the previous version before sending the new version. 

In this case, however, the previous version of the document cannot be deleted 
because it cannot be found by BROADCAST AGENT. This may be because the 
previous version of the document has been moved, renamed, or deleted by the 
supervisor, because the document domain tables have been corrupted, or 
because the document type is not supported by BUSINESSOBJECTS.

Action Check that the previous version of the file is still available on the document 
domain.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot terminate transaction while exporting documents on the document domain. 
(BCA0124)

Cause You started to export a document to the document domain of the repository, but 
you cannot successfully complete the operation because a problem has occurred 
on the document domain. This may be because:

• You have lost your connection to the document domain.

• The document domain is locked by another user, or the tables have become 
corrupted.

• The machine on which the document domain resides has run out of free disk 
space.

Action Try the following:

• If you suspect the file is currently being accessed by another user, wait a whil, 
and then try accessing it again.

• Check that there is sufficient disk space on the document domain machine.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot terminate transaction while exporting documents on the security domain. 
(BCA0125)

Cause You started to export a document to the document domain of the repository, but 
you cannot successfully complete the operation because a problem has occurred 
on the security domain. This may be because:

• You have lost your connection to the security domain.

• The security domain is locked by another user, or the tables have become 
corrupted.

Action A supervisor can test the connection to the security domain as follows:

1. Select Tools > Repository, and click the security domain.

2. Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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No folder specified for distribution via the file system (BCA0130)

Cause You have just used the Send Document to Broadcast Agent dialog box to send a 
document to BROADCAST AGENT. When you click OK, this message appears 
because you selected the Distribute via the Server File System option in the 
Distribution tab, but did not specify the server name or folder that you want.

Action In the Distribution tab:

1. Specify the name of the server and the path to the folder.
Note that:
• The folder you select is on the file server, not on your own computer. By 

default, BUSINESSOBJECTS uses a variable, 
$BO_FOLDER_ON_SERVER\UserDocs, which automatically sends 
processed documents to the folder in which BUSINESSOBJECTS is installed 
on the server. 

• You can specify a different folder on a different computer by clicking 
Browse, or by typing a path, e.g., \\HostName\FolderName.

2. Click OK to send the document.
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No folder specified for distribution via a Web server (BCA0131)

Cause You have just used the Send Document to Broadcast Agent dialog box to send a 
document to BROADCAST AGENT. When you click OK, this message appears 
because you selected the Distribute via Web Server option in the Distribution tab, 
but did not specify the location of the Web server.

Action In the Distribution tab:

1. Specify the location of your Web server. 
Note that:
• The field below the Distribute via Web Server checkbox indicates the path to 

the folder that is to receive the published document. By default, 
BUSINESSOBJECTS uses a variable, $BO_FOLDER_ON_SERVER\UserDocs, 
which automatically sends processed documents to the folder in which 
BUSINESSOBJECTS is installed on the server.

• You can use the Browse button to locate the server.

2. Click OK to send the document.

No users selected for distribution via the BusinessObjects repository (BCA0132)

Cause You have just used the Send Document to Broadcast Agent dialog box to send a 
document to BROADCAST AGENT. When you click OK, this message appears 
because you selected the Distribute via the Repository option in the Distribution 
tab, but did not select any users or groups.

Action In the Distribution tab:

1. Click the To button.

2. In the Select Users and Groups dialog box that appears, select the users and/
or groups to whom you want to send the processed document, then click OK.

3. Click OK to send the document.
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 Invalid condition: condition (BCA0133)

Cause A condition is a component that controls the type and the amount of data 
returned by a specific object in a query. This message is generated when you 
select Send to Broadcast Agent, click the Actions tab, and specify a condition 
using incorrect syntax or invalid operators.

Action Open a document, and enter the formula in the document. If the syntax is parsed 
correctly by BUSINESSOBJECTS, then you should be able to use the same formula in 
the condition field, without generating an error message.

Formula is not valid in Broadcast Agent context (not Boolean). (BCA0134)

Cause A condition is a component that controls the type and the amount of data 
returned by a specific object in a query. This message is generated when you 
select Send to Broadcast Agent, click the Actions tab, and specify a condition 
using incorrect syntax or invalid operators.

Action Open a document, and enter the formula in the document. If the syntax is parsed 
correctly by BUSINESSOBJECTS, then you should be able to use the same formula in 
the condition field, without generating an error message.

Check formula syntax. (BCA0135)

Cause A condition is a component that controls the type and the amount of data 
returned by a specific object in a query. This message is generated when you 
select Send to Broadcast Agent, click the Actions tab, and specify a condition 
using incorrect syntax or invalid operators.

Action Open a document, and enter the formula in the document. If the syntax is parsed 
correctly by BUSINESSOBJECTS, then you should be able to use the same formula in 
the condition field, without generating an error message.
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Variables are not compatible. (BCA0136)

Cause You inserted blocks from two or more separate cubes in Structure view into one 
block, forcing BUSINESSOBJECTS to display incompatible objects together. When 
you try to modify the object name, BUSINESSOBJECTS returns an error.

There are probably multiple paths, measures and contexts enabled for the 
universe. 

Action A universe designer can disable these options in the universe, so that 
BUSINESSOBJECTS has more leeway with report generation. The results may be 
flawed in certain circumstances with these options disabled, but BUSINESSOBJECTS 
can now display more freely. With no incompatible objects forced into the block, 
you should have no problem changing variable names.

You are not authorized to use this option. (BCA0137)

Cause You tried to start BROADCAST AGENT, but you do not have the necessary 
authorization.

Action A supervisor can enable the BROADCAST AGENT for your group as follows:

1. Launch SUPERVISOR.

2. Right-click the user group.

3. Click Properties on the pop-up men.
The Group Properties dialog box appears.

4. Click the Broadcast Agent tab.

5.  Click the Broadcast Agent radio button and enter values for the parameters 
as necessary.

6. Click OK.
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This document is not refreshable. (BCA0138)

Cause You tried to refresh a document, but cannot do so because you cannot access the 
repository, or because you do not have write-access to the document.

Action Try the following:

• Verify the network connection by “pinging” the server hosting the repository. 
If the network is running properly, the database administrator should then 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

• If you have read-only privileges to files or folders on the system, ask the 
Windows NT administrator to grant you full access.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.

Unknown error (BCAG0020)

Cause BROADCAST AGENT isn’t working, either when you launch it, or while it is 
processing tasks. This could be due to installation or configuration problems, the 
configuration of the server machine itself, or simply the result of an unrecognized 
error code that has been sent by an incompatible version of BOManager.

Action Relaunch BROADCAST AGENT. If you receive the same error message, see the 
system or network administrator.
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Internal error (BCAG0030)

Cause BROADCAST AGENT isn’t working, either when you launch it or while it is 
processing tasks, due to a system error.

Action Relaunch BROADCAST AGENT. If you receive the same error message, see the 
system or network administrator.

Toolkit error (BCAG0040)

Cause BROADCAST AGENT isn’t working, due to a problem with a resource library.

Action Make sure that BROADCAST AGENT has been correctly installed. 

CORBA error (BCAG0050)

Cause At startup, BROADCAST AGENT cannot communicate with the CORBA system, 
and therefore cannot function.

Action Do the following:

1. Verify that the CORBA’s Os_Agent was correctly installed.

2. Launch the Visigenics ORBeline Smart Finder by selecting Run from the Start 
menu, then entering osfind.exe. 

3. Check that: 
• You have only one OsAgent process throughout the cluster. 
• You have only one OAD (Orb Activation Daemon) process per cluster 

node, and only one OAD process for a stand-alone installation. 

4. If you have more than one process, stop then restart BROADCAST AGENT, then 
verify the BROADCAST AGENT processes. 

5. If you still do not obtain the correct results, log off your machine, relaunch it, 
then verify again.
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BOManager error (BCAG0060)

Cause BROADCAST AGENT cannot function because it cannot communicate correctly 
with the BOManagers through the CORBA system.

Action Check that you have a BOManager version that is compatible with the 
BROADCAST AGENT version you are using, and that BOManager is correctly 
installed. If either of these is a problem, (re)install a recent version of BOManager.

Also make sure the BOManager version is compatible with your version of 
BUSINESSOBJECTS.

ADE error (BCAG0070)

Cause The Application Development Environment (ADE) is a set of interfaces delivered 
with BUSINESSOBJECTS. All the documents processed by BROADCAST AGENT use 
the ADE.

Action Try the following:

1. Make sure that Visual Basic for Applications (VBA) was correctly installed.

2. Launch BUSINESSOBJECTS in interactive mode, then launch VBA from 
BUSINESSOBJECTS (Tools > Macro > Visual Basic Editor). 
• If it doesn’t launch correctly, uninstall VBA then re-install it. 
• If you can launch VBA from BUSINESSOBJECTS without any problem, ask 

the system administrator for help. 

Example Using Visual Basics for Applications (VBA), which is also delivered with 
BUSINESSOBJECTS, you can program the ADE to automate the inclusion of 
conditions in documents, and other BUSINESSOBJECTS procedures. You can attach 
a macro to a document using the ADE. In this case, a document with this macro 
has been sent to BROADCAST AGENT, but BROADCAST AGENT cannot access the 
ADE to interpret the macro. 
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Cannot initialize CORBA. (BCAG0080)

Cause BROADCAST AGENT cannot work because it cannot start the CORBA system which 
allows it to communicate with the other servers in the cluster.

Action Try to launch the CORBA manually using the OS Find utility. To open it:

1. Open the Inprise Smart Finder by opening a DOS command prompt window.

2. Change the folder to <Installation folder>\Server\ORB 2.5\bin, type 
osfind.

3. Press Enter.

Cannot get BOManager. (BCAG0090)

Cause BROADCAST AGENT cannot function because it cannot communicate correctly 
with BOManager. It is possible someone has stopped the BOManager you are 
using.

Action Verify that there is at least one active BOManager in your cluster, and that it is 
properly configured. 

• If you find a BOManager that isn’t running, start it.

• If a BOManager is running, test it manually, using the OS Find utility (to open 
it, open a DOS command prompt window, change the folder to 
<Installation folder>\Server\ORB 2.5\bin, type osfind, then press Enter.

If you can’t, make sure you have a BOManager version that is compatible with 
the versions of BROADCAST AGENT and BUSINESSOBJECTS that you’re using. 

• If it isn’t, install a recent version of BOManager, then try again to launch it 
manually. 

• If it still doesn’t launch, see the system administrator.
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Cannot log into BOManager. (BCAG0100)

Cause Every time a task is scheduled to be run, BROADCAST AGENT must enter into 
communication with BOManager. To do this, it must log into the BOManager 
server using the user name and password of the user who scheduled the task. In 
this case, either the user no longer has the right to log into the repository, or 
BOManager is not correctly installed.

Action Check with the supervisor to make sure the user who scheduled the task has the 
right to disable login. If the user does have the right, make sure BOManager is 
correctly installed, and active in the cluster.

Example Pauline Smith has scheduled a document containing an analysis of the month’s 
sales figures to be refreshed and distributed to the members of the Marketing 
department at the beginning of each month. During the course of this month, 
however, the supervisor has cancelled Pauline’s right to log into the repository. 
Therefore, at the beginning of the following month, when BROADCAST AGENT 
uses her username and password to log in with BOManager to refresh and 
distribute the document, BOManager refuses access.
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Recipient cannot log into BOManager. (BCAG0110)

Cause BROADCAST AGENT is trying to run a task in “report bursting” mode. Report 
bursting permits BROADCAST AGENT to generate a version of a document based 
on the profile of each recipient. Each time the task is scheduled to be run, 
BROADCAST AGENT must enter into communication with BOManager. To do this, 
it must login to the BOManager server using the username and password of each 
of the document’s recipients. In this case, either a recipient doesn’t have the 
required rights to log into the repository, or BOManager isn’t correctly installed.

Action A supervisor can check whether  the recipients have all the necessary access 
rights to receive the document (uncheck Disable login). If they do have the 
appropriate rights, make sure BOManager is correctly installed, and active in the 
cluster.

Example Paul Jones has just scheduled a document containing an analysis of the month’s 
sales figures to be refreshed and distributed to the members of the Marketing 
department at the beginning of each month. Some people in Marketing, however, 
don’t have the right to log into the repository, and therefore BOManager cannot 
refresh with data corresponding to the universe objects in the document.

When BROADCAST AGENT tries to log into BOManager with the username and 
password of each of these people, BOManager therefore refuses access.

Failed to release document context. (BCAG0120)

Cause When BOManager completes processing a task, it deletes a temporary folder for 
the document that it created on the server machine when the task was initiated. 
In this case, BOManager cannot remove the document’s folder. This problem is 
caused by an internal system error.

Action This problem is unimportant and requires no action.
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Failed to create document context. (BCAG0130)

Cause When BOManager begins processing a task, it creates a temporary folder for the 
document on the server machine. In this case, it cannot create this folder. This 
problem may arise because the server’s disk is full, or because the person who 
installed the server’s system doesn’t have access rights to the required directory 
or disk.

Action Try the following:

1. Check how much disk space is free on the BOManager’s host. If disk space is 
low, free some of it up.

2. Verify that the user name and password being used for launching BOManager 
can obtain access to the BOManager server. 
You can do this using the server configuration utility called servconf.exe.

Servconf.exe is a utility automatically installed with the Enterprise Server 
Products option in:

Business Objects\Server\BusinessObjects Manager 5.0

This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runs BusObj.exe processes (under the 
control of the BOManagers).
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Failed to create session. (BCAG0140)

Cause The BROADCAST AGENT machine is out of disk space or memory.

Action Try the following:

• Reboot the BROADCAST AGENT machine.

• Reduce the number of concurrent tasks in the BROADCAST AGENT Console on 
the server machine, to prevent this error from recurring.

• Run ScanDisk, empty the Recycle Bin and purge the Temp folder on the server 
machine.

• Install more BROADCAST AGENT machines to ensure failover and load-
balancing.

• Run the Servconf.exe utility to modify your memory settings. 

Servconf.exe is a utility automatically installed with the Enterprise Server 
Products option in: \Business Objects\Server\BusinessObjects Manager 5.0. 
This utility allows you to view and modify the system heap size settings. 
These settings determine how Windows NT runs BusObj.exe processes 
(under the control of the BOManagers).
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Cannot get user password. (BCAG0150)

Cause Every time a task is scheduled to be run, BROADCAST AGENT must enter into 
communication with BOManager. To do this, it must log into the BOManager 
server using the username and password of the user who scheduled the task. In 
this case, however, it cannot retrieve the user’s password from the repository.

Action A supervisor can verify the required password.

Cannot get login information. (BCAG0160)

Cause Before launching a task, the Scheduler scans the repository to check the names 
and passwords of the user(s) on the distribution list. This message is generated if 
this user login information is no longer available in the repository. 

 Users may have been deleted.

Action A supervisor can check the user login information.
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Cannot generate document. (BCAG0170)

Cause The BROADCAST AGENT machine is out of memory, or the document type that 
BROADCAST AGENT is trying to access is not supported by this release of 
BUSINESSOBJECTS. You can access only WEBINTELLIGENCE or BUSINESSOBJECTS 
documents.

Action Try the following:

• Reboot the BROADCAST AGENT machine.

• Reduce the number of concurrent tasks in the BROADCAST AGENT Console on 
the server machine, to prevent this error from recurring.

• Run ScanDisk, empty the Recycle Bin and purge the Temp folder on the server 
machine.

• Install more BROADCAST AGENT machines to ensure failover and load-
balancing.

• Run the Servconf.exe utility to modify your memory settings. 

Servconf.exe is a utility automatically installed with the Enterprise Server 
Products option in: \Business Objects\Server\BusinessObjects Manager 5.0. 
This utility allows you to view and modify the system heap size settings. 
These settings determine how Windows NT runs BusObj.exe processes 
(under the control of the BOManagers).

• Ask the owner of the document to resend it to BROADCAST AGENT as a 
WEBINTELLIGENCE or BUSINESSOBJECTS document.



v 5.1-2.7

 Error Message Guide 479

Task canceled by user. (BCAG0180)

Cause The current task has been canceled by the user who scheduled it.

Action No action.

Example Juan Diaz scheduled a document to be refreshed and distributed to a group of 
users every Monday at 11 AM. This Monday morning, however, he has 
interrupted the task as it was being processed.

Canceled because of shutdown of Scheduler. (BCAG0190)

Cause The WEBINTELLIGENCE administrator has stopped Scheduler. All running tasks 
have been canceled.

Action Ask the WEBINTELLIGENCE administrator to relaunch Scheduler.

Maximum duration reached. (BCAG0200)

Cause The WEBINTELLIGENCE administrator can determine the maximum amount of 
time a task takes to be processed. In this case, the current task has taken longer 
than the defined maximum duration.

Action Try the following solutions:

1. First, try to understand why the task is taking so long. The best way to 
troubleshoot in this instance is to launch the task interactively. This means 
launching BusObj.exe on the WEBINTELLIGENCE server so that you can see 
what happens when BUSINESSOBJECTS processes the document. This should 
tell you not only how long the task should take, but if there is a problem, it 
should pinpoint it and display a detailed error message.

2. If there is no problem, ask the WEBINTELLIGENCE administrator to check if the 
specified maximum time is reasonable given this type of task.
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Unknown job killed. (BCAG0220)

Cause When started, the Scheduler queries the repository to determine which 
documents are due for processing. In this case, it sees that it is already supposed 
to be processing a task, but because it is only now being launched, the task cannot 
be processed. This type of situation can occur when someone has unplugged the 
server hosting the Scheduler. 

Action Otherwise, run the job manually from the BROADCAST AGENT Console. 
If you get this message often, verify that the Scheduler was properly installed. 

Unknown running job killed. (BCAG0230)

Cause The server machine which hosts the Scheduler has failed while  processing a task.

Action Run the job manually from the BROADCAST AGENT Console. 
If you get this message often, verify that the Scheduler was properly installed. 
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Cannot duplicate job in repository. (BCAG0240)

Cause There is a database problem. It may be full.

Action See the database administrator about the status of the database.

Cannot flush cache on BOManager. (BCAG0250)

Cause BROADCAST AGENT has launched a report bursting task. To speed up the 
distribution of the document, BOManager has stored the document in a cache, 
then sent the document to each recipient from the cache. Upon completion of the 
task, however, BOManager cannot empty the document from the cache.

Action This is an interesting but not terribly important message. BOManager stops every 
couple of hours, and at that point flushes its cache automatically.

Cannot execute macro. (BCAG0260)

Cause The Application Development Environment (ADE) is a set of interfaces delivered 
with BUSINESSOBJECTS. Using Visual Basics for Applications (VBA), which is also 
delivered with BUSINESSOBJECTS, you can program the ADE to automate the 
inclusion of conditions in documents, and other BUSINESSOBJECTS procedures.

Users can attach a macro to a document using the ADE. 
In this case, a document with a macro has been sent to BROADCAST AGENT, but 
BROADCAST AGENT cannot access the ADE to interpret the macro.

Action Try the following:

1. Make sure that Visual Basic for Applications (VBA) was correctly installed.

2. Launch BUSINESSOBJECTS in interactive mode, then launch VBA from 
BUSINESSOBJECTS (Tools > Macro > Visual Basic Editor). 
• If it doesn’t launch correctly, uninstall VBA then reinstall it. 
• If you can launch VBA from BUSINESSOBJECTS without any problem, ask 

the system administrator for help. 
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Cannot execute a version 4.1 script. (BCAG0270)

Cause In BUSINESSOBJECTS 4.1, you could use the ReportScript programming language 
to program the Application Development Environment (ADE) to automate the 
inclusion of conditions in documents, and other BUSINESSOBJECTS procedures. 

In this case, BROADCAST AGENT has retrieved a document containing a 
BUSINESSOBJECTS 4.1 script, but in trying to convert it to the Visual Basic for 
Applications (VBA) macro used by version 5.0, it has come across a problem.

Action Retrieve the script and convert the script into a VBA macro using the 
Tools > ReportScript > Macro > Convert in BUSINESSOBJECTS. Make sure there are 
no errors.

Cannot generate document for recipient. (BCAG0280)

Cause A report bursting task is being processed, which means that the document is 
generated according to the access rights of each recipient. In this case, file 
generation failed.

Action A supervisor can check the recipient’s access rights and change them if necessary.
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Cannot distribute to recipient. (BCAG0290)

Cause BROADCAST AGENT cannot distribute the document to a recipient, due to:

• The database being full

• The repository being full

• The recipient lacking required right

Action Check with the database administrator to make sure the database is neither full 
nor corrupted.

A supervisor can do the following:

• Check the recipient’s access rights for the document, the universe the 
document is based on, the repository being used, etc. These rights should be 
modified if required.

• Scan the security domain in the repository to determine whether the domain 
is full, and whether it contains consistency or structural errors. If full, the 
domain should be compressed. 



 Broadcast Agent Error Messages

484 Error Message Guide

Cannot distribute to recipients. (BCAG0300)

Cause BROADCAST AGENT cannot distribute the document to a number of recipients, due 
to:

• The database being full

• The repository being full

• The recipients lacking the required rights

Action Check with the database administrator to make sure the database is neither full 
nor corrupted.

A supervisor can do the following:

• Check the recipient’s access rights for the document, the universe the 
document is based on, the repository being used, etc. These rights should be 
modified if required.

• Scan the security domain in the repository to determine whether the domain 
is full, and whether it contains consistency or structural errors. If full, the 
domain should be compressed. 

Cannot import document to server. (BCAG0310)

Cause It’s time for a task to be processed, but one of the following has happened:

• When the Scheduler scans the repository’s document domain for the relevant 
document, it cannot find the document.

• The Scheduler retrieves the document from the repository, but BOManager 
can’t import it. In this case, the disk on the BOManager server may be full.

Action First, a supervisor should verify whether the document exists in the document 
domain. If it doesn’t, delete the task using the BROADCAST AGENT Console, and 
send the document to BROADCAST AGENT again.

If this doesn’t work, ask the system or network administrator to check disk space 
on the BOManager server.
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Cannot get document from cache. (BCAG0320)

Cause During the processing of a task, the Scheduler has been able to retrieve the 
document from the repository and store it in the BOManager’s cache, but 
BOManager can’t subsequently retrieve the document from the cache. The disk 
on the BOManager server may not have enough space.

Action Ask the system or network administrator to check disk space on the BOManager 
server.

Cannot refresh document. (BCAG0330)

Cause 1 The secured command Refresh Documents has been disabled or hidden.

Action Enable the secured command Refresh Documents and re-send the document.

Cause 2 The document contains contexts or prompts, and the secured command Do not 
always regenerate SQL has been disabled.

Action Enable the Do not always generate SQL command.

Cause 3 The universe parameters are overloaded, that is, the document exceeds the row 
and/or time limits set in SUPERVISOR.

Action A supervisor can modify the row and time limit parameters.
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Cause 4 The document contains contexts, and the universe was exported after the 
document was sent to BROADCAST AGENT.

Action You may get a more specific error message, such as: “Command failed. A variable 
prevented the data provider xxx with yyy from being refreshed,” “Command 
failed internal memory error during SQL generation,” or “The data provider 
hasn’t been refreshed because of one variable.”

Prompts and contexts can cause these problems. Try these solutions:

• Go to Broadcast Agent > Console > Options > Advanced tab > Error recovery, 
and set Retry to 1.

• If there are @PROMPTs in the universe, make sure the third parameter 
contains the List of Values (an optional item).

• If the universe is new in the BROADCAST AGENT, the SQL is regenerated. 
Click Edit Data Provider > SQL and make sure that the command “Do not 
generate SQL before running” is not checked. (This problem has been 
resolved in versions 4.1.2 and higher.)

Cause 5 The document contains objects defined with prompts in the universe, and the 
universe was exported after the document was sent to BROADCAST AGENT.

Action See the Action for Cause 4.
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Cannot copy file to server. (BCAG0340)

Cause When the current document was sent, the user chose to distribute the document 
by the file system and defined the folder the document would be saved to. In this 
case, the task has been completed, but the document can’t be saved to the folder, 
because the user who configured the BOManager being used doesn’t have access 
rights to that disk.

Action Use the Servconf.exe utility to verify that the user who configured BOManager 
has access to the server.

This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runs.Servconf.exe is a utility automatically 
installed with the Enterprise Server Products option in:

Business Objects\Server\BusinessObjects Manager 5.0

This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runsBusObj.exe processes (under the 
control of the BOManagers).

Cannot process job. (BCAG0350)

Cause BROADCAST AGENT cannot process a job due to syntax errors, or characters which 
are not supported by your database.

Action Refer to the description which follows this error message for further information.
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Distribution by file system failed. (BCAG0360)

When sending the current document to BROADCAST AGENT, the user chose to 
distribute it by the file system and indicated a folder in which the document 
would be saved. In this case, the task has been completed, but the document 
cannot be saved in this folder.

Cause 1 The user who configured BOManager does not have write privileges to the folder 
on the network.

Action Grant this user write privileges. You can use the Servconf.exe utility to find out 
whether the user who configured BOManager has write privileges to the folder 
on the network.

Servconf.exe is a utility automatically installed with the Enterprise Server 
Products option in:

Business Objects\Server\BusinessObjects Manager 5.0

This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runs BusObj.exe processes (under the 
control of the BOManagers).

Cause 2 The folder is password-protected.

Action The system or network administrator can remove the password protection on the 
folder or suggest another location for the same purpose.

Cause 3 The folder specified by the user does not exist.

Action The user needs to resend the document and specify an existing folder on the 
network.

Cause 4 A document with the same name is already open in the folder.

Action The document that is already opened should be closed.
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Distribution failed. (BCAG0370)

Cause The generated document cannot be distributed to its recipient(s), or saved to the 
designated server folder. The problem can be anything from an inappropriate 
recipient or sender profile, to insufficient disk space on the server or in the 
repository.

Action Try the following solutions:

• Check the disk space on the server.

• If the task includes saving the document to a server folder, make sure the 
folder exists on the server, and that the server has sufficient disk space.

• Use the Servconf.exe utility to verify that the user who sent the document has 
access to the server. 

Servconf.exe is a utility automatically installed with the Enterprise Server 
Products option in:
Business Objects\Server\BusinessObjects Manager 5.0
This utility allows you to view and modify the system heap size settings. 
These settings determine how Windows NT runsBusObj.exe processes (under 
the control of the BOManagers).

A supervisor can do the following:

• Check whether the document domain has enough space; if it doesn’t compress 
it.

• Verify whether the document’s recipients exist in the repository’s security 
domain, and that they have the appropriate profile to receive the document.
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Document could not be sent. (BCAG0380)

Cause In report bursting mode, the current document could not be sent to its recipient, 
for any number of reasons.

Action Try the following solutions:

• Check the disk space on the server.

• If the task includes saving the document to a server folder, make sure the 
folder exists on the server, and that the server has sufficient disk space.

• Use the Servconf.exe utility to verify that the user who sent the document has 
access to the server. 

Servconf.exe is a utility automatically installed with the Enterprise Server 
Products option in:
Business Objects\Server\BusinessObjects Manager 5.0
This utility allows you to view and modify the system heap size settings. 
These settings determine how Windows NT runsBusObj.exe processes (under 
the control of the BOManagers).

A supervisor can do the following:

• Check whether the document domain has enough space; if it doesn’t compress 
it.

• Verify whether the document’s recipients exist in the repository’s security 
domain, and that they have the appropriate profile to receive the document.
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Cannot get user password. (BCAG0390)

Cause BROADCAST AGENT is unable to retrieve the user’s password from the repository. 
This may be because:

• The server has lost its connection to the repository due to network problems.

• The relevant records in the repository are currently locked by another user.

• The tables have become corrupted.

Action Try the following:

• If you suspect the file is currently being accessed by another user, wait awhile, 
and then try accessing it again.

• Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

A supervisor can test the connection to the document domain as follows:

• Select Tools > Repository, and click the document domain.

• Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Invalid distribution list. (BCAG0410)

Cause In this case of report bursting, the list of recipients for the current document is 
invalid, so BROADCAST AGENT cannot distribute it.

Action Do the following:

1. Edit the task’s properties in the BROADCAST AGENT Console and verify that the 
distribution list is correct and intact. If it isn’t, redo it and resubmit the task.

2. If the list is correct, contact the system administrator.
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Cannot get receiver list. (BCAG0420)

Cause BROADCAST AGENT is unable to retrieve the list of receivers from the repository. 
This may be because:

• The server has lost its connection to the repository due to network problems.

• The relevant records in the repository are currently locked by another user.

• The tables have become corrupted.

Action Try the following:

• If you suspect the file is currently being accessed by another user, wait awhile, 
and then try accessing it again.

• Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

A supervisor can test the connection to the document domain as follows:

• Select Tools > Repository, and click the document domain.

• Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Scheduler cannot start (explanation). (BCAG0430)

Cause 1 The Scheduler, which extracts documents that are due to be processed from the 
repository and sends them to BOManager for processing, cannot start. The key 
file you are using may not be valid.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the LocData folder for local installations or 
the ShData folder for shared installations.

Action Do the following:

1. Click the Synchronize Security Domain button in the Site Properties tab in the 
BUSINESSOBJECTS Services Administrator. 
This copies the key file located in the LocData folder of the cluster manager to 
the same folder in all the nodes of the system.

2. Use the BUSINESSOBJECTS Services Administrator to make sure the settings for 
the Scheduler are correct, and that the Scheduler is enabled.

Cause 2 The Scheduler cannot log into the repository because the Disable Login option 
has been applied to the user group in SUPERVISOR.

Action A supervisor can determine whether the Disable Login option was set as follows:

1. Log into SUPERVISOR.

2. Right-click the user group experiencing the problem.

3. Select Properties.

4. Click the Broadcast Agent tab.

5. Check whether the option Disabled Login is selected.
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Scheduler cannot create CORBA objects. (BCAG0440)

Cause At startup, BROADCAST AGENT cannot communicate with the CORBA system, 
and therefore cannot function.

Action Do the following:

1. Verify that the CORBA’s Os_Agent was correctly installed.

2. Launch the Visigenics ORBeline Smart Finder by doing the following:
• Open a DOS command prompt window. 
• Change the folder to <Installation Folder>\Server\ORB 2.5\bin.
• Type osfind, then press Enter. 

3. Check that: 
• You have only one OsAgent process throughout the cluster.
• You have only one OAD (Orb Activation Daemon) process per cluster 

node, and only one OAD process for a stand-alone installation.

4. If you have more than one process, stop then restart BROADCAST AGENT, then 
verify the BROADCAST AGENT processes. 

5. If you still don’t obtain the correct results, log off your machine, relaunch it, 
then verify again.
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Scheduler cannot initialize BO libraries. (BCAG0450)

Cause On start up, the Scheduler can’t find the BUSINESSOBJECTS libraries it needs to 
process tasks. 

Action Re-install the Scheduler.

Scheduler cannot log into repository. (BCAG0460)

Cause 1 The Scheduler periodically queries the repository to determine which documents 
are due for processing. In this case, however, the Scheduler cannot log into the 
repository because the Disable Login option has been applied to the user group 
in SUPERVISOR.

Action A supervisor can determine whether the Disable Login option was set as follows:

1. Log into SUPERVISOR.

2. Right-click the user group experiencing the problem.

3. Select Properties.

4. Click the Broadcast Agent tab.

5. Check whether the option Disabled Login is selected.

Cause 2 BROADCAST AGENT is incorrectly configured.

Action Using the BUSINESSOBJECTS Services Administrator, you can check the 
configuration of BROADCAST AGENT.

Click the Parameters button next to the name of the BROADCAST AGENT. Also 
check the BROADCAST AGENT Console to view the error messages.
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Scheduler cannot load domain security file. (BCAG0470)

Cause The key file used by the BROADCAST AGENT either doesn’t exist, or is incorrect. 

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the LocData folder for local installations or 
the ShData folder for shared installations.

Action In the BUSINESSOBJECTS Services Administrator, click the Synchronize Security 
Domain button in Site Properties tab. This copies the key file located in the 
LocData folder of the cluster manager to the same folder in all the nodes of the 
system.

Scheduler is stopped; cannot reach the repository. (BCAG0480)

Cause The Scheduler periodically queries the repository to determine which documents 
are due for processing. In this case, however, the Scheduler can’t log into the 
repository.

Action Using SUPERVISOR or the ServConf utility (servconf.exe), make sure the user 
whose user name and password are being used to log into the BROADCAST AGENT 
has the right to login.

Servconf.exe is a utility automatically installed with the Enterprise Server 
Products option in:

Business Objects\Server\BusinessObjects Manager 5.0

This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runs BusObj.exe processes (under the 
control of the BOManagers).
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Scheduler stopped on fatal error. (BCAG0490)

Cause A serious error has stopped the Scheduler.

Action Restart the Scheduler’s host.

If you still have problems, see the database administrator.

Scheduler cannot log into repository. (BCAG0500)

Cause The Scheduler periodically queries the repository to determine which documents 
are due for processing. In this case, however, the Scheduler can’t log into the 
repository.

Action Using the BUSINESSOBJECTS Services Administrator, check that BROADCAST 
AGENT is correctly configured (click the Parameters button next to the name of the 
BROADCAST AGENT).

Check the BROADCAST AGENT Console for error messages.
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Scheduler cannot attach to repository agent. (BCAG0510)

Cause This error is generated if BUSINESSOBJECTS cannot find a .dll file which is needed 
to ensure proper connectivity with the database middleware. The .dll is grouped 
together with a series of other dll files in the cnxsrv50.dll. This file is located in 
the Business Objects\Business Objects 5.0 folder.

Action The cnxsrv50.dll file may have been deleted, renamed, moved, or damaged. If 
you have a backup copy of this file, you should copy it to your Business Objects 
5.0 folder. If you do not have another copy of the file, you should contact Business 
Objects Customer Support, or possibly re-install BUSINESSOBJECTS.

A supervisor can test the connection to the document domain as follows:

1. Select Tools > Repository, and click the document domain.

2. Click the Test button.

The same test should be performed on the security domain.



 Broadcast Agent Error Messages

500 Error Message Guide

Scheduler cannot get the repository master. (BCAG0520)

Cause This message is generated if the Scheduler cannot access the repository security 
domain. This may be because:

• The security domain is currently locked by another user.

• The security domain may be hosted on a server which is down, or the network 
connection may not be working.

• The repository tables may be damaged, or the repository may have been 
corrupted.

Action Try the following:

• If you suspect that the security domain is currently locked by another user, 
run the scheduled task once more. If this problem occurs frequently, check if 
your repository database supports row-level locking. If so, you may need to 
manually activate this feature.

• Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Scheduler cannot get the repository dx. (BCAG0530)

Cause This message is generated if the Scheduler cannot access the repository document 
domain. This may be because:

• The document domain may be hosted on a server which is down, or the 
network connection may not be working.

• The repository tables may be damaged, or the repository may have been 
corrupted.

Action Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Scheduler cannot get timestamp ID. (BCAG0540)

Cause The local security file (.lsi) is stored either in the ShData\ folder of the shared 
server or in the LocData\ folder of the local client.  Users must have read and 
write access to this folder, since data is written to the security file every time they 
log in.  The file is identical in both folders, except for the extension: .lsi or .ssi.  The 
name and path of the file are as follows (default example):

N:\Program Files\Business Objects\BusinessObjects 5.0\ShData\<name>.ssi

C:\Program Files\Business Objects\BusinessObjects 5.0\LocData\<name>.lsi

You usually get this error if you do not have write access to the folder or file, or 
if the security file is damaged.

Action Delete the security file and restart your BUSINESSOBJECTS application. A blank 
login dialog box appears (without any previously defined names). However, you 
can still enter your previous login name and password. The security file is then 
automatically regenerated during login.
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Cannot get list of jobs. (BCAG0550)

Cause The BROADCAST AGENT Scheduler cannot start a scheduled task because there is 
no longer a connection with the document domain. This may be because:

• You have lost your connection to the repository.

• The document domain is locked by another user, or the tables have become 
corrupted.

Action Try the following:

• If you suspect that the document domain is currently locked by another user, 
run the scheduled task once more. If this problem occurs frequently, check if 
your repository database supports row-level locking. If so, you may need to 
manually activate this feature.

• Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

A supervisor can test the connection to the document domain as follows:

• Select Tools > Repository, and click the document domain. 

• Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Cannot get language from cluster manager. (BCAG0560)

Cause When started, the Scheduler first accesses the Cluster Manager to retrieve a list of 
settings it uses for this session. One of these settings determines the language 
used (English, French, German, etc). This message is generated if the Scheduler 
cannot access the Cluster Manager. In this case, the Scheduler uses English by 
default.

Action Check the connection to the Cluster Manager machine  by “pinging” the server. 
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Cannot update timestamp. (BCAG0570)

Cause The information in the time stamp table logs when the Scheduler comes online 
and goes offline, and is stored in one of the repository database tables. This 
message is generated when the Scheduler cannot update the time stamp table. 
This may be because:

• You have lost your connection to the repository.

• The document domain is locked by another user, or the tables have become 
corrupted.

Action Try the following:

• If you suspect that the document domain is currently locked by another user, 
run the scheduled task once more. If this problem occurs frequently, check if 
your repository database supports row-level locking. If so, you may need to 
manually activate this feature.

• Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

A supervisor can test the connection to the document domain as follows:

• Select Tools > Repository, and click the document domain. 

• Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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The timestamp table is full. (BCAG0580)

Cause The information in the time stamp table logs when the Scheduler comes online 
and goes offline, and is stored in one of the repository database tables. This 
message is generated when the table space allocated for the time stamp is 
exceeded.

Action A supervisor should run a Scan and Repair, and then click Compact to compact 
the contents of the security domain. This causes any information which has 
already been logically deleted to be physically deleted from the security domain.

Unknown SQLBO error. (BCAG0590)

Cause Each of the databases you are using has an associated .dll file which is normally 
located in the Business Objects\Data Access 5.0 folder. Each of these files has an 
Sq prefix as follows:

• Sqboci50.dll for Oracle databases

• Sqodbc50.dll for ODBC databases

The above error message may be generated if you try to access your data 
warehouse via the repository after the associated database .dll file has been 
moved, renamed, deleted, or damaged. This message can also occur if the .dll is 
locked by another application or user.

Action Replace the .dll file with a backup copy if you have one, or from another 
BUSINESSOBJECTS installation. If these are not available, you must re-install your 
Data Access module.
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Wrong kind of Scheduler (BCAG0600)

Cause The Scheduler is trying to process a document type not supported by your 
current BUSINESSOBJECTS installation.

Action Check your configuration, and your installed options. For example, if you have 
not installed WEBINTELLIGENCE, the Scheduler cannot process a 
WEBINTELLIGENCE document.

Cannot access directory of BOMain.key file. (BCAG0610)

Cause The directory (folder) containing the .key file is not present, or the security 
permissions on the folder are not correctly set.

By default, the main key file is BOMain.key. You may change this name during 
the repository setup process. This file is then stored by default in the directory (or 
folder):

Business Objects\BusinessObjects 5.0\LocData

This location can be changed during the installation process. If this folder is 
deleted or moved, or the permissions are set so that it cannot be written to or read 
from by the BOManager user, this error will result.

Action Change the permissions on the LocData folder so that it is readable and writable 
by the BOManager user. If the folder does not already exist, create it. You may 
also need to copy the BOMain.key file (or its equivalent on your system) from 
another machine. For more information on the creation and maintenance of key 
files, see the Supervisor’s Guide.

Note: To find the identity of the BOManager, use the utility servconf.exe which is 
provided on the Business Objects installation CD.
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Cannot access .key file. (BCAG0620)

Cause You tried to start one of the BUSINESSOBJECTS programs, but BUSINESSOBJECTS 
cannot find the key file.

This message is generated if the key file has been moved, renamed, deleted, or 
damaged. 

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the LocData folder on local installations or 
the ShData folder on shared installations. 

If you are unsure of the file type, you can click Setup.exe to find out.  Click the 
Modify button to view the Settings box which indicates whether the key file is 
local or shared.

Action A General Supervisor can perform a Safe Recovery to regenerate the key file, as 
follows:

1. Rename or delete the existing key file.

2. Log into SUPERVISOR with the reserved ID:
user name: GENERAL
password: SUPERVISOR

3. Click Next.
This starts the SetupWizard.

4. Select Safe Recovery, and enter the database name, user ID, and password.

Note: The new key file generated may no longer correspond to the .lsi file, which 
is also located in the same subfolder. Therefore, you may also need to delete your 
.lsi file. The .lsi file is then automatically regenerated the next time you log in.

If the problem persists, it may be necessary to reinstall BUSINESSOBJECTS.
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Cannot open .key file. (BCAG0630)

Cause You tried to start one of the BUSINESSOBJECTS programs, but BUSINESSOBJECTS 
cannot open the key file.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the LocData folder on local installations or 
the ShData folder on shared installations. 

If you are unsure of the file type, you can click Setup.exe to find out.  Click the 
Modify button to view the Settings box which indicates whether the key file is 
local or shared.

Action A General Supervisor can perform a Safe Recovery to regenerate the key file, as 
follows:

1. Rename or delete the existing key file.

2. Log into SUPERVISOR with the reserved ID:
user name: GENERAL
password: SUPERVISOR

3. Click Next.
This starts the SetupWizard.

4. Select Safe Recovery, and enter the database name, user ID, and password.

Note: The new key file generated may no longer correspond to the .lsi file, which 
is also located in the same subfolder. Therefore, you may also need to delete your 
.lsi file. The .lsi file is then automatically regenerated the next time you log in.

If the problem persists, it may be necessary to reinstall BUSINESSOBJECTS.
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Cannot create stream on .key file. (BCAG0640)

Cause You tried to start one of the BUSINESSOBJECTS programs, but BUSINESSOBJECTS 
cannot read the key file.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the LocData folder on local installations or 
the ShData folder on shared installations. 

If you are unsure of the file type, you can click Setup.exe to find out.  Click the 
Modify button to view the Settings box which indicates whether the key file is 
local or shared.

Action A General Supervisor can perform a Safe Recovery to regenerate the key file, as 
follows:

1. Rename or delete the existing key file.

2. Log into SUPERVISOR with the reserved ID:
user name: GENERAL
password: SUPERVISOR

3. Click Next.
This starts the SetupWizard.

4. Select Safe Recovery, and enter the database name, user ID, and password.

Note: The new key file generated may no longer correspond to the .lsi file, which 
is also located in the same subfolder. Therefore, you may also need to delete your 
.lsi file. The .lsi file is then automatically regenerated the next time you log in.

If the problem persists, it may be necessary to reinstall BUSINESSOBJECTS.
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Cannot find current repository. (BCAG0650)

Cause 1 You tried to start one of the BUSINESSOBJECTS programs, but BUSINESSOBJECTS 
cannot find the repository. The key file is missing.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the LocData folder on local installations or 
the ShData folder on shared installations. 

If you are unsure of the file type, you can click Setup.exe to find out.  Click the 
Modify button to view the Settings box which indicates whether the key file is 
local or shared.

Action A General Supervisor can perform a Safe Recovery to regenerate the key file, as 
follows:

1. Rename or delete the existing key file.

2. Log into SUPERVISOR with the reserved ID:
user name: GENERAL
password: SUPERVISOR

3. Click Next.
This starts the SetupWizard.

4. Select Safe Recovery, and enter the database name, user ID, and password.

Note: The new key file generated may no longer correspond to the .lsi file, which 
is also located in the same subfolder. Therefore, you may also need to delete your 
.lsi file. The .lsi file is then automatically regenerated the next time you log in.

If the problem persists, it may be necessary to reinstall BUSINESSOBJECTS.

Cause 2 The system running the repository database is down.

Action Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator can use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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Cannot send message to SQLBO agent. (BCAG0670)

Cause SQLBO is the BUSINESSOBJECTS SQL layer through which all SQL transactions 
pass on their way to and from your repository and corporate databases. This 
layer is required to normalize all SQL transactions into a format that can be 
interpreted by all supported database types and middleware versions. This error 
message is generated whenever no SQLBO connection can be established.

Action The communication between client machines and database servers is provided 
by the database middleware. Check that your middleware is set up and working 
correctly, and that you are using the correct middleware version. Check also the 
BUSINESSOBJECTS driver, which gives you access to the middleware.

Cannot obtain SQLBO connection. (BCAG0680)

Cause SQLBO is the BUSINESSOBJECTS SQL layer through which all SQL transactions 
pass on their way to and from your repository and corporate databases. This 
layer is required to normalize all SQL transactions into a format that can be 
interpreted by all supported database types and middleware versions. This error 
message is generated when no SQLBO connection can be established.

Action The communication between client machines and database servers is provided 
by the database middleware. Check that your middleware is set up and working 
correctly, and that you are using the correct middleware version. Check also the 
BUSINESSOBJECTS driver, which gives you access to the middleware.
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Cannot obtain SQLBO cursor. (BCAG0690)

Cause SQLBO is the BUSINESSOBJECTS SQL layer through which all SQL transactions 
pass on their way to and from your repository and corporate databases. This 
layer is required to normalize all SQL transactions into a format that can be 
interpreted by all supported database types and middleware versions. This error 
message is generated when no SQLBO channels can be established.

Action The communication between client machines and database servers is provided 
by the database middleware. Check that your middleware is set up and working 
correctly, and that you are using the correct middleware version. Check also the 
BUSINESSOBJECTS driver, which gives you access to the middleware.

Cannot obtain SQLBO network layer. (BCAG0700)

Cause SQLBO is the BUSINESSOBJECTS SQL layer through which all SQL transactions 
pass on their way to and from your repository and corporate databases. This 
layer is required to normalize all SQL transactions into a format that can be 
interpreted by all supported database types and middleware versions. This error 
message is generated when no SQLBO connection can be established.

Action The communication between client machines and database servers is provided 
by the database middleware. Check that your middleware is set up and working 
correctly, and that you are using the correct middleware version. Check also the 
BUSINESSOBJECTS driver, which gives you access to the middleware.
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Cannot access .RSS directory. (BCAG0710)

Cause One .rss file is created for each of the databases you are using. This file contains 
the necessary connection information, and is stored in the database folder:

Business Objects\Data Access 5.0\<database name>

This error is generated if BUSINESSOBJECTS cannot access the database folder, and 
therefore cannot establish a connection to the database. This may be because the 
folder has been deleted, renamed, or moved.

Action Copy a backup of the .rss folder to the Data Access 5.0 folder. If you do not have 
a backup, a supervisor must create the connection once more in SUPERVISOR.
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Invalid .key file (BCAG0720)

Cause The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the LocData folder on local installations or 
the ShData folder on shared installations. This message is generated if you are 
using the wrong key file for the associated repository connection.

If you are unsure of the file type, you can click Setup.exe to find out.  Click the 
Modify button to view the Settings box which indicates whether the key file is 
local or shared.

Action A General Supervisor can perform a Safe Recovery to regenerate the key file, as 
follows:

1. Rename or delete the existing key file.

2. Log into SUPERVISOR with the reserved ID:
user name: GENERAL
password: SUPERVISOR

3. Click Next.
This starts the SetupWizard.

4. Select Safe Recovery, and enter the database name, user ID, and password.

Note: The new key file generated may no longer correspond to the .lsi file, which 
is also located in the same subfolder. Therefore, you may also need to delete your 
.lsi file. The .lsi file is then automatically regenerated the next time you log in.
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Invalid repository version (BCAG0730)

Cause Access to BROADCAST AGENT is controlled via the security domain. However, this  
access is denied because the repository has not been updated to version 5.0.

Action A General Supervisor can run the Administration Setup wizard to install or 
update the repository to version 5.0. 

Note: If your repository is older than version 4.0, you first need to update to 
version 4.x, before you can successfully update to version 5.0.

Current actor is prevented from login for now. (BCAG0740)

Cause The user who is trying to log into BROADCAST AGENT belongs to a group that has 
not been granted access to this feature in SUPERVISOR.

Action The supervisor of your group can enable use of BROADCAST AGENT as follows:

1. Launch SUPERVISOR.

2. Right-click the user group.

3. Click Properties on the pop-up men.
The Group Properties dialog box appears.

4. Click the Broadcast Agent tab.

5.  Click the Broadcast Agent radio button and enter values for the parameters 
as necessary.

6. Click OK.
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The current server login is invalid. (BCAG0750)

Cause 1 The Scheduler cannot log into the repository because the Disable Login option 
has been applied to the user group in SUPERVISOR.

Action A supervisor can determine whether the Disable Login option was set as follows:

1. Log into SUPERVISOR.

2. Right-click the user group experiencing the problem.

3. Select Properties.

4. Click the Broadcast Agent tab.

5. Check whether the option Disabled Login is selected.

Cause 2 The current BOManager user name or password is not a valid login on the server. 
Hence, when BROADCAST AGENT attempts to log into the system, the login 
attempt fails.

Action Do one of the following:

• Use the servconf.exe utility to change the BOManager user name and 
password to an account which is recognized by the system.

• Restore the operating system user name and password to their original values 
using the appropriate operating system tools (e.g., User Manager for Domains 
on Windows NT, or admintool on Sun Solaris).

Error comes from invalid login. (BCAG0770)

Cause The Scheduler cannot log into the repository because of an invalid login. This 
behavior may be caused by a shutdown of the database. BcsScdul.exe will try to 
connect to the repository every n minutes until it does so successfully.

Action Log in again to check that your password is correct. If you are still unable to log 
in, contact your administrator.



 Broadcast Agent Error Messages

518 Error Message Guide

Canceling user login. (BCAG0780)

Cause The user who scheduled a BROADCAST AGENT task no longer has a valid login.

Example A user with a valid user name and password scheduled a task for execution at a 
later time. However, that time arrives, BROADCAST AGENT finds that the user’s 
login has been disabled by the supervisor.

Action Do one of the following:

• Resubmit the task using a valid user name and password which have not been 
disabled.

• Use SUPERVISOR to enable the login account.
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Cannot open LSI file. (BCAG0800)

Cause The .lsi security file is used to identify users who attempt to access the repository. 
When a user logs in, his or her name and password are checked directly against 
the corresponding data stored in the repository. If this authentication is 
successful, the user's specific authorization data (including user ID and 
password, specific user rights, restrictions, etc) is copied from the repository to 
the security file. 

The security file acts therefore as a read-write "cache" of authorization data for a 
specific user or group. For local installations, this .lsi file is created in the LocData 
folder. This message is generated if BROADCAST AGENT cannot access the local 
security file on a system. 

Action Check the following:

• For local installations, the .lsi file must be available in the LocData folder. 

• If the security file is damaged, or no longer corresponds to the associated key 
file, then it should be deleted. It is then automatically regenerated the next 
time the user logs in.

• You have write access to the lsi folder or file.

Note: You do not need the .lsi file if you are working in offline mode.
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Cannot write user name/password to LSI file. (BCAG0810)

Cause The security file is stored either in the ShData folder of the shared server or in the 
LocData folder of the local client.  Users must have read and write access to this 
folder, since data is written to this file every time they log in. The file is identical 
in both folders, except for the extension: lsi or ssi.  The name and path of the file 
are as follows:

Local client:
Business Objects\BusinessObjects 5.0\LocData\<name>.lsi

Shared server:
Business Objects\BusinessObjects 5.0\ShData\<name>.ssi

This error message is generated if BUSINESSOBJECTS cannot update the local 
security file. This may be because the file is write-protected or damaged.

Action Try the following:

• Make sure that users have write access to the lsi folder or file.

• If the security file is damaged, delete it. It is then automatically regenerated 
the next time the user logs in.
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Cannot update LRU list in LSI file. (BCAG0820)

Cause The LRU (List Recently Used) is part of the lsi security file. This file is stored 
either in the ShData folder of the shared server or in the LocData folder of the 
local client.  Users must have read and write access to this folder, since data is 
written to this file every time they log in. The file is identical in both folders, 
except for the extension: lsi or ssi.  The name and path of the file are as follows:

Local client:
Business Objects\BusinessObjects 5.0\LocData\<name>.lsi

Shared server:
Business Objects\BusinessObjects 5.0\ShData\<name>.ssi

This error message is generated if BUSINESSOBJECTS cannot update the local 
security file. This may be because the file is write-protected or damaged.

Action Try the following:

• Make sure that users have write access to the lsi folder or file.

• If the security file is damaged, then delete it. It is then automatically 
regenerated the next time the user logs in.

Cannot retrieve time reference from the main repository. (BCAG0830)

Cause Each of the databases you are using has an associated .dll file which is normally 
located in the Business Objects\Data Access 5.0 folder. Each of these files has an 
Sq prefix as follows:

• Sqboci50.dll for Oracle databases

• Sqodbc50.dll for ODBC databases

The above error message is generated if you try to access your data warehouse 
via the repository after the associated database .dll file has been moved, renamed, 
deleted, or damaged. This message can also occur if the .dll is locked by another 
application or user, or if you are using an incompatible .dll file.

Action Replace the .dll file with a backup copy if you have one, or from another 
BUSINESSOBJECTS installation. If these are not available, you must reinstall your 
Data Access modules. 
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Unknown application (BCAG0850)

Cause A scheduled task calls for execution by an application which is not recognized.

Action Resubmit the task, checking that any application required is correctly installed.

The current user is not authorized. (BCAG0860)

Cause The current user does not have the permissions necessary to execute the 
scheduled task.

Action Use the servconf.exe utility to check the identity of the BOManager user on each 
node in the cluster. Then check that this user has permission to execute the 
scheduled task using SUPERVISOR. Also check that the operating system rights 
(granted under Windows NT or UNIX) are correct.

Then resubmit the scheduled task.

The current user is not the Bootstrap General Supervisor. (BCAG0870)

Cause Some tasks—such as creating a new repository—can be carried out only by the 
Bootstrap General Supervisor; that is, the initial General Supervisor identified by 
the reserved user name “GENERAL.” The current user is not that user and 
therefore cannot carry out this action.

Action Log in with the user name GENERAL and the password SUPERVISOR, then try 
again.
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The Bootstrap General Supervisor cannot be used in this situation. (BCAG0880)

Cause Some tasks cannot be carried out by the Bootstrap General Supervisor (that is, the 
initial General Supervisor identified by the reserved user name “GENERAL”).

Action Log in as another user with General Supervisor permissions, and resubmit the 
scheduled task.

The user is LIGHT. (BCAG0890)

Cause The current user is logged in using the reserved user identity “LIGHT.” This user 
identity should not be used for normal BROADCAST AGENT activity.

Action Log in as another user and resubmit the scheduled task.

The current user TMS is not valid for the moment. (BCAG0900)

Cause The current user has login time restrictions defined in SUPERVISOR. At present, the 
user is not permitted to log in.

Action Do one of the following:

• Use SUPERVISOR to alter the user’s time restrictions.

• Resubmit the task so that it is scheduled to occur during the time when the 
user is permitted to log in.
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The .lsi file not writable. (BCAG0910)

Cause The security file is stored either in the ShData\ folder of the shared server or in 
the LocData\ folder of the local client.  Users must have read and write access to 
this folder, since data is written to this file every time they log in. The file is 
identical in both folders, except for the extension: lsi or ssi.  The name and path 
of the file are as follows:

Local client:
Business Objects\BusinessObjects 5.0\LocData\<name>.lsi

Shared server:
Business Objects\BusinessObjects 5.0\ShData\<name>.ssi

This error message is generated if BUSINESSOBJECTS cannot update the local 
security file. This may be because the file is write-protected or damaged.

Action Try the following:

• Make sure that users have write access to the lsi folder or file.

• If the security file is damaged, then delete it. It is then automatically 
regenerated the next time the user logs in.

The .lsi file is locked by another application. (BCAG0940)

Cause You tried to update some security settings, but you cannot store these changes 
because the local security file (.lsi) is locked by another application. 

Action Wait a few moments, and then try again. Stop any other processes that are 
running on your system, and quit all unnecessary applications.

There is no timestamp for this user in the .lsi file. (BCAG950)

Cause The .lsi file has become corrupt.

Action The .lsi file should be re-created automatically the next time this user logs in. 

Log in again as this user. Resubmit the task and try again.
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Cannot fetch universe list. (BCAG0960)

Cause The universe list stored in the repository is not available. This could be caused by:

• corruption in the repository

• failure in the repository connection

• network problems resulting in the loss of the server’s connection to the 
repository

Action A supervisor can test the connection to the document domain as follows:

• Select Tools > Repository, and click the document domain.

• Click the Test button.

A supervisor can also run a Scan and Repair (Tools > Repository); this feature 
allows the following operations on the security domain or a document domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

If the problem persists, the General Supervisor may need to re-create the 
repository.
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Invalid login ID (BCAG0980)

Cause The user ID which was used to schedule a task is no longer valid.

Example A user logs in and schedules a task. Then, the supervisor deletes this user from 
the repository. When the scheduled task is due, BROADCAST AGENT attempts to 
process it. However, it cannot log into the repository because the user ID no 
longer exists in the repository, and so this message is generated.

Action Resubmit the scheduled task giving a login name which will remain valid at the 
time when the task is scheduled to to be executed.

Invalid password entered in the Change Password dialog box. (BCAG0990)

Cause A user has attempted to change the password. However, do this requires the 
entry of the old password. The user has entered the old password incorrectly.

Action Repeat the process entering the correct password.

The user name is reserved (MANAGER or LIGHT). (BCAG1000)

Cause An attempt has been made to create a Broadcast Agent or a user named 
“MANAGER” or “LIGHT.” This is not permitted since these two user names are 
reserved for internal use.

Action Choose another name for the new Broadcast Agent or user.
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The Scheduler cannot run under this operating system. (BCAG1010)

Cause The Scheduler can run only under supported UNIX or Windows NT systems. 
This error occurs when an administrator attempts to start a Scheduler on an 
unsupported Windows system.

Action Start the Scheduler on a machine running a supported platform.

Cancel occurred during obligatory change in password. (BCAG1020)

Cause The BROADCAST AGENT system requires that users change passwords after a 
specified length of time if this is defined in the appropriate account in 
SUPERVISOR. When this is necessary, the Change Password dialog box is provided 
automatically whenever a user attempts to log in. However, the user has pressed 
Cancel instead of filling in the Change Password dialog box.

Action Use SUPERVISOR to change the password, and try again.
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Cannot load authentication driver. (BCAG1030)

Cause After the master setup.log file (in the Setup folder) has been updated, if you check 
this log file, some of the dlls couldn’t be updated because they were in use when 
you performed your master update. (You should see the message “Warning files 
in use.”)

Action Update the master when nobody is using BUSINESSOBJECTS. You might try 
temporarily disconnecting the computer from the network while you update.

Failed to initialize driver. (BCAG1040)

Cause When launching the Console, BUSINESSOBJECTS tries to locate the KGLUI50.DLL 
authentication file. However, BUSINESSOBJECTS cannot find the correct file, or the 
file has been changed or damaged.

Action Copy a backup of the KGLUI50.DLL file to the BusinessObjects 5.0 folder (if you 
have one), or copy it from another BUSINESSOBJECTS installation. If these are not 
available, you must reinstall BUSINESSOBJECTS.

Failed to initialize identification driver. (BCAG1050)

Cause When launching the Console, BUSINESSOBJECTS tries to locate the KGLUI50.DLL 
authentication file. However, BUSINESSOBJECTS cannot find the correct file, or the 
file has been changed or damaged.

Action Copy a backup of the KGLUI50.DLL file to the BusinessObjects 5.0 folder (if you 
have one), or copy it from another BUSINESSOBJECTS installation. If these are not 
available, you must reinstall BUSINESSOBJECTS. 
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Failed to initialize authentication. (BCAG1060)

Cause In SUPERVISOR, you have enabled Windows NT Authentication (Tools > 
Options > Security Policy). However, the KNTUI50.DLL file needed to enable 
this feature is not the correct file, or has been changed or damaged.

Action Try the following:

1. Delete the KNTUI50.DLL file from the BusinessObjects 5.0 folder.

2. Copy a backup of the KNTUI50.DLL file to the BusinessObjects 5.0 folder (if 
you have one), or copy it from another BUSINESSOBJECTS installation. 
If these are not available, you must reinstall BUSINESSOBJECTS. 

Release driver failure (BCAG1070)

Cause The release driver has become corrupted.

Action Run a disk check (fsck on UNIX, or ScanDisk on Windows NT).

Reboot the system.

If the problem is still occurring, you need to re-install the release driver. This may 
require re-installation of your Business Objects server software or 
re-installation of your database middleware on the server.

Release identification driver failure (BCAG1080)

Cause The release identification driver has become corrupted.

Action Run a disk check (fsck on UNIX, or ScanDisk on Windows NT).

Reboot the system.

If the problem is occurring, you need to re-install the release driver. This may 
require re-installation of your Business Objects server software or 
re-installation of your database middleware on the server.
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 Invalid key file (does not correspond to lsi file). (BCAG1120)

Cause You are using the wrong key file. The key file contains the address of the security 
domain generated by SUPERVISOR. It is generally stored in the LocData folder on 
local installations or the ShData folder on shared installations. 

If you are unsure of the file type, you can click Setup.exe to find out.  Click the 
Modify button to view the Settings box which indicates whether the key file is 
local or shared.

Action Delete the key file and restart your BUSINESSOBJECTS application. A blank login 
box appears (without any login names). However, you can still enter your 
previous user name and password. The key file is then automatically regenerated 
during login.

Example You may have been trying to use a different key file which has been renamed to 
the name of the file used by BUSINESSOBJECTS.
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Invalid lsi file (BCAG1130)

Cause The security file (.lsi) is used to identify users who attempt to access the 
repository. When a user logs in, his or her user name and password are checked 
directly with the corresponding data stored in the repository. 

If this authentication is successful, the user's specific authorization data 
(including user ID and password, specific user rights, restrictions, etc) is copied 
from the repository to the security file. The security file acts therefore as a read-
write "cache" of authorization data for a specific user or group. 

For local installations, this file is created in the LocData folder, together with the 
key file. This error message is generated if a local security file could not be 
opened. 

Action Try the following:

• Make sure that users have write access to the lsi folder or file.

• If the security file is damaged, then delete it. It is then automatically 
regenerated the next time the user logs in.

Domain from previous version (BCAG1140)

Cause You have installed BUSINESSOBJECTS 5.0 over a previous version of 
BUSINESSOBJECTS, but have not yet updated your repository.

Action A General Supervisor can run the Upgrade Wizard to update the repository to 
BUSINESSOBJECTS version 5.0.
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The security domain is older than the required one. (BCAG1150)

Cause You have updated your BUSINESSOBJECTS installation with a newer version, but 
you have not yet updated your repository.

Action A General Supervisor can run the Upgrade Wizard to update the repository to the 
version of BUSINESSOBJECTS you are using.

Key file not found. (BCAG1160)

Cause The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the LocData folder on local installations or 
the ShData folder on shared installations. If this file cannot be found, then it may 
have been deleted, renamed, moved, or corrupted.

If you are unsure of the file type, you can click Setup.exe to find out.  Click the 
Modify button to view the Settings box which indicates whether the key file is 
local or shared.

Action A General Supervisor can perform a Safe Recovery to regenerate the key file, as 
follows:

1. Rename or delete the existing key file.

2. Log into SUPERVISOR with the reserved ID:
user name: GENERAL
password: SUPERVISOR

3. Click Next.
This starts the SetupWizard.

4. Select Safe Recovery, and enter the database name, user ID, and password.

Note: The new key file generated may no longer correspond to the .lsi file, which 
is also located in the same subfolder. Therefore, you may also need to delete your 
.lsi file. The .lsi file is then automatically regenerated the next time you log in.
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Login has been disabled. (BCAG1170)

Cause In order to use BROADCAST AGENT, the group to which you belong must have the 
necessary authorization. This is set up by the supervisor in your group properties 
(Broadcast Agent tab). This message is generated if your login has been disabled 
in SUPERVISOR.

Action Your login (currently disabled) must be enabled by a supervisor.

Bad connection to repository. (BCAG1180)

Cause You are using the wrong key file. The key file that you are currently using does 
not point to your repository.

The key file contains the address of the security domain generated by 
SUPERVISOR. It is generally stored in the LocData folder on local installations or 
the ShData folder on shared installations. 

If you are unsure of the file type, you can click Setup.exe to find out.  Click the 
Modify button to view the Settings box which indicates whether the key file is 
local or shared.

Action A General Supervisor can perform a Safe Recovery to regenerate the key file, as 
follows:

1. Rename or delete the existing key file.

2. Log into SUPERVISOR with the reserved ID:
user name: GENERAL
password: SUPERVISOR

3. Click Next.
This starts the SetupWizard.

4. Select Safe Recovery, and enter the database name, user ID, and password.
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RSS file not accessible. (BCAG1190)

Cause One .rss file is created for each of the databases you are using. This file contains 
the necessary connection information, and is stored in the database folder 
(Business Objects\Data Access 5.0\<database name>). This error is generated if 
BUSINESSOBJECTS cannot find the .rss file in the database folder, and therefore 
cannot establish a connection to the database.

Action Copy a backup of the .rss file to the database folder. If you do not have a backup, 
a supervisor must create the connection once more.

Wrong SQL used. (BCAG1200)

Cause 1 This message may be generated when you try to access your corporate database 
using freehand SQL statements that you enter in the SQL Editor.  The SQL you 
used may not be compatible with your corporate database.

Action Check with the database administrator to see which versions of SQL are 
supported by your corporate database.

Cause 2 BUSINESSOBJECTS has encountered an exceptional error while attempting to access 
your corporate database.

Action Contact Business Objects Customer Support.
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Error during import. (BCAG1210)

Cause BROADCAST AGENT connected to the document domain to import a file to be 
processed. After connecting, BROADCAST AGENT was unable to import the file. 
The server housing the document domain may have gone down, or else there 
may be a database error.

Action Verify the network connection by “pinging” the server hosting the document 
domain. If the machine is down or if there are network problems, run the task 
again when the machine ad. If the machine is down or if there are network 
problems, run the task again when the machine and network are up.

If the machine is running properly, the database administrator should then use  
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

If the database is responding, check the Error column of the BROADCAST AGENT 
Console and confer with the database administrator about solving any SQL 
errors that may be logged, or have the database administrator check the 
transaction log of the database server.
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Not enough memory. (BCAG1220)

Cause Windows NT does not have sufficient memory to run the various server systems 
which have been configured.

Action Run the Servconf.exe utility to modify your memory settings. Servconf.exe is a 
utility automatically installed with the Enterprise Server Products option in:

Business Objects\Server\BusinessObjects Manager 5.0

This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runsBusObj.exe processes (under the 
control of the BOManagers).

Cannot obtain unique ID on security domain for export. (BCAG1230)

Cause You tried to export a universe or send a document to a user, but the Magic_ID 
assigned to the universe or document in the repository has been corrupted. 

The error usually occurs when you terminate a task submitted to BROADCAST 
AGENT abnormally (by rebooting the computer, for example). The same also 
happens when the task is abnormally terminated by BROADCAST AGENT. There 
may be other reasons, but these two are most frequent.

Action A supervisor can run a Scan and Repair (Tools > Repository); this feature allows 
the following operations on the security domain or adocument domain:

• scan (parse) the structure of the domain

• detect errors

• repair errors

• compress the contents of the domain

This should correct the anomaly in the Magic_ID. 
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Cannot begin transaction on the security domain. (BCAG1240)

Cause BROADCAST AGENT was unable to connect to the security domain to check 
pending tasks. The server housing the security domain may be down, or there 
may be a database error.

Action Verify the network connection by “pinging” the server hosting the security 
domain. If the machine is down or if there are network problems, run the task 
again when the machine and network are up.

If the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

If the database is responding, check the Error column of the BROADCAST AGENT 
Console and confer with the database administrator about solving any SQL 
errors that may be logged, or have the database administrator check the 
transaction log of the database server.

Cannot begin transaction on the document domain. (BCAG1250)

Cause BROADCAST AGENT was unable to connect to the document domain to import a 
document for processing. The server housing the document domain may be 
down, or there may be a database error.

Action Verify the network connection by “pinging” the server hosting the document 
domain. If the machine is down or if there are network problems, run the task 
again when the machine and network are up.

If the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

If the database is responding, check the Error column of the BROADCAST AGENT 
Console and confer with the database administrator about solving any SQL 
errors that may be logged, or have the database administrator check the 
transaction log of the database server.
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Cannot obtain information on previous document. (BCAG1260)

Cause A document was sent for processing in overwrite mode, meaning the newly 
processed document should overwrite the version already existing in the 
repository, but BROADCAST AGENT could not overwrite the existing document. If 
the problem persists, there is a database error.

Action Try again. If the problem persists, check the Error column of the BROADCAST 
AGENT Console and confer with the database administrator about solving any 
SQL errors that may be logged, or have the database administrator check the 
transaction log of the database server.

Cannot terminate transaction on the document domain. (BCAG1270)

Cause BROADCAST AGENT connected to the document domain to import a document for 
processing, but was unable to complete the import. The server housing the 
document domain may be down, or there may be a database error.

Action Verify the network connection by “pinging” the server to the document domain. 
If themachine is down or if there are network problems, run the task again when 
the machine and network are up.

If the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

If the database is responding, check the Error column of the BROADCAST AGENT 
Console and confer with the database administrator about solving any SQL 
errors that may be logged, or have the database administrator check the 
transaction log of the database server.
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Cannot terminate transaction on the security domain. (BCAG1280)

Cause BROADCAST AGENT connected to the security domain to check pending tasks, but 
was unable to complete the operation. The server housing the security domain 
may be down, or there may be a database error.

Action Verify the network connection by “pinging” the server hosting the security 
domain. If themachine is down or if there are network problems, run the task 
again when the machine and network are up.

If the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.

If the database is responding, check the Error column of the BROADCAST AGENT 
Console and confer with the database administrator about solving any SQL 
errors that may be logged, or have the database administrator check the 
transaction log of the database server.

BOManager is busy. (BCAG1290)

Cause The maximum number of simultaneous BUSINESSOBJECTS processing sessions has 
been reached. This is a parameter set in the BusinessObjects Services 
Administration tool.

Action The task is relaunched until a session can be opened for it. If you cannot wait, use 
the BusinessObjects Services Administrator tool to set the Max. number of busy 
processes parameter to a higher number. This is described in Chapter 3 of the 
Broadcast Agent Administrator’s Guide.
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Viewing optimization failed. (BCAG1300)

Cause A document has been scheduled with the Enhanced Document Viewing option, 
but BOManager cannot execute this option. 

This option, set when publishing a document to the repository, instructs 
BOManager to store a Windows Metafile version of the document in the 
repository cache when processing by BROADCAST AGENT is complete. Either the 
server housing BOManager does not have read/write rights to the appropriate 
folder on the repository server, or the disk is full.

Action Have the administrator of the repository server grant read/write rights to the 
BOManager server, or free disk space on the server. If the problem is one of rights 
to the cache, and you cannot get those rights for your BOManager, a workaround 
would be to disable the Enhanced Document Viewing option in the Broadcast 
Console by double-clicking the document name and clearing the option in the 
Actions tab of the Task Properties dialog box.

Cannot get MachineManager. (BCAG1310)

Cause MachineManager is a server module used by WEBINTELLIGENCE and BROADCAST 
AGENT. It has either stopped, gone down, or cannot be found. This is a CORBA 
communication problem.

Action Launch the BusinessObjects Services Administrator, or exit and relaunch if it is 
already running. This restores the module to working order.
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This Broadcast Agent Scheduler cannot process BusinessObjects documents. (BCAG1320)

Cause Processing of BUSINESSOBJECTS documents has been turned off for the BROADCAST 
AGENT. This is a parameter set in the BusinessObjects Services Administrator 
tool.

Action The Business Objects Services Administrator tool is normally located in:

 Program Files\Business Objects\Server\Admin Tools

1. Launch the Administrator, and select Broadcast Agent Manager on the left 
pane. 

2. Select a BROADCAST AGENT on the right and click Parameters. 

3. In the Settings dialog box, select the On option for BUSINESSOBJECTS 
documents. 

4. Open the BROADCAST AGENT Console and select the task to be processed.

5. Click Run Now on the Task menu.

This Broadcast Agent Scheduler cannot process WebIntelligence documents. (BCAG1330)

Cause Processing of WEBINTELLIGENCE documents has been turned off for the 
BROADCAST AGENT. This is a parameter set in the BusinessObjects Services 
Administrator tool.

Action The BusinessObjects Services Administrator tool is normally located in:

Program Files\Business Objects\Server\Admin Tools

1. Launch the Administrator, and select Broadcast Agent Manager on the left. 

2. Select a BROADCAST AGENT on the right and click Parameters. 

3. In the Settings dialog box, select the On option for WEBINTELLIGENCE 
documents. 

4. Open the BROADCAST AGENT Console and select the task to be processed.

5. Click Run Now on the Task menu.
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Cannot create WebIntelligence session. (BCAG1340)

Cause 1 The WIGenerator module on the server is not enabled.

Action Launch the BusinessObjects Services Administrator and enable the WIGenerator 
module.

Cause 2 The WEBINTELLIGENCE server is overloaded. 

Action Wait until traffic has dropped on the server, and run the task again.

Cannot get Session Manager. (BCAG1350)

Cause 1 The WISessionManager module has been disabled.

Action Launch the BusinessObjects Services Administrator, and enable the 
WISessionManager module.

Cause 2 The WISessionManager module has stopped, or cannot be found on the server. 
This is a CORBA communication problem.

Action Launch the BusinessObjects Services Administrator, or exit and relaunch if it is 
already running. This restores the module to working order.
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Cannot get WIQT. (BCAG1360)

Cause 1 Wiqt.exe is a server module launched by WISessionManager to build and refresh 
WEBINTELLIGENCE documents. It is unavailable because the WEBINTELLIGENCE 
server is overloaded.

Action Wait until traffic has dropped on the server and run the task again.

Cause 2 Wiqt.exe has either stopped, gone down, or cannot be found due to a CORBA 
communication problem.

Action Launch the BusinessObjects Services Administrator, or exit and relaunch if it is 
already running. This restores the module to working order.

Invalid NT login. (BCAG1370)

Cause The login/password combination used to launch BOManager to start processing 
sessions is not correct. This login/password information is that of the local 
NT Administrator for the WEBINTELLIGENCE or BROADCAST AGENT server 
machine and was entered during installation. The login and/or password has 
changed since installation. 

Action Verify that the username and password being used to launch BOManager is that 
of the local NT Administrator for the server machine. You can do this using the 
server configuration utility called servconf.exe.

Servconf.exe is a utility automatically installed with the Enterprise Server 
Products option in:

Business Objects\Server\BusinessObjects Manager 5.0

This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runsBusObj.exe processes (under the 
control of the BOManagers).

Launch servconf.exe and enter your login and password as local Windows NT 
administrator. 
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Warning: Insertion of one recipient’s information in database failed for report bursting task. 
(BCAG1380)

Cause 1 BROADCAST AGENT is unable to schedule a task for one recipient of a document 
for which “report bursting” was chosen. Report bursting is when a document is 
scheduled to be sent to several users according to their profiles, by means of the 
Refresh with the profile of each recipient option. The disk of the BROADCAST AGENT 
server machine is full.

Action Free disk space on the BROADCAST AGENT server machine and run the task again.

Cause 2 BROADCAST AGENT is unable to schedule a task for one recipient of a document 
for which “report bursting” was chosen. There is a database problem.

Action Contact the database administrator and check the database logs.

Time limit exceeded. (BCB0001)

Cause The expiration date for a task has been reached before BROADCAST AGENT 
finished processing the document. The task fails.

Action Try the following:

1. Resend the document to BROADCAST AGENT.

2. In the Scheduling tab, reset the expiration date and time.

Example The user set the expiration date and time to midnight on Friday, August 12. 
BROADCAST AGENT had not finished processing the document at that time.
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Cannot copy document to the file system folder specified. (BCB0002)

Cause The sender requested that BROADCAST AGENT post the processed document in a 
folder on a file server (Distribute via the Server File Server option > 
Distribution tab >  Send Document to Broadcast Agent dialog box).

BROADCAST AGENT cannot post the document in the specified folder.

Action Check that:

• The folder exists.

• Another document with the same name is not open in the folder.

• The folder is not read-only or password protected.

Then re-send the document but specify a different folder.

Cannot extract scripts from the document. (BCB0003)

Cause BROADCAST AGENT tried to process a document with scripts (BUSINESSOBJECTS 4.1 
document) or VBA macros (BUSINESSOBJECTS 5.0) attached, but cannot extract 
them. The file is corrupted.

Action Ask the user to check his or her document and send it again.

You must set a schedule using the Scheduler or File Watcher (or both). (BCB0004)

Cause You have tried to send a document to BROADCAST AGENT without selecting either 
the Time Schedule or the File Watcher option.

Action In the Scheduling tab of the Send Document to Broadcast Agent dialog box, select  
the Time Schedule and/or the File Watcher option.
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You have not specified a file for File Watcher. (BCB0005)

Cause You tried to send a document to BROADCAST AGENT using the File Watcher option 
but did not specify which file to watch for.

Action In the Scheduling tab of the Send Document to Broadcast Agent dialog box, enter 
the path and filename of the file to watch for. Click Browse if you want to browse 
the file system to find the file.

Scheduler cannot be contacted. It may not be connected. (BCB0006) 

Cause BROADCAST AGENT cannot access one of its Schedulers. This is because either the 
machine on which the Scheduler is running is down, or because there is no 
current connection to the Scheduler machine.

Action Check that your connections to the repository and the Data Source Name are 
correctly set up in SUPERVISOR (Tools > Connections > Edit).

Verify the network connection by “pinging” the server hosting the document 
domain. If the network is running properly, the database administrator should 
then use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

Scheduler is busy. Try again? (BCB0007)

Cause BROADCAST AGENT cannot access one of its Schedulers. This is because the 
Scheduler is busy processing a task.

Action Wait for a few moments, and then try again.
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CORBA error (BCB0008)

Cause When launched, BROADCAST AGENT cannot communicate with the CORBA 
system, and therefore cannot function.

Action Do the following:

1. Verify that the CORBA’s Os_Agent was correctly installed.

2. Launch the Visigenics ORBeline Smart Finder by selecting Run from the Start 
menu, then entering osfind.exe. 

3. Check that you have only one: 
•  OsAgent process throughout the cluster.
• OAD (Orb Activation Daemon) process per cluster node, and only one 

OAD process for a stand-alone installation. 

4. If you have more than one, stop then restart BROADCAST AGENT, then verify 
the BROADCAST AGENT processes. 

5. If you still don’t obtain the correct results, log off your machine, relaunch it, 
then verify again.

Scheduler command failed. (BCB0009)

Cause Resources were low for a Scheduler of the BROADCAST AGENT, and the Run Now, 
Interrupt or Purge command was unable to be executed. The problem is 
temporary.

Action Wait a moment and try again.
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Warning: The push task cannot be completed. (BCB0010)

Cause You selected Channel as an action in the Actions tab of the Send to Broadcast 
Agent dialog box and were asked if you wanted to create a channel since none 
existed. You clicked Yes and began to create a channel. A problem was 
encountered during the creation process and  the channel could not be created.

Action Start creating the channel again. For a description of how to do so, see Chapter 9, 
“Managing Channels,” in the Supervisor’s Guide. 
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Broadcast Agent Calculation Errors

BROADCAST AGENT can process documents based on the results of calculations in 
BUSINESSOBJECTS. For example, you can request that BROADCAST AGENT refresh a 
document when the number of products sold reaches 1000. You set this up by 
using the Condition Evaluation option in the Send to Broadcast Agent dialog box, 
as described in the InfoView User’s Guide.

When BROADCAST AGENT begins to process the document, it launches 
BUSINESSOBJECTS, which performs the calculation that you specified when you 
sent the document. At this point, calculation errors may occur. For example, if 
you mistype the name of a variable included in the formula for the calculation, 
BUSINESSOBJECTS returns the #SYNTAX error in the document.

In such cases, BROADCAST AGENT cannot successfully process your document 
because the calculation has returned an error. However, BROADCAST AGENT 
returns the calculation error to the Console, thus informing you that you must fix 
the calculation in BUSINESSOBJECTS and try again.

The calculation errors that BROADCAST AGENT can return to the Console are:

• #COMPUTATION

• #MULTIVALUE

• #DIV/0

• #ERROR

• #IERR

• #OVERFLOW

• #SYNTAX

• #UNKNOWN

Note: In the Console, a number appears before the error, e.g., 13#DIV/0. This 
number is an Automation Exception; it has no bearing on the way to fix the error.
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Comparison with Document Agent Server
Users who have updated from BUSINESSOBJECTS version 4.1 may have used 
DOCUMENT AGENT SERVER to process their documents. DOCUMENT AGENT SERVER 
also returned calculation errors to the Console, but the content of the errors was 
different. For example, where BROADCAST AGENT returns #OVERFLOW, 
DOCUMENT AGENT SERVER returned Condition: overflow error.

The following table shows the mapping between calculation errors returned by 
DOCUMENT AGENT SERVER and BROADCAST AGENT:

Where You Can Get More Information and What to Do Next
The InfoView User’s Guide contains detailed information on:

• How to use condition evaluation when sending documents to BROADCAST 
AGENT

• Guidelines for condition evaluation, i.e., the types of formulas that work

The BusinessObjects User’s Guide explains how to create calculations, and how to 
troubleshoot calculation errors.

When you have fixed the calculation error in your document, resend it to 
BROADCAST AGENT.

Broadcast Agent Calculation Error Equivalent in Document Agent Server

#COMPUTATION Condition: computation error

#MULTIVALUE Condition: multivalue error

#DIV/0 Condition: divide by zero error

#ERROR Condition: create formula error

#IERR Condition: internal error

#OVERFLOW Condition: overflow error

#SYNTAX Condition: syntax error

#UNKNOWN Condition: unknown error
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Installation Error Messages

This section describes the error messages that may occur when you install 
BROADCAST AGENT PUBLISHER MAIL COMPONENT.

Installation error messages range from SBP0001 to SBP0024.

WebIntelligence 2.7 has not been installed on this machine. The Broadcast Pages and the 
WebIntelligence Patches cannot be installed. (SBP0001)

Cause Setup could not find WEBINTELLIGENCE 2.7 on the machine.

Action Click OK to continue Setup. If a component that requires WEBINTELLIGENCE must 
be installed, continue until the component list appears, and abort Setup. Install 
WEBINTELLIGENCE. Run Setup again. (See also special note concerning missing 
BUSINESSOBJECTS components required for installation on page 559.)

An error occurred with a Cscript command line! (SBP0002)

Cause An internal error occurred while executing an IIS command using the scripting 
host. (Note: This error should never happen unless the scripting host is corrupt.)

Action Click OK. You may have to configure the virtual directories manually. Refer to 
the Broadcast Agent Publisher mail component Administrator’s Guide for more 
information.
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Setup could not register the following file: [FileName] (SBP0003)

Cause A DLL file could not be registered using REGSVR32.EXE. (Note: This error 
should never happen unless the REGSVR32.EXE file is corrupted or removed, or 
a serious internal Windows error occurred.)

Action Note the DLL file name with complete file path and open a command prompt. 
Then, execute the following command line: REGSVR32.EXE CompleteFileName.

Setup could not unregister the following file: [FileName] (SBP0004)

Cause A DLL file could not be unregistered using REGSVR32.EXE. (Note: This error 
should never happen unless the REGSVR32.EXE file is corrupted or removed, or 
a serious internal Windows error occurred.)

Action Note the DLL file name with complete file path and open a command prompt. 
Then, execute the following command line: REGSVR32.EXE /u 
CompleteFileName.

Setup cannot continue due to an error while opening the Windows Service Manager. 
(SBP0005)

Cause The Windows service manager could not be accessed to check the 
WEBINTELLIGENCE service. (Note: This error should never happen unless an 
internal error occurred.)

Action Click OK to abort Setup. Verify that the WEBINTELLIGENCE service is running or 
stopped, and make sure that the user is allowed to access Windows services.



 Broadcast Agent Publisher mail component Error Messages

554 Error Message Guide

Setup cannot continue due to an error while opening the WebIntelligence Service. (SBP0006)

Cause The Windows service manager could not be accessed to check the 
WEBINTELLIGENCE service. (Note: This error should never happen unless an 
internal error occurred.)

Action Click OK to abort Setup. Verify that the WEBINTELLIGENCE service is running or 
stopped, and make sure that the user is allowed to access Windows services.

Setup cannot continue because the WebIntelligence Service is running. Please stop 
WebIntelligence and then start the setup program again. (SBP0007)

Cause WEBINTELLIGENCE is running and Setup requires that WEBINTELLIGENCE be 
stopped.

Action Stop WEBINTELLIGENCE and restart Setup.

BusinessObjects Reporter and/or BusinessObjects Designer were not found on your 
computer. The Recipient Manager cannot be installed. (SBP0008)

Cause BUSINESSOBJECTS REPORTER and BUSINESSOBJECTS DESIGNER could not be found 
on your computer. Both are needed by the Recipient Manager to be installed.

Action Click OK to continue Setup. (See also special note concerning missing 
BUSINESSOBJECTS components required for installation on page 559.)

At least one component must be installed. (SBP0009)

Cause User unchecked every component that could be installed.

Action Install at least one component by checking its checkbox, and click Next.
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You entered an incorrect serial number. You must enter a valid serial number. (SBP0010)

Cause As explained in warning message.

Action Type the correct serial number.

Setup could not create the specified shortcut: “[ShortCut Name]” (SBP0011)

Cause A shortcut in the Program Files menu could not be created.

Action Make sure you typed a valid menu folder name before installing. User might 
need to create the shortcuts manually.

The Microsoft Data Access Component (MDAC) is required by the Recipient Manager, the 
Broadcast Pages and the Broadcast External Pages. Do you really want to skip MDAC 
installation? (SBP0012)

Cause One component requires MDAC 2.6, but the user chose not to install MDAC 2.6 
(may be already installed).

Action Click Yes if you are sure you do not want to install MDAC 2.6. Click No to install 
MDAC 2.6.

You selected the Microsoft Data Access Component (MDAC), but it is not required. Do you 
really want to install MDAC on your computer? (SBP0013)

Cause User can choose to install the MDAC 2.6 component although none of the other 
components chosen for installation require MDAC 2.6.

Action Click Yes to install MDAC 2.6, or click No to not install MDAC 2.6.
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You are using Microsoft Windows 98. Only the Recipient Manager and the Demo Kit can be 
installed. (SBP0014)

Cause As explained in warning message.

Action None unless user changes the operating system. (See also special note concerning 
missing BUSINESSOBJECTS components required for installation on page 559.)

Setup cannot find the original copy of a WebIntelligence file. Setup cannot backup the 
original file for uninstallation and will install a newer version. Refer to the Broadcast Agent 
Publisher mail component Administrator’s Guide for more information. (SBP0015)

Cause Setup needs to replace one WEBINTELLIGENCE file with an updated version, but 
the original was not found. Thus, setup could not backup the original file for 
uninstallation. (Note: This error should not happen unless the required 
WEBINTELLIGENCE files have been removed.) 

Action None. WEBINTELLIGENCE may show dead links after uninstalling the application.   
(See also special note concerning missing BUSINESSOBJECTS components required 
for installation on page 559.)

Setup cannot find the original copy of a WebIntelligence file. Setup cannot replace the 
newer file with the backup file. The newer file has been removed. Refer to the Broadcast 
Agent Publisher mail component Administrator’s Guide for more information. (SBP0016)

Cause Setup needs to replace one WEBINTELLIGENCE file with the older version that was 
backed up upon installation. The newer file will be kept. (Note: This error should 
not happen unless the required WEBINTELLIGENCE files have been removed.) 

Action None. WEBINTELLIGENCE may show dead links after uninstalling the application.
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The Microsoft MDAC 2.6 component is an “install-only” component. Once installed, it cannot 
be uninstalled. Click OK to continue. (SBP0017)

Cause None. This is a warning message that appears when running Setup for 
maintenance. This message appears when the user unchecked MDAC 2.6 to 
remove it although it has already been installed with the application, but cannot 
be removed.

Action None.

This version of WebIntelligence does not use English, and so cannot be patched. (SBP0018)

Cause Non-English version of WEBINTELLIGENCE found.

Action Continue Setup. Some WEBINTELLIGENCE files will be patched manually. Refer to 
the Broadcast Agent Publisher mail component Administrator’s Guide for more 
information on manually updating your WebIntelligence configuration.   (See 
also special note concerning missing BUSINESSOBJECTS components required for 
installation on page 559.)

Setup could not write the registry key for the “Trace” folder. The registry key will have to be 
manually added. Refer to the Broadcast Agent Publisher mail component Administrator’s 
Guide for more information. (SBP0019)

Cause Setup could not read or write the registry key containing the path of the “Trace” 
folder.

Action Click OK to continue Setup. Once finished, use REGEDIT to manually add (when 
installing) or delete (when uninstalling the whole application) the “Trace” 
registry key.
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To add the registry key:

1. Run REGEDIT.EXE.

2. Open the 
HKEY_LOCAL_MACHINE\SOFTWARE\BusinessObjects\Broadcast Agent 
Publisher\1.0 key.

3. On the right frame of REGEDIT, right-click the mouse to add a new value using 
the “New -> String Value” menu entry.

4. Type Trace.

5. Double-click the Trace key to enter its value.

6. Type the full path of the Trace folder (i.e. C:\Program 
Files\BusinessObjects\Server\Broadcast Agent Publisher 1.0\Trace)

To delete the registry key:

 1. Run REGEDIT.EXE.

2. Open the 
HKEY_LOCAL_MACHINE\SOFTWARE\BusinessObjects\Broadcast Agent 
Publisher\1.0 key.

3. On the right frame of REGEDIT, delete the Trace key.

Action None. WEBINTELLIGENCE may show dead links after uninstalling the application.

Your IIS configuration is not valid. The IIS virtual directories will have to be added or removed 
manually. Refer to the Broadcast Agent Publisher mail component Administrator’s Guide for 
more information. Do you want to continue? (SBP0020)

Cause User wants to install or remove a component that implies a change to the virtual 
directory structure.

Action Click Yes to continue, or No to abort Setup.
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WebIntelligence 2.7 has not been installed on the machine, so cannot be patched. 
(SBP0022)

Cause WEBINTELLIGENCE was not found on the computer, so its files cannot be 
configured to work with BROADCAST AGENT PUBLISHER MAIL COMPONENT.

Action Click OK to continue Setup.

The path of the WebIntelligence WIS files to patch is not valid. Setup cannot patch these files. 
Refer to the Broadcast Agent Publisher mail component Administrator’s Guide for more 
information on manually updating your WebIntelligence configuration. (SBP0023)

Cause Setup cannot patch these files.

Action Click OK to continue Setup. It is possible to fix the problem after Setup and run 
Setup again to install the patches.

The path of the WebIntelligence WEB files to patch is not valid. Setup cannot patch these files. 
Refer to the Broadcast Agent Publisher mail component Administrator’s Guide for more 
information on manually updating your WebIntelligence configuration. (SBP0024)

Cause Setup cannot patch these files.

Action Click OK to continue Setup. It is possible to fix the problem after Setup and run 
Setup again to install the patches.

Note: For a component that cannot be installed due to missing components, you 
can continue installing BROADCAST AGENT PUBLISHER MAIL COMPONENT, then 
install the missing BUSINESSOBJECTS components. You can then run Setup again 
to update BROADCAST AGENT PUBLISHER MAIL COMPONENT.
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A previous installation of Broadcast Agent Publisher mail component required the machine 
to be restarted. The machine has not yet been restarted, so Setup cannot continue. 
(SBP0025)

Cause You were asked to reboot the machine but have not yet done so.

Action Reboot the machine and run setup again.

Setup could not write the “RebootSkip” registry key. If you are prompted to restart your 
machine, you must do so before running Setup again. (SBP0026)

Cause An internal error occurred while attempting to write the “RebootSkip” registry 
key.

Action None. If you are asked to reboot the machine, you MUST do so before running 
the setup again.

Setup could not read the “RebootSkip” registry key. If the last setup required the machine to 
be restarted, please do so before continuing. Do you want to continue? (SBP0027)

Cause An internal error occurred while attempting to read the “RebootSkip” registry 
key.

Action Reboot your machine if previously asked to do so. Continue only if you are sure 
that no reboot was required.
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Recipient Manager Error Messages

This section contains the following error messages:

• Domino Address Retrieval

• Exchange Address Retrieval

• Recipient Manager

• SMTP Mailer

• SMapiMailer (Exchange)

• Domino Mailer

Domino Address Retrieval
This section describes the error messages that may occur when you configure a 
Lotus Domino plug-in to provide a connection between the mail server and 
BROADCAST AGENT PUBLISHER MAIL COMPONENT.

Domino address retrieval error messages range from DDC0001 to DDC0005.

An error occurred while connecting to Lotus Notes. (DDC0001)

Cause The system cannot connect to Lotus Notes.

Action Verify your password and Lotus Notes installation. Make sure your password 
matches the ID file set up on your node.

An error occurred while logging out. (DDC0002)

Cause Lotus Notes has been used during publication processing.

Action Do not use Lotus Notes during the processing of a publication.
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Cannot start a Notes session. Please check your Lotus Notes version. (DDC0003)

Cause Notes is not installed or is not the correct version number.

Action Install Lotus Notes 5.02b or higher.

No address books are available. (DDC0004)

Cause Cannot connect to an address book.

Action Verify that Lotus Notes is connected to a Domino server.

Please enter a valid name. (DDC0005)

Cause You have chosen the same option twice in the combo boxes.

Action Select the current format of the name definition.
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Exchange Address Retrieval
This section describes the error messages that may occur when you configure a 
Microsoft Exchange plug-in to provide a connection between the mail server and 
BROADCAST AGENT PUBLISHER MAIL COMPONENT.

Domino address retrieval error messages range from EDC0001 to EDC0006.

An error occurred while retrieving address lists. (EDC0001)

Cause The component cannot retrieve one or more address lists.

Action Retry after checking your network connection.

An error occurred while logging in. (EDC0002)

Cause The system cannot log in.

Action Verify that you are using the correct Exchange Profile in the plug-in setup.

An error occurred while logging out. (EDC0003)

Cause Outlook cannot log out.

Action The communication with the Exchange Server has been interrupted. Check your 
exchange server.
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An error occurred while importing recipients. (EDC0004)

Cause The component cannot retrieve one or more recipients.

Action Retry after checking your network connection.

Error resolving name. (EDC0005)

Cause The component cannot resolve a given name.

Action Retry after checking your network connection.

The plug-in cannot detect an installed version of Microsoft Collaboration Data Objects or 
how to use it with your default email client. (EDC0006)

Cause 1 The plug-in needs Microsoft Collaboration Data Objects to be installed.

Action Go to the setup of Microsoft Exchange and install Microsoft Collaboration Data 
Objects. Refer to the Broadcast Agent Publisher mail component Administrator’s Guide 
for more information.

Cause 2 Your default email client is not supported by BROADCAST AGENT PUBLISHER MAIL 
COMPONENT.

Action Install a supported email client.
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Recipient Manager
This section describes the error messages that may occur during normal use of the 
BROADCAST AGENT PUBLISHER MAIL COMPONENT Recipient Manager.

Recipient Manager error messages range from BRM0001 to BRM0072.

Please complete all the required fields. (BRM0001)

Cause One or more mandatory fields in the dialog box are empty.

Action Fill in the fields correctly.

BusinessObjects software not installed. (BRM0002)

Cause Recipient Manager cannot detect BUSINESSOBJECTS.

Action Install BUSINESSOBJECTS 5.1 SP2 or higher.

Incorrect user name or password, please try again. (BRM0003)

Cause The user name or password you provided are not valid on the domain you 
selected.

Action Enter a valid user name and password. (Note: You must be a general supervisor 
to enter the Admin part of Recipient Manager or a member of the Broadcast 
Recipient Manager group to be allowed to enter Recipient Manager.)
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Your login is not valid. (BRM0004)

Cause The user name or password you provided are not valid on the domain you 
selected.

Action Enter a valid user name and password. (Note: You must be a general supervisor 
to enter the Admin part of Recipient Manager or a member of the Broadcast 
Recipient Manager group to be allowed to enter Recipient Manager.)

Cannot use a predefined database connection, the program will not launch. (BRM0005)

Cause Recipient Manager cannot find a valid database connection to the repository.

Action Re-execute the Admin part to redefine your database connection.

You must specify a default directory plug-in. (BRM0006)

Cause To be allowed to use this function, you should specify a Directory plug-in as a 
default.

Action In the Tools menu, choose the Email server plug-in configuration. Select and 
configure the appropriate plug-in and set it as default.

Cannot connect to the specified default plug-in. Please check the plug-in’s configuration. 
(BRM0007)

Cause Your default plug-in configuration has been changed.

Action In the Tools menu, choose the Email server plug-in configuration. Select and 
configure again the default plug-in and test it.
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This is not a directory plug-in! (BRM0008)

Cause The file you tried to add is not a Directory Plug-in.

Action Choose a valid Directory plug-in DLL file.

The plug-in is already registered! (BRM0009)

Cause The same plug-in is already in the list.

Action Choose another plug-in.

This plug-in cannot be used on this computer. Please configure another one. (BRM0010)

Cause The plug-in you tried to configure cannot be used directly on your computer.

Action Install the correct software to access your email server depending on the selected 
plug-in.

Error configuring plug-in! (BRM0011)

Cause An error occurred during the configuration process of your plug-in.

Action Your plug-in has a registration problem. Uninstall and reinstall BROADCAST 
AGENT PUBLISHER MAIL COMPONENT or the plug-in.
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Please configure the plug-in first! (BRM0012)

Cause Your plug-in is not configured.

Action Before setting as default or testing a plug-in, configure it.

Please configure the plug-in. (BRM0013)

Cause Your plug-in is not configured.

Action Before setting as default or testing a plug-in, configure it.

You should define a default plug-in before leaving this dialog box. Do you want to define 
one? (BRM0014)

Cause You have not set a default plug-in.

Action To use the import of external users or the automatic or manual retrieval of email 
addresses from an address book, you must have a configured plug-in set as 
default.

The type of address required was not found! (BRM0015)

Cause You have asked for a special kind of email address. The recipient in the address 
book does not have one.

Action Ask for another kind of email address, or ask IT to provide such an email address 
to your recipient.
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The server is not responding! (BRM0016)

Cause The database server you tried to connect to is not responding.

Action The server is down or your connection parameters are wrong. Verify your 
connection.

An error occurred while creating the Broadcast Agent Publisher mail component tables. 
(BRM0017)

Cause The Recipient Manager encountered an error in creating the BROADCAST AGENT 
PUBLISHER MAIL COMPONENT tables.

Action Either your connection is down, the tables already exist, or you do not have the 
right to create them. Check your rights and the database connection. Then try to 
create the tables manually using the provided script.

You must have BusinessObjects Reported installed to use this feature. (BRM0018)

Cause BUSINESSOBJECTS REPORTER is required to use Recipient Manager.

Action Install BUSINESSOBJECTS client software 5.1 SP2 or higher.

You must define a WebIntelligence Domain (.key) to run Recipient Manager! (BRM0019)

Cause Recipient Manager cannot find any KEY files on your computer.

Action Generate, import or copy the correct KEY file into your 
“BusinessObjects\BusinessObjects 5.0\LocData” folder.
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The profile is attached to a publication. You must delete the publication. (BRM0020)

Cause You cannot delete a profile used by a publication.

Action Delete all the publications used by this profile.

This is not an email server plug-in! (BRM0021)

Cause The file you tried to add is not an email server plug-in.

Action Choose a valid email plug-in DLL file.

Please select an external user group. (BRM0022)

Cause The function you chose is only available for the external users group

Action Select an external user group in the tree window.

An error occurred during synchronization. Please try again. (BRM0023)

Cause An error occurred in the repository synchronization process.

Action Perform synchronization again or check your database connection in the wizard.
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An error has occurred during the test. You may need to modify your configuration. 
(BRM0024)

Cause You can use that plug-in, but need to check your configuration parameters.

Action Enter valid configuration parameters.

Please select a plug-in. (BRM0025)

Cause No selected plug-ins found in the list box.

Action Select a plug-in within the list box. If no plug-in is installed, add at least one.

You must enter a value in the name field. (BRM0026)

Cause You tried to update a user name without entering a name.

Action Enter the new name of your user.

Business Objects is running and will be closed if you continue. If you have any open 
documents, you should save them before continuing. Continue? (BRM0027)

Cause BUSINESSOBJECTS REPORTER is currently running.

Action Save your open documents in REPORTER and continue. BUSINESSOBJECTS 
REPORTER will be closed and can be reused later.
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You are not authorized to use Recipient Manager. (BRM0028)

Cause The user name and password you provide does not allow you to use Recipient 
Manager.

Action You must be a general supervisor to enter the Admin part of Recipient Manager 
or a member of the Broadcast Recipient Manager group to be allowed access to 
Recipient Manager.

The connection you have defined is not to the database that contains the repository. 
(BRM0029)

Cause You entered a valid database connection, but for a database that does not contain 
a repository corresponding to your KEY file.

Action Ask your database administrator for the connection parameters corresponding to 
your repository defined in the KEY file.

The mailing list you require does not exist in the address book you have chosen. (BRM0030)

Cause You are trying to update an unknown mailing list.

Action The mailing list does not exist in your address book. Verify that you are using the 
correct plug-in and connection to the address book. (Note: The groups you create 
manually are not necessarily attached to a mailing list in your address book.)

The mailing list you require does not contain any email addresses. (BRM0031)

Cause There is no email address assigned to the selected mailing list.

Action You can simply import the mailing list as users with individual email addresses.
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An error occurred while extracting the universe. (BRM0033)

Cause The universe data cannot be saved on disk.

Action Make sure that you have enough free disk space and sufficient access rights for 
writing on disk. Run the wizard again.

An error occurred while checking the universe structure. (BRM0034)

Cause The universe structure failed the integrity check.

Action Make sure that your repository contains the required tables used by the universe. 
Check your connection and run the wizard again.

An error occurred while removing the universe file. (BRM0035)

Cause The temporary universe file saved on disk could not be removed (possibly 
because of insufficient user rights).

Action Make sure that you are allowed to delete files on your disk and run the wizard 
again.

An error occurred while opening the universe. (BRM0036)

Cause The universe file extracted on disk could not be opened.

Action Make sure that no other Business Objects applications are running.
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An error occurred while closing the universe. (BRM0037)

Cause The universe file extracted on disk could not be closed.

Action Make sure that no other Business Objects applications are running.

An error occurred while saving the universe. (BRM0038)

Cause The universe could not be saved on disk after being modified.

Action Make sure you have the correct user rights and enough free space to write on 
disk.

An error occurred while exporting the universe. (BRM0039)

Cause The universe could not be exported to the repository.

Action Make sure that you have the rights to export documents to the repository and that 
your repository is not corrupted. Make sure you selected the correct document 
domain and user group. Run the wizard again to export the document with 
correct parameters.

An error occurred while setting the universe connection. (BRM0040)

Cause The universe could not be assigned its connection.

Action Try setting the connection manually, and export the universe manually. You will 
need to use the universe in the “Custom” Files folder. Refer to the Broadcast Agent 
Publisher mail component Administrator’s Guide for more information.
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Please select a valid Universe Domain. (BRM0041)

Cause You have no universe domain available, thus leaving you with an empty 
universe domain list.

Action Create a valid universe domain. Then refresh the lists by clicking Back and Next.

Please select a valid Document Domain. (BRM0042)

Cause You have no document domain available, thus leaving you with an empty 
document domain list.

Action Create a valid document domain. Then refresh the lists by clicking Back and 
Next.

Please select a valid User Group. (BRM0043)

Cause You have no user group available, thus leaving you with an empty user group 
list.

Action Create a valid user group. Then refresh the lists by clicking Back and Next.

You do not have the rights to log into Designer with that profile. (BRM0044)

Cause The user rights set in your profile do not allow you to log into DESIGNER.

Action Contact your BUSINESSOBJECTS administrator to obtain the requested user rights 
and run the wizard again.
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An error occurred while extracting the BusinessObjects document. (BRM0046)

Cause The document data could not be saved on disk.

Action Make sure that you have enough free disk space and sufficient access rights for 
writing on disk. Then run the wizard again.

An error occurred while exporting the document to the repository with the parameters: 
(BRM0047)

Cause The document failed to export to the repository.

Action Do the following:

• Make sure that you have the rights to export documents to the repository and 
that your repository is not corrupted. 

• Make sure you selected the correct document domain and user group. 

• Run the wizard again to export the document with correct parameters, or 
publish the document manually using the document stored in the “Custom” 
Files folder. Refer to the Broadcast Agent Publisher mail component 
Administrator’s Guide for more information.

There is no connection available. Create one using BusinessObjects Supervisor or contact 
your BusinessObjects administrator. Click Refresh Connection List to view the connection 
once you have created it. (BRM0050)

Cause There is no connection available to export the universe.

Action Create a valid connection using BUSINESSOBJECTS SUPERVISOR. Click Refresh List 
to refresh the connection list and select the newly created connection.
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Could not find a Document Group or Document Domain Error. (BRM0052)

Cause You did not create a document group or a document domain.

Action Create a document group or a document domain. Click Back and Next to refresh 
the lists. If the error persists, run the wizard again, or publish the document 
manually using the document stored in the “Custom” Files folder. Refer to the 
Broadcast Agent Publisher mail component Administrator’s Guide for more 
information.

No document domain or document group is available. (BRM0053)

Cause The document failed to export to the repository.

Action Make sure that your user profile has enough user rights to export the documents 
to the repository. Contact your BUSINESSOBJECTS administrator to obtain correct 
user rights. Run the wizard again, or publish the document manually using the 
document stored in the “Custom” Files folder. Refer to the Broadcast Agent 
Publisher mail component Administrator’s Guide for more information.

No universe domain or universe group is available. (BRM0054)

Cause The universe failed to export to the repository.

Action Make sure that your user profile has enough user rights to export the universe to 
the repository. Contact your BUSINESSOBJECTS administrator to obtain correct 
user rights. Run the wizard again, or export the universe manually using the 
document stored in the “Custom” Files folder. Refer to the Broadcast Agent 
Publisher mail component Administrator’s Guide for more information.
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You must have a general supervisor profile to use the Repository Wizard. (BRM0056)

Cause Your user profile has insufficient rights to log into the wizard.

Action Contact your BUSINESSOBJECTS administrator to obtain a General Supervisor 
profile and run the wizard again.

Error: Could not retrieve BusinessObjects general path. (BRM0057)

Cause The path where your BUSINESSOBJECTS applications were installed could not be 
found.

Action Make sure that your BUSINESSOBJECTS applications are correctly installed on your 
disk. Then run the wizard again.

Error: Could not find BusinessObjects Supervisor. (BRM0058)

Cause The wizard required BUSINESSOBJECTS SUPERVISOR, but could not find it.

Action Install BUSINESSOBJECTS SUPERVISOR and run the wizard again.

Wrong version of BusinessObjects. The minimum version required is 5.1.2 and you are using 
version XXX. (BRM0060)

Cause Recipient Manager has detected an older version of BUSINESSOBJECTS.

Action Install the correct version (5.1 SP2 or higher).
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The universe connection you have selected links to a different repository from the 
connection specified at Step 1. (BRM0061)

Cause The connection that you selected for exporting the universe links to a repository 
that does not match the repository linked to the connection established for 
creating the BROADCAST AGENT PUBLISHER MAIL COMPONENT tables.

Action Select a connection that links to the same repository as the one linked to the 
connection at Step 1. You may run the wizard again to change the connection set 
at Step 1.

An error occurred while accessing the universe “RepoID” value. (BRM0062)

Cause The repository ID stored in the universe could not be retrieved.

Action Your repository might be bad: check the repository structure. 

Your connection might be invalid: check your connection.

An error occurred while setting the universe tables owner. (BRM0063)

Cause An error occurred while setting the owner of the universe tables.

Action Type a valid owner name. If the problem persists, open the universe stored in the 
“Custom” Files folder using BUSINESSOBJECTS DESIGNER, and export the universe 
manually.
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The universe failed the integrity check. You must manually fix the problem. (BRM0064)

Cause An error occurred during the universe integrity check.

Action Make sure that your repository contains the required tables used by the universe. 
Check your connection and run the wizard again.

An error occurred while setting the database owner of the universe tables. You must fix the 
problem manually. Click OK to close the wizard. (BRM0065)

Cause An error occurred while setting the owner of the universe tables.

Action Click OK to close the wizard. Open the universe stored in the “Custom” Files 
folder using BUSINESSOBJECTS DESIGNER, and export the universe manually.

The universe failed the new integrity check. (BRM0066)

Cause You entered a new database owner name after a bad universe integrity check, but 
the new database owner name is not valid.

Action Click OK and type a valid database name, or click Abort to close the wizard.

An error occurred while closing the universe. (BRM0067)

Cause The universe extracted on disk could not be closed.

Action Make sure that no other BUSINESSOBJECTS applications are running. Close them 
and run the wizard again.
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The connection is not on a valid BusinessObjects Repository. (BRM0068)

Cause The database connection you set up is valid but not corresponding to a 
BUSINESSOBJECTS repository.

Action Define the correct database connection pointing to the repository associated with 
your KEY file.

BusinessObjects Designer is currently running. (BRM0071)

Cause DESIGNER is currently running on your computer.

Action Save the universe(s) open with DESIGNER. Close DESIGNER and start again.

Recipient Manager cannot load one or more components, because they are either missing 
or not registered. Try uninstalling and reinstalling Recipient manager. These components are: 
XXX. (BRM0072)

Cause An error occurred during the setup of Recipient Manager.

Action Uninstall or reinstall Recipient Manager, or manually register the components. 
To know exactly which components are registered, try refreshing the report 
BCAPubCheck.rep located in the custom folder of your BROADCAST AGENT 
PUBLISHER MAIL COMPONENT main installation folder. This will provide a list of all 
components used by Recipient Manager and their status.
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An error occured while retrieving the local universe directory. The temporary directory will 
be used instead. (BRM0074)

Cause An error occurred while retrieving the local universe directory where the 
universes are stored.

Action The temporary directory will be used to store universes instead.
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SMTP Mailer Plug-in
This section describes the error messages that may occur when you configure a 
connection for broadcasting emails using SMTP.

SMTP Mailer error messages range from SMM0001 to SMM0010.

Memory error. Insufficient space to allocate memory. (SMM0001)

Cause Not enough memory.

Action Close one or more applications. It might be necessary to add physical memory.

Socket error. The component cannot initialize the socket. (SMM0002)

Cause The component cannot establish a network connection.

Action Check your network connection and configuration.

No SMTP Mail Server defined. (SMM0003)

Cause As explained above.

Action Define a server for the profile in Recipient Manager.

An error occurred while creating the message. (SMM0004)

Cause The files exported from the BUSINESSOBJECTS report used to create the body of the 
message cannot be found or merged.

Action Check your BROADCAST AGENT node configuration.
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You have not specified a recipient. (SMM0005)

Cause No recipient was specified for an email.

Action Check the definition of your publication. Each recipient must have an SMTP valid 
email address.

Can’t establish a connection with the SMTP Server. (SMM0006)

Cause The component cannot reach the server.

Action Verify that your server defined in the profile is correct, and that the BROADCAST 
AGENT node can reach it.

An error occurred while sending the email content. (SMM0007)

Cause As explained above.

Action The error message might list one or more of the following problems: (The 
solutions follow the colon.)

• Not enough memory: Close one or more applications.

• Unable to create the socket: Check your network connection and 
configuration.

• Unable to connect to server: Define a valid server for the profile in Recipient 
Manager. Then, try to ping the server from the BROADCAST AGENT node.

• Server didn’t respond: Make sure your mail server is enabled.

• Socket error, no response, time out reached (10s): Your server is overloaded or 
has been disabled. Contact your IT department.
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An error occurred while closing the email and disconnecting from the SMTP server. 
(SMM0008)

Cause The connection is broken or has been reset.

Action Check your network connection and configuration.

Please complete all the mandatory fields. (SMM0010)

Cause One or more mandatory fields in the dialog box are empty.

Action Fill in the necessary fields.
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SMapiMailer Plug-in
This section describes the error messages that may occur when you configure a 
connection for broadcasting emails using Microsoft Exchange.

Exchange mailer error messages range from MPM0001 to MPM0015.

An error occurred while logging in. Please check the profile and password parameters. 
(MPM0001)

Cause The chosen profile name is not defined in the list of profiles used by Outlook on 
the BROADCAST AGENT node.

Action In Recipient Manager, define a correct profile name to be used by each 
BROADCAST AGENT node. Or, on each node, verify that the profile name for 
Outlook is correct.

An error occurred while logging out. (MPM0002)

Cause Outlook cannot log out because the communication with the Exchange server has 
been interrupted.

Action Check your Exchange server.

The MAPIMailer component does not support HTML in the email body. (MPM0003)

Cause You are creating your publication in HTML, but MAPI does not support HTML 
as a mail format.

Action Change your publication to text mode.
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An error occurred while reading text files. (MPM0004)

Cause The text files used to build the body of your email cannot be read.

Action Check your BROADCAST AGENT node configuration.

No recipient defined. (MPM0005)

Cause There was no recipient specified for an email.

Action Check the definition of your publication. Each recipient must have a valid and 
recognized Exchange email address or recipient name without ambiguity.

An error occurred while sending an email in text mode. (MPM0006)

Cause When an email is sent, a recipient cannot be recognized. This is either because the 
name has changed, or because duplicates of the name exist.

Action Check the recipient name. An error may have occurred in Outlook, in which case 
you should check your installation.

Several recipients correspond to the given name or address. (MPM0007)

Cause The email address or name given to the recipient match more than one name in 
the address book.

Action Provide a unique identifier recognized by the address book.
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An error occurred while trying to send an attachment. (MPM0008)

Cause The file set as an attachment cannot be found.

Action Check the file path in the publication for an external file or your BROADCAST 
AGENT node configuration.

An error occurred: no login. (MPM0009)

Cause Your login on the BROADCAST AGENT node is not valid.

Action Verify that Outlook is properly installed on the node with the valid profile 
definition.

The email body is too large. (MPM0010)

Cause Your Exchange server cannot handle so large a body in your email.

Action Reduce the size of the body in your publication.

Too many files attached. (MPM0011)

Cause You have attached too many files to your email.

Action Reduce the number of attachments in your publication.
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Unknown recipient. (MPM0012)

Cause The recipient cannot be reached because a wrong email address has been given.

Action Provide a correct email address.

MAPI is not installed on your computer. (MPM0013)

Cause You need to have MAPI installed.

Action Install Microsoft Outlook 2000 SR1.

OR

Check that your default mail client is correctly configured (Microsoft Outlook 
2000 SR1).

SMAPIMailer cannot find the component Mistools.dll. (MPM0014)

Cause SMAPIMailer is unable to find the component Mistools.dll. It may have been 
deleted or there may have been a problem during installation.

Action Uninstall and reinstall BROADCAST AGENT PUBLISHER MAIL COMPONENT.

The body exceeds 64Kb. SMAPIMailer can’t send the mail. (MPM0015)

Cause The email body size has exceeded the maximum possible when using this driver.

Action Reduce the size of the email body.
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Domino Mailer Plug-in
This section describes the error messages that may occur when you configure a 
connection for broadcasting emails using Lotus Domino.

Domino Mailer error messages range from DOM0001 to DOM0011.

Please complete all the mandatory fields. (DOM0001)

Cause One or more of the mandatory fields in the dialog box are empty.

Action Fill in the necessary fields.

The attachment you specified does not exist. Please verify the file path. (DOM0002)

Cause The file set as an attachment cannot be found.

Action Check the file path in the publication for an external file or your BROADCAST 
AGENT node configuration.

The DominoMailer component does not support HTML in the email body. (DOM0003)

Cause The publication is set using HTML in the message body.

Action Change the publication from HTML to text format.
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No password. Please provide a password for the active profile. (DOM0004)

Cause No password attached to the ID file used by Lotus Notes is provided in the 
profile.

Action Provide a password in the profile definition in Recipient Manager.

An error occurred while logging in. Please check the profile and password parameters. 
(DOM0005)

Cause Lotus Notes is either not installed, is the wrong version, or contains the wrong 
password defined in the profile.

Action Install the correct version of Lotus Notes (5.02b or higher) on each BROADCAST 
AGENT node used by BROADCAST AGENT PUBLISHER MAIL COMPONENT. On each 
node, set up the profile with the correct password attached to the ID file used by 
Lotus Notes.

An error occurred while logging out. (DOM0006)

Cause Lotus Notes has been used during the processing of a publication.

Action Do not use Lotus Notes during the processing of a publication.

Attachment Error. Please verify the given path of the file. (DOM0007)

Cause The file set as an attachment cannot be found.

Action Check the file path in the publication of an external file or your BROADCAST 
AGENT node configuration.
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Cannot send email as no recipients have been defined. (DOM0008)

Cause There are no recipients specified for an email.

Action Check the definition of your publication. Each recipient must have a valid and 
recognized Lotus Notes email address.

An error occurred while sending the email in text mode. (DOM0009)

Cause An error occurred during the mailing process.

Action A recipient cannot be recognized due to an ambiguous name. Verify the recipient 
name, or check your installation, in case the error occurred with Lotus Notes.

DominoMailer can’t find the component Mistools.dll (DOM0011)

Cause DominoMailer is unable to find the component Mistools.dll. It may have been 
deleted or there may have been a problem during installation.

Action Uninstall and reinstall BROADCAST AGENT PUBLISHER MAIL COMPONENT.
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Mail Publication Error Messages

This section describes the error messages that may occur when you work with 
mail publications.

Mail publication error messages range from PUB0001 to PUB0160.

The WebIntelligence server is not running. (PUB0001)

Cause The WEBINTELLIGENCE server is not running.

Action Run the WEBINTELLIGENCE server.

Cannot retrieve the “WebIntelligenceSession” cookie. (PUB0002)

Cause The WEBINTELLIGENCE cookie is either not valid or out-of-date.

Action Make sure your browser accepts cookies. Log out of INFOVIEW to initialize a new 
session cookie.
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Cannot access the Broadcast Agent Publisher mail component tables. (PUB0003)

Cause BROADCAST AGENT PUBLISHER MAIL COMPONENT pages either could not find the 
MKEY file on the server, or the connection in the MKEY is not pointing to a 
repository that contains BROADCAST AGENT tables.

Action See the Broadcast Agent Publisher mail component Administrator’s Guide to create an 
MKEY file. Copy the correct MKEY file onto the server, making sure that the 
MKEY file is unique and called “Bomain.MKEY.” Also make sure that the 
connection of the MKEY file is pointing to a repository that contains the 
BROADCAST AGENT PUBLISHER MAIL COMPONENT tables.

You do not have the rights to use this feature. Please contact your BusinessObjects 
Administrator. (PUB0004)

Cause The user has no access rights to Publication pages or My Subscriptions pages.

Action The user is not synchronized in the Recipient Manager to have access to the My 
Subscriptions page. The user has no publisher rights. Please refer to Broadcast 
Agent Publisher mail component Administrator’s Guide to set up the correct rights 
according to his or her profile.

The publication XXX is corrupted. (PUB0005)

Cause An error occurred while retrieving publication properties during activation.

Action Check the connection to the database. Log out of and back into INFOVIEW.
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The publication XXX is already activated. (PUB0006)

Cause You tried to activate a publication that is already activated.

Action None. You cannot activate a publication that is already activated.

The XXX publication needs to be deactivated. (PUB0007)

Cause The publication is activated.

Action You need to deactivate this publication before reactivating it.

No default schedule selected for this publication. (PUB0008)

Cause Each publication requires at least one schedule before it can be activated.

Action You need to create a schedule in that publication and set it to default. Please refer 
to the Broadcast Agent Publisher mail component User’s Guide to see how to create a 
default schedule.

No document selected for this publication. (PUB0009)

Cause Each schedule must have a document associated with it.

Action You need to associate a document with the publication. Please refer to the 
Broadcast Agent Publisher mail component User’s Guide for help.
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You do not have the right to access the universe. (PUB0010)

Cause You cannot access the BROADCAST AGENT PUBLISHER MAIL COMPONENT universe.

Action Please make sure that the “BCApub” universe is exported in the repository and 
that the user has the right to access it.

An error occurred while opening the BCAPub document used for this publication. (PUB0011)

Cause INFOVIEW has a problem opening the document “BCAPub.”

Action Make sure the “BCAPub” document is exported to Corporate Documents, and 
that you have access to it. In addition, make sure the BUSINESSOBJECTS processes 
are running well, and that there is no problem when opening the document in 
INFOVIEW.

Database error. Please contact your BusinessObjects Supervisor. (PUB0012)

Cause An error occurred while reading publication properties during activation.

Action Make sure the connection to your database is working correctly.

Schedule Database error. Please contact your BusinessObjects Supervisor. (PUB0013)

Cause An error occurred while reading Schedule properties during activation.

Action Make sure the connection to your database is working correctly.
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An error has been returned by the Send function. The document XXX cannot be scheduled. 
(PUB0014)

Cause There was a problem sending the report “BCAPub” to Corporate Documents in 
Schedule mode.

Action Do the following:

• Log out of INFOVIEW and try again.

• The document domain could be full. Add space to your database.

• There is a problem with the connection to the repository. Perform a Safe 
Recovery, making sure that the connection is set to Disconnect after every 
transaction on the Advanced tab of the Setup screen. Verify this configuration 
on the Universe and Document domains from the WEBINTELLIGENCE server.

• The disk on the cluster node is full. Verify that the hard drive on which 
WEBINTELLIGENCE resides has enough space. Remember that Windows NT 
requires a certain amount of space on drive C:\ for the Virtual Memory file 
pagefile.sys.
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• Perform Scan and Repair / Scan and Compact. Important: Backup your 
repository first.

• Login to SUPERVISOR as a general supervisor and go to Tools > Repository. 
Select the Security domain and click Scan, followed by Repair.

• Click Scan, then Compact. (Clicking Compact deletes all repository table 
rows that are marked for deletion and can clear up many forms of 
repository corruption as well as trim the size of the repository, increasing 
performance.)

• Make sure that you have the BUSOBJ process running on the server.

• You chose the First day of the month option in a Monthly interval. This option 
is incompatible with DB2, and there is no work around.

Note: The following steps will reproduce the same error in INFOVIEW:

• Open “BCAPub” in Corporate Documents.
• Click Send.
• Select Schedule Refresh.
• Select schedule Parameters.
• Send the document. You should receive the following error messages: 

WI304, and WI303.

Database error and the publication has not been activated. (PUB0015)

Cause An error occurred reading Schedule properties during activation.

Action Make sure the connection to your database is working properly. Log out of and 
back into INFOVIEW.
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Database error and the publication has not been activated. (PUB0016)

Cause An error occurred reading Publication properties during activation.

Action Make sure the connection to your database is working properly. Log out of and 
back into INFOVIEW.

No dynamic recipients selected for that publication. (PUB0017)

Cause You tried to create a dynamic publication, but you did not select any recipients 
for it.

Action Please refer to the Broadcast Agent Publisher mail component User’s Guide to see how 
to select dynamic users in your publication.

A database error occurred while activating the dynamic publication. (PUB0018)

Cause An error occurred while reading the dynamic users properties during activation.

Action Make sure the connection to your database is working properly. Log out of and 
back into INFOVIEW.

A database error occurred due to the publication type. (PUB0019)

Cause An error occurred while reading the publication properties during activation.

Action Make sure the connection to your database is working properly. Log out of and 
back into INFOVIEW.
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A database error occurred while activating the publication. (PUB0020)

Cause An error occurred while reading the publication properties during activation.

Action Make sure the connection to your database is working properly. Log out of and 
back into INFOVIEW.

The publication XXX is already activated. (PUB0021)

Cause You tried to activate a publication that is already activated.

Action None. You cannot activate a publication that is already activated. 

Problem retrieving the Infoview session. (PUB0023)

Cause The INFOVIEW session cannot be retrieved. This could be because your session has 
timed out.

Action Log out of and back into INFOVIEW. Check that your browser accepts cookies.

An error occurred while deleting. (PUB0024)

Cause An error occurred while deleting an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
Infoview. Login and try again.
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An error occurred while saving. (PUB0025)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while saving the subject. (PUB0026)

Cause As explained above.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while saving the report body layout. (PUB0027)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW. 

An error occurred while saving the InfoView link. (PUB0028)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.
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An error occurred while changing the body format to text. (PUB0029)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while changing the body format to html. (PUB0030)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while saving the document attachment. (PUB0031)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while saving the report attachment. (PUB0032)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.
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An error occurred while saving the data provider attachment. (PUB0033)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while saving the external file attachment. (PUB0034)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while saving the filter. (PUB0035)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while saving the variable. (PUB0036)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.
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An error occurred while moving up. (PUB0037)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while moving down. (PUB0038)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while saving the attachment compression option. (PUB0039)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while saving the Delivery Rule. (PUB0040)

Cause An error occurred while saving an email content element.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.
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Delivery Rule not saved. You must specify a name. (PUB0041)

Cause A delivery rule may contain up to a maximum of 250 characters.

Action Type the name of the delivery rule.

An error occurred while saving the dynamic recipients parameters. (PUB0042)

Cause An error occurred while saving the recipient list.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

Publication name already exists. Please choose a new name. (PUB0043)

Cause You cannot modify a publication with a duplicate name.

Action Choose a publication name that does not exist in the publication list.

You must deactivate the publication before changing its name. (PUB0044)

Cause You cannot change the name of a publication if it is activated.

Action Deactivate the publication, change its name, and activate it again.
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You must deactivate the publication before changing its Broadcast Agent Server. (PUB0045)

Cause You cannot change the BROADCAST AGENT Server of a publication if it is activated.

Action Deactivate the publication, change its BROADCAST AGENT Server, and activate the 
publication again.

An error occurred while updating the publication. (PUB0046)

Cause An error occurred while updating the Publication definition.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

The publication XXXX is already deactivated. (PUB0047)

Cause You cannot deactivate a publication that is already deactivated.

Action You must activate a publication before deactivating it.

Publication name already exists. (PUB0048)

Cause You cannot copy a publication using a name that already exists.

Action Choose a publication name that does not exist in the publication list.
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An error occurred while copying the publication. (PUB0049)

Cause As explained above.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

Publication partially copied. (PUB0050)

Cause The publication has been copied, but some of the elements (schedules, reports, 
email contents, delivery rule, recipients) have not been copied.

Action You must check each element of your publication to correct it.

The name you typed already exists. Please choose a new name. (PUB0051)

Cause You cannot create a publication using a name that already exists.

Action Choose a publication name that does not exist in the publication list.

An error occurred while creating the publication. (PUB0052)

Cause As explained above.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.
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An error occurred while associating the publication with the email profile. (PUB0053)

Cause An error occurred while creating the publication.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while deleting the publication. (PUB0054)

Cause An error occurred while deleting one publication.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

No publication to delete. (Monodelete) (PUB0055)

Cause The publication you selected is already deleted.

Action Return to the publication list.

No publication to delete. (MultiDelete) (PUB0056)

Cause The publication you selected is already deleted.

Action Return to the publication list.
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An error occurred while deleting the publication(s). (MultiDelete) (PUB0057)

Cause The publication you selected is already deleted.

Action Return to the publication list.

An error occurred while associating the document with the publication. (PUB0058)

Cause An error occurred while saving the publication.

Action Verify that the document is in Corporate Documents in INFOVIEW. Make sure that 
the connection to your database is working properly. Log out of and back into 
INFOVIEW.

Document change cancelled. (PUB0059)

Cause An error occurred while saving the publication.

Action Verify that the document is in Corporate Documents in Infoview. Make sure that 
the connection to your database is working properly. Log out of and back into 
INFOVIEW.
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The publication contains email elements that may be incompatible with the document you 
selected. Do you want to delete them? (PUB0060)

Cause You have changed the publication document, but have built some email element 
linked to the previous document. Some of these elements could be incompatible 
with the new document.

Action It is advised to delete the Body Element of the Publication. However, if you are 
sure that the report, object, and variable, and data provider names that you have 
selected in the Build Email Content section are the same, you can keep those 
elements.

Publication activation failed. (PUB0061)

Cause The activation of the publication failed.

Action Please refer to the error message on the previous screen.

Publication deactivation failed. (PUB0062)

Cause The deactivation of the publication failed.

Action Please refer to the error message on the previous screen.

An error occurred while deactivating the publication. (PUB0063)

Cause The deactivation of the publication failed.

Action Please refer to the error message on the previous screen.
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An error occurred while disabling test mode. (PUB0064)

Cause An error occurred while saving publication properties.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while enabling test mode. (PUB0065)

Cause An error occurred while saving publication properties.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

Schedule name already used. (PUB0066)

Cause You cannot use the same name for a schedule.

Action Rename the schedule.

You must deactivate the publication before you can modify a schedule. (PUB0067)

Cause Schedule modifications are not possible in activation mode.

Action Deactivate the publication and modify your schedule.
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An error occurred while creating the schedule. (PUB0068)

Cause An error occurred while saving schedule properties.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

An error occurred while saving the recipient list. (PUB0069)

Cause An error occurred while saving the recipient list properties.

Action Make sure that the connection to your database is working properly. Log out of 
and back into INFOVIEW.

You must define a default schedule before you can save the list of recipients. (PUB0070)

Cause As explained above.

Action You must define a default schedule before inserting your recipient.

Please select the recipients to move. (PUB0071)

Cause No recipient selected.

Action Select the recipients you want to move.



v 5.1-2.7

 Error Message Guide 613

Publication activation failed. (PUB0072)

Cause The publication could not be activated. If activation of a publication fails, the 
reasons for the failure are displayed on screen during the activation attempt. This 
error message is displayed once you have left the activation page, as a summary 
of the publication's status.

Action For more information, please refer to the error message that was displayed on 
screen during the activation process.

Publication deactivation failed. (PUB0073)

Cause The publication could not be deactivated. If deactivation of a publication fails, the 
reasons for the failure are displayed on screen during the deactivation attempt. 
This error message is displayed once you have left the deactivation page, as a 
summary of the publication's status.

Action For more information, please refer to the error message that was displayed on 
screen during the deactivation process.

Cannot edit that publication. (PUB0074)

Cause The publication either no longer exists, or its data cannot be retrieved from the 
database. This error message is displayed once you have left the edit page, as a 
summary of the publication's status.

Action For more information, please refer to the error message that was displayed on 
screen when you tried to edit it.
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An error occurred with the list of users in the database. (PUB0075)

Cause The activation of the publication failed, because one or more of the recipients 
could not be found. This error message is displayed once you have left the 
activation page, as a summary of the publication's status.

Action For more information, please refer to the error message that was displayed on 
screen during the activation process.

There is no email creation facility available because no Broadcast Agent has been defined 
in the Supervisor. (PUB0076)

Cause You tried to start the Publication Creation Wizard without defining a Broadcast 
Agent.

Action Create a Broadcast Agent in SUPERVISOR and enable it in the BROADCAST AGENT 
Administrator Console.

There is no email creation facility available because no Broadcast Agent has been defined 
in the Supervisor. (PUB0077)

Cause At some point after your publication was created, the Broadcast Agent used to 
send it was deleted. When you try to update the publication, there is no Broadcast 
Agent available.

Action Create a Broadcast Agent in SUPERVISOR and enable it in the BROADCAST AGENT 
Administrator Console.
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There is no email creation facility available because no email server profile has been 
defined in the Recipient Manager. (PUB0078)

Cause You tried to start the Publication Creation Wizard without defining an email 
server profile.

Action Create an email server profile in the BROADCAST AGENT PUBLISHER MAIL 
COMPONENT Recipient Manager.

There is no email creation facility available because no email server profile has been 
defined in the Recipient Manager. (PUB0079)

Cause At some point after your publication was created, the email server profile used to 
send it was deleted. When you try to update the publication, there is no email 
server profile available.

Action Create an email server profile in the BROADCAST AGENT PUBLISHER MAIL 
COMPONENT Recipient Manager.

You must select the Yes radio button before you can save a delivery rule. (PUB0080)

Cause You have not selected the radio button that enables you to save delivery rule 
information.

Action Click on the Yes radio button and save the delivery rule.

Please enter the name of the delivery rule. (PUB0081)

Cause You cannot save a delivery rule that has no name defined.

Action Enter a name for the delivery rule.
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Please enter the formula for the delivery rule. (PUB0082)

Cause You cannot save a delivery rule that has no formula defined.

Action Enter a formula for the delivery rule.

Please select a valid document. (PUB0083)

Cause No document has been selected.

Action You must select a document that is in the Corporate Documents lists.

Please select publication(s) to delete. (PUB0084)

Cause No publication has been selected for deletion.

Action Select one or more publications to delete.

Please enter an attachment name. (PUB0085)

Cause You have not entered an attachment name.

Action Enter an attachment name.

Please enter the path and name of the file you want to attach. (PUB0089)

Cause No path and name have been entered.

Action Enter the path and name of the file you want to attach.
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Please enter a report layout name. (PUB0090)

Cause No report layout name has been entered.

Action Enter the report layout name you want to add.

You must enter a subject for this publication before continuing. (PUB0094)

Cause You have not entered a subject.

Action Enter a subject to continue.

You must save a subject for this publication before continuing. (PUB0095)

Cause You have not saved a subject.

Action Click Save to continue.

Please select a body element to delete. (PUB0096)

Cause You have not selected a body element to delete.

Action Click on the body element to delete.

Please select a body element to delete or to move. (PUB0097)

Cause You have not selected a body element to delete or move.

Action Click on the body element to delete or move.
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Please select an attachment to modify. (PUB0098)

Cause You have not selected an attachment to modify.

Action Click on the attachment to modify.

Please select an attachment element to modify. (PUB0099)

Cause You have not selected an attachment element to modify.

Action Click on the attachment element to modify.

Please select an attachment element to delete. (PUB0100)

Cause You have not selected an attachment element to delete.

Action Click on the attachment element to delete.

Please select a filter element to modify. (PUB0101)

Cause You have not selected a filter element to modify.

Action Click on the filter element to modify.

Please select a filter element to delete. (PUB0102)

Cause You have not selected a filter element to delete.

Action Click on the filter element to delete.
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Please select a variable to modify. (PUB0103)

Cause You have not selected a variable element to modify.

Action Click on the variable element to modify.

Please select a variable element to delete. (PUB0104)

Cause You have not selected a variable element to delete.

Action Click on the variable element to delete.

Please enter a variable name. (PUB0105)

Cause You have not entered a variable name.

Action Enter a variable name.

There is no data provider in the document selected. (PUB0106)

Cause No data provider was specified to get the Dynamic Recipient List in the 
document you have associated with the publication. 

Action If you create a publication for dynamic recipients, you need to specify a data 
provider that contains the list of recipients.
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Please select a data provider. (PUB0107)

Cause You have not selected a data provider.

Action Select a data provider to continue.

The data provider selected has no lines, so it is impossible to retrieve the names of the 
objects. (PUB0108)

Cause As explained above.

Action Do the following:

• Fetch the lines in the data provider you want to select.

• Make sure BUSOBJ is running on the server.

• Make sure you can open and refresh the document in INFOVIEW. 

Please select an object for the email address. (PUB0109)

Cause No object has been selected for the email address.

Action Select an object for the email address to continue.
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The data provider selected has no lines, so it is impossible to retrieve the names of the 
objects. (PUB0110)

Cause As explained above.

Action Do the following:

• Fetch the lines in the data provider you want to select.

• Make sure BUSOBJ is running on the server.

• Make sure you can open and refresh the document in INFOVIEW. 

Please select an object for the recipient name. (PUB0111)

Cause No object has been selected for the recipient name.

Action Select an object for the recipient name.

An error occurred while deleting the schedule. (PUB0112)

Cause As explained above.

Action Check the connection to the database. Log out of and back into INFOVIEW.

There is no default schedule set in the publication. (PUB0113)

Cause As explained above.

Action Set a default schedule for the publication. If no schedule has been created, please 
make one.
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An error occurred while creating the schedule. (PUB0114)

Cause As explained above.

Action Check the connection to the database. Log out of and back into INFOVIEW.

Schedule name already exists. Please choose a new name. (PUB0115)

Cause As explained above.

Action Select another name to continue.

You must deactivate the publication before deleting the schedule. (PUB0116)

Cause You cannot delete a schedule if the publication is activated.

Action Deactivate the publication and delete the schedule.

You must deactivate the publication before changing the default schedule. (PUB0117)

Cause You cannot change the default schedule if the publication is activated.

Action Deactivate the publication and change the default schedule.
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Invalid character entered in the name of the publication. Do not use / \ ? : * “ < > and |. 
(PUB0118)

Cause You have entered an invalid character in the publication name.

Action Do not use the characters / \ ? : * “ < > and |.

Please select a Broadcast Agent server. (PUB0119)

Cause No Broadcast Agent has been selected for the current publication.

Action Select a Broadcast Agent.

Please select an email server profile. (PUB0120)

Cause No email server has been selected for the current publication.

Action Select an email server profile.

Please select a recipient type. (PUB0121)

Cause No recipient type has been selected for the current publication.

Action Select a recipient type.
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You must enter an email address to send the test email to. (PUB0122)

Cause You have not entered an email address to send the test to.

Action Enter an email address.

You must enter a positive number in the field ‘Number of recipients to test’. (PUB0123)

Cause You have not entered a positive number in the field “Number of recipients to 
test.”

Action Enter a positive number in the field.

Please enter the schedule name. (PUB0124)

Cause No schedule name has been entered.

Action Enter a schedule name.

Invalid character entered in the name of the publication. Do not use / \ ? : * “ < > and |. 
(PUB0125)

Cause You have entered an invalid character in the publication name.

Action Do not use the characters / \ ? : * “ < > and |.
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Please select at least one mandatory or optional recipient to continue. (PUB0126)

Cause You have not selected a recipient for the publication.

Action Select at least one recipient.

No recipients selected in the left list box. (PUB0127)

Cause You cannot move a recipient to the optional list box if you do not first select it in 
the recipient list box.

Action Select a recipient first.

No recipients selected in the bottom right list box. (PUB0128)

Cause You cannot move a recipient from the optional list box if you do not first select it 
in the recipient list box.

Action Select a recipient first.

No recipients selected in the top right list box. (PUB0129)

Cause You cannot move a recipient from the mandatory list box to the optional list box 
if you do not select it.

Action Select a recipient first.
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No recipients selected in the top right list box. (PUB0130)

Cause You cannot remove a recipient from the mandatory list box if you do not select it.

Action Select a recipient first.

No recipients selected in the left list box. (PUB0131)

Cause You cannot remove a recipient from the mandatory list box if you do not select it.

Action Select a recipient first.

No recipients selected in the bottom right list box. (PUB0132)

Cause You cannot remove a recipient from the optional list box if you do not select it.

Action Select a recipient first.

Publication name already exists. (PUB0133)

Cause The publication name entered already exists.

Action Enter a publication name that does not already exist.

Invalid character entered in the variable name. Do not use < or >. (PUB0134)

Cause You have entered the characters < or >.

Action Remove the characters < or >.
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You are not the owner of the publication XXX, so you cannot activate it. (PUB0135)

Cause You have tried to activate a publication that you did not create. BROADCAST 
AGENT PUBLISHER MAIL COMPONENT does not allow you to do this.

Action Copy the publication to a new name. Since you are the owner of this new 
publication, you can now activate it.

Cannot retrieve the document associated with the publication. (PUB0136)

Cause You have tried to activate a publication that you did not create. BROADCAST 
AGENT PUBLISHER MAIL COMPONENT does not allow you to do this.

Action Copy the publication to a new name. Since you are the owner of this new 
publication, you can now activate it.

Internal error while opening document. (PUB0137)

Cause You cannot open the document associated with this publication.

Action Do the following:

• Log out of and back into INFOVIEW. 

• Verify that you can open that document in INFOVIEW.

• Verify that the BUSOBJ processes are present.

• Verify your document domain.
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Internal error while retrieving the report list. (PUB0138)

Cause You cannot open the document associated with this publication.

Action Do the following:

• Log out of and back into INFOVIEW. 

• Verify that you can open that document in INFOVIEW.

• Verify that the BUSOBJ processes are present.

• Verify your document domain.

Please enter the URL of the WebIntelligence Server. (PUB0139)

Cause You have not entered the URL of the WEBINTELLIGENCE server.

Action Enter the URL pointing to the WEBINTELLIGENCE server.

Impossible to create the Mistools Object. Please check that Mistools.dll is has been 
registered. (PUB0140)

Cause The component Mistools.dll has not been correctly installed.

Action Do the following:

• Launch Setup in the Start menu to see if the component has finished 
installation.

• Uninstall and reinstall Setup.

• You can manually register the Mistools.dll file using the regsrv32.exe 
program.

• Check with the report BCAPubCheck.rep to verify which components are 
installed.
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Impossible to create the MBC Object. Please check that MBC.dll is has been registered. 
(PUB0141)

Cause The component MBC.dll has not been correctly installed.

Action Do the following:

• Launch Setup in the Start menu to see if the component has finished 
installation.

• Uninstall and reinstall Setup.

• You can manually register the MBC.dll file using the regsrv32.exe program.

• Check with the report BCAPubCheck.rep to verify which components are 
installed.

Broadcast Agent Publisher mail component cannot use documents that are set to refresh on 
open. Please update this document property. (PUB0150)

Cause The document you are trying to publish is set to refresh on open.

Action Update the document properties so that it is not set to refresh on open.

Please enter an = symbol at the beginning of the formula. (PUB0151)

Cause Your formula does not begin with an = symbol.

Action Enter an = symbol at the beginning of the formula.
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You must select a recipient before you can activate the publication. (PUB0152)

Cause You tried to activate a publication that contains no recipients.

Action Select at least one recipient to activate publication.

Please select a document to associate with your publication. (PUB0153)

Cause You have not selected a document to associate with your publication.

Action Select a document to associate with your publication.

Please enter a number for the minute between 0 and 59. (PUB0154)

Cause You have entered a number for the minute that is not between 0 and 59, or you 
have not entered any value.

Action Enter a number for the minute between 0 and 59.

Please enter a number for the year between 1970 and 2030. (PUB0155)

Cause You have entered a number for the year that is not between 1970 and 2030, or you 
have not entered any value.

Action Enter a number for the year betwee 1970 and 2030.
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Please enter a number for the Every between 1 and 99. (PUB0156)

Cause You have entered a number for the Every that is not between 1 and 99, or you 
have not entered any value.

Action Enter a number for the Every between 1 and 99.

Please enter a number for the Minute(s) after the hour between 0 and 59. (PUB0157)

Cause You have entered a number for the Minute(s) after the hour that is not between 0 
and 59, or you have not entered any value.

Action Enter a number for the Minute(s) after the hour between 0 and 59.

Cannot retrieve any object from the data provider. (PUB0158)

Cause Your data provider does not contain any objects. This may be due to a problem 
with the document or with your WEBINTELLIGENCE installation.

Action Contact Business Objects Customer Support.

There is no object in the data provider. To retrieve the object name, you need to have some 
lines in the data provider. (PUB0159)

Cause Your data provider does not contain any objects. This may be due to a problem 
with the document or with your WEBINTELLIGENCE installation.

Action Contact Business Objects Customer Support.
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Invalid character entered in the variable name. Do not use < or >. (PUB0160)

Cause You have entered the characters < or > in the variable name.

Action Remove the characters < or >.
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Web Publication Error Messages

This section describes the error messages that may occur when you work with 
web publications.

Web publication error messages range from BAW0012 to BAW0044.

User report list is empty (BAW0012)

Cause No reports have been sent to this user through BROADCAST AGENT Publisher.

Action Before a user can view a document, it must be sent to the user in the form of a 
publication from BROADCAST AGENT Publisher web component. For an 
explanation of how to create and send publications, see the Broadcast Agent 
Publisher User's Guide.

Cannot connect to remote report manager (BAW0013)

Cause BROADCAST AGENT Publisher is unable to connect to one or more server machines 
in the cluster.

Action Check that your network is functioning correctly, and that you can ping all the 
servers in the cluster from the BROADCAST AGENT Scheduler server.

If necessary, reboot any server machine(s) that are not responding.



 Broadcast Agent Publisher mail component Error Messages

634 Error Message Guide

Cannot convert date format (BAW0014)

Cause BROADCAST AGENT Publisher can handle several types of calendar data. It 
recognizes any of these formats, and converts them automatically into its own 
internal date format. 

However, BROADCAST AGENT Publisher does not understand your document's 
date format.

This may be because you are using a non-standard date format, or because the 
document is corrupted.

Action Try converting your date field into a different format, such as a format using only 
numbers rather than text for the names of the months.

Check that you can access the document correctly from BUSINESSOBJECTS. 

Use SUPERVISOR to run a Scan and Repair operation on the repository.

Report cannot be found in the repository (BAW0015)

Cause BROADCAST AGENT Publisher cannot find the requested document in the 
repository. This may be because the document has been deleted, or because its 
name has been changed, or because the repository has become corrupted.

Action Check that the document name is spelled correctly.

Check that the document exists in the repository, using BUSINESSOBJECTS or 
SUPERVISOR.

Use SUPERVISOR to run a Scan and Repair operation on the repository.
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User cannot see requested report instance (BAW0016)

Cause The document requested is not available for this user. This may be due to security 
restrictions, or because of corruption in the repository.

Action Check that the user has the security privileges required to access the specified 
document.

If necessary, use SUPERVISOR to run a Scan and Repair operation on the database, 
following the instructions in the Supervisor's Guide.

Missing processing status from database xml (BAW0017)

Cause BROADCAST AGENT Publisher cannot find a part of the information expected 
within the database. This may be because the server process was interrupted 
during processing, or because the database has become corrupt.

Action Try repeating the action.

If this fails, use Supervisor to run a Scan and Repair operation on the database, 
following the instructions in the Supervisor's Guide.

Cannot find the required information in the database reply (BAW0018)

Cause BROADCAST AGENT Publisher cannot find a part of the information expected 
within the database. This may be because the server process was interrupted 
during processing, or because the database has become corrupt.

Action Try repeating the action.

If this fails, use SUPERVISOR to run a Scan and Repair operation on the database, 
following the instructions in the Supervisor's Guide.
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A property value is not stored in the database (BAW0019)

Cause BROADCAST AGENT Publisher cannot find a part of the information expected 
within the database. This may be because the server process was interrupted 
during processing, or because the database has become corrupt.

Action Try repeating the action.

If this fails, use SUPERVISOR to run a Scan and Repair operation on the database, 
following the instructions in the Supervisor's Guide.

Image file cannot be found (BAW0020)

Cause A graphic image file is referenced within a document. However, the file is not 
stored at the specified location.

Action Examine the document to determine the name and location specified for the 
image file.

Search for the file in other locations on your network, and, if you find it, either 
copy the file to the specified location, or change the specified location to point to 
a location where the file currently exists.

If you cannot find the file, either recreate it yourself, or delete the reference to it 
from your document.
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HTML file cannot be found (BAW0021)

Cause An HTML file is referenced within a document. However, the file is not stored at 
the specified location.

Action Examine the document to determine the name and location specified for the 
HTML file.

Search for the file in other locations on your network, and, if you find it, either 
copy the file to the specified location, or change the specified location to point to 
a location where the file currently exists.

If you cannot find the file, either recreate it yourself, or delete the reference to it 
from your document.

License limit reached (BAW0022)

Cause The license you have purchased enables your BROADCAST AGENT Publisher 
deployment to run up to a limited number of users, servers, and/or documents 
at any one time. You are currently using the maximum permitted number of 
these resources, and a request for more resources has therefore been denied.

Action Wait until a less busy time of day to perform your task. 

Consult your Business Objects vendor for more information about extending 
your license.

Passwords do not match (BAW0023)

Cause The password you have entered in the Confirm Password field is different from 
the password in the Password field.

Action Retype the password correctly. The entry in the Confirm Password field must be 
identical to the entry in the Password field.
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The field requires a numeric value (BAW0024)

Cause You have entered a text value into a field that must contain a number.

Action Enter a number into the field. Numeric values can contain only numeric 
characters ("0"-"9"), the minus sign ("-"), and the decimal point (".").

A field has been left blank (BAW0025)

Cause You have not entered a value into a field that requires a value.

Action Enter a value in all the required fields to complete the form. Note that in most 
forms within BROADCAST AGENT Publisher, there is a "*" symbol next to all the 
required fields.

Field value already in use (BAW0027)

Cause The field must contain a unique value. The value you have entered is the same as 
a value of this field in another record, and is therefore not unique.

Action Enter a new value which does not appear in this field in another record.

Not an administrator (BAW0028)

Cause The action you have requested requires administrator rights, but your user 
account does not have administrator rights.

Action Contact a user who has administrator rights, and ask him/her to perform the 
action on your behalf, or assign administrator rights to your user account.
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The document already exists in the group (BAW0029)

Cause You are attempting to add a document to a group, but the document is already 
assigned to the group.

Action No action is required, since the document is already in the group.

Document name already in use. Enter a different name. (BAW0030)

Cause You are trying to enter a document with the same name as an existing document. 
This is not permitted, since document names must be unique.

Action Choose a different, and unique, name for your document.

Profile already exists (BAW0031)

Cause The profile you are attempting to create already exists.

Action No action is required, since the profile already exists. You can proceed to define 
the profile values for your users.

Groups containing users cannot be deleted (BAW0032)

Cause You are attempting to delete a group that contains one or more users. This is not 
pemitted.

Action Remove the users from the group, either by deleting them or by moving them to 
other groups.

Then delete the empty group.
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Users cannot be removed from the default group (BAW0033)

Cause You are attempting to remove a user from the default group, but this is not 
permitted. 

All users belong to the default group in BROADCAST AGENT Publisher web 
component. The only way to remove users from this group is to delete them from 
the system. 

However, users may belong to multiple groups, and their main group can be the 
default group or any other group.

Action Either delete the user from the system, or add them to other groups. You can also 
change the user's main group.

Users cannot be removed from their main group. You must assign another group as the main 
group. (BAW0034)

Cause You are trying to remove a user from a group. However, the group is the user's 
main group, and so the operation is not permitted.

Action First, choose which group you would like to be the user's main group. 

Then make the user a member of this group, and select the Is Main Group check 
box.

You can now remove the user from the group which was previously the user's 
main group.

For more information about groups and main groups, see the Broadcast Agent 
Publisher Administrator's Guide.
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Incompatible operator (BAW0035)

Cause The operator you have selected is not compatible with the specified operation. 

The operators Equal To and Not Equal To can only take one value.

Action Select a valid operator.

If you want to use more than one value, use the In List or Not In List operators 
instead of Equal To or Not Equal To.

User name already exists. Please enter a different name. (BAW0036)

Cause Every user name within BROADCAST AGENT Publisher must be unique.

You are trying to create a new user, but the name you have specified is that of an 
existing user.

Action Select a unique name for the new user, and try again.

User already exists in group (BAW0037)

Cause You are trying to add a user to a group, but the user is already a member of the 
group.

Action No action is required, since the user is already a member of the specified group.
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Cannot delete a category that contains documents (BAW0038)

Cause In BROADCAST AGENT Publisher, categories that contain documents cannot be 
deleted.

Action First, move all the documents in this category into other categories.

Then delete the empty category.

Malformed XML data returned from database (BAW0039)

Cause The XML data returned from the database is not correctly formatted. This could 
be due to database corruption, or due to an internal software error.

Action Use SUPERVISOR to run a Scan and Repair operation on the repository, as 
described in the Supervisor's Guide.

Repeat the operation that resulted in the error. If the error still occurs, contact 
Business Objects customer support.

Online Report Server connection error (BAW0040)

Cause The connection to the report server has failed. This may be due to a network error, 
or because the report server machine is down.

Action Check the network connection between the BROADCAST AGENT server and the 
report server. 

If necessary, reboot the report server.
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Online Report Server replied with unrecognizable data (BAW0041)

Cause The report server has returned corrupted data. This may be due to a network 
error, or because the report server machine has become unstable.

Action Check the network connection between the BROADCAST AGENT server and the 
report server. 

If necessary, reboot the report server.

Problem creating Broadcast Agent Publisher report data (BAW0042)

Cause BROADCAST AGENT Publisher is unable to complete the report bursting task. This 
may be due to lack of RAM or disk space on the server, or may be because the 
data is corrupted.

Action Check that the document has not become corrupt by opening it in 
BUSINESSOBJECTS. If necessary, restore the document from a backup.

Check that the server has sufficient free disk space.

If the report is very large, consider increasing the amount of RAM on your server.

 User does not have the privileges necessary for this operation. (BAW0043)

Cause The user does not have the security rights needed to perform the action.

Action Contact your administrator to request the security privileges you need.
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Invalid or unrecognized information returned from database (BAW0044)

Cause The data returned from the database is not correctly formatted. This could be due 
to database corruption, or due to an internal software error.

Action Use SUPERVISOR to run a Scan and Repair operation on the repository, as 
described in the Supervisor's Guide.

Repeat the operation that resulted in the error. If the error still occurs, contact 
Business Objects customer support.
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My Subscriptions Page Error Messages

This section describes the error messages that may occur when you use the My 
Subscriptions page through INFOVIEW.

My Subscriptions page error messages range from MYS0001 to MYS0011.

Cannot access the Broadcast Agent Publisher mail component tables. (MYS0001)

Cause BROADCAST AGENT PUBLISHER MAIL COMPONENT pages could not find the MKEY 
file on the server, or the connection in the MKEY is not pointing to a repository 
that contains BROADCAST AGENT PUBLISHER MAIL COMPONENT tables.

Action See the Broadcast Agent Publisher mail component Administrator’s Guide to create an 
MKEY file, then copy the correct MKEY file on the server. Verify that the MKEY 
file is unique, and is called “Bomain.MKEY.”

Cannot retrieve the “WebIntelligenceSession” cookie. (MYS0002)

Cause The WEBINTELLIGENCE cookie is either not valid or out of date.

Action Make sure that your browser accepts cookies. Log out of INFOVIEW to initialize a 
new session cookie.

Problem retrieving the Infoview session. (MYS0003)

Cause An error occurred retrieving the correct INFOVIEW session. This could be due to 
the time out of your session.

Action Log out. Make sure that your browser accepts cookies.
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Cannot reach the repository database. (MYS0004)

Cause The problem has one of the following causes:

• The connection to the server does not work.

• BROADCAST AGENT PUBLISHER MAIL COMPONENT pages could not find the 
MKEY file.

• The server or the connection in the MKEY file is not pointing to a repository 
that contains BROADCAST AGENT PUBLISHER MAIL COMPONENT tables. 

Action Do the following:

• Check your database connection.

• See the Broadcast Agent Publisher mail component Administrator’s Guide to create 
an MKEY file, then copy the correct MKEY file on the server. Verify that the 
MKEY file is unique, and is called “Bomain.MKEY.”

You do not have the rights to use this feature. (MYS0005)

Cause The user has no rights to access My Subscriptions pages.

Action The user is not synchronized in the Recipient Manager to have access to the My 
Subscriptions page. The user has no publisher rights. Please refer to Broadcast 
Agent Publisher mail component Administrator’s Guide to set up the correct rights 
according to his or her profile.

An error occurred while saving preferences. (MYS0006)

Cause The component cannot save the preferences.

Action Log out of and back into INFOVIEW. Verify your connection.
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The WebIntelligence server is not running. (MYS0007)

Cause The WEBINTELLIGENCE server has been shut down.

Action Run the WEBINTELLIGENCE server.

An error occurred while saving new settings. (MYS0008)

Cause The component cannot save the settings.

Action Log out of and back into INFOVIEW. Verify your connection.

Database connection errors have occurred. Please contact your BusinessObjects 
Administrator. (MYS0009)

Cause The component cannot connect to the database.

Action Log out of and back into INFOVIEW. Verify your connection.
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Impossible to create the Mistools Object. Please check that Mistools.dll is has been 
registered. (MYS0010)

Cause The component Mistools.dll has not been correctly installed.

Action Do the following:

• Launch Setup in the Start menu to see if the component has finished 
installation.

• Uninstall and reinstall Setup.

• You can manually register the Mistools.dll file using the regsrv32.exe 
program.

• Check with the report BCAPubCheck.rep to verify which components are 
installed.

Impossible to create the MBC Object. Please check that MBC.dll is has been registered. 
(MYS0011)

Cause The component MBC.dll has not been correctly installed.

Action Do the following:

• Launch Setup in the Start menu to see if the component has finished 
installation.

• Uninstall and reinstall Setup.

• You can manually register the MBC.dll file using the regsrv32.exe program.

• Check with the report BCAPubCheck.rep to verify which components are 
installed.
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External User My Subscriptions Error Messages

This section describes the error messages that may occur when an external user 
uses his or her My Subscriptions page.

External user My Subscriptions page error messages range from EXT0001 to 
EXT0011.

Cannot access the Broadcast Agent Publisher mail component tables. (EXT0001)

Cause BROADCAST AGENT PUBLISHER MAIL COMPONENT pages could not find the MKEY 
file on the server, or the connection in the MKEY is not pointing to a repository 
that contains BROADCAST AGENT PUBLISHER MAIL COMPONENT tables.

Action See the Broadcast Agent Publisher mail component Administrator’s Guide to create an 
MKEY file, then copy the correct MKEY file on the server. Verify that the MKEY 
file is unique, and is called “Bomain.MKEY.”

You do not have the rights to use this feature. (EXT0002)

Cause The user has no rights to access My Subscriptions pages.

Action The user is not synchronized in the Recipient Manager to have access to the My 
Subscriptions page. The user has no publisher rights. Please refer to Broadcast 
Agent Publisher mail component Administrator’s Guide to set up the correct rights 
according to your profile.
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An error occurred while saving preferences. (EXT0003)

Cause The component cannot save the preferences.

Action Log out of and back into INFOVIEW. Verify your connection.

An error occurred while saving new settings. (EXT0004)

Cause The component cannot save the settings.

Action Log out of and back into INFOVIEW. Verify your connection.

Database connection errors have occurred. Please contact your BusinessObjects 
Administrator. (EXT0005)

Cause The component cannot connect to the database.

Action Log out of and back into INFOVIEW. Verify your connection.



v 5.1-2.7

 Error Message Guide 651

Impossible to create the Mistools Object. Please check that Mistools.dll is has been 
registered. (EXT0010)

Cause The component Mistools.dll has not been correctly installed.

Action Do the following:

• Launch Setup in the Start menu to see if the component has finished 
installation.

• Uninstall and reinstall Setup.

• You can manually register the Mistools.dll file using the regsrv32.exe 
program.

• Check with the report BCAPubCheck.rep to verify which components are 
installed.

Impossible to create the MBC Object. Please check that MBC.dll is has been registered. 
(EXT0011)

Cause The component MBC.dll has not been correctly installed.

Action Do the following:

• Launch Setup in the Start menu to see if the component has finished 
installation.

• Uninstall and reinstall Setup.

• You can manually register the MBC.dll file using the regsrv32.exe program.

• Check with the report BCAPubCheck.rep to verify which components are 
installed.
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BCA Pub Error Messages

This section describes the error messages that may occur due to incomplete or 
incorrect data in the BCA Pub.rep file that BROADCAST AGENT PUBLISHER MAIL 
COMPONENT sends as a task to the Broadcast Agent for each publication. See back 
page for more details.

BCA Pub error messages range from BPB0001 to BPB0011.

You do not have any email servers configured. (BPB0001)

Cause The component could not retrieve the email server configuration.

Action Make sure that you have an email server defined in your publication properties. 
You can do this from the Publication Definition page.

Cannot create the mailer component. (BPB0002)

Cause Cannot create the mailer component.

Action Make sure that the mailer components are installed. Launch BROADCAST AGENT 
PUBLISHER MAIL COMPONENT Setup to see if the components have finished being 
installed. You need to install the Broadcast Agent Extension Component on every 
node that could execute the task. Make sure that you have an email server defined 
in your publication properties. You can do this from the Publication Definition 
page.

Cannot retrieve email server from repository. (BPB0003)

Cause The component could not retrieve the email server configuration.

Action Make sure that you have an email server defined in your publication properties. 
You can do this from the Publication Definition page.
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Cannot retrieve data for this publication. (BPB0004)

Cause The component could not fetch the data for this publication.

Action Make sure that your publication is activated. If it is not activated, delete the task 
contained in the BROADCAST AGENT Administrator console.

Test email address is invalid or empty. (BPB0005)

Cause The component could not fetch the data for the test email configuration.

Action Enter the correct email configuration.

An error occurred with at least one recipient while sending the email. (BPB0006)

Cause The mailer component could not send the email to one or more recipients.

Action Check that you can send an email from the node where your publication task was 
executed and that the recipient’s email address is compatible with the mailer you 
selected.

IDSUB is not a number. (BPB0007)

Cause An error occurred retrieving the subscription ID.

Action Rename your publication.
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IDSCHED is not a number. (BPB0008)

Cause An error occurred retrieving the subscription ID.

Action Rename your publication.

Cannot access the following external file: XXX. (BPB0009)

Cause BROADCAST AGENT could not access the specified file in the attachment.

Action Do the following:

• Make sure the attached file is correct and accessible from all BROADCAST 
AGENT nodes.

• Make sure the local NT administrator chosen to install WEBINTELLIGENCE and 
BROADCAST AGENT has the right to that file on the network. You can check the 
chosen local administrator using servconf.exe.

Either no recipients have been assigned to the chosen schedule, or the publication 
document has been deleted from Corporate Documents. (BPB0010)

Cause 1 You have not assigned any recipients to the chosen schedule.

Action Assign at least one recipient to the schedule.

Cause 2 The document you have chosen for publication has been deleted from Corporate 
Documents.

Action Choose another document.
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Data provider export failed. (BPB0011)

Cause An error occured while exporting the data provider.

Action Check that the data provider can be exported.



 Broadcast Agent Publisher mail component Error Messages

656 Error Message Guide



 Error Message Guide 657

  Chapter 13 WebIntelligence
Error Messages

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

In this chapter 

 ❑ WebIntelligence Error Messages 646



 WebIntelligence Error Messages

658 Error Message Guide

WebIntelligence Error Messages

WEBINTELLIGENCE error messages fall into these categories:  

Range Category

WI0003 - WI0005 Dispatcher

WI0100 - WI0105 HSAL

WI0202 - WI0204 Session

WI0300 - WI0315 Generator

WI0500 - WI0507 wiqt

WI0600 - WI0601 Report Generator
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Could not get the authentication mode. (WI0003)

Cause 1 The SessionManager is not running. One of the most important modules in the 
WEBINTELLIGENCE system, the SessionManager tracks user activity from the time 
users log in until they log out. It interacts with the Dispatcher module to provide 
an authentication method, a process for identifying users and controlling the 
resources users can access.

The SessionManager is installed on the cluster manager of the WEBINTELLIGENCE 
system.

Action Check to see whether the process WISessionManager.exe is running from the 
Windows NT Task Manager. If it does not appear on the list of tasks:

1. Launch BusinessObjects Services Administrator. 

BusinessObjects Services Administrator

2. Select SessionManager on the cluster manager on the Host or Report page.

3. Modify the parameters as desired.

4. Click the Apply button.



 WebIntelligence Error Messages

660 Error Message Guide

Cause 5 The authentication mode was not correctly synchronized between the 
WEBINTELLIGENCE system and the Web server in use. 

WEBINTELLIGENCE allows four authentication modes:

• NT Challenge/Response

• Basic authentication

• BusinessObjects standard

• No authentication

Action To configure your WEBINTELLIGENCE system to use an authentication mode, you 
must carry out three tasks:

• Select the appropriate authentication method for the Web server in use; for 
example, Microsoft’s Internet Information Service (IIS). By default, the options 
Anonymous Access and Windows NT Challenge/Response are selected.

• Select the appropriate authentication mode parameter from the 
SessionManager module of the WEBINTELLIGENCE Administrator, and apply. 

• Set up the account information for each WEBINTELLIGENCE user from  
SUPERVISOR.

For more information on WEBINTELLIGENCE and authentication modes, refer to 
Chapter 7, “Using the BusinessObjects Services Administrator” of the 
WebIntelligence System Administrator’s Guide.
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Unable to load the properties.  (WI0004)

Cause The config file for the Dispatcher module may have been damaged or deleted. 
This file is located in:

Business Objects\Server\WebIntelligence\WIDispatch

Action You can regenerate the config file from the Dispatcher module of BusinessObjects 
Services Administrator by setting the required parameters and clicking the 
Apply button.  

The parameters of the Dispatcher module.



 WebIntelligence Error Messages

662 Error Message Guide

Unable to invoke the DII request. (WI0005)

Cause 1 The CORBA call did not work.

Action Stop the Web server and entire WEBINTELLIGENCE system, then restart them.

Cause 2 There is a problem in the syntax of the URL.

Action Check the syntax from the URL.

This page is empty. (WI0100)

Background  This is a generic error which can arise in a number of situations. It may be caused 
by a complex query or by a BUSINESSOBJECTS report that generates results 
exceeding the capacity of your hardware.

How to trace the error from WebIntelligence

1. Log into BusinessObjects Services Administrator using your Windows NT 
login.

2. Turn the Internal Trace button on in the following modules: 
WIGenerator
WISessionManager
WIDispatcher
These parameters are persistent, which means that they are not reset if you 
stop and restart the WEBINTELLIGENCE server.

3. Log out of the Administrator.

4. Use WEBINTELLIGENCE until the error appears on the screen.

5. Open the error file called internal.log.
The file is located in Business Objects\Server\System 2.5\Bin.

6. Search for the cause(s) of the error in the file and implement the solution(s).

7. Log into the Administrator and switch off the internal trace in the three 
modules.
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How to trace the error from Java

If you are using Internet Explorer 4.x or higher, you may wish to trace Java 
communication as well. To do so:

1. Log into Internet Explorer.

2. Select View> Internet Options.

3. Click the Advanced tab.
The dialog box looks as follows: 

4. Under the section Java VM, make sure the option Java logging enabled is 
checked.
All Java transactions from then on are recorded in a file called javalog.txt. This 
file (usually located in the System folder) indicates whether there are Java-
related problems in your configuration.
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General Actions

• Restrict the amount of data that can be retrieved with a query.

• Apply one or more filters to the report to be generated.

• Stop the Web server and entire WEBINTELLIGENCE system, then restart them.

Specific Causes and Actions

The following is a non-exhaustive list of the possible causes for the “this page is 
empty” message and the recommended actions. Please contact Business Objects 
Customer Support for new or additional information regarding this error 
message.

Cause 1 The problem originates in your RDBMS. 

Action A database administrator can determine whether the error results from a 
limitation or restriction within the RDBMS.

Example The Oracle repository is busy thereby causing the WIQT process to stop. In the 
connection parameters (Advanced tab), you select the option Wait for resources. 
As a result, the WIQT process now waits for the repository rather than failing by 
default. This option is recommended for all Oracle repositories and for all the 
subsequent universe and document domains created.

Cause 2 The source of the error lies in your network configuration. 

Action A network administrator can investigate the network configuration to determine 
if it is the cause of the error.

Example There may be differences between the settings of the WEBINTELLIGENCE server 
(the cluster manager or a node) and the Ethernet switch: 10 Mb versus 100 Mb. Or 
the server may be set to full, while the Ethernet switch is set to half duplex.
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Cause 3 Any one of the CORBA processes in the WEBINTELLIGENCE system has timed out.

Action Stop the Web server and entire WEBINTELLIGENCE system, then restart them.

Cause 4 WEBINTELLIGENCE needs to create temporary folders on your computer but you 
have read-only privileges on the drive in which WEBINTELLIGENCE folders are 
installed.

Action A system or network administrator can grant you Change or Full Control 
privileges to the drive on which WEBINTELLIGENCE is installed.  

Cause 5 You attempted to run a query on a universe which contains one or more objects 
defined with incorrect SQL syntax. The syntax cannot be parsed and produces an 
error. You cannot run a query on a universe containing invalid objects.

Action A designer can modify the definition of all the objects in a universe.

You can view the SQL of the query from BUSINESSOBJECTS using the SQL Viewer. 
See the explanation given in Cause 7 for more details on this feature.

Example A State object (Illinois, Indiana) is incorrectly defined with syntax such as:

State = IL, IN

rather than the correct syntax:

State in (‘IL’, ‘IN’)

Cause 6 A restriction on the execution time of queries was set in the universe parameters 
from which you are trying to run a query. The restriction may be one of two 
parameters: Limit size of result set to x rows or Limit execution time to x minutes.

Action A universe designer or supervisor can set or remove such restrictions from 
DESIGNER or SUPERVISOR.
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Cause 7 The SQL of certain objects cannot be parsed as a result of restrictions set in 
SUPERVISOR.

Action You can view any restrictions set by the supervisor by editing the query from the 
Query Panel in BUSINESSOBJECTS and selecting the View SQL button.  

The SQL Viewer

This button displays the SQL corresponding to the query. You (or the database 
administrator) can then check the SQL for its validity, or cut and paste it into the 
native query tool of the RDBMS, then execute it. The RDBMS error code 
generated should reveal the SQL syntax error.
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Cause 8 The connection of the universe was defined with the parameter Use Business 
Objects user name and password. The user name and password specified do not 
match those already defined in the RDBMS.

Action The database administrator should ensure that all BUSINESSOBJECTS or 
WEBINTELLIGENCE users have a valid login to the underlying RDBMS. The 
administrator can check a login by logging into the RDBMS with the 
BUSINESSOBJECTS user name and password using the native SQL tool of the 
RDBMS.

Example For Oracle, the native SQL tool is SQL* Plus.

Cause 9 Incorrectly named .wqy files were copied to the corporate documents folder in 
WEBINTELLIGENCE.

This folder is located in:

Business Objects\Server\WebIntelligence 2.5\Storage\docs\Document

Action Replace any spaces with file names with a plus (+) sign.

Example Among your files, one is named Cust Name.wqy. Change it to Cust+Name.wqy.
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Cause 10 The connection of the universe is defined with an incorrect database engine.

Action A designer can edit the connection of the universe as follows:

1. Open the universe in DESIGNER.

2. Select File > Parameters.
The Universe Parameters dialog box appears.

3. Click the Edit button and check that the appropriate database engine is 
selected.

4. Modify the connection.

5. Re-export the universe to the repository.

6. Test the new connection by opening the universe from WEBINTELLIGENCE.

Cause 11 You are working with a repository which has a document domain that was 
created before version 5.0. In addition, the name of this document domain 
contains a space.

Action A supervisor should create a new document domain (with no spaces in its name) 
on a different database account. The connection of the new document domain 
should then be changed to point to the old database containing the old document 
domain.

Problem during processing of the query. (WI0101)

Cause This is an internal CORBA error.

Action Stop the Web server and entire WEBINTELLIGENCE system, then restart them.
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CORBA exception during processing of the query. (WI0102)

Cause This is an internal CORBA error.

Action Stop the Web server and entire WEBINTELLIGENCE system, then restart them.

If the problem persists, consult the system activity log for CORBA calls using the 
Business Objects Services Administrator (see “Tracing System Activity” in the 
WebIntelligence System Administrator’s Guide. Except for the WIStorageManager, 
all system modules contain a parameter called Internal Trace. This activates the 
internal trace for the module by recording its requests.

Problem during processing of the query. (WI0103)

Cause A generic system problem made it impossible to process the query you are 
working on.

Action Stop the Web server and entire WEBINTELLIGENCE system, then restart them.

CORBA exception during processing of the query. (WI0104)

Cause This is an internal CORBA error.

Action Stop the Web server and entire WEBINTELLIGENCE system, then restart them.
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WebIntelligence server is not ready. (WI0105)

Cause 1 You have not started the WEBINTELLIGENCE system.

Action You can start the WEBINTELLIGENCE system using:

• WebIntelligence Notify 

• the Start Menu

• the Services Control Panel

WEBINTELLIGENCE Notify is a utility that can be used to start and stop 
WEBINTELLIGENCE and check its status.

During installation, the WINotify.exe file was added to your machine’s Start 
menu. Whenever you log into Windows NT, the corresponding Notify icon 
appears in the status area at the far right of the Windows NT taskbar.

Right click the Notify icon on your task bar and from the pop-up menu select the 
Start WebIntelligence command. 

Cause 2 WEBINTELLIGENCE is started but you still received the above message. The 
problem is an internal CORBA error.

Action Stop the Web server and entire WEBINTELLIGENCE system, then restart them.

Cause 3 There is a conflict in the OSAgent port number (TCP/IP number) used by the 
CORBA services. There may be another machine on the network that has the 
same port number.

Action The OSAgent port number needs to be changed; however, because this number 
is defined as part of the installation process, please contact Business Objects 
Customer Support for more information.

Notify
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Login via generator call has caused an exception. (WI0202)

Cause The Generator module has either not been installed or activated. The Generator 
dynamically builds the HTML pages which allow each user to access the 
WEBINTELLIGENCE resources for which the user has access rights.

Action First check the BusinessObjects Services Administrator tool to view the Generator 
module:

• If the Generator does not appear, then you need to install it using the installer 
program.

• If the Generator appears but is disabled, then enable it.

If the Generator module is enabled but the problem persists, check for the 
WIGenerator.exe process in the Windows NT Task Manager. If this task does not 
appear, stop the Web server and entire WEBINTELLIGENCE system, then restart 
them.
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Login via generator call has caused an exception. (WI0203)

Cause The Generator module has either not been installed or activated. The Generator 
dynamically builds the HTML pages which allow each user to access the 
WEBINTELLIGENCE resources for which the user has access rights. 

Action First check the BusinessObjects Services Administrator tool to view the Generator 
module: 

• If the Generator does not appear, then you need to install it using the installer 
program.

• If the Generator appears but is disabled, then enable it.

If the Generator module is enabled but the problem persists, check for the 
WIGenerator.exe process in the Windows NT Task Manager. If this task does not 
appear, stop the Web server and entire WEBINTELLIGENCE system, then restart 
them.
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The login has returned an error code. (WI0204)

Cause 1 There may be a problem with the connection to the repository.

Action A supervisor can check and test the connection settings to the repository using 
SUPERVISOR.

Cause 2 There is a problem with the password you are using for one of the following 
reasons:

•  It is invalid.

• You have entered the wrong password more than three times; consequently, 
your user profile has been locked as a security precaution.

• Your user profile has been disabled from SUPERVISOR.

Action A supervisor can resolve problems relating to locked, forgotten, or disabled 
passwords.

Your profile does not allow you to overwrite other users’ document. (WI0300).

Cause You tried to publish (save) a document in the corporate repository which already 
contains a document with the same name. You are not authorized to overwrite 
this document.

Action You do not have the right to overwrite documents published by other users at 
your site. This may be a normal situation in which case there is nothing you can 
do about it.

However, a BUSINESSOBJECTS supervisor can change your user profile so that you 
can overwrite other users’ documents. Once the change has been made, you can 
log into WEBINTELLIGENCE and try publishing the document again.
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 Problem occurred during attempt to save the user options. (WI0301)

Cause 1 The user options file profile.txt is write-protected. 

This file is located on the node running the Storage Manager module in:

Business Objects\Server\WebIntelligence 2.5\Storage\user\(user_name)

Action Check that the profile.txt file is read-write.

Cause 2 The hard disk is full.

Action Check the capacity of the hard disk and reconfigure it if required. When you 
check the capacity of the disk drive, remember that the Windows NT virtual 
memory setting is dynamic in size. 

You can optimize the performance of the virtual memory by modifying the 
setting from the Control Panel > System > Performance > Virtual Memory.

Problem occurred during attempt to update the password. (WI0302)

Cause There is a problem in the connection settings to the repository. The repository 
settings cannot be modified.

Action A supervisor can check and test the repository connection settings as well as the 
user profile as set up in SUPERVISOR.
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Problem occurred during attempt to send the document. (WI0303)

Cause 1 There is a problem with the connection to the repository.

Cause 2 The database has reached a point of saturation.

Cause 3 The disk of the cluster node is full.

Action Check that all of the above resources are working correctly: 

• the connection

• the repository

• the database

If you suspect the database has reached a point of saturation, you can obtain 
a more specific RDBMS error message using the internal trace option available 
in the BusinessObjects Services Administrator tool.

• the cluster node

When you check the capacity of the disk drive, remember that the Windows 
NT virtual memory setting is dynamic in size. 
You can optimize the performance of the virtual memory by modifying the 
setting from the Control Panel > System > Performance > Virtual Memory.
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Problem occurred during attempt to publish the document. (WI0304)

Cause 1 There is a problem with the connection to the repository.

Cause 2 The database has reached saturation.

Cause 3 The disk of the cluster node is full.

Action Check that all of the above resources are working correctly: 

• the connection

• the repository

• the database

If you suspect the database has reached a point of saturation, you can obtain 
a more specific RDBMS error message using the internal trace option available 
in the BusinessObjects Services Administrator tool.

• the cluster node

When you check the capacity of the disk drive, remember that the Windows 
NT virtual memory setting is dynamic in size. 
You can optimize the performance of the virtual memory by modifying the 
setting from the Control Panel > System > Performance > Virtual Memory.

Problem occurred during attempt to save the document. (WI0305)

Cause There is a problem with the Storage Manager, which manages the cache of the 
WEBINTELLIGENCE system as well as the document storage areas. 

The Storage Manager stores two types of documents:

• Reports generated by Report Generator as .wqy files.

• Reports generated by the HTML Generator as .html files.

Action Check to see that the Storage Manager has been installed on at least one cluster 
node of the WEBINTELLIGENCE system and that this module is active. Then stop 
and restart the entire WEBINTELLIGENCE system.
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Properties update error (WI0308)

Cause 1 If your document belongs to a personal category, the hard disk of the server 
running the Storage Manager may be full.

Action Check the hard disk of the server running the Storage Manager if your document 
belongs to a personal category.

Cause 2 The connection to the repository is invalid.

Action A supervisor can check and test a connection to the repository.

Cause 3 The database is overloaded.

Action If you suspect the database has reached a point of saturation, you can obtain a 
more specific RDBMS error message using the internal trace option available in 
the BusinessObjects Services Administrator tool

Cause 4 There is a problem with one or more document attributes. Among such attributes 
are the document’s data provider, size, or category.

Action Inspect the various attributes of the document and try to identify if any of them 
are invalid.

The new password contains invalid characters. (WI0309)

Cause The password you attempted to enter contains restricted characters. Such 
characters are set by the supervisor from SUPERVISOR.

By default, a BUSINESSOBJECTS password can be made up of alphanumeric 
characters including a backslash (\), a hyphen (-), an underscore (_), or a dollar 
sign ($). BUSINESSOBJECTS passwords are case-sensitive.

Action Try entering a new password with different characters.
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No available universe (WI0310)

Cause 1 No universes exist. 

Cause 2 The universes exist but they have not yet been exported by the designer(s) to the 
universe domain of the repository.

Action For both of the above causes, see the BUSINESSOBJECTS designer or supervisor 
(that is, whoever is responsible for creating and exporting BUSINESSOBJECTS 
universes to the repository).

Cause 3 The personal universe list is out-of-date. It does not reflect the universes available 
to users.

Action Refresh the users’ list of universes. It is possible to force the update of this list 
each time a user starts a WEBINTELLIGENCE session by selecting the Refresh each 
session option in the Universe section of the user options.

Cause 4 Access rights to the universe have been removed in SUPERVISOR.

Action The supervisor can check whether the user should have access rights to the 
universe.

No document domain available (WI0311)

Cause No document domain has been created. The document domain is the area of the 
repository that contains the structures for storing shared BUSINESSOBJECTS 
documents and for executing tasks according to a timestamped definition.

Action See the BUSINESSOBJECTS supervisor, the person responsible for the deployment 
and administration of BUSINESSOBJECTS resources.
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This category does not exist. (WI0312)

Cause 1 No categories have been created.

Action Check that the category exists. See the InfoView User’s Guide for details on creating 
and using categories.

Cause 2 You have entered the name of the category incorrectly. Note that category names 
are case-sensitive.

Action If you entered (rather than selected) the name of the category, this time select it. 

The file name and/or path is not recognized. (WI0313)

Cause 1 You incorrectly typed in the path and/or file name in the edit field used to upload 
files.

Action Check the syntax for the file name and/or path and re-enter it necessary.

Or open the file directly from your browser. With Internet Explorer, select File > 
Open > Browse. With Netscape Communicator, select File > Open Page > Choose 
File.

Cause 2 The file was not found in the specified path. The file may not exist.

Action Specify an existing file.

Cause 3 The file is empty.

Action Select a file that is not empty.
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No host available to process your login (WI0314)

Cause You tried to log into WEBINTELLIGENCE but were not able to open a session. 
Opening a session requires a WIQT, which is provided by a WIGenerator. The 
problem may be any of the following:

• No WIGenerator is enabled over the cluster.

• Some WIGenerators are present but their Node Load Factor parameter is set 
to 0.

• Some WIGenerators are present, but none has the Enable Interactive 
Processing parameter set to On.

• Some WIGenerators are present but cannot be reached. 

The parameters of WIGenerator in the Business Objects Services Administrator tool
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Action First check the Business Objects Services administrator tool to view the 
WIGenerator module:

• If the WIGenerator does not appear, then you need to install it using the 
installer program.

• If the WIGenerator appears but is disabled, then enable it.

• Select the WIGenerator module from the Host or Report tab, then set the Node 
Load Factor parameter to a value other than 0, and click Apply. 

Note: You should set this value for each node with care, according to the 
capacities of each machine. This kind of fine-tuning can make an enormous 
difference in the overall performance of your system.

• Select the WIGenerator module, set the Enable Interactive Processing 
parameter to On, and click Apply.

If the WIGenerator module is enabled but the problem persists, check for the 
WIGenerator.exe process in the Windows NT Task Manager. If this task does not 
appear, stop the Web server and entire WEBINTELLIGENCE system, then restart 
them.

You cannot logon as your Administrator has put the WebIntelligence system offline. (WI0315)

Cause You tried to start a WEBINTELLIGENCE session, but cannot log in because the 
WEBINTELLIGENCE system has been stopped.

Action Ask the WEBINTELLIGENCE administrator to restart the system using the Business 
Objects Administrator tool.
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No data to fetch (WI0500)

Cause 1 The query is semantically incorrect; i.e. it makes no sense in terms of the universe 
that you are using.

Action Examine the components of your query, such as the conditions or filters, more 
closely to ascertain that they are semantically sound.

Try expanding the query to include more components so that it returns more 
data.  After you have done this, run the query once again.

Cause 2 Given the data available in the database, the query would yield no results.

Action See the database administrator for information on the database you are using.

Context problem. Please edit the report and click on Run Query button. (WI0501)

Cause The universe you are working with contains contexts. A context is a rule by which 
BUSINESSOBJECTS can decide which of two paths to choose when more than one 
path is possible from one table to another in the database. When a user runs a 
query from a universe containing contexts, BUSINESSOBJECTS prompts the user to 
indicate the correct perspective for the query.

Action You must edit the query and indicate the correct context. Then click the Run 
Query button to generate the report.
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You do not have the rights to refresh this document. Please contact your supervisor after 
updating to WebIntelligence version 2.5. (WI0502)

Cause 1 You have obtained this error messages and the following describes your work 
environment:

• You have updated to WEBINTELLIGENCE 2.5.

• You are working with a 5.0 repository.

• You can click a document from the personal folder and view the report.

• You are trying to edit a WEBINTELLIGENCE report.

A feature in BUSINESSOBJECTS 5.0 and WEBINTELLIGENCE 2.5 allows you to store 
documents in multiple repositories. However, if you attempt to read a document 
in a 5.0 repository that was not correctly exported from a 4.1.x repository, this 
error may occur.

Note: Before updating your repository, you should publish all your 
WEBINTELLIGENCE documents in the corporate documents part of the 4.1.x 
repository.

Action A General Supervisor can do the following:

1. Restore a back-up copy of the 4.1.x repository.
If you do not have a back-up, see the alternative actions described below.

2. Publish all your old WEBINTELLIGENCE reports in the corporate documents 
part of the 4.1.x repository.

3. From SUPERVISOR 5.0, perform a Safe Recovery from the 4.1.x repository.
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Alternative Actions

Here are two alternative actions if you do not have a back-up copy of your old 
repository:

Alternative 1
A General Supervisor can do the following:

1. Create a new 4.1.x repository and publish your old WEBINTELLIGENCE reports 
in this repository with the relevant universes.

2. Launch SUPERVISOR.

3. Perform a Safe Recovery (follow the steps below).

4. Import the list of users from your existing 5.0 repository.

Running a Safe Recovery

The following are the steps for performing a Safe Recovery in SUPERVISOR 5.0. 
They are intended for a user with a General Supervisor profile. It is necessary to 
first remove (or de-activate by renaming) the key file.

1. Launch SUPERVISOR with a General Supervisor profile.
The wizard appears.

2. Click the Begin button.

3. Click the Run a safe recovery option.

4. Define a connection to your restored 4.1.x repository only.

5. Click Next and follow the instructions of the wizard to perform a Safe 
Recovery.

6. Click Yes when you are prompted with the message “Your repository is an 
older version. Do you want to upgrade?”

7. Complete the steps in the wizard.

Alternative 2
You can re- create the reports using WEBINTELLIGENCE 2.5.
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Cause 8 The supervisor has disabled the universe on which the report was built for the 
user or for the group to which the user belongs.

Action A supervisor can do the following:

1. Launch SUPERVISOR.

2. Log into the repository used by the WEBINTELLIGENCE server.

3. Click the Universe tab.

4. Click your user symbol.

5. Right-click the universe, and select Enable Universe.

Note: The supervisor should check each instance of the user especially if the 
repository is large or complex and has duplicate users. To locate each instance of 
the user, the supervisor can select Edit > Find and enter the user name.

You do not have query rights! (WI0503)

Cause You are attempting to drill beyond the limits of the microcube; thus the query 
cannot be executed.

Action You need to edit the query by expanding its scope so that drilling up or down 
becomes feasible.
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No full client report service available: Please contact your administrator to enable this 
module. (WI0504)

Cause 1 From WEBINTELLIGENCE, you tried to open a BUSINESSOBJECTS document, an 
action that requires launching BUSINESSOBJECTS. However, the supervisor has 
restricted your user profile from using the application by disabling it.

Action See your supervisor to obtain access rights to BUSINESSOBJECTS.

Cause 2 You have attempted to perform an action that requires BOManager, a service 
which is currently not activated for the WEBINTELLIGENCE system.

BOManager is a scalable, server-based version of BUSINESSOBJECTS that offers 
display and refresh capabilities for BUSINESSOBJECTS documents via 
WEBINTELLIGENCE.  In general, it is automatically started whenever you launch 
WEBINTELLIGENCE.

Action Activate BOManager from the BusinessObjects Services Administrator  tool.

Cause 3 The CORBA call failed to function.

Action Stop the Web server and entire WEBINTELLIGENCE system, then restart them.

Cause 4 The BOManager folder does not match the one shown in the registry.

Action The folder of BOManager needs to be synchronized with the corresponding 
registry settings; however, because this folder and its associated registry settings 
are defined as part of the installation process, it is recommended to contact 
Business Objects Customer Support for more information.

Note: Incorrect Registry editing can cause unpredictable results. Please ensure 
that you know how to restore it if a problem occurs by understanding the restore 
concepts in the Registry online help.
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The system has timed out due to a WebIntelligence server setting. Ask your administrator to 
increase Max. WIQT active time. (WI0505)

Cause The system timed out due to a parameter set in the WEBINTELLIGENCE server. 
Called Max. WIQT active time, this parameter is located in the Generator module 
of the BusinessObjects Services Administrator. Its value specifies the maximum 
amount of time (in seconds) that a query can take before being terminated by the 
system.

Action As the message indicates, the value set for the parameter needs to be increased by 
the WEBINTELLIGENCE administrator. For more information on this and other 
Generator parameters, refer to Chapter 7 of the WebIntelligence System 
Administrator’s Guide.

Document not available (WI0506)

Cause 1 You are attempting to access a document that is no longer available on the 
repository. Although you can view the document name, the document itself has 
been moved or no longer exists. The inaccurate view results from your 
computer’s cache.

Action Refresh the list of documents from your browser. The unavailable document 
should no longer appear. It is possible to force the update of the list of documents 
each time a user starts a WEBINTELLIGENCE session by selecting the option Refresh 
each session in the Documents section of the user options.

Cause 2 The file name you have chosen is too long, or contains special characters that are 
not allowed.

On Windows 2000, a file name can contain up to 215 characters, including spaces. 
On Windows NT, a file name can contain up to 255 characters, including spaces. 
File names cannot contain the following characters: \ / : * ? " < > | "

Action Give your file a shorter name or remove those characters that are not allowed.
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This document is an add-in and therefore cannot be visualized (WI0507)

Cause The document contains one or more add-ins written inVisual Basic. This 
document cannot be displayed by the viewer of your browser because it is 
considered to be an add-in file.

Action Do the following:

1. From BUSINESSOBJECTS, launch the Visual Basic editor.

2. In the Properties window of the document, change the IsAddIn property from 
True to False.

3. Save the document in the Visual Basic editor.

Alternatively, you can decide to remove any add-ins attached to your document 
as follows:

1. In BUSINESSOBJECTS open your document.

2. Select Tools > Add-Ins.
A dialog box lists all available add-ins. Any add-ins attached to your 
document are displayed beside a check mark.

3. Uncheck the activated add-in(s), and click OK.

4. Save the document.
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Access to the universe, or refreshing the document, is not allowed. (WI0508)

Background You tried to carry out a command such as Refresh, that requires the document to 
access the universe on which it was created.

Cause You are not authorized to access the universe on which the query was created.

Action The BUSINESSOBJECTS supervisor can grant you access rights to the universe.

Too many selected values. (WI0509)

Cause You selected more values in the object and conditions panel than the maximum 
amount defined in the parameter MAX_INLIST_VALUES in acc2en.prm.

Action Select fewer values. 

* Error in parameters (WI0600)

Cause The report is no longer valid or has become incompatible with your current 
version of WEBINTELLIGENCE.

Action Try re-creating the report using a more recent version of WEBINTELLIGENCE. If the 
error persists, contact Business Objects Customer Support for more information.
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* Error creating report. (WI0601)

Cause 1 The query has become inadvertently modified.

Cause 2 There is a problem in the formatting of the report.

Cause 3 There is a problem in the filters used in the report.

Action All of the above possible causes are internal in nature.  Please contact 
Business Objects Customer Support for more information.
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BOManager Error Messages

The code range BOMGR0010 - BOMGR0320 identifies BOManager error 
messages.

Bad login parameters; login failed. (BOMGR0010)

Cause 1 BOManager  could not refresh your BUSINESSOBJECTS documents from 
WEBINTELLIGENCE because it could not create an instance of Busobj.exe. To do so, 
it requires a valid user login.

Action Ask the BUSINESSOBJECTS supervisor about the login requirements for running 
BUSINESSOBJECTS from BOManager.

Cause 2 BOManager could not refresh your BUSINESSOBJECTS documents from 
WEBINTELLIGENCE because it could not create an instance of Busobj.exe. To do so, 
it requires a valid user profile. In other words, the supervisor has probably 
disabled your user profile or group from accessing BUSINESSOBJECTS.

Action Ask the supervisor to enable your user profile or group as follows:

• Select the user or group in SUPERVISOR.

• From the Configuration tab, click the BUSINESSOBJECTS icon.

• Select the Disable/Enable command.

Document already open. (BOMGR0020)

Cause This is an internal WEBINTELLIGENCE error.

Action Stop and start up your WEBINTELLIGENCE session once again.
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Unexpected error during login. (BOMGR0040)

Cause This is a general error caused by a system-related event such as a COM error or a 
GPF.

Action Stop and start your WEBINTELLIGENCE session once again. If you cannot do this, 
then reboot the server on which BOManager resides.

BusinessObjects server process raised an automation exception. (BOMGR0060)

Cause 1 An incorrect script or macro referenced by your document.

Action Check the contents of the script or macro to determine whether any of the 
commands involve unauthorized rights or access to restricted resources. 

Example The macro may include instructions that invoke a restricted universe or data 
provider.

Cause 2 An action that fails partially or totally.

Action Refer to the detailed error message for more precise information on the cause of 
the error.

Example You were attempting to refresh a document.

COM error during call to BusinessObjects server process. (BOMGR0070)

Cause This is an internal COM error. 

Action Exit the BUSINESSOBJECTS session and reboot the server on which BOManager 
resides.
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File exception (BOMGR0080)

The error can occur for reasons relating to the file system of the machine on which 
BOManager resides:

Cause 1 The files have been deleted or removed.

Cause 2 You do not have write access to the destination files.

Cause 3 There is no room left on the hard disk.

Action Check whether you have write access to the file system of the machine. Check the 
contents of the file system to determine whether maximum capacity has been 
reached.

Network exception (BOMGR0090)

Cause The network is down or experiencing anomalies. 

Action See your network administrator to obtain information on the status of your 
network.

Generic exception (BOMGR0110)

Cause A general system-related problem has occurred.

Action Reboot the server on which BOManager resides.
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Unable to find session (BOMGR0120)

Cause The BOManager session has timed out before the WEBINTELLIGENCE session. This 
situation can occur whenever the session timeouts of BOManager and 
WEBINTELLIGENCE are set to different values.

Action First log out from WEBINTELLIGENCE.

TheWEBINTELLIGENCE administrator can then set both these parameters from the 
BusinessObjects Services Administrator, the Java applet used to tune BROADCAST 
AGENT or WEBINTELLIGENCE. The applet can be launched either from BROADCAST 
AGENT or a web browser. 

Here the steps are for launching the applet from BROADCAST AGENT:

1. Point to Broadcast Agent on the Programs menu.

2. Select Administrator
The applet is displayed.
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Within the applet BOManager and BROADCAST AGENT appear as modules from 
which you can set parameters.

For BOManager, the session timeout is set from the parameter Auto-shutdown 
BOManager after x minutes; by default, the value is 60 minutes. 

For WEBINTELLIGENCE,  the session timeout is set from a parameter in the 
WISessionManager module. This parameter is called Session Timeout. By default, 
this value is set to 5,400 seconds or 90 minutes.

It is recommended that the timeout parameters of BOManager and 
WEBINTELLIGENCE be synchronized.

Once this has been done, you can launch a new WEBINTELLIGENCE session.

For more information on the parameters discussed above, see the WebIntelligence 
System Administrator’s Guide or the Broadcast Agent Administrator’s Guide.

Unable to find document context. (BOMGR0140)

Cause When coding an extension to the standard products using either the SDK, 
Developer Suite, VBA macros, or some other customization method, a developer 
called API routines in the wrong order.

Example A call to ReleaseDocContext has been made before the required call to 
GetHtmlElement.

Example No call has been made to CreateDocContext before the attempt to open the 
document.

Action Rewrite the customized code so that the correct function calls occur in the right 
order.
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Maximum number of loaded server processes reached. (BOMGR0180)

Cause The maximum number of BUSINESSOBJECTS processes allowed to run on the 
BOManager server has been reached. By default, this number is set to 10 
processes.

Action This number can be changed from a parameter in BOManager called Max. number 
of loaded processes. 

If you have this number modified, you should be aware of the memory capacity 
of your machine. Each process is equivalent to a full BUSINESSOBJECTS client. Also, 
the number should always be greater than the value set for Min. number of loaded 
processes.

Maximum number of busy server processes reached. (BOMGR0190)

Cause The maximum number of busy BUSINESSOBJECTS processes allowed to run on the 
BOManager server has been reached. By default, this number is set to four busy 
processes.

A “busy” process is one that takes up CPU time. It also means that only x 
processes (such as refresh, save, or computing data) can be active at the same time 
in terms of CORBA calls.

Action This number can be changed from a parameter in BOManager called Max. number 
of busy processes. 

The optimal value should be based on the CPU power of the BOManager server. 
The value entered must always be greater than the value set for Min. number of 
loaded processes and less than the value set for Max. number of loaded processes.
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Server is shutting down... (BOMGR0200)

Cause The action you attempted failed because the BOManager server processing your 
documents is shutting down.

Action See the network administrator or the person responsible for the server. You can 
repeat the action once the server is up and running.

Out of memory (BOMGR0210)

Cause The BOManager server processing your documents is out of memory, probably 
because too many applications and/or processes are running simultaneously.

Action Close some applications on the server and try again.
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Unable to launch BusinessObjects server process. (BOMGR0220)

Cause In order to execute a scheduled action, the BOManager process tried to start a 
BusObj.exe process on the server. It was unable to do so because of an 
unidentified problem with the server-side configuration.

This problem may result from any one of the following:

• An incorrect  password, user name or permissions supplied for the 
BusObj process

• Insufficient memory

• Inappropriate license

• Incorrect version of a dll.

Action To identify the specific cause of the problem, try to launch BusObj.exe in 
interactive mode on the server.  To do this, follow the steps given in Chapter 11, 
“BOManager Troubleshooting” in the WebIntelligence System Administrator's 
Guide. 

You then receive a more specific error message which should enable you to fix the 
cause of the problem. When you are able to run the process successfully in 
interactive mode, your scheduled operations should also run without problems.

Undefined error. (BOMGR0230)

Cause 1 The Folder C:\Program Files\Business Objects\Server\WebIntelligence 
2.5\Storage\docs has been deleted or removed.

Action Restore the doc folder to its original location or create a new directory in 
C:\Program Files\Business Objects\Server\WebIntelligence 2.5\Storage.

Cause 2 The Folder C:\Program Files\Business Objects\Server\WebIntelligence 
2.5\Storage\docs is not accessible.

Action 1. Right click the docs folder and click Properties.

2. Click the Security tab and click Permissions.

3. On the directory Permissions dialog box, ensure the Type of Access value is set   
to Add or greater.
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Unable to initialize COM library. (BOMGR0240)

Cause The system was unable to initialize the COM library due to a configuration 
problem.

Action Check the configuration of the system. Stop and start WEBINTELLIGENCE once 
again.

Unable to write configuration file. (BOMGR0250)

You attempted to modify a parameter in BOManager but the system was unable 
to write to BOMgr.ini, the file in which the value for this parameter is stored. This 
configuration file, which initializes BOManager, is located in:

Business Objects\Server\BusinessObjects Manager 5.0

Cause 1 The file does not exist or has been deleted.

Cause 2 You do not have write access to this file.

Cause 3 There is no room left on the hard disk.

Action If the file does not exist or has been deleted, ask the WEBINTELLIGENCE 
administrator or the person who has installed BUSINESSOBJECTS server products 
to replace the configuration file, or reinstall BOManager.

The error may also result from a security restriction set by the network 
administrator on the drive in which the BUSINESSOBJECTS server products were 
installed.
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Invalid parameter (BOMGR0260)

A string representing part of a URL path is malformed or an invalid repository 
type is referenced. 

Cause 1 A misspelling in an environment variable if you are using a CGI server.

Action If you are using a CGI server, print out and check the spellings of all path 
components contained in your WEBINTELLIGENCE or HTTP server-related 
environment variables.

Cause 2 If you have made modifications to your code using the WEBINTELLIGENCE SDK, 
you may have misspelled a path component, or forgotten to include the 
document extension; for example, rep, wqy, etc.

Action If you are developing code with the WEBINTELLIGENCE SDK, check that all URL 
path components generated in code are correctly spelled. If you are generating 
HSAL PATH_INFO data in code, check that the spelling is correct in the relevant 
variables and the generated string.

Cause 3 An attempt in SDK code was made to export or import documents to or from an 
unsupported repository type (i.e. one that is not corporate, personal, or inbox).

Action If exporting or importing documents within WEBINTELLIGENCE SDK code, check 
that the repo_type_id parameter is correctly set.
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Could not overwrite existing document. Operation aborted. (BOMGR0270)

Cause You attempted to export a document to a repository in which a document with 
the same name already exists.

Action Select Yes for the Overwrite if document exists option,  and repeat the action. You 
can gain access to this option in INFOVIEW by clicking Corporate Documents in 
the navigation bar, and then clicking Upload to display the Upload and Publish 
window.

You can also rename the document and try exporting it once again.

Unable to create directory. (BOMGR0280)

You attempted to perform an operation requiring the creation of a directory; for 
example, report bursting. You cannot do so for any one of the following reasons 
relating to the server:

Cause 1 You do not have the rights to create a directory on the server.

Cause 2 The disk drive of the server is too full.

Cause 3 A security restriction has been set on the server by a network administrator.

Action Check with your WEBINTELLIGENCE administrator or network administrator for 
more information on the capacity and possible restrictions set on the server.
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Unable to copy file from cache. (BOMGR0290)

BOManager attempted to perform an operation that involves copying a file from 
the cache. It could not do so for any of the following reasons:

Cause 1 The cache has been restricted.

Cause 2 The disk drive of the server is too full.

Cause 3 A security restriction has been set on the server by a network administrator.

Action Check with your WEBINTELLIGENCE administrator or network administrator for 
more information on the capacity and possible restrictions set on the server.

Unable to import file in cache. (BOMGR0300)

Cause Some of the Scheduler files are corrupted.

Action Create a new BROADCAST AGENT in SUPERVISOR. Recreate all the tasks for the new 
Scheduler.

Unable to export document.  (BOMGR0305)

Cause This error may occur when you try to export a BUSINESSOBJECTS document to the 
repository. The network connection to the repository may be lost, the repository 
server may have gone down, or the repository tables may be full.

Action Try the following:

• Verify the network connection by “pinging” the server hosting the repository. 
If the network is running properly, the database administrator should then 
use database middleware (such as Net8 for Oracle) to check if there is any 
response from the repository database.

• Check that there is sufficient disk space on the machine hosting the document 
domain.
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• Check that your own account owns the right to access the repository.
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Macro execution failed. (BOMGR0310)

Cause An invalid macro is referenced in the document you are working with. The macro 
may be invalid due to commands that involve unauthorized actions or require 
access to restricted resources.

Action Check the contents of the macro to determine whether any of the commands 
involve unauthorized rights or access to restricted resources. 

Example The macro may include instructions that invoke a restricted universe or data 
provider.
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Task interrupted. (BOMGR0320)

Cause In INFOVIEW, you have clicked on a BUSINESSOBJECTS document, or tried to 
refresh it. The task, i.e., opening or refreshing the document, has been 
interrupted, for one of the following reasons:

• You started another task before the first task ended.

• The action timed out. The WEBINTELLIGENCE administrator sets a time-out 
parameter, which determines the maximum amount of time during which a 
document can be processed. In this case, the document was still being 
processed when the time-out parameter was reached.

Action You can:

• Perform the task again.

• Ask the WEBINTELLIGENCE administrator to change the time out parameter. 
Once this is done, you can perform the task again.

Example You click a document in INFOVIEW, then click Refresh. Ten minutes later, 
BUSINESSOBJECTS is still refreshing the document on the server, either because the 
document is very large, or because many processes are running simultaneously. 
Ten minutes is the maximum length of time for document processing, set by the 
WEBINTELLIGENCE administrator; therefore, BOManager interrupts the task.
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You cannot open this document which contains macros. Ask the WebIntelligence 
administrator to enable macros. (BOMGR0330)

Cause The document contains one or more macros created with Visual Basic. You are 
not allowed to open documents containing macros.

Action Using Business Objects Services Administrator, a WEBINTELLIGENCE 
administrator can apply a parameter that makes it possible to open documents 
with macros. This parameter is called Enable macros for interactive users and is 
located in the parameter set for the BOManager module. 

If for security reasons macros are not allowed at you site, you can remove them 
from your document in BUSINESSOBJECTS using File > Remove Macro(n). You 
should then save the document and re-export it.
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Sorry, but the selected document cannot be viewed with the current viewer (BOMGR0340)

Cause The document contains one or more add-ins written inVisual Basic. This 
document cannot be displayed by the viewer of your browser because it is 
considered to be an add-in file.

Action Do the following:

1. From BUSINESSOBJECTS, launch the Visual Basic editor.

2. In the Properties window of the document, change the IsAddIn property from 
True to False.

3. Save the document in the Visual Basic editor.

Alternatively, you can decide to remove any add-ins attached to your document 
as follows:

1. In BUSINESSOBJECTS open your document.

2. Select Tools > Add-Ins.
A dialog box lists all available add-ins. Any add-ins attached to your 
document are displayed beside a check mark.

3. Uncheck the activated add-in(s), and click OK.

4. Save the document.
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Auditor Error Messages

AUDITOR error messages range from ADT0001 to ADT0009.

Document with the same name already exists, unable to overwrite. (ADT0001)

Cause You tried to publish a document when a document with the same name already 
exists.

Action Select overwrite or change the name of your document.

There is no Broadcast Agent defined for the selected document domain. (ADT0002)

Cause No Broadcast Agent is defined for the document domain you selected.

Action Install or activate BROADCAST AGENT.

You do not have the access rights needed to delete indicators. (ADT0003)

Cause You do not have the access rights to delete a document.

Action Contact your administrator to obtain the necessary access rights.

A problem occured while opening the document. Please contact your administrator. 
(ADT0004)

Cause This is a generic error that occurs when you try to open a document. It may be 
related to the BOManager or BusObj processes.

Action Check that WEBINTELLIGENCE is stable.
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A problem occured while refreshing the document. Please contact your administrator. 
(ADT0005)

Cause This is a generic error that occurs when you try to refresh a document. It may be 
due to a discrepancy between your document and the corresponding universe, or 
because no universe can be found.

Action Check that you have the right universe, and that the universe you want to use to 
create the document is available.

Error, please contact your administrator. (ADT0006)

Cause This is a generic error that may occur at the end of a web session. It may also occur 
at login if the web server or application server is not available or has problems.

Action Log in again after checking that the web server and application server are 
available.

The new password and the password confirmation are not identical. (ADT0007)

Cause When asked to confirm your new password, you entered a different password.

Action Enter your new password again and confirm it.

The new password must be different than the old one. (ADT0008)

Cause Your new password is the same as your old one.

Action Enter a different new password.
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You do not have the access rights needed to change your password. (ADT0009)

Cause You do not have the access rights to change your password.

Action Contact your administrator to obtain the necessary access rights.
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Miscellaneous Error Messages

Miscellaneous error messages include the following ranges and categories:  

The file name must contain no more than 8 characters. (GUI0002)

Cause You attempted to save a universe using a name made up of more than eight 
characters.

Action Repeat the action using a name made up of eight characters or less. Universe files 
have a .unv extension.

Range Category

GUI0002 - GUI0006
USU0001

GUI

LOV0001 - LOV0002
VAR0001

List of Values
(LOV)

FRM0001 - FRM0025 Framework

BOL#05, BOL#102, 
BOL#109,
BOL#130 - BOL#134 
and BOL#136

bolightsvr
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The file name contains forbidden characters. (GUI0003) 

Cause You tried to save a universe with a name that contains unauthorized characters. 
This restriction may originate from:

• the character set allowed by the database on which the BUSINESSOBJECTS 
repository resides

• the options, set by the supervisor from the SUPERVISOR module, which limit 
the characters allowed in the repository

Action Use a different name to save your universe. If the problem persists, ask the 
BUSINESSOBJECTS supervisor about the authorized character set for your 
universes.

File not found. Please verify the correct file name was given.  (GUI0005)

Cause You tried to open a BUSINESSOBJECTS report by entering a file name that does not 
exist.

Action Enter the correct name of the file, or use the Up One Level button in the Open 
dialog box to locate the desired report.

[name] Path not found. Please verify the correct path name was given. (GUI0006)

Cause You tried to open a BUSINESSOBJECTS report using an incorrect path name. The 
report may exist, but it is not at the location you specified.

Action From the Open dialog box, use the Up One Level button to locate the report.
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Cannot find [name]. Please check that all components have been correctly installed. 
(USU0001)

Cause You selected the User’s Guide command from the Help menu of the 
BUSINESSOBJECTS application but no guide appeared. The online guides, which 
are in Acrobat PDF format, may not have been installed on your hard disk.

Action Check the contents of the Online Guides\En (language) folder of your 
BUSINESSOBJECTS files. If there are no PDF files, then you need to install them 
using the BUSINESSOBJECTS installer program. This program also installs the 
Acrobat Reader which lets you read these files.

Too many selected values. (LOV0001)

Cause 1 From a list of values in the Query Panel, you attempted to select more than the 
authorized number of values. By default, you can select up to 99 values at the 
same time.

Action Limit the number of values you select to less than 99.

Cause 2 You selected less than 99 values but the above error appears. This means that a 
restriction has been set in the prm file corresponding to your database. This 
restriction appears as the parameter  MAX_INLIST_VALUES.

Action Remove this parameter, or set its limit to a higher number.

You have not been authorized to use this universe. (LOV0002)

Cause You do not have rights to this universe (to which lists of values have been 
assigned). 

Action See the BUSINESSOBJECTS supervisor to find out about the universes you are 
authorized to work with.
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Syntax error (VAR0001)

Cause The query contains a condition with a prompt for which you must enter one or 
more values using a separator between each value. The separator is usually a 
semicolon (;) or a comma (,). It is defined in the Windows Control Panel (Regional 
Settings).

The error results from the use of the separator. Perhaps you entered it at the 
beginning of the prompt, or inadvertently entered it twice between two values.

Action In the Enter or Select Values dialog box, re-enter the values using one separator 
between each value.

The file could not be found. (FRM0001) 

Cause 1 You attempted to open a file from the Recent File list of the application but the 
file either no longer exists, or is at a different location.

Cause 2 You launched a BUSINESSOBJECTS application from the command line or with the 
Run command, and you specified a file that either no longer exists or is at a 
different location.

Cause 3 The file cannot be found because the mapping of the network drive has been 
modified; that is, the file may now be on a different server.

Action Search your hard disk for the file you tried to open. If you find it, note its location. 
If you cannot find the file, check the mapping of your network drive.

This file is read-only. (FRM0002)

Cause The universe or document you tried to save is write-protected. 

Action From the Windows Explorer, right-click the file and from the Properties dialog 
box, uncheck the Read-only option.
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The file is corrupted and cannot be opened. (FRM0003)

Cause The file you tried to open has become corrupted or damaged. This may be due to 
a virus or errors on your hard disk. 

Action Run a standard utility program such as ScanDisk which checks files, folders, and 
the disk surface for errors and then repairs them. If this does not work, then use 
a back-up of the file, if one is available.

File could not be saved due to a disk error. (FRM0004)

Cause There may be no room left on your hard disk.

Action Delete unused files or applications to free up space on your hard disk.

Could not create temporary file. Your startup disk is probably full. (FRM0006)

Cause Whenever you create or edit reports, BUSINESSOBJECTS simultaneously creates 
temporary reports in the Temp folder of the startup disk. Because the disk is 
probably full, BUSINESSOBJECTS can no longer create these temporary files.

Action First exit BUSINESSOBJECTS. Then get rid of unused applications or files, and 
empty out the Temp folder. Launch BUSINESSOBJECTS once again.

Cannot open the file due to an unknown error. (FRM0007)

Cause BUSINESSOBJECTS could not open the file for reasons it could not determine. 

Action Try opening other BUSINESSOBJECTS files. If you receive the same error message 
with other files, try re-installing the BUSINESSOBJECTS applications. If the errors 
persist, contact Business Objects Customer Support.
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You are not authorized to use this document. (FRM0008)

Cause The person who created the document that you are trying to open did so with a 
connection to the repository. You also need a connection to the repository in 
order to open this document. You are probably working offline, meaning that:

• Check the option Work in offline mode when launching BUSINESSOBJECTS.

• You are working away from your office and thus cannot connect to the 
repository.

• You cannot work online because the supervisor did not provide you with a 
repository connection (user name and password).

Action You can read the document if you first connect to the repository. However, the 
person who created the document may not want you to have access to the 
repository. In this case, the document creator has to save the document, then 
make it available to you a second time. Here’s what the document creator has to 
do:

1. Open the document in BUSINESSOBJECTS with a connection to the repository.
This means that he or she must enter a user name and password at login.

2. Select File > Save As.

3. In the Save As dialog box, check the option Save for all users.

4. Click Save.

5. Make the document available to other users, either by e-mail, the repository, 
file system, diskette, etc.

Note: This procedure can also be carried out on universes from DESIGNER.

An alternative action is for the General Supervisor to save the same document 
with a different file name. This should enable you to read the document.
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Example Frank launches BUSINESSOBJECTS, and, when prompted, enters his user name and 
password. This means that Frank is working with a connection to the repository. 
Frank creates a document, then sends it to you by e-mail. You don’t have the time 
to read the document while you are at the office, so you synchronize your e-mail 
before leaving, hoping to read the document on the train home.

When you’re on the train, you’re working offline—there is obviously no network 
to connect you to the repository. Therefore, when you try to open the document, 
you get this error message.

You have no write authorization on this document. It will be opened as read-only. (FRM0009)

Cause You tried to open a document that is write-protected. You cannot make changes 
to it. The restriction may have been placed by the BUSINESSOBJECTS supervisor.

Action See the BUSINESSOBJECTS supervisor for more information on the documents you 
are allowed to work with.

Invalid password. Please try again. (FRM0010)

Cause You tried to open a universe with an incorrect password.

Action Try entering the password again. If this still does not work, contact the 
BUSINESSOBJECTS designer (the person who set the password on the universe) to 
find out if the password has been changed recently.
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[name] is reserved. (FRM0011)

Cause You tried to open a universe but a Password dialog box indicates that the 
universe is reserved. This means that a write reservation password has been 
assigned to the universe.

Action Ask the designer of the universe for the write reservation password, then try 
opening the universe with it. 

Even without this password, you can still view the universe in read-only mode. 
In this mode, you cannot save any changes you make to a universe unless you 
rename it. To open a universe in this mode, click the Read Only button. 

BusinessObjects is not correctly installed. Please rerun BusinessObjects Setup. (FRM0013)

Cause There is a problem in the way that BUSINESSOBJECTS was set up on your system. 
Certain essential files or folders were not properly configured or installed. 

Action You must re-install BUSINESSOBJECTS on your machine. If the error persists, 
contact Business Objects Customer Support.

Warning: this version of BusinessObjects will expire in [n] days. Please contact your 
BusinessObjects distributor. (FRM0014)

Cause The version of BUSINESSOBJECTS installed on your system is an evaluation copy 
that expires after 90 days. It is not the official version of the product.

Action See the system administrator or whoever installed BUSINESSOBJECTS at your site. 
It is possible that the person inadvertently used the license key for the evaluation 
rather than the official version.

If, however, the correct key was used then you should contact your 
BUSINESSOBJECTS distributor.
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This version of BusinessObjects has expired. Please contact your BusinessObjects distributor. 
(FRM0015)

Cause The version of BUSINESSOBJECTS installed on your system is an evaluation copy 
that has just expired. It is not the official version of the product. You can continue 
to work with this version for one more day.

Action See the system administrator or whoever installed BUSINESSOBJECTS at your site. 
It is possible that the person inadvertently used the access key for the evaluation 
rather than the official version. Re-install the product using the correct license 
keys.

If, however, the correct key was used then you should contact your 
BUSINESSOBJECTS distributor.

This version of BusinessObjects has expired. Please contact your BusinessObjects distributor. 
(FRM0016)

Cause The version of BUSINESSOBJECTS installed on your system is an evaluation copy 
that has just expired. It is not the official version of the product. The product will 
no longer function.

Action See the system administrator or whoever installed BUSINESSOBJECTS at your site. 
It is possible that the person inadvertently used the license key for the evaluation 
rather than the official version.

If, however, the correct key was used then you should contact your 
BUSINESSOBJECTS distributor.

The system is out of memory or resources. (FRM0017)

Cause You attempted to perform an action that exceeds the capacity of your machine.

Action Close all the open applications on your machine, launch the BUSINESSOBJECTS 
application, and then try the operation once again.



v 5.1-2.7

 Error Message Guide 723

The setup.exe file is invalid. (FRM0018)

Cause 1 The installer program was unable to create a temporary setup file in the Temp 
folder of your hard disk. There may not be enough space on your hard disk to 
install BUSINESSOBJECTS applications.

Action Clean out the Temp folder of your hard disk by deleting its contents. Then try 
running the installer program once again.

Cause 2 You already ran the installer program once but it failed to execute properly.

Action Check the Temp folder of your hard disk and delete the following files:

• imsg50%s.dll

• _su50.exe

• setup50.exe

• servconf%s.dll

• servconfdll.dll

Then run the installer program once again.

The setup.exe file was not found. (FRM0019)

Cause The installer program was unable to create a temporary setup file in the Temp 
folder of your hard disk. There may not be enough space on your hard disk to 
install BUSINESSOBJECTS applications.

Action Clean out the Temp folder of your hard disk by deleting its contents. Then try 
running the installer program once again.
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The setup path was not found. (FRM0020)

Cause The installer program was unable to create a temporary setup file in the Temp 
folder of your hard disk. There may not be enough space on your hard disk to 
install BUSINESSOBJECTS applications.

Action Clean out the Temp folder of your hard disk by deleting its contents. Then try 
running the installer program once again.

Unknown error when Setup was running. (FRM0021)

Cause 1 There may be a problem with your access or connection to the network.

Cause 2 The server on which the setup.exe is located has gone down.

Action See the network administrator to find out about the status of the network.

Unknown Setup Path. (FRM0022)

Cause 1 There may be a problem with your access or connection to the network.

Cause 2 The server on which the setup.exe is located has gone down.

Action See the network administrator to find out about the status of the network.
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More than one macro with the same name. Cannot execute macro. (FRM0023)

Cause You tried to run a query on a universe containing an object that references a 
macro; however, BUSINESSOBJECTS detected more than one macro with the 
specified name.

An object that references a macro is defined with the @Script function in its 
properties.

Action See the person who created the macros, or the designer who created the universe. 
It is necessary to rename one of the macros, or assign a more explicit name to one 
of them. Macros are stored as .rep or .rea files in the UserDocs folder.

No macro with this name. Cannot execute macro. (FRM0024)

Cause You tried to run a query on a universe containing an object that references a 
macro but BUSINESSOBJECTS could not find it.

An object that references a macro is defined with the @Script function in its 
properties.

Action Search for the document that contains the macro and open it. Either fix or remove 
the macro. If you cannot find it, see the designer of the universe or the person 
responsible at your site for creating macros.
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Cannot create VBA macro. (FRM0025)

Cause While trying to create a macro from BUSINESSOBJECTS, you entered an invalid 
macro name.

Action Enter another name for the macro. In Microsoft Visual Basic, a macro name must 
meet the following requirements:

• It must begin with a letter.

• It cannot exceed 255 characters.

• It cannot be a restricted keyword.

For more information on macro names, refer to Microsoft Visual Basic for 
Applications documentation.

No open document (BOL#05)

Cause You tried to carry out a command such as Refresh, on a document that has been 
deleted. You are viewing a cached version of the document.

Action Refresh your corporate, personal or inbox document list for a complete list of 
available documents.

Error while importing document (BOL#102)

Cause An error occurred while you were retrieving a document from the repository. 
The import was aborted for one of the following reasons:

• There was a network error.

• The server which hosts the document domain has failed.

Action Verify the network connection by “pinging” the server hosting the repository. If 
the network is running properly, the database administrator should then use 
database middleware (such as Net8 for Oracle) to check if there is any response 
from the repository database.
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Too many values selected (BOL#109)

Cause In the object and conditions panel, you selected more values than is allowed by 
the maximum amount defined in the parameter MAX_INLIST_VALUES.  This 
parameter is located in the .prm file for the connectivity you are using, for 
example ora7EN.prm for Oracle.

Action Select fewer values.

Unable to open this document, not authorised (BOL#130)

Cause You tried to open a document that you are not authorized to view. The restriction 
may have been placed by the BUSINESSOBJECTS supervisor.

Action See the BUSINESSOBJECTS supervisor for more information on the documents you 
are allowed to work with.

Unable to open this document, cancelled by user (BOL#131)

Cause You tried to carry out a command on a document before WEBINTELLIGENCE 
completed opening the document.

Action Avoid running commands before a document is open.

Unable to open this document, no read access (BOL#132)

Cause You do not have read access to the storage directory on the WEBINTELLIGENCE 
server, where the document is stored. 

Action The UNIX administrator can grant you read access to the WEBINTELLIGENCE 
storage directory.
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Unable to open this document, no write access (BOL#133)

Cause You do not have write access to the storage directory on the WEBINTELLIGENCE 
server, where the document is stored. 

Action The UNIX administrator can grant you write access to the WEBINTELLIGENCE 
storage directory.

Unable to open this document, no read and write access (BOL#134)

Cause You do not have read or write access to the storage directory on the 
WEBINTELLIGENCE server, where the document is stored. 

Action The UNIX administrator can grant you read and write access to the 
WEBINTELLIGENCE storage directory.

Unable to open this document, file is corrupted (BOL#136)

Cause 1 The file you tried to open has become corrupted or damaged. This may be due to 
a virus or errors on your hard disk.

Action The network or system administrator needs to run a standard utility program 
such as FSCK which checks files, directories, and the disk surface for errors and 
then repairs them. If this does not work, then use a back-up of the file, if one is 
available.

Cause 2 There is not enough disk space on the server where the document is stored or in 
the repository database.

Action The network or system administrator needs to free up some disk space on the 
system.
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Overview

This appendix summarizes the most common types of problems you may 
encounter when installing, configuring and running BUSINESSOBJECTS or 
WEBINTELLIGENCE.

Middleware Problems
As a general point, bear in mind that in many situations, problems may arise from 
your middleware configuration. The first thing to check is that the middleware is 
set up and working correctly. You also need to check that you are using the 
correct middleware version. 

Network Configuration
There are a number of network issues that you should check:

• The OS_Agent port value must be the same on each of the machines within the 
same CORBA network cluster. If you are using two clusters, then you should 
also be using two distinct OS_Agent port values for the machines of each 
cluster. You can check these values using the OSFIND utility, located on each 
of the cluster nodes in the folder: Server\ORB 2.5\Bin.

• Each of your server machines must have a fixed TCP/IP address.

• If you are using ODBC, then your Data Sources must be declared as System 
DSNs, and not as User DSNs.

Memory Problems - Using the ServConf Utility
Problems may occur when Windows NT does not have sufficient memory to run 
the various server systems which have been configured. In this case, close all 
applications that may be running, and restart your system. If the problem 
persists, you may have to increase the amount of RAM installed on your system.

Additionally, you can run the Servconf.exe utility to modify your memory 
settings. Servconf.exe is a utility automatically installed with the Enterprise 
Server Products option in:

Business Objects\Server\BusinessObjects Manager 5.0
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This utility allows you to view and modify the system heap size settings. These 
settings determine how Windows NT runs BusObj.exe processes (under the 
control of the BOManagers). Defining the appropriate settings is essential to 
ensure the correct behavior and performance of your BOManager system, 
especially regarding the number of BusObj.exe processes that can be launched 
simultaneously. These values control how Windows NT allocates system 
memory to your server systems.

At any given time, several BusObj.exe processes can be running simultaneously 
from one or more BOManagers. If for any reason there is insufficient system 
memory available for a given BOManager, then processes may fail in various and 
unpredictable ways. 

Running BOManager Interactively
When you run BOManagers in your server environment, the processes are 
running in background. This makes it difficult to identify any problems which 
may occur, since you do not see the error messages that are generated.

If you suspect that you have a problem with the BOManager on one of your 
servers, you should:

1. Run the Servconf utility to change the server identity to Launching User (see 
above).

2. Stop the BOManager service.

3. Run the following command on the same server: 

BOMgr.exe -visible

This opens a DOS window. 

4. Restart the WEBINTELLIGENCE services. 
This effectively starts the BUSINESSOBJECTS full client interactively, and allows 
you to view any error messages which are flagged.

5. Run the Servconf utility again, and change the server identity back to This 
User.
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Generating a Debug Log
You can generate a debug log by copying the BOMgr_Diag.ini file to the 
Server\ BusinessObjects 5.0 folder, and restarting BOManager. BOManager then 
creates a file in the same folder called BOMgr_Diag.Log. This is a plain-text file 
which lists all CORBA calls and parameter sets. It is useful for detecting problems 
relating to BOManager.

Repository Access Problems
Repository access problems may occur because:

• There is no valid connection to the document and/or security domain. A 
supervisor can select Tools > Repository,  click the document domain, and 
then click the Test button. This checks whether the connection to the 
document domain is still valid. The same test should be done on the security 
domain.

• There is a problem exchanging information with the document domain of the 
repository. This can be due to corrupted tables in the repository database. A 
supervisor can run Scan and Repair to fix damaged repository tables. If the 
problem persists, the General Supervisor may have to re-create the repository.

• The machine hosting the repository is down. Check if the machine hosting the 
repository is responding by “pinging” the server. If the network is running 
properly, the database administrator can use database middleware (such as 
Net8 for Oracle) to check if there is any response from the repository database.

• The documents you are trying to access may already be open or in use by 
another user or application. If you suspect the file is currently being accessed 
by another user, wait a while, and then try accessing it again.

• The repository tables have become corrupted. A supervisor can run a Scan 
and Repair on the document and security domains to fix damaged repository 
tables. This scans or parses the structure of the domain, detects errors, and 
repairs errors. If the problem persists, the General Supervisor may need to
re-create the repository.

• Lack of Windows NT access rights: the Windows NT administrator may not 
have granted you the necessary read/write authorization in the folder where 
you are trying to import a document. Ask the Windows NT administrator to 
grant you full access to the folders on the system.
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RSS file - Database Connection Problems
One .rss file is created for each of the databases you are using. This file contains 
the necessary connection information, and is stored in the database folder: 

BusinessObjects 5.0\Data Access 5.0\database_name. 

Errors can occur if BUSINESSOBJECTS cannot find the .rss file in the database folder, 
and therefore cannot establish a connection to the database. If this happens, copy 
a backup of the .rss file to the database folder. If you do not have a backup, a 
supervisor must create the connection once again in SUPERVISOR.

SBO File - Database Access Problems
Each of the databases you are using has an associated .sbo file which is normally 
located in the Business Objects\Data Access 5.0 \database folder:

• Oracle.sbo for Oracle databases

• Odbc.sbo for ODBC databases

Errors are generated if you try to access your data warehouse via the repository 
after the associated database .sbo file has been moved, renamed, deleted, or 
damaged. This message can also occur if the .sbo is locked by another application 
or user.

If this happens, replace the .sbo file with a backup copy if you have one, or from 
another BUSINESSOBJECTS installation. If these are not available, you must run 
Setup and re-install your ODBC connections (which you can find in the Data 
Access folder). This re-installs the Odbc.sbo file.

SQLBO Network Layer Problems
SQLBO is the BUSINESSOBJECTS SQL layer through which all SQL transactions 
pass on their way to and from your repository and corporate databases. This 
layer is required to normalize all SQL transactions into a format that can be 
interpreted by all supported database types and middleware versions. Errors are 
generated whenever no SQLBO connection can be established.

The communication between client machines and database servers is provided 
by the database middleware. Check that your middleware is set up and working 
correctly, and that you are using the correct middleware version. Check also the 
BUSINESSOBJECTS driver, which gives you access to the middleware.
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Each of the databases you are using has an associated .dll file which is normally 
located in the Business Objects\Data Access 5.0 folder. Each of these files has an 
Sq prefix as follows:

• Sqboci50.dll for Oracle databases

• Sqodbc50.dll for ODBC databases

Error messages are generated if you try to access your data warehouse via the 
repository after the associated database .dll file has been moved, renamed, 
deleted, or damaged. Errors can also occur if the .dll is locked by another 
application or user, or if you are using an incompatible .dll file.

Replace the .dll file with a backup copy if you have one, or from another 
BUSINESSOBJECTS installation. If these are not available, your Data Access 
modules must be reinstalled. 

Invalid Characters
The characters you specify must be supported by the RDBMS you are using. 
Default valid characters are a-z (all lowercase letters), A-Z (all uppercase letters), 
0-9 (whole numbers from 0 to 9), dash (-), underscore (_), dollar ($), and space 
characters. Edit the list of valid characters for the repository, using only 
characters that are supported by your RDBMS.

Update Problems
SUPERVISOR can encounter errors while attempting to update the repository from 
an earlier version. This may be because the existing repository already contained 
errors, or because you are trying to update from a version of BUSINESSOBJECTS 
which pre-dates version 4.x.

You can update your repository only from BUSINESSOBJECTS 4.x. You cannot 
update directly to BUSINESSOBJECTS 5.0 from an earlier version (such as 3.x). If you 
want to update from version 3.x, you must first perform an intermediate update 
to version 4.x, and then update to 5.0.

In all cases, you are advised to run a Scan and Repair before updating your 
repository. Also, make sure the repository is stable, compact, and error-free. 
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Installation Problems
Problems can occur while the BUSINESSOBJECTS Installer is running. These 
problems may be due to:

• Insufficient disk space to continue the installation. In this case, you should 
quit the installation, and free up some disk space. Empty your Recycle Bin and 
delete any unnecessary files, then try running the Installation Wizard again.

• Windows NT access rights: The Windows NT administrator may not have 
granted you the necessary read/write authorization in the folder where you 
are trying to install BUSINESSOBJECTS. You should ask the Windows NT 
administrator to grant you full access to the folders on the system where you 
are trying to install BUSINESSOBJECTS.

• Dll file conflicts: You may already have one or more .dll files installed which 
conflict with the .dlls the Installer is trying to copy to your system. Whenever 
a .dll file conflict occurs, you can choose to skip the error message and 
continue with the installation. It may be that the .dlls installed with 
BUSINESSOBJECTS are more recent than the .dlls already installed, or they may 
be older. In either case, you should bear in mind that although you can 
complete the installation and run BUSINESSOBJECTS, you may later have 
problems running specific applications. If this is the case, you need to run the 
Installer again, and re-install the .dll files provided with BUSINESSOBJECTS.

• Locked files: One or more of the files or resources that the Installer needs to 
complete the installation may already be in use or locked by another user or 
application. 

To ensure that all the files or resources the Installer needs to complete the 
installation are available, you should quit all other applications before running 
the Installer. 
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LSI Security File Access Problems
The security file (.lsi) is used to identify users who attempt to access the 
repository. When a user logs in, his or her name and password are checked 
directly against the corresponding data stored in the repository. If this 
authentication is successful, the user's specific authorization data (including user 
ID and password, specific user rights, restrictions, etc) is copied from the 
repository to the security file. The security file acts therefore as a read-write cache 
of authorization data for a specific user or group. For local installations, this file 
is created in the LocData folder, together with the key file.

The local security file (.lsi) is stored either in the ShData folder of the shared 
server or in the LocData folder of the local client. You must have read and write 
access to this folder, since data is written to the security file every time you log in. 
The file is identical in both folders, except for the extension: .lsi or .ssi. Errors may 
occur if the file is write-protected, damaged, deleted, or if you are using the 
wrong key file. 

For example, you may have been trying to use a different key file, or the file may 
have been renamed. A problem can also occur if you log in, become impatient 
with the lack of response to the login, and reboot the system. This immediately 
corrupts the lsi file.

Make sure you have write access to the lsi folder or file. If necessary, a General 
Supervisor can perform a Safe Recovery by deleting the security file. Then try 
restarting your BUSINESSOBJECTS application. A blank login box appears (without 
any login names). However, you can still enter your previous login name and 
password. The security file is then automatically regenerated during login.

Universe Problems
Universes may cause problems if they contain:

• Invalid syntax in the SQL definition of an object, condition, or join

• Loops

• Isolated tables

• Missing or incorrect cardinalities.

A universe designer can usually resolve these problems by running an Integrity 
Check on the universe. This checks whether the structure of the universe matches 
the requirements of the database.
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Saving Temporary Files
When you send a document to the repository, BUSINESSOBJECTS temporarily saves 
the document locally to disk before sending it to the repository. This causes errors 
if you do not have write-access to the disk, or the disk is full.

Empty your Recycle Bin. If necessary, delete any redundant or unwanted files, 
and empty the Recycle Bin again. If you have read-only privileges on the root C:\ 
drive, ask the Windows NT administrator to grant you full access privileges on 
the C:\ root drive.

Key File Access Problems
The key file (.key) identifies the connection to a specific repository. Errors are 
generated if the key file has been moved, renamed, deleted, or damaged. 

The key file is generally stored in the BusinessObjects 5.0\LocData folder on local 
installations or BusinessObjects 5.0\ShData on shared installations. If you are 
unsure, run Setup.exe, and click the Modify button to see if it says Local or Shared 
for the key file.

To correct this problem, a General Supervisor must perform a Safe Recovery to 
automatically regenerate it once more. Note that the new key file may no longer 
correspond to the .lsi file, also located in the same subfolder. Therefore, you also 
need to delete your .lsi file. The .lsi file is then automatically regenerated the next 
time you log in.

If the problem persists, BUSINESSOBJECTS may have to be reinstalled.

Tracing RDBMS Problems
Some errors are generated by the database itself, not by BUSINESSOBJECTS. These 
specific database errors are not displayed in BUSINESSOBJECTS.

In these cases, you should activate a trace to locate the source of the error. To do 
this, you can either use the trace utility delivered by your database supplier (e.g. 
for Oracle, this is SQL+), or you can use the BUSINESSTRACKER utility supplied 
with BUSINESSOBJECTS.

Whichever tool you use, you first need to quit BUSINESSOBJECTS, start the trace, 
and then restart BUSINESSOBJECTS. The trace that is generated records all SQL 
transactions that pass between the front-end client and the repository, and 
between the repository and the corporate database. 

You can scroll this trace information on-screen or save it to a file. You can also 
send it to Business Objects Customer Support for analysis.
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By default, the BUSINESSTRACKER utility is installed in the following folder:  

C:\Program Files\Business Objects\Business Objects 5.0\

It is an executable file called Bologapp.exe.

In the trace file, you need to look for any error or negative value. You can conduct 
a search by selecting Edit > Find and typing words such as: error, -0, -1 and so on.

Tracing Scheduler Problems
The Scheduler periodically connects to the repository to check for any tasks 
which need to be processed. Error messages are generated if there is a problem 
with the connection to the security domain.

To access more detailed information, open the Bcsscdul.log file, located in 
Business Objects\Server\Broadcast Agent. This file provides a log of all 
Scheduler messages, and may help you detect the problem.
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